• ベストアンサー
  • すぐに回答を!

増設HDDの転送モードがDMAにならない

増設したHDDの転送モードがDMAになりません。 このサイトなどの関連する情報を元に色々試しましたがだめでした。 (レジストリ操作、IDEチャネルドライバの削除など) ケーブルも問題ありません。 プライマリのデバイス0のHDDはDMA5動いているのですが スレーブに設定してあるデバイス1のHDDはPIOモードです。 増設したHDDもDMA5で動かすにはどうしたらよいのでしょうか? 現在の環境は以下の通りです。 M/B Name INTEL 875P Processor Intel(R) Pentium(R) 4 CPU 2.60GHz VideoCard 128 DDR ATI Radeon 9800 Resolution 1280x1024 (32Bit color) Memory 523,260 KByte OS WindowsXP Home SP1 Intel(R) 82801EB Ultra ATA Storage Controllers プライマリ IDE チャネル IC35L120AVV207-1 <= DMA5で動作中 ST3120026A      <= PIOで動作中 <=これをDMAで動かしたい Intel(R) 82801EB Ultra ATA Storage Controllers セカンダリ IDE チャネル _NEC DVD+RW ND-1100A

共感・応援の気持ちを伝えよう!

  • 回答数3
  • 閲覧数314
  • ありがとう数2

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.3
  • Mitz
  • ベストアンサー率65% (2863/4366)

デバイスマネージャでの設定は確認済みのようですので、BIOS設定を確認してみてください。 機種により、場所、項目名が異なる場合がありますが、参考URLのBIOSの場合は、「Integrated Peripherals」内の「IDE Primary Slave UDMA」になります。 ここがAUTOになっているかチェックです。

参考URL:
http://www.plaza.across.or.jp/~kusunoki/bios_i815e.htm

共感・感謝の気持ちを伝えよう!

質問者からのお礼

項目名は違いましたが、セカンダリがOFFになっている項目があり、 それをONにしたら見事にDMA5になりました! ありがとうございました。

関連するQ&A

  • HDDの転送速度がDMAにならないのですが・・・

    OS:windowsXP HDD:Maxtor 5T040H4 Maxtor 6Y160L0 上記の物を使用しているのですが、デバイスマネージャーで確認してみたところHDDは二つとも、標準デュアルチャネルPCI IDEコントローラーのプライマリIDEチャネルに接続されていて、プロパティーを開き詳細設定で転送モードをデバイス0、1共にDMAにしているのですが、現在の転送モードが二つともPIOモードのままなのですがDMAにすることは出来ないのでしょうか? 他にも、Intel(R) 82801FB Ultra ATA Storange Controllers-2651と Intel(R) 82801FB/FBM Ultra ATA Storange Controllers-266Fがあり、前者には、何も接続されていなく、後者の方のプライマリにはDVDドライブが接続されていて、こちらはプロパティの転送モードはDMAで、現在の転送モードもウルトラDMAモード2となっているのですが、HDDの方もこのようにはならないのでしょうか? どうか回答の方よろしくお願いします。

  • DMA転送モードが度々変わるのですが?

    タイトルの通りなのですが、DMA転送モードが起動の度に変わります。 装着しているHDDはATA100の物をプライマリに2基です。起ち上げた直後のBIOSの画面では2基ともDMA5と表示されているのですが、デバイスマネージャIDEチャネル(プライマリ)の詳細設定を見ますと、現在の転送モードが5のときあり、2のときあり、4のときありとまちまちです。デバイス0も1も両方こんな感じです。 同じような経験、対処の方法等ご存じの方がいらっしゃいましたらお願いします。 OSはwindowsXPsp1です。機種はEPSONDIRECT EdiCUBE MX2300ですが、HDDは当初より大容量のものに載せ替えてます。

  • PIOモードでしか起動できない。

    こんばんは^^ PCのHDDについて困っているのですがどなたかご教授ください>< PIOモードを直そうと思い、いろいろと調べ、まずはデバイスマネージャからのプライマリIDEチャネルのほうを削除したのですが、そうした場合再起動した際にブルースクリーンになり起動が不可になってしまいます。 設定自体もDMA(可能な場合)のほうにしていますが転送モードはPIOモードのままです。 つぎは、レジストリの書き換えもしましたが、前回と同様に、 ブルースクリーンになってしまい起動ができない状況になります。 セカンダリIDEチャネルのほうは正常にDMAで動作しています。 またプライマリのデバイス0のみPIOモードです。 デバイス1はDMAモードで動いています。(HDDは2台です。) どなたかDMAモ^ドに戻すための方法をご教授いただけないでしょうか? よろしくお願いいたします。

その他の回答 (2)

  • 回答No.2
  • TT250SP
  • ベストアンサー率41% (2393/5813)

BIOSは確認しましたか? DMAとかAUTOにしてみてください あと、同じチャンネルに遅いIDE/ATAPI機器があるとか、ケーブルが40芯だとか 他の原因は思いつきません IntelのM/BのBIOSはよく判らないので識者に任せます

共感・感謝の気持ちを伝えよう!

  • 回答No.1
  • PC-GATE
  • ベストアンサー率38% (551/1445)

トラブルシューティングを試してもダメだったんですか?まさか、スレーブに付けたHDDも「マスター」にしていて"競合"しているオチじゃないですよね!

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • HDDがDMA転送モードにならない

    HDDがDMA転送モードにならず、そのせいか、タスクマネージャーで モニターするとCPUに負担が掛かっていることが多く、全体のパフォ ーマンスが悪いようです。ウインドウを数個開くと、反応が遅くな ったり、動画再生が途切れ途切れになったりします。 PCの主な構成は以下の通りです。 M/B: ECS L4S5A/DX+ CPU: Celeron 1.7GHz RAM: DDR PC2700 256MB VGA: NVIDIA TNT2 M64(AGP 32MB) HDD: Maxtor 6Y060L0 (Primary Master) CD-RW:AOpen4048 (Secondary Master) OS: WIN2000(SP3) デバイスマネージャーで確認すると、 「IDE ATA/ATAPI コントローラー」の 「SiS PCI IDE UDMA Controller」、 「プライマリ IDE チャンネル」は、 共に正常に作動しているのですが、 「プライマリ IDE チャンネル」の「詳細設定」タブで 「デバイス 0」の「転送モード」を 「DMA(利用可能な場合)」にして再起動しても、 「現在の転送モード」が「PIO モード」のままで、 「DMA モード」になりません。 「システム情報」の「ハードウェア リソース」の 「DMAコントローラー」の状態も「OK」になっています。 M/Bに付属のCD-ROMからIDEのデバイスはインストール済みです。 また、BIOS(Phoenix-Award)の「Integrated Peripherals」の 「SIS OnChip IDE Device」の設定は上から、 「Internal PCI/IDE」は「Both」。 「PIO」「UltraDMA」関連はすべて「Auto」。 「IDE DMA Transfer Access」と「IDE Burst Mode」は 「Enaibled」になっています。 DMA転送が可能になっていい筈だと思うのですが、何かアドバイスが ありましたら宜しくお願いします。

  • 転送モードの変更

    すいません、検索しましたがわかりませんでしたので質問します。 PC環境はP4 2.6Gh 512MB XPHomeマシンは8300DELL製です。 デバイスマネージャーでセカンダリIDEのプロパティで見るとデバイス0はウルトラDMA モード2になっていますが、デバイス1はPIOになったままです。 プライマリも同じようになっています。プライマリ、セカンダリいずれも増設をしています。 プライマリはHDD、セカンダリはIOの4040Bドライブをスレーブに(DELLはCS)しています。 セカンダリIDEチャネルを一度削除して再起動もためしてみましたがダメでした。 変更する方法が分かりません。よろしくお願いします。

  • SATAのHDDを増設したらDVDドライブがIOエラー

    M/B ASUS P4C800-Deluxe HDD U-ATA120GB(Master)、U-ATA320GB(Slave)、SATAII 320GB OS Windows2000-SP4(ビッグドライブ対応パッチ適用済み) SATAのHDDを増設したらDVDドライブの読み取りが悪くなりIOエラーが頻発します。(DVDビデオのディスクを開いてみるとVIDEO_TSフォルダしか見えず当然ビデオも再生できない。) Bios設定はIDE Configurationの所でEnhanced Mode>P-ATA+S-ATAにしてあります。 Windows2000のデバイスマネージャで”IDE ATA/ATAPIコントローラ”の所を開くと 82801EB Serial Ultra ATA Storage Controller - 24D1 82801EB Ultra ATA Storage Controller があり プライマリIDEチャネルとセカンダリIDEチャネルが2つずつあります。 DVDはセカンダリなので 一番上のセカンダリIDEチャネルの詳細設定を見ると 転送モード DMA(利用可能な場合) 現在の転送モード Ultra DMAモード となっており 二番目は 転送モード DMA(利用可能な場合) 現在の転送モード 無効 となっていました。 これが原因だと思ったのですがBios設定のどの部分の設定を変えればいいか分かりません。 SATA-HDDを増設する際にBiosの設定を何回も変更して光学ドライブの部分がDisableになったりした事もありました。 SATAのHDDが認識された時点でDVDがおかしくなっていました。 光学ドライブは2台とも同じ症状です。 Master IO DATA ABH16A Slave 松下 LF-D521 分かる方、アドバイスをお願いします。

  • DMA転送になりません

    eitontonと申します。よろしくお願いいたします。 外付けHDDに編集したビデオをAVIで保存後、オーサリングソフトを使って、外付けDVDでビデオDVDを作成しようとしたところ、以下のようなメッセージが出てました。 『My DVDはシステムに接続されている1台以上のレコーディング機器に対してDMAがオフになっていることを検出しました。機器に問題なく書き込むためにDMAをオンにする必要があります。詳細はオペレーティングシステムのマニュアルを参照するか、オンラインヘルプをご覧ください。』 DMA転送に関する質問はいくつかあったので同じようにデバイスマネージャーからIDEチャネルのプロパティを開いて転送モードをDMAに変更しました。 再起動をした後、もう一度IDEチャネルのプロパティを開くと プライマリIDEチャネル デバイス0 転送モード:DMA(利用可能な場合) 現在の転送モード:ウルトラDMAモード4 デバイス1 転送モード:DMA(利用可能な場合) 現在の転送モード:無効 セカンダリIDEチャネル デバイス0 転送モード:DMA(利用可能な場合) 現在の転送モード:PIOモード デバイス1 転送モード:DMA(利用可能な場合) 現在の転送モード:無効 となっています。 やはり、オーサリングソフトを開こうとすると、上記のメッセージが出てDMAモードに変更できていないようです。 DMAモードにする方法を教えていただけないでしょうか。 PC環境は PC:Dynabook:T5/512CME OS:XP/SP2 外付けHDD:BUFFALO HD-HS320U2 外付けDVD:BUFFALO DVM-X16U2 HDD、DVDともにUSB2.0接続 Windows movie Maker で編集後 DVDに同封されていたMyDVDというオーサリングソフトを 開こうとしたらエラーメッセージが出てきました。 ※一度、そのまま書き込みをしたのですが、すぐにフリーズしてしまいました。 子供の成長記録をDVDに残したいと思っているのですが、上手くできずに困っています。よろしくお願いします。

  • IDE転送モードの設定はこれでいいのでしょうか?

    DVD(内蔵)が遅くなったので「教えて」で過去質問を調べたら、IDEの転送モードをDMAへ設定とのアドバイスが目にとまりました。 PIOの場合は削除、再インストールと書いてありました。 私の現在の転送モードは プライマリIDE デバイス0=ウルトラDMAモード5   デバイス1=無効 セカンダリIDE デバイス0=PIOモード         デバイス1=無効 となっており、この場合、プライマリIDEのデバイス0がウルトラDMAモード5になっているから問題はないのでしょうか? IDEやデバイス0、デバイス1の存在もよくわからない初心者ですが教えて下さい。

  • HDおよびDVDドライブへの転送速度について

    使用環境 PC:DELL Dimension5150C OS:Windows XP professional Ver.2002 Service Pack3 のPCでDVDの書き込みが遅いことから色々調べまして,IDEチャンネルの転送モードがPIOモードになっていることがわかりました. しかしながら,このPCの場合,デバイスマネージャーで「IDE ATA/ATAPIコントローラー」の下層には 「Intel(R) 82801G (ICH Family) Ultra ATA Storage Controllers - 27DF」「Intel(R) 82801GR/GH SATA AHCI Controller」「プライマリIDEチャンネル」の3つしか表示されません.通常,プライマリ=HDD,セカンダリ=DVDと説明されますが,「セカンダリIDEチャンネル」というものが存在しません.一度,プライマリIDEチャンネルを削除して,再起動しましたら新たなドライブ(DVD)が見つかりましたと表示が出て,やはりプライマリIDEチャンネルが再インストールされました. この場合,従来のプライマリ=HDD,セカンダリ=DVDドライブが表示されないということは,どこかおかしいのでしょうか? 「プライマリIDEチャンネル」のプロパティでは,デバイス0の転送モードがやはりPIOになっていました.デバイス1は転送モードが無効になっています.さらに強制的に変更するために「regedit」から指定ファイル(HKEY_LOCAL_MACHINE→SYSTEM→CurrentControlSet→Control→Class→{4D36E96A-E325-11CE-BFC1-08002BE10318} )をみていくとそこには「0000」「0003」「0006」「Properties」のフォルダしか見当たりません.通常は,「0001」=「プライマリ」,「0002」=「セカンダリ」だそうです.それぞれのフォルダ内の「DriverDesc」をみると,「0000」=プライマリIDEチャンネル 「0003」=Intel(R) 82801G (ICH Family) Ultra ATA Storage Controllers - 27DF 「0006」=Intel(R) 82801GR/GH SATA AHCI Controller となっていました. 「0000」フォルダに新規DWORD値ファイル「ResetErrorCountersOnSuccess」を作成して値を1にして,再起動. 結果,「プライマリIDEチャンネル」のプロパティでは,デバイス0の転送モードが「ウルトラDMAモード2」になりました.しかし,デバイス1はもとの転送モード「無効」のままです. 質問ですが, Q1.このPCでなぜセカンダリIDEチャンネルがないのか? Q2.ウルトラDMAモード2以上には早く出来ないのか? Q3.デバイス1の転送モードが無効となるのを改善できないのか? 以上についてアドバイスをください.よろしくお願いします.

  • DMAモードとPIOモード

    ATA規格の転送方法には、DMAモードとPIOモードというのがあるそうなんですが、DMAモードとPIOモードの転送速度はどの程度違うんでしょうか? マザーボードの説明書にはマスタにDMAデバイス、スレーブに非DMAデバイスを接続するように記載されていましたが、DMAモードはマスタデバイスのみで使用されるということでしょうか? また、ディスクの転送モードがDMAかPIOかを確認する方法があれば教えてください。

  • ハードディスクの接続、設定について

    自作(ベアボーン)の調子が悪くなり、また当初のHD160GBの容量が足らなくなってきたのでメーカーで調整後500GBのハードディスクを購入、500GBのHDをATA2に接続、元の160GBのHDをスレーブにジャンパーを設定しIDEに接続、DVDドライブは160GBのHDと同じくIDEに接続し WindowsXP を500GBのHDに最初から入れなおしました。 BIOSのブート設定を500GBにして一旦立ち上げても、再起動すると元の160GBが立ち上がってしまいます。 160GBで立ち上がると、500GBが認識されていません。(500GBで立ち上げると160GBは認識されています。 機器の接続方法もしくは設定がおかしいのでしょうか DVDドライブもNeroのドライブチェックでエラーが出てしまいます READ OF SCRAMBLED SECTOR WITHOUT AUTHENTICATION(056F03) 機器構成 マシン Soltec EQ3401MW OS : WindowsXP PRO sp2 HDD(1) WD5000AAKS (500G SATA300 7200) HDD(2) Deskstar7K250/160GB DVDRAM GSA-4082B デバイスマネージャー IDE ATA/ATAPIコントローラ (1)Intel(R)80801EB Ultra ATA Storage Controllers (2)Intel(R)80801EB Ultra ATA Storage Controllers (3)セカンダリ IDE チャネル (4)セカンダリ IDE チャネル (5)プライマリ IDE チャネル (6)プライマリ IDE チャネル (1)場所:PCI バス 0, デバイス 31, 機能 2・・・HDドライブ (2)場所:PCI バス 0, デバイス 31, 機能 1 (3)現在の転送モード「ウルトラDMAモード2」・・・DVDドライブ (4)現在の転送モード「ウルトラDMAモード5」・・・(HDドライブ) (5)現在の転送モード「無効」 (6)現在の転送モード「無効」 IDEチャネルがプライマリ、セカンダリとも2つづつありますが、これはおかしいのでしょうか、よろしくお願いします。

  • IDEチャネルの転送モード表示

    いわゆるPIO病の確認に、デバイスマネージャのプライマリ/セカンダリ IDEチャネルの「詳細設定」内にある、現在の転送モードを見ろ、というのがありますが、これは私の場合で3つづつあります。 複数のドライブがつながっている場合、どのドライブがPIOになっているのか、確実に特定するには、どうすればいいのでしょう? それと現在、ウルトラDMAモード1になっているものがあるのですが、これは、故障なのかどうなのか、どう考えればいいんでしょうか?いつもはそんな表示は出ていませんでした。

  • HDDがPIOモードで認識される

    HDDがPIOモードでしか認識されません。 東芝のdynabookTX TX/450DSを使っているのですが、HDDがPIOモードでしか認識されないようになりました。 BIOSを見てもIDEcontolerはEnhanced IDEがENABLEになっていますが、デバイスマネージャのプライマリIDEチャンネルは転送モードをDMA(利用可能な場合)にしていますが現在の転送モードはPIOになっています。 また、セカンダリのほうはウルトラDMAモード2になっています。 HDDをDMAモードで認識させる方法はないでしょうか?