• ベストアンサー
  • 困ってます

ハードディスクの接続、設定について

自作(ベアボーン)の調子が悪くなり、また当初のHD160GBの容量が足らなくなってきたのでメーカーで調整後500GBのハードディスクを購入、500GBのHDをATA2に接続、元の160GBのHDをスレーブにジャンパーを設定しIDEに接続、DVDドライブは160GBのHDと同じくIDEに接続し WindowsXP を500GBのHDに最初から入れなおしました。 BIOSのブート設定を500GBにして一旦立ち上げても、再起動すると元の160GBが立ち上がってしまいます。 160GBで立ち上がると、500GBが認識されていません。(500GBで立ち上げると160GBは認識されています。 機器の接続方法もしくは設定がおかしいのでしょうか DVDドライブもNeroのドライブチェックでエラーが出てしまいます READ OF SCRAMBLED SECTOR WITHOUT AUTHENTICATION(056F03) 機器構成 マシン Soltec EQ3401MW OS : WindowsXP PRO sp2 HDD(1) WD5000AAKS (500G SATA300 7200) HDD(2) Deskstar7K250/160GB DVDRAM GSA-4082B デバイスマネージャー IDE ATA/ATAPIコントローラ (1)Intel(R)80801EB Ultra ATA Storage Controllers (2)Intel(R)80801EB Ultra ATA Storage Controllers (3)セカンダリ IDE チャネル (4)セカンダリ IDE チャネル (5)プライマリ IDE チャネル (6)プライマリ IDE チャネル (1)場所:PCI バス 0, デバイス 31, 機能 2・・・HDドライブ (2)場所:PCI バス 0, デバイス 31, 機能 1 (3)現在の転送モード「ウルトラDMAモード2」・・・DVDドライブ (4)現在の転送モード「ウルトラDMAモード5」・・・(HDドライブ) (5)現在の転送モード「無効」 (6)現在の転送モード「無効」 IDEチャネルがプライマリ、セカンダリとも2つづつありますが、これはおかしいのでしょうか、よろしくお願いします。

共感・応援の気持ちを伝えよう!

  • 回答数3
  • 閲覧数169
  • ありがとう数3

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.3

下記URLのベアボーンでしょうか。 http://www.owltech.co.jp/products/bb/EQ3401300P/eq3401300p.html EIDEは2chあるようなので、プライマリとセカンダリが二つづつ存在するのは問題ありません。IDEデバイスなら4台まで接続可能です。また、S-STAも2chありますので、500GB S-ATAII(S-ATAIでの動作になる)の接続も問題ないと思います。 参考URLはAOpenのものですが、ICH5RでS-ATA HDDとIDE HDDを混在させる場合、BIOSでの設定が必要のようです。 <Combined Mode> P-ATAのどちらかのチャンネルを潰して、S-ATAを割り当てるモードです。最大でS-ATAを2台、P-ATAを2台認識をさせることができます。プライマリ、セカンダリのどちらかに割り当てることにより、P-ATAと同じ働きとなり、起動ドライブとしても使用することができます。[Serial ATA Port0 Mode]は[Primary Master / Primary Slave / Secondary Master / Secondary Slave]が選択可能で。Port1 Modeは、同一チャンネルに引っ張られます。 例えばPort0をPrimary Slaveに設定するとPort1はPrimary Masterになります。 BIOSの設定内容が違う可能性もありますが、Combined Modeを選択して500GBを起動の上位にすれば行けそうに思いますが、M/Bの取扱説明書等で確認してみてください。

参考URL:
http://aopen.jp/tech/faq/mb/ich5.html

共感・感謝の気持ちを伝えよう!

質問者からのお礼

現在単身赴任中でなかなか家に帰れず、お礼が遅くなってすみません やっとアドバイスに従って設定をやり直したところ正常に戻ったようです。ありがとうございました。

関連するQ&A

  • DMAに設定を変更できません

    内蔵のDVDドライブがいつのまにかPIOモードになっており、デバイスマネージャーでDMAモードに変更ができません 現在の環境は WindowsXP sp2 BIOS AMI マシン:Soltek DVD-D LG電子 GSA-4167B(IDEセカンダリマスターに設定) 現在のデバイスマネージャーのIDEコントローラーのセカンダリIDEチャンネルのプロパティを開くと、デバイス0のデバイスの種類は「自動検出」(グレー表示で選択不可)、転送モードは「DMA(転送可能な場合)」、現在の転送モードは「PIOモード」となっています。 プライマリIDEチャネルの転送モードはウルトラDMAモード5に設定されています どうしたらDMA転送に変更できるでしょうか よろしくお願いします

  • 増設HDDの転送モードがDMAにならない

    増設したHDDの転送モードがDMAになりません。 このサイトなどの関連する情報を元に色々試しましたがだめでした。 (レジストリ操作、IDEチャネルドライバの削除など) ケーブルも問題ありません。 プライマリのデバイス0のHDDはDMA5動いているのですが スレーブに設定してあるデバイス1のHDDはPIOモードです。 増設したHDDもDMA5で動かすにはどうしたらよいのでしょうか? 現在の環境は以下の通りです。 M/B Name INTEL 875P Processor Intel(R) Pentium(R) 4 CPU 2.60GHz VideoCard 128 DDR ATI Radeon 9800 Resolution 1280x1024 (32Bit color) Memory 523,260 KByte OS WindowsXP Home SP1 Intel(R) 82801EB Ultra ATA Storage Controllers プライマリ IDE チャネル IC35L120AVV207-1 <= DMA5で動作中 ST3120026A      <= PIOで動作中 <=これをDMAで動かしたい Intel(R) 82801EB Ultra ATA Storage Controllers セカンダリ IDE チャネル _NEC DVD+RW ND-1100A

  • IDE転送モードの設定はこれでいいのでしょうか?

    DVD(内蔵)が遅くなったので「教えて」で過去質問を調べたら、IDEの転送モードをDMAへ設定とのアドバイスが目にとまりました。 PIOの場合は削除、再インストールと書いてありました。 私の現在の転送モードは プライマリIDE デバイス0=ウルトラDMAモード5   デバイス1=無効 セカンダリIDE デバイス0=PIOモード         デバイス1=無効 となっており、この場合、プライマリIDEのデバイス0がウルトラDMAモード5になっているから問題はないのでしょうか? IDEやデバイス0、デバイス1の存在もよくわからない初心者ですが教えて下さい。

その他の回答 (2)

  • 回答No.2
  • char2nd
  • ベストアンサー率34% (2685/7757)

 基本的にブートデバイスとなるHDDはプライマリ側のMASTERに接続します。オンボードコネクタで云えばATA1の方です。  BIOSでブートさせるデバイスの順番を設定し直すか、IDEケーブルの接続を入れ替えるかのどちらかでしょうね。後者の方が、後々のことを考えても確実だと思います。  それと、HDDと光学ドライブは同一のケーブルに繋がない方がよいです。つまり、もともとあった方のHDDはプライマリ側のSLAVEに接続する、ということです。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ありがとうございます ATA1につなぎなおしてやって見ます

  • 回答No.1

500GBのHDDをプライマリマスターに、160GBをプライマリスレーブに接続してください。 BIOSでHDDの順位を500GBのHDDを1位にしてやれば、500GBのほうから立ち上がります。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ありがとうございます ためしてみます

関連するQ&A

  • HDDの転送速度がDMAにならないのですが・・・

    OS:windowsXP HDD:Maxtor 5T040H4 Maxtor 6Y160L0 上記の物を使用しているのですが、デバイスマネージャーで確認してみたところHDDは二つとも、標準デュアルチャネルPCI IDEコントローラーのプライマリIDEチャネルに接続されていて、プロパティーを開き詳細設定で転送モードをデバイス0、1共にDMAにしているのですが、現在の転送モードが二つともPIOモードのままなのですがDMAにすることは出来ないのでしょうか? 他にも、Intel(R) 82801FB Ultra ATA Storange Controllers-2651と Intel(R) 82801FB/FBM Ultra ATA Storange Controllers-266Fがあり、前者には、何も接続されていなく、後者の方のプライマリにはDVDドライブが接続されていて、こちらはプロパティの転送モードはDMAで、現在の転送モードもウルトラDMAモード2となっているのですが、HDDの方もこのようにはならないのでしょうか? どうか回答の方よろしくお願いします。

  • IDEチャネルの転送モード表示

    いわゆるPIO病の確認に、デバイスマネージャのプライマリ/セカンダリ IDEチャネルの「詳細設定」内にある、現在の転送モードを見ろ、というのがありますが、これは私の場合で3つづつあります。 複数のドライブがつながっている場合、どのドライブがPIOになっているのか、確実に特定するには、どうすればいいのでしょう? それと現在、ウルトラDMAモード1になっているものがあるのですが、これは、故障なのかどうなのか、どう考えればいいんでしょうか?いつもはそんな表示は出ていませんでした。

  • IDE ATA/ATAPIコントローラーについて

    OSはXPのSP2で、ASUSのP4P800 SEというマザーボードを使っており、このたびS-ATAのHD(Hitachi HDT725032VLA360 320GB )を増設しました。 それに以前使っていたIDEのプライマリに二つのHD(Maxtor 4R120L0)がつながっており、セカンダリはDVDドライブ(PLEXTOR DVDR PX-760 )が一つ付いています。 今まで気にしてなかったのですが、ディバイスマネージャで見てみると ■「プライマリIDEチャンネル」が二つあり、 一つ目は「デバイス0」の転送モードが「ウルトラDMA モード5」になっており、「デバイス1」の転送モードが「無効」になってます。 二つ目は「デバイス0と1」ともに転送モードが「ウルトラDMA モード6」になています。 ■「セカンダリIDEチャンネル」も二つあり、 一つ目は「デバイス0、1」の転送モードが「無効」になってます。 二つ目は「デバイス0」の転送モードが「ウルトラDMA モード2」になっており、「デバイス1」の転送モードが「無効」になってます。 ■「Intel(R) 82801EB Ultra ATA Storage Contr ollers」というのも二つあります。これがS-ATAのデバイスなのでしょうか? この状態で正常に動いているのか教えてください。 最近OSの立ち上がりがとても重く感じ、アプリを使うまでの待ち時間が長くなったように感じています。

  • I/Oデバイスエラーと出てCDが読み込めません

    音楽CDを読み込みたいのですが、入れてもカコカコ音がするばかりで読み込んでくれません。マイコンピュータからGドライブを開こうとするとI/Oデバイスエラーが出て開けません。特定のCDのみでこうなり、他のCDだとすんなり読み込めます。 調べてみたところ、デバイスマネージャのプライマリ IDE チャネル・セカンダリ IDE チャネル両方のデバイス1の「現在の転送モード」が「無効」になっているのが原因ではないかと判断したのですが、既に「DMA (利用可能な場合)」になっており、設定し直しても回復しませんでした。 (1)「現在の転送モード」が「無効」になっているのが原因なのでしょうか? (2)どうすればCDを読み込めるようになるでしょうか? どなたか教えてくれませんでしょうか?

  • DVD再生時に映像のコマ切れ

    DVDを焼き、いくつかのDVDを再生してみると何枚かに再生中のコマ切れを発見しました。 早送りをしてみても全く動かない状態になってしまい コンピューターのIDE転送モードの確認をしてみたところ セカンダリIDEチャネル(デバイス0、デバイス1共に) <デバイスの種類>  自動検出 <転送モード>    DMA(利用可能な場合) <現在の転送モード> 無効 プライマリIDEチャネル ・デバイス0 <デバイスの種類>  自動検出(選択不可) <転送モード>    DMA(利用可能な場合) <現在の転送モード> ウルトラDMAモード2 ・デバイス1 <デバイスの種類>  自動検出 <転送モード>    DMA(利用可能な場合) <現在の転送モード> 無効 このような状態になっていました。 現在の転送モードが“無効”ということは 転送モードはきちんとDMAにはなっていないということですよね? だとすれば、DMAモードにするには何か方法はありますでしょうか。 長文で読みづらいかとは思いますがご返答お待ちしております。

  • PIOモード病の判定方法

    「PIOモード病」というのがあることを知りました。 早速、ディスクアクセスが遅いような気がしている自分のPCも調べたのですが、 プライマリIDEチャネル  転送モード:DMA(利用可能な場合)  現在の転送モード:ウルトラDMAモード セカンダリIDEチャネル  転送モード:PIOのみ  現在の転送モード:PIOモード となっていました。 プライマリは問題なさそうですが セカンダリは「PIOモード」になってしまっています。 或るページによると、 &#8203;http://inspiron1720.seesaa.net/article/56001181.html&#8203; PIO病かどうかはデバイスマネージャ、設定が「DMA(利用可能な場合)」となっているにもかかわらず「現在の転送モード」が「PIO」となっているかどうかで確認できます。 とあったのですが、  転送モード:PIOのみ  現在の転送モード:PIOモード となっている場合は問題ないという理解でよいのでしょうか? 専門家の方教えてください。

  • HDおよびDVDドライブへの転送速度について

    使用環境 PC:DELL Dimension5150C OS:Windows XP professional Ver.2002 Service Pack3 のPCでDVDの書き込みが遅いことから色々調べまして,IDEチャンネルの転送モードがPIOモードになっていることがわかりました. しかしながら,このPCの場合,デバイスマネージャーで「IDE ATA/ATAPIコントローラー」の下層には 「Intel(R) 82801G (ICH Family) Ultra ATA Storage Controllers - 27DF」「Intel(R) 82801GR/GH SATA AHCI Controller」「プライマリIDEチャンネル」の3つしか表示されません.通常,プライマリ=HDD,セカンダリ=DVDと説明されますが,「セカンダリIDEチャンネル」というものが存在しません.一度,プライマリIDEチャンネルを削除して,再起動しましたら新たなドライブ(DVD)が見つかりましたと表示が出て,やはりプライマリIDEチャンネルが再インストールされました. この場合,従来のプライマリ=HDD,セカンダリ=DVDドライブが表示されないということは,どこかおかしいのでしょうか? 「プライマリIDEチャンネル」のプロパティでは,デバイス0の転送モードがやはりPIOになっていました.デバイス1は転送モードが無効になっています.さらに強制的に変更するために「regedit」から指定ファイル(HKEY_LOCAL_MACHINE→SYSTEM→CurrentControlSet→Control→Class→{4D36E96A-E325-11CE-BFC1-08002BE10318} )をみていくとそこには「0000」「0003」「0006」「Properties」のフォルダしか見当たりません.通常は,「0001」=「プライマリ」,「0002」=「セカンダリ」だそうです.それぞれのフォルダ内の「DriverDesc」をみると,「0000」=プライマリIDEチャンネル 「0003」=Intel(R) 82801G (ICH Family) Ultra ATA Storage Controllers - 27DF 「0006」=Intel(R) 82801GR/GH SATA AHCI Controller となっていました. 「0000」フォルダに新規DWORD値ファイル「ResetErrorCountersOnSuccess」を作成して値を1にして,再起動. 結果,「プライマリIDEチャンネル」のプロパティでは,デバイス0の転送モードが「ウルトラDMAモード2」になりました.しかし,デバイス1はもとの転送モード「無効」のままです. 質問ですが, Q1.このPCでなぜセカンダリIDEチャンネルがないのか? Q2.ウルトラDMAモード2以上には早く出来ないのか? Q3.デバイス1の転送モードが無効となるのを改善できないのか? 以上についてアドバイスをください.よろしくお願いします.

  • PIOモードでしか起動できない。

    こんばんは^^ PCのHDDについて困っているのですがどなたかご教授ください>< PIOモードを直そうと思い、いろいろと調べ、まずはデバイスマネージャからのプライマリIDEチャネルのほうを削除したのですが、そうした場合再起動した際にブルースクリーンになり起動が不可になってしまいます。 設定自体もDMA(可能な場合)のほうにしていますが転送モードはPIOモードのままです。 つぎは、レジストリの書き換えもしましたが、前回と同様に、 ブルースクリーンになってしまい起動ができない状況になります。 セカンダリIDEチャネルのほうは正常にDMAで動作しています。 またプライマリのデバイス0のみPIOモードです。 デバイス1はDMAモードで動いています。(HDDは2台です。) どなたかDMAモ^ドに戻すための方法をご教授いただけないでしょうか? よろしくお願いいたします。

  • ノートPCでブランクDVDを読み取れない・・・

    ノートPCでブランクDVDを読み取れなくなってしまいました・・・。ノートPCでブランクDVDを読み取れなくなってしまいました・・・。 ディスクをドライブに入れても反応しないため、マイコンピュータで該当ドライブをダブルクリックすると「I/O デバイスエラーが発生したため、要求を実行できませんでした。」とエラーメッセージが表示されます。ここ1年はほとんどDVDドライブを使用していなかったのですが、1年前までは問題なく使用できました。メディアもその時に使用していたメーカーと同じものです。また、試しに市販されているDVDソフトを入れてみたところ、普通に再生できました。おそらく何かの設定の問題なのかと思いますが、どなたか解決法をご存知の方教えていただけますと助かります。ちなみに、当方の環境は以下の通りです。 PC:SHARP PC-XG50J OS:Windows XP DVDドライブ:MATSHITA DVD-RAM UJ-840S また、デバイスマネージャのプライマリIDEチャネルとセカンダリIDEチャネルの設定は以下の通りです。(デバイスマネージャとDVDドライブは一度削除してPCを再起動してみましたが、ブランクDVDを認識できませんでした・・・。以下の設定は再起動後の設定です) プライマリIDEチャネル デバイス 0 デバイスの種類:自動検出(グレーがかっていて選択できません) 転送モード:DMA 現在の転送モード:ウルトラ DMA モード5 デバイス1 デバイスの種類:自動検出 転送モード:DMA 現在の転送モード:無効 セカンダリIDEチャネル デバイス 0 デバイスの種類:自動検出(グレーがかっていて他に選択できません) 転送モード:DMA 現在の転送モード:ウルトラ DMA モード2 デバイス1 デバイスの種類:自動検出 転送モード:PIOのみ 現在の転送モード:無効 以上です。 よろしくお願いいたします。

  • 転送モードの変更

    すいません、検索しましたがわかりませんでしたので質問します。 PC環境はP4 2.6Gh 512MB XPHomeマシンは8300DELL製です。 デバイスマネージャーでセカンダリIDEのプロパティで見るとデバイス0はウルトラDMA モード2になっていますが、デバイス1はPIOになったままです。 プライマリも同じようになっています。プライマリ、セカンダリいずれも増設をしています。 プライマリはHDD、セカンダリはIOの4040Bドライブをスレーブに(DELLはCS)しています。 セカンダリIDEチャネルを一度削除して再起動もためしてみましたがダメでした。 変更する方法が分かりません。よろしくお願いします。