• ベストアンサー
  • 困ってます

HDDがDMA転送モードにならない

HDDがDMA転送モードにならず、そのせいか、タスクマネージャーで モニターするとCPUに負担が掛かっていることが多く、全体のパフォ ーマンスが悪いようです。ウインドウを数個開くと、反応が遅くな ったり、動画再生が途切れ途切れになったりします。 PCの主な構成は以下の通りです。 M/B: ECS L4S5A/DX+ CPU: Celeron 1.7GHz RAM: DDR PC2700 256MB VGA: NVIDIA TNT2 M64(AGP 32MB) HDD: Maxtor 6Y060L0 (Primary Master) CD-RW:AOpen4048 (Secondary Master) OS: WIN2000(SP3) デバイスマネージャーで確認すると、 「IDE ATA/ATAPI コントローラー」の 「SiS PCI IDE UDMA Controller」、 「プライマリ IDE チャンネル」は、 共に正常に作動しているのですが、 「プライマリ IDE チャンネル」の「詳細設定」タブで 「デバイス 0」の「転送モード」を 「DMA(利用可能な場合)」にして再起動しても、 「現在の転送モード」が「PIO モード」のままで、 「DMA モード」になりません。 「システム情報」の「ハードウェア リソース」の 「DMAコントローラー」の状態も「OK」になっています。 M/Bに付属のCD-ROMからIDEのデバイスはインストール済みです。 また、BIOS(Phoenix-Award)の「Integrated Peripherals」の 「SIS OnChip IDE Device」の設定は上から、 「Internal PCI/IDE」は「Both」。 「PIO」「UltraDMA」関連はすべて「Auto」。 「IDE DMA Transfer Access」と「IDE Burst Mode」は 「Enaibled」になっています。 DMA転送が可能になっていい筈だと思うのですが、何かアドバイスが ありましたら宜しくお願いします。

共感・応援の気持ちを伝えよう!

  • 回答数4
  • 閲覧数373
  • ありがとう数5

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.3

私もuyoku007さんと同様で、マザーはATA133・HDDはATA100対応なのに「プライマリIDEチャンネル」の転送モードは「PIOモード」として認識されていました。 そこで、下記のことを実行したら「ウルトラDMAモード5」として認識してくれました。 1.デバイスマネージャ上からセカンダリIDEチャンネルを削除 2.デバイスマネージャ上からプライマリIDEチャンネルを削除 3.再起動を要求されるので再起動 4.OSが起動し、デバイスドライバが勝手にインストールされる 5.再起動を要求されるので再起動 6.確認すると「ウルトラDMAモード5」になっていた 私の場合はXP(SP1)+VIAなのですが、4in1ドライバ(ver.4.45)のインストールやデバイスマネージャ上の「VIA Bus Master IDE Controller」だけを削除した場合は何度やっても「PIOモード」のままでした。 SiSの場合に当てはまるかわかりませんが一度トライしてみてはいかがでしょう?

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご丁寧な回答を有り難うございます。 ご指摘の順序で試してみました。IDEデバイスの再認識は 問題なくされるのですが、「PIO モード」はやはり改善 されませんでした。 IDEドライバーをアンインストールしてから再インストール もやってみたのですが、効果はありませんでした。 私のPC知識では、あとはクリーンインストールくらいしか、 試みてみる事が思いつかないのですが、もしまた何かあり ましたら宜しくお願い致します。

関連するQ&A

  •   DMA PIO  ドライブ転送モード

    http://www.iodata.jp/support/advice/dvr-abn4p/setup1.htm http://www.iodata.jp/support/advice/dvr-abn4p/setup4.htm 上記にDVDファームアップデートには 接続しているデバイスの転送モードを「DMA」から「PIO」に変更します  とあります [IDE ATA/ATAPI コントローラ]-[セカンダリIDEチャンネル](ドライブが接続しているチャンネル)をダブルクリックします。 ドライブが接続しているチャンネルがわかりません セカンダリ 詳細設定タブ  現在の転送モード PIOモード(デバイス0)デバイス1無効 プライマリ  現在の転送モード デバイス0 1共に無効なのでセカンダリに接続されていると考えていいですか? 2 「接続しているデバイスの転送モードを「DMA」から「PIO」に変更します」とあります。そして ファームアップデート実行してからDMAに戻すとあります ただ私のPCの設定では初めからPIOです ファームアップデートしてからDMAに戻す必要ありますか? 転送モードをDMA(利用可能な場合)に変更しても その下の現在の転送モードはPIOモードでかわりません 再起動などはしてませんが・・・ 関係あるかわかりませんが・・・・ MB  A8N SLI premium XPインストール初めは店でやってもらいました ちょっとここはあやふやなんですが 1回ファームアップデートやりました 上記URLその時は知らずに何もしないで実行しました その後しばらくして上記URL見つけて調べたらDMAだったような気がします ファームアップデート失敗でした その後XP再インストールしました NCQ使うには確か nforceドライバー??が必要とわかりそれを入れてます 店でやってもらった時はいれてなかったようです(=NCQ使えてない状態)

  • HDDの転送速度がDMAにならないのですが・・・

    OS:windowsXP HDD:Maxtor 5T040H4 Maxtor 6Y160L0 上記の物を使用しているのですが、デバイスマネージャーで確認してみたところHDDは二つとも、標準デュアルチャネルPCI IDEコントローラーのプライマリIDEチャネルに接続されていて、プロパティーを開き詳細設定で転送モードをデバイス0、1共にDMAにしているのですが、現在の転送モードが二つともPIOモードのままなのですがDMAにすることは出来ないのでしょうか? 他にも、Intel(R) 82801FB Ultra ATA Storange Controllers-2651と Intel(R) 82801FB/FBM Ultra ATA Storange Controllers-266Fがあり、前者には、何も接続されていなく、後者の方のプライマリにはDVDドライブが接続されていて、こちらはプロパティの転送モードはDMAで、現在の転送モードもウルトラDMAモード2となっているのですが、HDDの方もこのようにはならないのでしょうか? どうか回答の方よろしくお願いします。

  • DMAに設定を変更できません

    内蔵のDVDドライブがいつのまにかPIOモードになっており、デバイスマネージャーでDMAモードに変更ができません 現在の環境は WindowsXP sp2 BIOS AMI マシン:Soltek DVD-D LG電子 GSA-4167B(IDEセカンダリマスターに設定) 現在のデバイスマネージャーのIDEコントローラーのセカンダリIDEチャンネルのプロパティを開くと、デバイス0のデバイスの種類は「自動検出」(グレー表示で選択不可)、転送モードは「DMA(転送可能な場合)」、現在の転送モードは「PIOモード」となっています。 プライマリIDEチャネルの転送モードはウルトラDMAモード5に設定されています どうしたらDMA転送に変更できるでしょうか よろしくお願いします

その他の回答 (3)

  • 回答No.4
  • kabasan
  • ベストアンサー率44% (264/588)

IDEドライバを付属CDのものではなく、最新版をダウンロードしてみては?

共感・感謝の気持ちを伝えよう!

質問者からのお礼

MaxstorのHDDはATA133なのですが、M/BもATA133に対応しているので、 私はDMAモード転送も問題ないと思っていました。しかし「UDMA133」は 「モード6」になるようで、「UDMA100(=モード5)」までしかサポート していないこのM/Bでは、「PIOモード4」でしか認識されないようです。 大変お騒がせして申し訳ありませんでした。色々なアドバイスを頂き、 有り難うございました。

質問者からの補足

私もそう思い、先日、メーカー(日本エリートグループ)のサイトを 見たのですが、同マザー用の新しいドライバはなく、添付されて いるモノが最新版のようなのです。 再度、確かめるつもりですが、今朝からメーカーサイトにアクセス 不可の状態が続いていて。

  • 回答No.2
  • Mitz
  • ベストアンサー率65% (2863/4366)

一度デバイスマネージャ上の「SiS PCI IDE UDMA Controller」を右クリックして、削除してから再起動してみてください。 私は仕事で組んだインテルチップマシンで同じ状況に陥った事がありますが、「削除⇒再起動」で正常になりました。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

お返事有り難うございます。 「削除⇒再起動」でIDEデバイスは問題なく再認識されるのですが、 転送モードはやはり「PIO」のままです。この方法は試していなかった ので、私も修正できるかと期待したのですが。 PC2700が使え、USB2対応で6980円のバーゲンプライスに釣られて 購入したマザーですが、素直にIntelチップにしておけばよかったかも しれません。(^_^;)

  • 回答No.1

自分のパソコンも2度ほど同じような状態になったことがあるのですが、その時は、 ○ハードディスクが物理的に損傷し始めている ○マザーボードとハードディスクをつなぐケーブルが微妙に劣化している が原因でした。ハードディスクを取り替えたりして、マザーボードとハードディスクをつなぐケーブルを何度かいじっているなら、それが原因かもしれません。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

早速のお返事、どうも有り難うございます。 マザーもHDDも一応新品で購入し、数日前に組み立てました。 ピンの曲がりや欠損も含め再度確認し、念のためIDEケーブルも 交換して、改めて繋ぎ直してみましたが、やはり変わりませんでした。 しかし、目視では分からない何らかの不良があるのかもしれません。 あと、 「M/Bに付属のCD-ROMからIDEの『デバイス』はインストール済みです。 」は、 「M/Bに付属のCD-ROMからIDEの『ドライバ』はインストール済みです。 」の 間違いでした。訂正しておきます。

関連するQ&A

  • IDE転送モードの設定はこれでいいのでしょうか?

    DVD(内蔵)が遅くなったので「教えて」で過去質問を調べたら、IDEの転送モードをDMAへ設定とのアドバイスが目にとまりました。 PIOの場合は削除、再インストールと書いてありました。 私の現在の転送モードは プライマリIDE デバイス0=ウルトラDMAモード5   デバイス1=無効 セカンダリIDE デバイス0=PIOモード         デバイス1=無効 となっており、この場合、プライマリIDEのデバイス0がウルトラDMAモード5になっているから問題はないのでしょうか? IDEやデバイス0、デバイス1の存在もよくわからない初心者ですが教えて下さい。

  • 増設HDDの転送モードがDMAにならない

    増設したHDDの転送モードがDMAになりません。 このサイトなどの関連する情報を元に色々試しましたがだめでした。 (レジストリ操作、IDEチャネルドライバの削除など) ケーブルも問題ありません。 プライマリのデバイス0のHDDはDMA5動いているのですが スレーブに設定してあるデバイス1のHDDはPIOモードです。 増設したHDDもDMA5で動かすにはどうしたらよいのでしょうか? 現在の環境は以下の通りです。 M/B Name INTEL 875P Processor Intel(R) Pentium(R) 4 CPU 2.60GHz VideoCard 128 DDR ATI Radeon 9800 Resolution 1280x1024 (32Bit color) Memory 523,260 KByte OS WindowsXP Home SP1 Intel(R) 82801EB Ultra ATA Storage Controllers プライマリ IDE チャネル IC35L120AVV207-1 <= DMA5で動作中 ST3120026A      <= PIOで動作中 <=これをDMAで動かしたい Intel(R) 82801EB Ultra ATA Storage Controllers セカンダリ IDE チャネル _NEC DVD+RW ND-1100A

  • HDDがPIOモードで認識される

    HDDがPIOモードでしか認識されません。 東芝のdynabookTX TX/450DSを使っているのですが、HDDがPIOモードでしか認識されないようになりました。 BIOSを見てもIDEcontolerはEnhanced IDEがENABLEになっていますが、デバイスマネージャのプライマリIDEチャンネルは転送モードをDMA(利用可能な場合)にしていますが現在の転送モードはPIOになっています。 また、セカンダリのほうはウルトラDMAモード2になっています。 HDDをDMAモードで認識させる方法はないでしょうか?

  • セカンダリIDEチャネルのDMAモードへの変更

    マイコンピュータ - プロパティ - ハードウエア - デバイスマネジャー - IDE ATA/ATAPIコントローラ - セカンダリIDEチャネル - 詳細設定 と操作してきて、 デバイス0が転送モード(T):PIOのみ、現在の転送モード(C):PIOモードとなっているものを、転送モード(T):DMA(利用可能な場合)にして、 再起動しても、現在の転送モード(C)は、PIOモードのままです。 どうしたら、現在の転送モード(C)がDMAモードになるか、教えてください。よろしくお願いいたします。

  • DMAモードとPIOモード

    ATA規格の転送方法には、DMAモードとPIOモードというのがあるそうなんですが、DMAモードとPIOモードの転送速度はどの程度違うんでしょうか? マザーボードの説明書にはマスタにDMAデバイス、スレーブに非DMAデバイスを接続するように記載されていましたが、DMAモードはマスタデバイスのみで使用されるということでしょうか? また、ディスクの転送モードがDMAかPIOかを確認する方法があれば教えてください。

  • DMA転送モードが度々変わるのですが?

    タイトルの通りなのですが、DMA転送モードが起動の度に変わります。 装着しているHDDはATA100の物をプライマリに2基です。起ち上げた直後のBIOSの画面では2基ともDMA5と表示されているのですが、デバイスマネージャIDEチャネル(プライマリ)の詳細設定を見ますと、現在の転送モードが5のときあり、2のときあり、4のときありとまちまちです。デバイス0も1も両方こんな感じです。 同じような経験、対処の方法等ご存じの方がいらっしゃいましたらお願いします。 OSはwindowsXPsp1です。機種はEPSONDIRECT EdiCUBE MX2300ですが、HDDは当初より大容量のものに載せ替えてます。

  • DMA転送になりません

    eitontonと申します。よろしくお願いいたします。 外付けHDDに編集したビデオをAVIで保存後、オーサリングソフトを使って、外付けDVDでビデオDVDを作成しようとしたところ、以下のようなメッセージが出てました。 『My DVDはシステムに接続されている1台以上のレコーディング機器に対してDMAがオフになっていることを検出しました。機器に問題なく書き込むためにDMAをオンにする必要があります。詳細はオペレーティングシステムのマニュアルを参照するか、オンラインヘルプをご覧ください。』 DMA転送に関する質問はいくつかあったので同じようにデバイスマネージャーからIDEチャネルのプロパティを開いて転送モードをDMAに変更しました。 再起動をした後、もう一度IDEチャネルのプロパティを開くと プライマリIDEチャネル デバイス0 転送モード:DMA(利用可能な場合) 現在の転送モード:ウルトラDMAモード4 デバイス1 転送モード:DMA(利用可能な場合) 現在の転送モード:無効 セカンダリIDEチャネル デバイス0 転送モード:DMA(利用可能な場合) 現在の転送モード:PIOモード デバイス1 転送モード:DMA(利用可能な場合) 現在の転送モード:無効 となっています。 やはり、オーサリングソフトを開こうとすると、上記のメッセージが出てDMAモードに変更できていないようです。 DMAモードにする方法を教えていただけないでしょうか。 PC環境は PC:Dynabook:T5/512CME OS:XP/SP2 外付けHDD:BUFFALO HD-HS320U2 外付けDVD:BUFFALO DVM-X16U2 HDD、DVDともにUSB2.0接続 Windows movie Maker で編集後 DVDに同封されていたMyDVDというオーサリングソフトを 開こうとしたらエラーメッセージが出てきました。 ※一度、そのまま書き込みをしたのですが、すぐにフリーズしてしまいました。 子供の成長記録をDVDに残したいと思っているのですが、上手くできずに困っています。よろしくお願いします。

  • PIOモード病の判定方法

    「PIOモード病」というのがあることを知りました。 早速、ディスクアクセスが遅いような気がしている自分のPCも調べたのですが、 プライマリIDEチャネル  転送モード:DMA(利用可能な場合)  現在の転送モード:ウルトラDMAモード セカンダリIDEチャネル  転送モード:PIOのみ  現在の転送モード:PIOモード となっていました。 プライマリは問題なさそうですが セカンダリは「PIOモード」になってしまっています。 或るページによると、 &#8203;http://inspiron1720.seesaa.net/article/56001181.html&#8203; PIO病かどうかはデバイスマネージャ、設定が「DMA(利用可能な場合)」となっているにもかかわらず「現在の転送モード」が「PIO」となっているかどうかで確認できます。 とあったのですが、  転送モード:PIOのみ  現在の転送モード:PIOモード となっている場合は問題ないという理解でよいのでしょうか? 専門家の方教えてください。

  • PIOモードでしか起動できない。

    こんばんは^^ PCのHDDについて困っているのですがどなたかご教授ください>< PIOモードを直そうと思い、いろいろと調べ、まずはデバイスマネージャからのプライマリIDEチャネルのほうを削除したのですが、そうした場合再起動した際にブルースクリーンになり起動が不可になってしまいます。 設定自体もDMA(可能な場合)のほうにしていますが転送モードはPIOモードのままです。 つぎは、レジストリの書き換えもしましたが、前回と同様に、 ブルースクリーンになってしまい起動ができない状況になります。 セカンダリIDEチャネルのほうは正常にDMAで動作しています。 またプライマリのデバイス0のみPIOモードです。 デバイス1はDMAモードで動いています。(HDDは2台です。) どなたかDMAモ^ドに戻すための方法をご教授いただけないでしょうか? よろしくお願いいたします。

  • IDEチャネルの転送モード表示

    いわゆるPIO病の確認に、デバイスマネージャのプライマリ/セカンダリ IDEチャネルの「詳細設定」内にある、現在の転送モードを見ろ、というのがありますが、これは私の場合で3つづつあります。 複数のドライブがつながっている場合、どのドライブがPIOになっているのか、確実に特定するには、どうすればいいのでしょう? それと現在、ウルトラDMAモード1になっているものがあるのですが、これは、故障なのかどうなのか、どう考えればいいんでしょうか?いつもはそんな表示は出ていませんでした。