• 締切済み
  • 暇なときにでも

BIOS設定でSATAモードがAHCIしか無い

最近UEFI対応マザーボード:h110mh-pro-d4を購入しました。 http://www.biostar.com.tw/app/en/mb/introduction.php?S_ID=840 BIOS設定でSATAコントローラを見るとAHCIがデフォルトになっています。 内容(SATA Mode Selection)を確認しても、添付画像のようにAHCIしか選択できません。 ---------- [質問1] AHCIしか設定できないのは最近では一般的なことなのでしょうか。 ---------- SATA HDD(非AFT)を装着してwin10 proをインストールしました。 BIOSでの認識も問題なく、MBR構成 , UEFI構成とも試してみました。 それぞれ、問題なくインストールできて、正常に動作しています。 [質問2] 過去の経験ではSATA HDD(非AFT)の場合はSATA Modeには「IDE互換」を選択してインストールしていました。 最近はAHCIのままでOKなのでしょうか。 ---------- このマザーに別のSATA HDD(AFT)を装着してみました。 BIOSで認識できません。 したがって、何もできない状態です。 SATA HDD(非AFT)を装着すると、もちろんBIOSで正常に認識します。 また、このSATA HDD(AFT)を別のマザーボード(SATA Mode IDE互換が選択できるマザー)に装着すると正常にBIOS認識、正常に動作します。 [質問3] SATA Mode「AHCI」のままSATA HDD(AFT)をBIOS認識できる方法はあるのでしょうか。 それともこのマザーのBIOSがおかしいのでしょうか。 BIOS updateは行なっていません。 ---------- よろしくおねがいいたします。

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数1726
  • ありがとう数2

みんなの回答

  • 回答No.2

[質問1]はそうですね。インテルのCPUだと第7世代(Kaby Lake)以降はWin10(Win10ベースのサーバーOSも含みます)以外のWindowsOSのインストールをサポートしてないですからBIOS(UEFI)でIDE/AHCIを切り替えるような設定を用意する必要性も無いですから。 [質問2]はAFT・非AFTって話とSATAのモードのAHCIは直接関係のない話なので >最近はAHCIのままでOKなのでしょうか。 って言うのは意味がよくわからないです。 [質問3]についてはマザーボードやBIOS(UEFI)の設定なども含めて確認した方が良いかも。軽くマニュアルを見た限りでは特にSATAポートが何かと排他仕様になっているような事は無いですね。 またHDDでメーカーによってはAFTに関係してファームウェアなどを書き替えたりするツールを用意しているような場合がありそれらを使った記憶があるなら元に戻すとかでしょうか。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

SATAモード:AHCIは一般的だということがわかりました。 ありがとうございました。 HDD(AFT)を認識しない件は、わたしのチェック不足でした。 ノッチ付きのSATA信号ケーブルに替えて挿し直したら認識しました。

関連するQ&A

  • AHCIモードによるブルースクリーン

    SSDを新調したついでにIDE互換からAHCIに変更してみようと思ったのですが、うまくいきません。 OSはVista 32bit版を使用しているのですがOSのインストールの途中(インストールの最終処理)でバーが進まなくなりその後ブルースクリーン、スタートアップ修復でも修復できず、OSの再インストールを余儀なくされます。 Vistaの場合はドライバを入れなくても大丈夫だと書いてあったので入れてはいません、また、OSのインストール先選択でもSATA1~6ポートの内のAHCIで作動する1~4ポートは選択することが出来ました。(逆に言うと5~6につないであるHDDは認識しませんでした) また、BIOS上での設定はOSインストール前にIDE互換→AHCIに変更しました。 これはドライバを入れないと途中で落ちてしまうのでしょうか?または、マザーボードの不具合(相性)があるのでしょうか?

  • IDEで使用したHDDをSATAのAHCIモードへ

    IDEで使用したHDDをSATAのAHCIモードへ 追加HDDとして 利用するには? WIN8をSATAのAHCIモードで 使用しています。 で、IDEでXPのシステムの入った HDDが余っているので、バックアップ用にそのHDDを接続しました。 BIOSで 2番目に認識されているのを確認。しかし、WIN8が立ち上がらず。 SATAは 順番の概念がないのと XPも生きているためかと思い、XPのWINDOWSのフォルダーのみリネーム。 これで、WIN8は 立ち上がりましたが、XP時代のディスクトップアイコンが勢ぞろい、タイルにXP時代のソフトすべて表示(叩いても パスが通らないので起き上がりませんが)。 でも、HDD 認識せず・・・(ところが、知識不足で C:に合体されて、容量が増えたかどうか未確認) 追加HDD外して WIN8のシステムの復元で タイルはきれいになりましたが・・・ さて、どこが間違いなのでしょうか。認識させる 儀式が抜けている?? BIOSの SATAコンフィグは AHCI-MODE となっており SATA1以降 6まで HOTPULG DISABLED です。   

  • Vista での IDE互換モードからAHCI モード移行について

    WindowsXP Professional SP2のインストールディスクと、アップグレード版のWindowsVistaBusinessを使って、Vistaをインストールしました。 まず、XPをマザーボード上のSATAポートに接続したSATA HDDにインストールしました。BIOSで選択しておいたのは、IDE互換モードです。(フロッピーでAHCIドライバを読まなくて済むように。) そして、XP上からVistaをアップグレードインストールしました。ここまで、IDE互換モードのままです。 ここで、BIOSのSATA設定をIDE互換からAHCIモードへ変更した場合、今インストールされているVistaは正常に起動するのでしょうか? それとも、XPインストールの時から、AHCIモードにしておく必要がありますか? ちなみに、マザーボードは ASUS P5Q-E、HDDはHGSTのHDP725050GLA360です。 以上よろしくお願いします。

  • 回答No.1
  • 486HA
  • ベストアンサー率45% (1012/2245)

Advanced Host Controller Interface (AHCI) とは、 インテルが策定したSerial ATA (SATA) ホストバスアダプタの インターフェース仕様のことなので至極あたりまえのことです。

参考URL:
https://ja.wikipedia.org/wiki/Advanced_Host_Controller_Interface

共感・感謝の気持ちを伝えよう!

質問者からのお礼

SATAモード:AHCIは一般的だということがわかりました。 ありがとうございました。 HDD(AFT)を認識しない件は、わたしのチェック不足でした。 ノッチ付きのSATA信号ケーブルに替えて挿し直したら認識しました。

関連するQ&A

  • SATAのAHCIモードについて

    初投資しますzeropsです!何分文章を作るのが下手なので不快な表現がありましたら申し訳ございません。 初自作PCを作ったのですがOSを導入する前にSATAのモードをAHCIにしたいのですが、どのサイトでも「BIOSで設定」のみでどこをいじればいいかよくわからないです(;´Д`) 構成はこんな感じです! 【OS】 Windows 7 pro 64bit 【マザーボード】GA-Z68X-UD3H-B3 【HDD】0S03224 【SSD】m4 SSD CT128M4SSD2 【光学ドライブ】  iHAS324-27 一応それらしき物はいじっていみたのですが正しいかどうかわかりません(;´Д`) いじったところ↓ ・BIOS設定画面から「Integrated Peripherals」→「PCH SATA Control Mode」の項目を「AHCI」に設定する。 ・GSATA3 Ctrl Mode を AHCIに設定する。 POSTスクリーンでは画像のように表示されています! また導入前にやっておいた方がいい設定などありましたら教えてもらえると助かります。

  • AHCIモード

    現在のマザーボードは、P55タイプです。(i7 860 Windows7 32ビット) 標準では、IDEモードになっています。 この度、Cドライブのみ、SSD(256GB)にします。 そこで質問です。 マザーボードのBIOSを見ると、標準では、「IDE」なっていますが、「AHCI」に変更出来るようです。 それで、AHCIモードにすると、ソフトなどに、不都合が出るような事はないのでしょうか? 古いソフト、例えばOffice2003とか、WindowsXP時代に購入したソフトなどがあります。どれも、一応Windows7での動作には、問題無いです。 また、BIOSで設定するという事は、他のHDD(2TB×2台 ※2TBはデータ用)も、同じように、AHCIモードで動くという事でしょうか? 自分で調べた範囲では、IDEに比べて、AHCIは、書き込み等が早いぐらいで、トラブルの事はあまり見つけられませんでした。 一応、PCの使用目的は、ネット、メール、Office(2003&2013)、動画編集です。 トラブルは避けたいので、IDEの方が安定しているのなら、IDEでインストールしようかなと思っております。 詳しい方がおみえでしたらよろしくお願いします。

  • BIOSでAHCIモードにするとSATAのDVDから起動できない

     下記の構成で自作し、デフォルトのBIOS設定では問題なく動作しておりますが、BIOSでAHCIモードに設定したところDVDからの起動ができず、First BootDriveをDVDに指定してもHDDから立ち上がってしまいます。IDEモード(デフォルト)では、問題なく動作します。  下記構成でAHCIモードでDVDから起動可能とする方法についてお教えいただければ幸いです。  ※ ハード・ソフト構成  ・GIGABYTE ME-D00(MB:GA-TBLGHM)  ・HDD:HDT25032VLA(SATA 320GB)  ・DVD:GSAH62NBL(LG電子製 SATA)  ・CPU:Core 2 Duo E6750

  • AHCIモードでのHDDの認識について

    初めて自作をするのですが、AHCIモードにてOSがインストールできず困っています。御教授頂けますよう、よろしくお願い致します。 BIOSにて、 SATA RAID/AHCI Mode:Disable SATA Port0-3 Native Mode:Disable の設定にてPCを起動しBIOSのStandard CMOS Featuresを参照すると、 IDE Channel 0 Master [Hitachi HDP725025GLA] IDE Channel 0 Slave [None] IDE Channel 1 Master [None] IDE Channel 1 Slave [None] IDE Channel 2 Master [None] IDE Channel 3 Master [HL-DT-ST DVDRAM GH20] IDE Channel 4 Master [None] IDE Channel 4 Slave [None] であり、OSインストールもインストール開始画面まで問題なく進みます。 しかし、BIOS設定を SATA RAID/AHCI Mode:AHCI SATA Port0-3 Native Mode:Enabled とすると、Standard CMOS FeaturesではどのIDE Channelも[None]となり、BIOSで認識できなくなってしまいます。 起動時の画面(BIOS画面へ移るまでのSATA接続機器を確認する画面)では、 Port-00:Hard Disk,Hitachi HDP725025GLA380 Port-01:No device detected Port-02:No device detected Port-03:No device detected Port-04:No device detected Port-05:CDROM, HL-DT-ST DVDRAM GH20NS10 AHCI BIOS Installed と表示され、認識はされているようです(なぜBIOS画面で表示されないのでしょうか?)。 上記の状態(AHCIモード)にてOSインストールを開始すると、途中でブルー画面となりインストールが止まってしまいます(開始画面までいきません)。 ※OSインストール中に、F6キー押下し、FDDからRAID/SATAドライバをインストールする手順は実施しています(FDはM/B添付のCDから必要ファイルをコピーし作成しました)。 PC構成 CPU :Intel E8200 M/B :GIGABYTE GA-X38-DS4 メモリ :Kingston KVR800D2N5K2/2G(DDR2-800 1G×2枚) グラボ :GIGABYTE GV-NX88T512HP HDD   :HITACHI Deskstar P7K500(HDP725025GLA380) DVD-R/RW :LG電子 GH20NS10 FDD :Owltech FA404MX(B)/BOX 電源 :Owltech Seasonic M12 SS-600HM(600W) PCケース :Antec NINE HUNDRED OS :Windows XP Home edition SP2 ※BIOSはRev.F2へアップデート済 M/B配線状況: SATA0:HDD SATA1~4:なし SATA5:DVD-R/RW AHCIモードにてOSをインストールする為には、他に何か必要な手順が抜けているのでしょうか? よろしくお願い致します。

  • IDE→AHCIについて

    一度、IDEでインストールしたものを AHCIに変更したいのですが、再インストールが必要ですか? BIOSで変えるだけではダメだと思われます。 ハードウェア(マザーボード、HDD)は対応しています。 また、AHCI(NCQ)を有効にしたら体感的に変わるものですか。

  • AHCI Modeの確認方法

    AHCI Modeの確認方法 BIOSでIDEからAHCIに変更したのですが、タスクバーのアイコン 「ハードウェアを安全に取り外してメディアを取り出す」 に、HDDが表示されません。 これは、AHCI Modeになっているのでしょうか? AHCI Modeでも表示されないことがあるのでしょうか? ほかのマザーボードでは表示されます。 マザーボードはMSIのP55-SD50です。

  • BIOSにSATAの項目がなくAHCIにできない。

    LS550を使っているものですが結構前にSSDに交換したのですが、BIOSの設定画面にAHCIにする項目がなく。諦めてそのまま使っていまいしたが、やっぱり納得がいかなく質問させてもらっています。レジストリエディタではAHCIモードに切り替えていて、BIOSの設定をしようとしたら、項目がなく設定できませんでした。デバイスマネージャーのIDE ATA/ATAPIコントローラーにはIntel(R)5 Series 4 Port SATA AHCI Controllerとなっています。この場合BIOSをいじらなくてもAHCIモードになっているのでしょうか?どなたかお解りの方お力を貸してください。 ※OKWAVEより補足:「NEC 121ware :パソコン本体」についての質問です

  • SATAの光学ドライブとAHCI

    マザボP5K-E、OSはXP。AHCIを設定しました。 SATA1~3番にHDD、4~5空けて6番に光学ドライブLG GH20NS10を繋いでます。 どうもDVDの読み込み速度が遅いようなのです。 別途IDE光学ドライブもつないでますが、そちらは大丈夫みたいで。IDE側はJmicronチップが受け持っていてBIOSにてIDE互換にて設定してます。 LGの光学ドライブはAHCIだと不具合を起こすんでしょうか? どなたかお解りになりますか?

  • SATA にOSを・・・

    現在はprimaryIDEマスターにHDD         スレーブにHDD    secondaryIDEマスターに光学ドライブ          スレーブに光学ドライブ    thirdIDEマスターにはなし    fourthIDEにHDD(SATA) になっています(BIOS上) マザーはASUS:P4P800     OS:XPpro です。 今回、SATAにOSをいれたいと思いまして、気になることを質問させていただきます。 もちろん現在BIOSではEnhanced ModeになっていますのでCombined Modeに変えると思いますが。このとき IDEのデバイスはこのまま認識して使用できるのでしょうか??(光学2台とIDEHDD2台とSATA1台)OSをインストールする上で注意点などあればお願いします。

  • BIOSでATA/IDE MODEの設定

    デスクトップパソコンで次の場合のBIOSの設定はどれが良いのか教えてください。 インテルのマザーボードDG33FB ハードディスク HITACHI HDP725025GLA(SATAIIです) BIOSの設定画面のDrive configuration  ATA/IDE MODEが「Legacy」と「Native」のどちらかを選択、「Native」にした場合、Configure SATA asで「IDE」と「AHCI」のどちらかを選択をするようになっています。 現在、「Native」と「IDE」の組み合わせでwindows7をインストールして使っていますが、BIOS画面を見ている時、時々フリーズします。 ATA/IDE「Legacy」に変えてもWINDOWSは普通に動きます。 「Native」+「AHCI」(マザーボード工場出荷時のBIOSの設定)にするとWINDOWS7は起動できません。ただし、WINDOWS7をインストールしなおすと使えるような気がします。 どの設定にすると良いのでしょうか。BIOSの設定画面で時々フリーズするのは設定が間違っているからなのでしょうか。