• ベストアンサー
  • すぐに回答を!

HPが見れない

以前467353の質問をしたLioです 現在 Red Hat7.2 Apache1.3.27 perlはデフォルトインストールのもの 回線速度はISDN64K で運用しています。 LAN経由でサーバーにアクセスすると、問題なくサクサクHPが見れます。 しかし、外部からアクセスすると、 IEの右下のバーがゆっくり動いて、そのうちエラーになります。 (エラーになる場合と、問題なく見れる場合があります。 問題なく見れるときでも、IEの右下バーはMAXまで動いたまま止まって居ます。) バーがゆっくり動いているとき、IEのSTOPボタンを押すと、 部分的にHPが見れることがあります(上半分とか。見れない場合もあります。) アクセスログは正常に200を返しています。 前回ご指摘いただいたDNSも再度見直し、またIPアドレス直接でも 同様の問題が起きている事から、 DNSの問題ではなく、サーバーの問題だと思って居ます。(再インストール直後なのに・・・) 原因と思われる事が思いつくこと何でも良いので 回答お願いします。(三月から実稼動させたいです) 出来る限り設定ファイルなどを補足があれば公開します。 よろしくおねがいします。

  • Lio
  • お礼率44% (46/103)

共感・応援の気持ちを伝えよう!

  • 回答数4
  • 閲覧数277
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.4

ルータでポート塞いでいるのなら ファイアウォールを止めればいいのでは? もしくはファイアウォールとWEBサーバを分離するとか。 アパッチは関係ないような気がする。。。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

御礼が遅くなってしまって申し訳ありません。 ファイアーウォールの設定ミスでした。 いろいろ有難うございます。

関連するQ&A

  • Apacheの問題?HTMLかCGIの問題?Linuxの設定の問題?

    お世話になります。 RedHat7.2でApache/1.3.27をインストールしています。 LAN経由でサーバーにアクセスすると、問題なく表示されるのですが、 外部からアクセスすると、アクセス出来る場合と、なぜか出来ない場合があります。 出来ない場合は、IEの右下の読み込み進度のバーがゆっくりと動いて、じきにDNSエラーになります。 Apacheのアクセスログには、正常に200を返してます。 また、proxy経由アクセスの場合、HTML(Apacheインストールテスト画面以外)が確実に見れません。CGIについては、print"";で記載されたcgiしか実行出来ません。(openなどの関数があると、動きません) いずれの場合もLAN経由では正常に動作します。 バーチャルホストは設定してません。 ipchains -Lは、ACCEPT tcp -y---- anywhere anywhere any -> http となってます。 DNSも正常に設定されています。 当方では何が原因かさっぱり分かりません。 どなたか宜しくお願いします。

  • microsoftのHPが表示されない

    microsoftのHPが表示されない 先日PCを修理に出してHDDを交換し新しい状態で戻ってきたので、 IEやその他アップデートしようと思ったのですがmicrosoftのHPへ接続できません。 「ページを表示できません。 サーバーが見つからないか、DNS エラーです。」 この、よく見る表示が出ます。 その他のページへは問題なくアクセスできるのですが、 microsoftのサイトとアップデートができません。 原因は何でしょうか??

  • 見れないHPがあり困っています。

    infoseekのHP、アドレスにinfoseekが入っているHPが見れません。特にページがないわけでも、混雑しているわけでもないのに、表示に時間がかかり、右下のメーターが半分もいかずに、ページが表示されませんと、出てきます。 インターネットオプションからCookieやファイルを削除してみたり、時間をおいてアクセスをしてみましたが、一向に変わりはありません。どのようにしたら、直るでしょうか? Windows Me IE 6.0 です。

その他の回答 (3)

  • 回答No.3

とりあえずLinuxはおいといて、Windows+ANHTTPDあたりでテストしてみれば何かわかるのでは。

共感・感謝の気持ちを伝えよう!

質問者からの補足

Windows + AnHTTPD + ActivePerl で試して見ました。 問題なく動くようです。 よって サーバーの設定が悪いと思い始めました Apacheなどの再インストールをしてみようと思います。

  • 回答No.2

ルータが80番を通してないとか 内部LANしかアクセス出来ないようになってるとか telnetやftpを試してみるとか システムのログを見てみるとか そんな感じでひとつずつ潰していくしか。

共感・感謝の気持ちを伝えよう!

質問者からの補足

回答有難うございます セキュリティーポリシーで外部からアクセスできるのは25と80だけです。 アクセスログには正常に記録されている事から、ルーターが80を通していると思います。 ルーター設定部分(ルータはオムロンのMT128-NET 1.61) ip filter 1 reject in 0.0.0.0/32 * * * * remote * ip filter 2 reject in 255.255.255.255/32 * * * * remote * ip filter 3 reject in 10.0.0.0-10.255.255.255 * * * * remote * ip filter 4 reject in 172.16.0.0-172.31.255.255 * * * * remote * ip filter 5 reject in 192.168.0.0-192.168.255.255 * * * * remote * ip nat 1 192.168.1.2/*/80 ipcp remote * Linuxのipchainの設定 :input ACCEPT :forward ACCEPT :output ACCEPT -A input -s 0/0 -d 0/0 80 -p tcp -y -j ACCEPT -A input -s 192.168.1.1 53 -d 0/0 -p udp -j ACCEPT -A input -s 0/0 -d 0/0 -i lo -j ACCEPT -A input -s 0/0 -d 0/0 -i eth0 -j ACCEPT -A input -s 0/0 -d 0/0 -p tcp -y -j REJECT -A input -s 0/0 -d 0/0 -p udp -j REJECT 関係すると思われる個所を明示して見ました

  • 回答No.1
  • Spur
  • ベストアンサー率25% (453/1783)

状況が良く分からないのですが、「そのLinuxサーバを外からアクセスすると」ということなのか、「そのLinuxサーバのIEで他のサイトをアクセスすると」ということのどちらでしょうか? 最初の状況なら、設定とかそういう問題ではなく、HTMLの書き方が悪いのじゃないかと思います。 私にも経験がありますが、特にCGIで吐き出した画面などが、やたらに遅かったりします。 ほとんどはHTMLの文法ミスか、<META>タグの日本語コード指定と実際が合っていないとか、そういった問題でした。

共感・感謝の気持ちを伝えよう!

質問者からの補足

早速の回答有難うございます。 説明が悪かったみたいです 外部からLinuxサーバーにアクセスする再に問題が発生します。 文法は多分有っていると思います。 いちようW3勧告のチェックではOKになりますが、心配ですので、一度見て見てください HTMLの場合、 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html lang="ja"> <head> <meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS"> <link rev="made" href="mailto:***@**.**"> <link rel="stylesheet" type="text/css" href="./css/index.html.css"> <title>テストページ</title> </head> <body> CGIの場合 &header(); print << "END"; <h1>TOPページですよ~。</h1> END &footer(); sub header { print << "END"; Content-type: text/html <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html lang="ja"> <head> <meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS"> <title>私のHPです</title> </head> <body> <img src="images/title.gif" alt="title"><br> END } sub footer { print << "END"; <div align="center"><font size="-3">(C)2003 ***.All Rights Reserved.</font></div> </body> </html> END }

関連するQ&A

  • HPがwww.で表示されない。エラー

    お名前.comで独自ドメインを取得し、ロリポップをサーバーで使ってHP運用しています。 HPのアドレスが「http://example.com」では表示されるのに、「http://www.example.com」ではエラーになってしまいます。 これはサーバー側の問題ではなくドメイン側の問題なんでしょうか? 初心者で分かりませんが、ドメイン取得会社でDNSレコードの設定でサブドメインwww.を設定するのですか? ちなみに今DNSレコードのページは空欄です。

  • apacche2のアクセスログ

    apacche2.2.8(CentOS)でサーバを立てたのですが、アクセスログを見るとfirefoxからアクセスしたログが書き込まれません。IEは正常に書き込まれます。 ご存じの方、教えてください。

  • あるHPが見れません

    PCを変えたら、それまで見れていたHPが見れなくなりました。 検索でそのHPをクリックすると 「Webサイトによって、このページの表示を拒否されました」 とでてきます。 詳細情報をクリックしてみると このエラー (HTTP 403 アクセス不可) は、Web サーバーに接続できましたが、この Web ページを表示するアクセス許可がなかったことを意味します。 となっています。 HP管理者に問い合わせてみたら (そのHPを作成している人のブログに問い合わせてみました) ちゃんと見れるはずだ、とのことです。 さっぱりわからないのですが、何をどうしたら、このHPを見ることが できるのでしょうか?

  • 特定のHPの表示が出来ません

    お友達に教えて貰ったHPが見れません。 http://www.jin.ne.jp/herbin/ http://www.jin.ne.jp/bonheur/ http://www.jin.ne.jp/b-ohtani/ タイトルバーには、「サーバーが見つかりません」 本文は、「ページを表示できません 検索中のページは現在、利用できません。Web サイトに技術的な問題が発生しているか、 ブラウザの設定を調整する必要があります。 次のことを試してください : …サーバーが見つからないか、DNS エラーです。」 のエラーが出ます。 もう五日位見れないです。 家はISDNでフレッツで繋いでいます。 IE(5.5)とネットスケープからも試してみましたが見れません。 学校のLANで繋いでいるIE(5.5)からも見れませんでした。 携帯電話(J-Phone)でアドレスを打ち込むと 繋がりました(携帯対応ではないので一部は見れませんが) 何人かのお友達は、キャッシュに残っているのが 見れているだけなのでしょうか? 同じサーバーのところばかりなので、ずっとサーバーが ダウンしてるだけなのでしょうか? 復旧するのを待つしかないのでしょうか。。。

  • 自分のHPだけアクセスできません。

    gooの個人サイトと簡単HPにエラーが出てアクセスできません。 検索によりLOGやTASKなどには何とかアクセスできていましたが、ついにサーバーが見つかりませんとでました。 そして携帯からもアクセスできません。 どうすればいいでしょうか? 本当に困ってます。 どなたか解決に導いてください。

  • 一部のHPにアクセス不可

    ディズニーコンシューマプロダクツのHPにアクセスできなくて、困っています。 URLは &#8203;http://disneyconsumerproducts.com/&#8203; 米国のサーバのようですが、自宅からアクセスした場合は表示されますが、事務所からアクセスすると表示されずに困っています。 ルータ等にフィルタリングは一切しておらず、SSLや通常の閲覧で使用する80番ポートなども開放されています。 (上記のURLにアクセスするとSSL通信のアドレスに転送されるため) 当然、上記のサービス以外のSSL通信は正常に行われており、こちらには問題がないと考えております。 DNS側の問題ではないかと考え、nslookupにて確認しましたが問題なくIPアドレスが取得できています。 tracertしてみたところ途中で 「* * * Request timed out」(16番目付近) となります。 これはプロバイダ側の問題と考えてもいいのでしょうか。 ※ウェブプロクシでログイン画面まで確認できるのですが、ログイン後はプロクシを検地しているのか、サーバエラーとなってしまいます。

  • HPが見られなくなりました

    先日、家のノートパソコンを使用してHPを見ていたところ、 突然回線が途切れ、それ以来ネットに繋がらない状態です。 時間を置いたりデフラグをしたりファイヤーウォールを切ったりしましたが、 全く改善しません。 ・回線はADSL。フレッツ接続ツールで繋いでみると 「プロバイダに接続しました」と表示され、速度表示も出ている。 ・しかしIEやネットゲームを立ち上げてみると、IEでは「ページが見付かりません」、  ゲームは「サーバーとコンタクト出来ません」と表示される。 ・IEのアドレスバーには英語(http://~)も数字(○○.○○.~)も入れたが、  どちらも表示されず。 ・同じ回線を利用して別のパソコンで繋げるときちんと出来る。 (今はそちらから繋いでいます) ・DNSやIPは自動取得設定。(繋がるパソコンも同じ) ・スキャンディスクをやってみたら「問題があるので完了出来ません」と出た。 ・時々「rundll32.exeが正常に終了されていません~」というエラー表示が出る。 ・OSは繋がらない方がXP、繋がる方が95。 似たような質問を見ながら色々試したのですが、どうにもよくなりません。 システムエラーが問題になっているのでしょうか。 ネットゲームのソフトのDL後もちゃんと動いていましたし、 それ以外のDLはしていないのでそちらは関係無いと思うのですが… どなたか対処法を教えて頂けたら幸いです。

    • ベストアンサー
    • ADSL
  • 全ての環境で見れるHPの作り方は?

    今、自分で会社のHPを作成しています。 Win/IE5.0以降とWin/Netscape4.78と7.0でなら 当方の環境で確認することが出来ます。 というよりも、上記の環境で対応していればいいもんだと 思っていました。 だが、数ヶ月分のアクセスログを見ていたところ、 Win/Netscape4.78や、Macでのアクセスが 以外に多いのに気づきました。 以前、Win/IEで見れていたものが、 Mac/IEでは、文字や画像やFLASHが、ずれていました。 今も、Win/Netscape4.78では、めちゃくちゃな表示になってしまっています。 Win/IEとWin/Netscape7.0では、ちゃんと見れています。 HPの作成ソフトは、ホームページビルダー6.5/7.0です。 ある程度の環境でHPを見れるようにするには、 どういうことに気をつけて作成したらいいのでしょうか? また、その辺の事を書いてあるサイトはありますか?

    • ベストアンサー
    • HTML
  • 前に見ることのできたHPが見られない

    あるHP(海外の手芸のデザイナーのHP)が見たいのに、数日前からなぜか、そのページだけが見られなくて困ってます。 『サーバーが見つからないか、DNS エラーです。  Internet Explorer 』と出ます。 ●毎日時間を変えて、試した ●友人に頼んで、そのサイトを見てもらったら、普通に見られた ●ウチにあるDTパソコンとノートパソコン両方とも症状は同じ パソコンは フレッツADSL24M ルータ:ELECOM LaneedブロードバンドルータLD-BBR4L3 両方とも OS:Win98 IE6 ウィルスバスター2003 です。 よろしくお願いします。

  • アップロードができなくなりました。

    ワード2000でHPを作って無料のサーバにIEでアップロードしたのですが、アクセスエラーが出ました。 マイコンピューターで関連付けろとメッセージが出たのですが、どうしたらいいのか判りません。 どうしたもんでしょう。

    • ベストアンサー
    • Mac