• ベストアンサー
  • すぐに回答を!

RAIDの構築

HDD2つで、RAID0を構築する予定なのですが、 一方にはOSインストール済みで、もう一方にはデータが 入っていますが、このままでRAIDを構築することは できるのでしょうか? 自分ではBIOS上でRAID設定をする過程で 「Revert HDD to Non-raid」の項目で初期化をしてから やるのではと考えていますが…。 どなたかわかる方教えてください。

共感・応援の気持ちを伝えよう!

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • ZENO888
  • ベストアンサー率49% (8944/18242)

RAIDを構成する段階で、一旦データは消えます。 RAIDを構成してから、OSをインストールし直して下さい。

共感・感謝の気持ちを伝えよう!

質問者からの補足

ご回答ありがとうございます。 クドイようですが、ということは 「Revert HDD to Non-raid」はやらなくてもよいと いうことでよろしいのでしょうか?

その他の回答 (3)

  • 回答No.4
noname#113190
noname#113190

一部のチップセットの物を除いて、起動システムの入った単体HDDをRAID-0にはできません。 例外的には3番さんがアドバイスされている、インテルチップは可能で、手順は 1. Windowsの修復セットアップをRAID BIOSを有効にした状態で実行し、RAIDドライバーをインストール。 2. Windowsを起動させ、IMSCを起動させ「アクション」メニューから「既存のハードドライブからRAIDボリューム作製」を選択。 3. 作製ウィザードに従って作業(数時間かかる) 4. 再起動後Windowsの管理でパーテーションの確認。 手順は大体上記ですけど、できないチップセットも多いですし、各々手順は異なります。

共感・感謝の気持ちを伝えよう!

  • 回答No.3
  • roukin
  • ベストアンサー率24% (622/2564)

マザボの機種を書きましょう。 INTEL965チップセット以降なら、後からRAIDがくめます。 http://www.intel.co.jp/jp/products/chipsets/P965/index.htm

共感・感謝の気持ちを伝えよう!

  • 回答No.2
  • aki_orz
  • ベストアンサー率41% (61/146)

BIOS上でRAIDとNonRAIDは、ただの切り換えです。 HDDを読み込む際、1台で読み込むのか、複数で読み込むのかです。 RAIDの設定をしても、あくまでもNonRAID時のデータが読み込めないだけで、 上書きのされてない場所の、前データは見えない場所で残ってます。 現在のHDD内のデータのフォーマット(初期化)とは別問題です。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • RAID1の構築について

    マザーボード GIGABYTE GA-Z68X-UD3H-B3 を使っています。 現在、1TバイトのHDDを使っていますが、期せずして全く同じHDDが手に入ったので、RAID1を組もうと思いました。 しかし、今から構築すると、元のHDDのデータが消えてしまうか心配です。 もし、わかる方がいましたら、RAID1の構築手順中、データが消えないか教えてください。 私の概念では、 1.BIOSでRAID1を組むHDDを指定する。(ここではデータ破壊は起こらない) 2.RAID1を組んだHDD 2台は、ミラーリングができていない。(当たり前です) 3.ミラーを作成する。(有効なHDDを増設したHDDにBIOSレベルでコピー → データ破壊は起こらない) というイメージなのですが(以前、RAID1を構築したときは、このような手順でした。)、合っているでしょうか? 下手をすると、RAID1を構築したら、OSでフォーマットしなければならない、という作業が必要であれば、データを喪失してしまいます。 よろしくおねがいします。

  • RAID1の構築方法

    HDDの2台目を(1TB)買ったので、RAIDを組んでみようと思ったのですが、構築方法がよくわからず、質問しました。教えてください。 また、RAIDに関していくつか質問があります。 1.パーティションしたHDDでRAIDは組めるか?   例 2TBのHDDを1TBずつに分け、一方を他のHDDとのRAIDに、もう一方をRAIDに無関係なデータ保存用に、、、 2.BIOS設定より市販ソフトの方が楽か? 3.データが入ってあるHDDと新しいHDDとでRAIDを組むとき、データはそのまま保存されるのか?されない場合、回避できるのか? スペックは、 マザーボード:ASUS P7H57D-V EVO CPU:intel Corei5 650 OS: Windows 7 Professional です。

  • ハードウェアRAID(1)の構築

    マシンはDELLのPowerEdge R410、OSは無し(CentOS5.9を入れる予定)、 HDD(ハードウェアRAID対応)は1TB×2台を既に組み込んでいる状況です。 RAID1を構築したいのですが、何から始めればいいのかさっぱりわかりません。 いきなりCentOSのDVDをドライブに入れてCentOSをインストールする最中、あるいは インストール後にRAID1を構築するのか、 はたまた、CentOSのインストール前のBIOS設定画面から何らかの操作をして RAID1を構築してCentOSをインストールするのか、とにかく基本からわかりません。 手順、構築方法などをご教授していただけると助かります。

  • RAID1構築後・・

    こんばんは。 本日RAID1を構築してVistaをインストールしました。 正常に起動したのですが、RAID1が機能しているか確認したくて、試しに構築しているHDDを抜いてみました。すると見事に起動したのですが、その後元に戻すと、起動時BIOS画面でRAIDを構築しているHDDが表示されるのですが、一度抜いてしまった方のHDDが赤く点滅してしまいました。 RAID機能の方は働いているようですが、この点滅を消すにはどうすればよいでしょうか?

  • RAID 1構築について

    DELL PowerEdge2600サーバ(Windowd Server2003)を使用しており、RAID 1を構築しています。 HDD 1番が破損したので交換を実施しようと思うのですが、 HDD 0番にエラーが検出されなければミラーリングでデータをコピーできるのですが、 HDD 0番にエラーが検出された場合は2本ともHDDを交換することになります。。 その際、RAID構築とOS再インストールをしないといけないのですが、 RAID 1構築とはどのようにするのでしょうか。 どなたか手順をご教授下さい。

  • RAID0構築について

    新しいHDD2台でRAID0を構築しようと考えていますが、 構築してOSを入れたら、今まで使ってきたデータがはいってるHDD(AHCIモードで使用していたもの)をそのまま接続しても大丈夫なんでしょうか? RAIDモード、IDEモード、AHCIモードの書き込み方式が異なって 3者択一だから、RAIDモードにすれば、今までのHDDのデータが読み出せなくなるなど聞いた事があります。 非RAID HDDを、データも、物理的にもRAID0を構築した環境で問題無く使用することができますか?

  • RAID0の構築設定

    自作PCに初めて挑戦しやっと完成しました。 OSwindowsXPのインストールも無事終わり順調に動いています。 自作の過程でRAID0なるものを知りこれから挑戦したいのですが、 マザーボードにサポートされているという事だけの知識しかありません。 CPU:Athlon64 X2 5200+ M/B:BIOSTAR TFORCE 6100 AM2 Memory:PC6400 1GB×2 HDD:200GB×2(内臓S-ATA2) (1)構築するにはBIOSで設定するだけでよろしいか? マニュアル(英語)には設定項目の記載が見つかりませんが どの項目を何に設定すればいいのか? (2)現況この環境で他に必要なパーツはありますか? (3)構築に関して詳しいサイトなどあれば教えてください

  • 【緊急】RAID1の再構築について【至急】

    RAID1でミラーリングを構築していました。 パソコンが固まったので、強制終了し、PCを再起動しました。 で、RAIDはまた自動的に再構築?同期?をはじめると思うのですが、その同期している最中に、またPCが固まって、 強制終了しました。(これがそもそもの間違いか…) そして、また起動しようとしたら、OSが立ち上がらない… なんかシステムのファイルが壊れてるみたいな表示があり、 一度、RAID構築をBIOSにて解除し、片方だけHDDを接続し、BIOSのストレージ設定をRAIDからIDEに変更して、 1個のHDDのみで起動したら、なんとかセーフモードで立ち上がり、その後再起動したら、普通に立ち上がって一安心。 で、もう一回RAID1のミラーリングを構築するために、BIOS画面の次のRAID設定画面でRAID1を設定しました。 そして、また再起動したらもう、ウィンドウズのマークが現れなくなってしまった…。 もう一度、RAID構築を解除し、1個のHDDで起動したが、起動しなくなってしまった…。 なんとか、ここから直せる方法はありませんでしょうか? そもそも、RAID1の再構築方法が間違っていたのでしょうか? 物理的にHDDが壊れたときは、HDD交換したら、すんなり再構築されたので、個別にはHDDが生きているのを確認したから、大丈夫だと思ったのですが…。 アドバイス頂けませんでしょうか… よろしくお願いいたします。 OS:XP SP3 マザーボードP5Q Deluxe

  • Raidの構築これでいいでしょうか?

    こんどRaid 0 を構築しようと思ってい色々調べたんですが、いまいち不安なので指導してもらえませんでしょうか? マザーは、 P5QL-E まずHDDをsata1.sata2に接続。(500G×2) biosでraidを選択しbootをCDにし再起動。 再起動時、DELキーを押し、変な画面が出たらCtri+Lを押す。 raidの設定画面に変わり、Raid0を選択。 使用したいディスクを選択。 ???を128KBを選択。 ディスクの容量を選択し、Yを押す。 OS(ビスタ)DVDを入れPCを起動 インストール途中でRAIDのドライバーを入れる。 後は普通のインストールでいい。 これでraidの構築はいいのでしょうか?ご指導して下さい。

  • RAID構築の手順

    自作PC、M/B ASUSP5Q-ProでRAID0(160GBHDD×2台)を構築しました。 M/Bのマニュアルに従い、BIOSでRAIDを設定し、Ctrl+Iにて2台のHDDを指定(その他にNon-RAIDのHDD500GB1台)。OSをインストールし、確認するとディスク0に320GBのドライブが確認できました。OS(Vista SP1)はこのディスクに入れております。 ところで、マニュアルには更に「RAIDに組み込まれたハードディスクドライブにWindowsXP/Vistaをインストールする際は、ドライバを保存したフロッピーディスク(Vistaの場合はUSBでも可能)が必要です」とあり、ドライバディスクを作成する手順が記載されています。 確かに付属のDVDには「ディスク作成」機能の中に「Intel CH10R32bit RAID Driver Disk」が入おり、USB(今やフロッピーはないので)にダウンロードしようとしたのですが、どういう訳かUSBを認識しません。 そこで質問ですが、 1.RAID構築にはBIOSの設定だけではだめでこのドライブも入れなければ正常に機能しないのでしょうか? 2.何本かのUSBでトライしたのですが、付属のDVDからのダウンロードがうまくいきません、その原因として考えられるものは何でしょうか?