-PR-
締切済み

ハードディスクが遅いのです。

  • すぐに回答を!
  • 質問No.83042
  • 閲覧数44
  • ありがとう数4
  • 気になる数0
  • 回答数6
  • コメント数0

お礼率 55% (25/45)

PentiumII350MHzのPCをアップグレードしようとしたところ、マザーボードから電源までごっそりと変えなければならないことがわかり、もう一台作るつもりでそうしました。
古い部品は、ATAPIのCD-ROMとDVD-ROM、そしてUATA33のHDです。
Athron1GHZ/266 にギ○バイトのマザーボードですが、ベンチマークテストをすると、HDアクセスが前のPCはおろかi486ぐらいしかスピードが出ていないのです。ほかの項目は格段に速くなっているのですが……
なぜなのでしょうか? BIOSの設定が悪いのでしょうか。
ちなみにPrimaryにはUATA66/100のケーブルでマスタにUATA100のHD、スレイブにDVD-ROMを
SecondaryにはUATA33のケーブルでマスタにUATA33のHD、スレイブにCD-ROMを接続しています。
CD-ROMやDVD-ROMもなんだか変です。どうか、助けてください!!!!!!
通報する
  • 回答数6
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

回答 (全6件)

  • 回答No.6

あくまでも提案ですが、普通こういう風に接続しませんか。

IDE-1 マスターCD
    スレーブDVD
IDE-0 マスターHD ATA100
スレーブHD ATA33

マザー付属のIDEフラットケーブルで接続してIDE-0にHD2個を接続してみてください。

BIOS 全部AUTOで認識を確認する。
補足コメント
Ogacha

お礼率 55% (25/45)

DVDドライブは、CD-ROMとCD-RWとDVD-ROMをかねたものです。HDDの方はtoyoyukiさんのおっしゃるのと同じにしていましたが、だめだったのです。
BIOSでAUTOにしていましたが、DMAをきちんと認識していなかったようです。
投稿日時 - 2001-05-30 21:31:09


  • 回答No.1
レベル10

ベストアンサー率 42% (80/187)

ATAは転送速度の低いほうに合わされてしまいますので
(SCSIそうなのですが)
すべて33で動かされてしまっていると思います。
とりあえず、33のHDを外してみてください。
速度に関しては、これで解決すると思います。

個人的には、Primaryに、DMAをオンにしたHD、SecondaryにDVD-ROM、CD-ROM、というようにしたいところですが・・・、
(これは、それほど問題ではないと思いいます)
  • 回答No.2
レベル9

ベストアンサー率 33% (27/81)

oneyanさんの仰る通り、ATAは繋がっている機器の中で最も遅いものの転送速度に合わされます。

また、御使用のDVDドライブの転送速度がどれだけか判りませんが、ATA100と云った事はないと思います。

従って、ATA100のHDの速度を最大限生かすには、
・プライマリのマスター:ATA100のHD
・セカンダリのマスター:CD-ROMドライブ
・セカンダリのスレイブ:DVD-ROMドライブ
と接続し、ATA33のHDの使用は諦めるしかないでしょう。

どうしてもATA33のHDを使いたいので在れば、ATA100等のボードを増設して、そちらに繋いだら宜しいのではないでしょうか?
補足コメント
Ogacha

お礼率 55% (25/45)

おっしゃるようにしてみたのですが…… 伸びません。S.M.A.R.T.をEnableにしてみたせいか、MMXPentiumぐらいの速さにはなりました。
投稿日時 - 2001-05-30 04:12:14
  • 回答No.3
レベル7

ベストアンサー率 32% (8/25)

もしもM/BのチップセットがVIAであれば、4in1Driverはきちんとインストール
されていますでしょうか?とりあえず最新のドライバを入れてみてください。
お礼コメント
Ogacha

お礼率 55% (25/45)

やってみたのですが…… 結果は変わりませんでした。でも、最新のドライバのURLをつけてくださってありがとうございます。どうして直らないんだろ?
投稿日時 - 2001-05-30 04:26:59
  • 回答No.4
レベル10

ベストアンサー率 46% (85/181)

新しいDMA100のHDD・使用しているマザーボードが書いてないから簡単に説明
相性がでているかもしれません
IBMのHDDは相性がでやすく、動作はするがめちゃくちゃ遅いことがあります
ほかのメーカーも可能性はあります
相性かどうかの確認方法
1・知り合いのところに持っていき動作を確認してみる
(なるべく同じメーカーの同じHDDを使用していて動作に支障のない人のところ)
2・ドライバを最新の物に変更する
(更新されている場合がある)
3・ドライバを旧バージョンに変更する
(新しい物にバグ等がでている場合があるため)
4・DMA33にシステムをインストール後動作を確認する
(システムが入っていてそれが相性とでる場合もあるための確認 システムがなければまともに動く場合もある)
5・必要最低限の物以外を付けずに動作を確認する
(CPU・メモリ・グラフィック・HDD(DMA100の方)のみ OSデータはDOS等を使用してHDD内にコピー後インストールを行いチェック)
6・パソコンがそのDMA100HDDをDMA5と認識しているかを確認する
ベンチマークだけ? 体感も感じますか? ベンチが正常に動作していない場合もあります
このチェックですべてだめなら初期不良の可能性があります
1でだめなら特にその可能性が高い
1が大丈夫で、5まで行ってだめならほかのパーツの初期不良が考えられます
1が大丈夫で、4でDMA33のHDDが正常ならほかのパーツの初期不良の可能性は低いので、相性の可能性が高いです
6ですがマザーボードが正常にDMA100を認識していない場合があります
この場合はプライマリー・セカンダリー マスター・スレーブを変更してみてきちんと認識するかを確認
認識されない場合は相性・マザーボードの初期不良の可能性が大きいです
まあ、この程度はチェックしてみてくださいね~ 
お礼コメント
Ogacha

お礼率 55% (25/45)

詳しい解説をありがとうございます。デバイス・マネージャのディスクドライブのDMAのチェックボックスをONにしたところ、やっと速度が上がりました。
これでよかったのかわかりませんが、体感速度は先ほどまでむちゃくちゃ遅かっただけに、よくなって一安心です。
バイオスの設定なども、専門用語が多くて難しいですね。もっと勉強します。
みなさん、ありがとうございました。
投稿日時 - 2001-05-30 21:30:43
  • 回答No.5
レベル10

ベストアンサー率 28% (39/138)

ベンチマークは本当に当てになるのか?
体感速度でそんなに遅いのでしょうか?
このQ&Aで解決しましたか?
AIエージェント「あい」

こんにちは。AIエージェントの「あい」です。
あなたの悩みに、OKWAVE 3,500万件のQ&Aを分析して最適な回答をご提案します。

関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


専門家があなたの悩みに回答!

-PR-

ピックアップ

-PR-
ページ先頭へ