-PR-
解決済み

IDEのCD-RとLiveWare!3.0

  • 暇なときにでも
  • 質問No.62439
  • 閲覧数62
  • ありがとう数4
  • 気になる数0
  • 回答数5
  • コメント数0

お礼率 75% (39/52)

こんにちは。sato_yosと申します。

Gateway社のPERFORMANCE750(Pentium!!!750MHz、
マザーボードはWS440BX)を、パーツをあれこれ交換
しながら使っています。OSはWindows98SEです。

このマシンのIDEのセカンダリマスタにATAPIのCD-R(PlextorのPW-1210TA)を繋いでいます。この状態で、Creative社のサウンドカード SoundBlaster Live!
X-Gamerのユーティリティ群であるLiveWare!3.0を
導入すると、マイコンピュータやエクスプローラー
からCD-Rが消えてしまいます。

デバイスマネージャからは見えていまして、ここで
DMAのチェックを外すとCD-Rがエクスプローラーでも
見えるようになるのですが、DMAのチェックを入れると
再びエクスプローラーから見えなくなります。

Plextorのサポートに聞いてみたところ、この症状は
私のCD-R機種固有の問題ではなく、他社のドライブ
でも似たような症状が出ることがあるそうです。
現在調査中とのことですが、まだその調査結果は
知らせてもらっていません。

質問1: 同様の問題に遭遇され、解決された方は
いらっしゃいませんか?

質問2: DMAのチェックは、外すと性能的に問題がある
のでしょうか?それとも、外していても特に問題はない
ものなのでしょうか?

以上、よろしくお願いします。
通報する
  • 回答数5
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.2
レベル9

ベストアンサー率 76% (52/68)

質問2についてですが、下のリンク先の特集No.003とNo.004の記事が参考になると思います。
チェックをはずしている(PIO)と転送速度が20倍速あたりで頭打ちになります。
私も試してみましたが、同様になりました。
書き込みの際はそれほど問題にはならない(CPU負荷はかかりますが)でしょうが、読み込みの際にスペックどおりの速度が出ないことになります。

質問1については、私がSoundBlaster Live!を持っていないため、残念ながらお答えできません。
補足コメント
sato_yos

お礼率 75% (39/52)

この記事を参考にハードウェア的にDMAに設定し、
Windows上ではDMAのチェックを外したところ、
LiveWare3.0が問題無く導入できました。
ただ、Windows98SEですので、記事に載っていた
方法で実際にDMAになっているかどうかを確かめる
ことはできませんでしたが…

どうもありがとうございました。
投稿日時 - 2001-04-17 13:40:23
お礼コメント
sato_yos

お礼率 75% (39/52)

面白い記事の紹介をありがとうございました。
今度時間ができたとき、ジャンパをショート
させるとどうなるか試してみようと思います。
投稿日時 - 2001-04-11 15:53:50

その他の回答 (全4件)

  • 回答No.3
レベル10

ベストアンサー率 50% (50/99)

もともとIDEはCPU使用率が高い
インターフェースなので
CPU使用率が上がることがいやなのであれば
SCSIにしてみてはいかがですか?
安定性も高いですし
(良いSCSIカードを選べば)
CPUの使用率はほとんどありません。
マルチタスクに対応した唯一の
インターフェースなのでお奨めです。
IDEは同一ライン上にあるデバイスを
同時処理できないんですよね

って買い替えは大変ですよね。
今度買う時のご参考までに・・・
お礼コメント
sato_yos

お礼率 75% (39/52)

「CPU利用率が上がるのは嫌」と書きましたが、IDEを
使っているのである程度は覚悟しています。
SCSIインタフェースはあるのですが、CD-Rは最近買い
替えたばかりなので、再度の買い替えはちょっと
避けたいです。(^^;)

コメントをありがとうございました。
投稿日時 - 2001-04-11 15:57:54
  • 回答No.4
レベル10

ベストアンサー率 37% (43/114)

こんにちは、sato_yosさん。
私もSB Live!を使っています。
私の場合もいろいろ問題があったのでその対策を書いておきます。

1)SoundBlaster16エミュレーションは使わないようにした。

2)プリンタポートと同じIRQを使用するようにした。

これだけなんですが違ってたら無視してください。
補足コメント
sato_yos

お礼率 75% (39/52)

回答をありがとうございます。
IRQの変更はすぐできるかどうか分からないので、
時間が出来た時に試してみます。
投稿日時 - 2001-04-13 09:42:50
  • 回答No.1
レベル10

ベストアンサー率 50% (50/99)

LiveWareをインストールすると
起こる症状ならば
Creative社に電話してみてはいかがですか?
LiveWare自体はサウンドフォントなので
IDEに関与するはずはないと思います。
製品保証書にサポートセンターの
電話番号が記載されてるはずです。
それか相性のトラブルですね。
あまりCD-Rドライブとサウンドの相性は
聞かないですが。

DMAとは
CPUを介さずにデータ転送行うもので
これを外すとCDROM/CD-R使用時に
CPU使用率が上がると思います。
Pen3-700Mhzを積んでいるのであれば
大した問題でもない気がしますね。
お礼コメント
sato_yos

お礼率 75% (39/52)

回答をありがとうございます。
Plextorのサポートで聞いてみたところ、Plextorの
ドライブ固有の問題ではなく、他社のドライブでも
同様の症状が生じるそうなので、既に有名な問題
なっているのに、Creativeが気付かないフリを
しているのかと思っていました。
一度Creativeに聞いてみるのもありかもしれませんね。

DMAの件、了解しました。
CPU利用率が上がるのは、あまりいい気がしないですねぇ。

どうもありがとうございました。
投稿日時 - 2001-04-11 15:05:34
  • 回答No.5
レベル11

ベストアンサー率 41% (96/229)

winaspi関係のデバイスドライバに何か問題がないか、気になります。

Sound Blaster Live!とIDEデバイスの関係でトラブルがあった人の多くはwnaspi32.dll、apix.vxdの入れ替えで解決されたという報告があがっているようです。

一応、B's Recorderの販売元のBHAのサイトに詳しいやり方がありますので、参考にしてみてください。

# IDEのバスマスタ(DMA転送)は有効にして使いたいものです。440BXなどPCIチップのほうでデータ転送してくれるわけですから、CPU負荷が軽減されるのは当然です。
お礼コメント
sato_yos

お礼率 75% (39/52)

回答をありがとうございます。
帰宅して早速試してみましたが、状況は改善しません
でした。
投稿日時 - 2001-04-13 09:41:38
このQ&Aで解決しましたか?
AIエージェント「あい」

こんにちは。AIエージェントの「あい」です。
あなたの悩みに、OKWAVE 3,500万件のQ&Aを分析して最適な回答をご提案します。

関連するQ&A
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-

特集


専門家があなたの悩みに回答!

ピックアップ

ページ先頭へ