• 締切
  • すぐに回答を!

Windows XPがインストールできない

  • 質問No.4579465
  • 閲覧数3188
  • ありがとう数4
  • 回答数4

お礼率 88% (8/9)

 友達からもらった自作PCのパーツを交換したりしたことはありますが、CPUやマザーボードの交換は今回が初めての初心者です。
 先日、パソコン構成を変更しました。
 構成 CPU:AMD Phenom X4 9350e
    マザー:GIGABYTE GA-MA790GP-DS4H
    メモリ-:DDR-2 2G
    HDD:500G S-ATA
        120G UltraATA 
    DVD:LG製 UltraATA
    OS:Windows XP (SP2対応) DSP版
XPをインストールすると、読み込みは行うのですが、エラー(黒色の画面)で落ちてしまいます。
インストールの最初にF6キーを押して実行すると、青色画面に
 Setup could not determine the type of one or more mass storage devices installed in your system, or you have chosen to manually specify an adapter.
Cunnently,setup will load support for the following mass strage devices(s)
のコメントが出て来ます。
 「ドライバーがない?」と思いマザーボードに添付されていたCDをいれて実行したりしましたが、そのCDを読み込んでいる気配もありません。
 誰か対処の仕方をご存じの方がいましたらご教授下さい。

回答 (全4件)

  • 回答No.4

ベストアンサー率 74% (74/100)

S-ATA(AHCI)であれば、Intel、AMDのチップセットで
導入に関してさほど違いはありません。

問題はOSをインストールするときに、デバイスを認識できるかがカギです。

XP起動中からXPをインストールであれば、もちろんS-ATAのHDDが認識しての
OSインストールになると思いますから問題はありません。
(しかしながら、この方法は一般的な導入ではないので、ご注意を)

問題はXPのインストールメディアにS-ATA用のドライバーが入っていないことです。
ドライバーが無い為、インストールウィザードがS-ATAのHDDを認識できないのです。

また、BIOS上でS-ATAの動作モードをIDE互換モードにすることで、S-ATAのドライバーが
なくても、インストールすることは可能です。
(BIOSの「Integrated Peripherals」の項目の「OnChip SATA Type」を「Native IDE」に
変更する)

しかしながら、IDE互換モードでインストールしてしまうと、S-ATA本来の力が
でません。
この場合OSインストール後にAHCIドライバーを組み込んで、
変更することになり、また変更すること自体が、うまくいかないこともあるので
OSインストールの時に、組み込んだ方がいいと思われます。

上記の様にS-ATA(AHCI)について書きましたが、
「OSがインストールできない」という問題が、「S-ATAのドライバーが原因」と特定できていないので、
とりあえず、ドライバーを格納したFDDを使用してみてください。
FDDでうまくいかない場合は、上記に書いた様にS-ATAのモードを変更してみてください。
  • 回答No.3

ベストアンサー率 50% (563/1116)

onasu0316さん 今晩は!
■できる!自作パソコン作り方教室について ↓
http://www.pc-info.sakura.ne.jp/
▼HDD換装したのですが再インストールが出来ないのです↓
http://oshiete1.goo.ne.jp/qa2723740.html
■PC自作なんでも相談室LOG↓
http://www.fpcu.jp/pcdiy/topic/nandemo/10443.html
マザーボードを交換すると、特にCPU等を含む交換するとBIOSもHDDにも
影響が出るのは当然です。
特にCPUを交換した場合はフアン・電源の状態は如何ですか?
■Windows再インストール回避編↓
http://dennou.stakasaki.net/noinst_mbchange-j.html
■[電脳])「自作に便利な両対応パーツ」マザーボードとCPU交換↓
http://stakasaki.at.webry.info/200606/article_1.html
こんなサイトも有りました。
決定的な回答が出来ず済みません。
参考までに。
お礼コメント
onasu0316

お礼率 88% (8/9)

アドバイスありがとうございます。
自分でも対策をサイトで色々探してみたのですが、ヒットするのはなかなか分かりづらくて・・・。お教え頂いたサイト参考にしてみます。
投稿日時:2008/12/25 12:21
  • 回答No.2

ベストアンサー率 74% (74/100)

OSのインストール先HDDはS-ATAでしょうか?

S-ATAの場合、XPのメディアはS-ATA用のドライバー(AHCI)をもっていません。
XPのメディアでブート時にS-ATA用のドライバーを組み込まなければなりません。

マザーボードメーカーからS-ATA用のドライバーを取得し、FDDに保存し、
XPのメディアでブートした時にF6を押して、FDDからドライバーを組み込めば動作するはずです。

FDDを搭載していない場合は、IDEモードでインストールし、後に変更するか、
XPメディアにドライバーを組み込んだメディアを用意することで、AHCIで
インストールすることが可能です。


AHCIドライバーを組み込みXPインストールCDの作成
http://inspiron1720.seesaa.net/article/70717257.html
お礼コメント
onasu0316

お礼率 88% (8/9)

早急のアドバイスありがとうございます。
早速、ギガバイトのホームページよりドライバーをダウンロードして、
試してみます。ありがとうございました。
ところで、この現象はAMDならではの現象なのでしょうか?組み替える前(Pen4)では、このような現象は起こりませんでした。入力手順は最初にUltraATAにインソールして、その後増設したS-ATAにインソール(UltraATA内のXPから起動)しました。後学のためにご存じの方はお教え下さい。
投稿日時:2008/12/24 12:33
  • 回答No.1

ベストアンサー率 38% (930/2427)

USB機器を外して、もしくはSP/2マウス、キーボードで試してみる。
BIOSでレガシーUSBをONにしてみる。
お礼コメント
onasu0316

お礼率 88% (8/9)

早々のご意見ありがとうございます。
USB機器ですか。外付けのものは付けていませんが、内蔵型のカードリーダーを内部のUSBに付けてますのではずして試してみます。
BIOSの設定についても試してみます。
マウスは現在付けていません。SP/2キーボードのみを接続しています。
投稿日時:2008/12/24 11:08
関連するQ&A
ページ先頭へ