• ベストアンサー
  • すぐに回答を!

ネット接続がおかしい。

  • 質問No.5756591
  • 閲覧数728
  • ありがとう数8
  • 気になる数0
  • 回答数8
  • コメント数0

お礼率 20% (5/24)

ネット接続がおかしい。
はじめまして。
実は先ほどからネット接続がおかしくなっています。
セーフモードのネットワーク有りで速度計測したところ約80Mbpsなのですが
通常起動で計測すると約0.10Mbpsとなってしまいます。
今まではそんなことはなかったのですが、マイネットワークで別PCにある共有フォルダ
に接続できなかったのでファイアーウォールが問題になっているのか確認したかったので
一度pc tools firewall plus 5をアンインストールしました。
その後共有フォルダにアクセスできることを確認後、ファイアーウォールの設定をすれば
共有フォルダにも接続可能になると重い、もう一度pc tools firewall plus 5を
インストールしようとして、間違ってver6のほうをインストールしてしまいました。
すぐにアンインストールしver5に戻したあたりからネットにつながりにくくなったと思います。
なのでもう一度アンインストールをしましたが、今度は共有フォルダにもつながらなくなり通信速度も
極端に(0.10Mbps)落ちてしまったしだいです。
通常起動状態でpingを127.0.0.1に飛ばすとDestination host unreachableとなり
ルーターのある192.168.1.1に飛ばすとReply from 192.168.1.1: bytes=32 time<1ms TTL=64
とかえってきます。ほかにも192.168.1.3(別PC)に飛ばすとDestination host unreachable
となりました。
またセーフモードで行ったときはすべてReplyで応答がありました。
私はipを192.168.1.4を手動構成で設定しています。この場合ネットにはつなげるんですが、自動構成に
変更してみたところ169.254.xx.xxとなりipが割り振れていない状態です。
またルーターはNPBBRLを使用していて別PCからは設定ページを見れますが
このPCではつながらない状況です。
OSはXPSP2でウィルスソフトにavira、プロバイダはeo光100Mを使用しています。
どなたか対応策教えていただけないでしょうか?
私個人としてはpc tools firewall plusの設定が残っていてそれがアンインストールしきれず邪魔しているか、セーフモードでは正常なことから何かのアプリが邪魔していると考えています。
それでは何か対策方法をよろしくお願いします。

質問者が選んだベストアンサー

  • 回答No.8
  • ベストアンサー

ベストアンサー率 44% (39/88)

そうですね。pc tools firewall plusが残っている可能性が高いですね。
対策といえそうなのは
1.スタートアップまたはサービスで起動されるようになっていないかをチェック
Runscannerなどのツールを使えば簡単にできそうです。

2.GMERやRootkit Hook AnalyzerなどでWinsockなどがフックされていないか調べる。

あまりお勧めではありませんが。
3.サンドボックスなどで変更点を調べて修復する

ぐらいですかね。
お礼コメント
momosa22

お礼率 20% (5/24)

様子見ではありますが速度が回復しました。
行った事はファイアーウォールをインストール後
1番のツールでサービス関係を先に削除してアンインストーラで
もう一度消すということです。
とりあえずではありますが共有フォルダにも接続できるようになりました。
zonealarmがだめだったのでpc toolsに乗り換えたのですが、
これもだめそうなのでcomodoなどを検討してみたいと思います。
長い間いろいろ対応策を検討してくださってありがとうございました。
投稿日時:2010/03/21 01:13

その他の回答 (全7件)

  • 回答No.7

ベストアンサー率 44% (39/88)

本当に何度もすみません。
いろいろ調べているのですがこれといったのもが見つからないので最悪リカバリですかね。
僕の中ではもうそろそろ出し尽くした感があるのですが…。

残る解決策といえそうなのは、

1.ルータ側でIPを固定(DHCPの代わり)
http://www.akakagemaru.info/port/io/NP-BBRLdhcpdmz.html

2.winsockの破損の回復
http://support.microsoft.com/kb/811259/ja

後は微妙

3.ルータの再起動
4.ドライバの再インストール
5.システムの復元

あとは僕はお手上げです。
補足コメント
momosa22

お礼率 20% (5/24)

いえいえいろいろ情報ありがとうございます。
新しいことがわかりました。
というのは今ブラウザにIEとDonutRAPTを主に使ってるんですが
久しぶりにfirefoxを使ってみて、速度計測をしたところ
正常な数値が返ってきました。(50Mbps)
そのままDonutとIEで調べてみたらやはり0,1Mbpsでした。
何が違うか考えてみたところ、PC tools firewall plusで許可するかどうか
確認された時、許可を押していたのがDonutとIEで、pc tools firewall plus
をインストールしていた間にはfirefoxは一度も起動していなく、
許可等の設定を行っていませんでした。
インストールしていたときに設定をしていたものについては速度が遅くなっていて、
firefoxの他にもダウンローダーでorbitを使っているのですが
それも設定はしていなかったので速度は速いままでした。
やはり原因はpc tools firewall plusにありそうです。
投稿日時:2010/03/18 02:42
  • 回答No.6

ベストアンサー率 44% (39/88)

/allの結果の中で他のPCと何らか違うところはありませんか?
それと、基本的なところですが、サブネットマスクは他のPCと合っていますよね?
それとIPが重複しているといったこともありませんよね?

もし大丈夫だったら
一度ルータにログインしてどれだけIPが割り当てられているか見てみてください。
補足コメント
momosa22

お礼率 20% (5/24)

/allの結果DHCPで割り振れているほうには違いがありましたが
手動でやったほうには違いはありませんでした。もちろんその場合でも別PCでは
正常な速度はでています。次にサブネットマスクは255.255.255.0であっています。
IPも2~32までふれるようになっていますがためしに30番などで試してみましたが
遅いままでした。重複もありませんでした。
少し進展がありまして、netsh winsock resetというコマンドを打ち込むと
エラー (0xメモし忘れた)がメッセージをアプリケーション(PCToolsFirewallPlus)
へ送信中に発生しました。
という表示がされて再起動をしたところ50Mbps程度まで速度がでるようになりました。
しかしもう一度再起動したところまた速度が0.1Mbps程に戻ってしまいました。
同じ方法でnetsh winsock resetをしてみたところこんどは再ほどのエラーメッセージは表示されず
再起動しても速度が落ちたままでした。
エラーが発生した段階ではアンインストールしていたはずなんですが
(PCToolsFirewallPlus)へ送信中に発生しました。ということから
レジストリに何かやサービスがなにかに残っているのかもしれません。
インストール先にはフォルダもなくちゃんとアンインストールされているように見えるのですが
この辺で不具合が出ていそうな感じはします。
投稿日時:2010/03/17 23:13
  • 回答No.5

ベストアンサー率 44% (39/88)

すみません、何度も。

一度ipconfig /allの結果を張り付けてみてください。
それと何台のPCでLANを組んでいるのかも教えてください。
補足コメント
momosa22

お礼率 20% (5/24)

まずこれがip自動取得にした場合の/allの結果です。こちらでは接続はできません。
C:\Documents and Settings\o>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : ******
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter ローカル エリア接続:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR8121/AR8113/AR8114 PCI-E E
thernet Controller
Physical Address. . . . . . . . . : ******
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.0.141
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : 169.254.0.141

---------------------------------------------------------
そしてこちらが手動で設定した場合の/allです。
こちらは接続できますが速度が異常に遅くなってしまったほうです。

C:\Documents and Settings\o>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : ******
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter ローカル エリア接続:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR8121/AR8113/AR8114 PCI-E E
thernet Controller
Physical Address. . . . . . . . . : ******
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.4
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
---------------------------------------------
LANはこのPCを含め4台で組んでいます。他の3台には速度の異常はなく
IP自動取得もうまくいっており割り振りがされてました。
投稿日時:2010/03/17 18:51
  • 回答No.4

ベストアンサー率 44% (39/88)

DHCPサーバは合っていて接続できる状態なんですか?
/renewしたときにエラーなどは表示されませんでした?
補足コメント
momosa22

お礼率 20% (5/24)

ip自動取得にした場合のrelease renew結果

C:\Documents and Settings\o>ipconfig /release

Windows IP Configuration


Ethernet adapter ローカル エリア接続:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :

C:\Documents and Settings\o>ipconfig /renew

Windows IP Configuration

An error occurred while renewing interface ローカル エリア接続 : unable to conta
ct your DHCP server. Request has timed out.
-----------------------------------------------------------------------
手動でipを設定した場合のrelease renew結果

C:\Documents and Settings\o>ipconfig /release

Windows IP Configuration

The operation failed as no adapter is in the state permissible for
this operation.

C:\Documents and Settings\o>ipconfig /renew

Windows IP Configuration

The operation failed as no adapter is in the state permissible for
this operation.
-------------------------------------------------------------------
このようになりました。
投稿日時:2010/03/17 18:44
  • 回答No.3

ベストアンサー率 44% (39/88)

すみません、追加です。
「ローカルエリア接続のプロパティ」を開いたら
接続時に使用されるドライバが表示されるのですが、
そこにpc tools firewall plusのドライバが表示されていませんか?
もし表示されていたらチェックを外して再起動してみてください。
補足コメント
momosa22

お礼率 20% (5/24)

pc tools firewall plusという項目はアンインストールしている今は表示されていません。
ためしにインストールしてその項目のチェックをはずし再起動して見ましたが速度は落ちたままでした。
投稿日時:2010/03/16 23:01
  • 回答No.2

ベストアンサー率 44% (39/88)

デフォルトゲートウェイ合ってましたか。
たいていはこれが原因らしいんですけどね。

次に「169.254.xx.xx」について調べてみたのですが、
これは「リンクローカル」アドレスと呼ばれて、通常ホストがDHCPサーバを見つけられないときなどに、自動設定されるそうです。
なのでDHCPサーバが合っていて接続できるかどうかを調べてみてください。
接続可能でしたら
/release
してから
/renew
してみてください。
補足コメント
momosa22

お礼率 20% (5/24)

とりあえず手動構成からipアドレスとDNSサーバーのアドレスを自動取得に変更し、
コマンドプロンプトで ipconfig /releaseをした後ipconfig /renewとやったところ
やはり169.254.xx.xxになりました。
投稿日時:2010/03/16 22:56
  • 回答No.1

ベストアンサー率 44% (39/88)

別に詳しいものではないのですがちょっと気になったので一応…。

デフォルトゲートウェイはどこになっていますか?
ルータのIPアドレスになっているかどうか確認してみてください。
それと、Windows ファイアーウォールは無効になっていますか?
補足コメント
momosa22

お礼率 20% (5/24)

デフォルトゲートウェイはルータと同じ192.168.1.1になっています。
また標準付属のファイアーウォールはon offとも両方試しましたが
速度に変化はなしです。現在はonにしています。
投稿日時:2010/03/16 21:11
結果を報告する
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。
関連するQ&A

ピックアップ

ページ先頭へ