• ベストアンサー
  • 困ってます

パッケージ名って・・・

Vain2.5をインストールして勉強しています 付属の(2枚目)PlusCDからのインストールがどうしてもうまくいかず、ネットからアップデートしたところ成功しました apt-get update apt-get dist-upgrade そして apt-get install task-kde とやってKDEをインストールしました。 そしてここのページ http://vinelinux.org/manuals/package-1.html の下を参考にして apt-get install xemacs などとやってほかのソフトもインストールしたのですが、ふと思った疑問があります。 この”task-kde””xemacs”等のパッケージ名はどうやって知ればいいのですか?? rpmでパッケージをインストールする場合も、 「どんなパッケージがアあるかな?」 と思ったとき何を見て、調べれば良いんでしょうか?? 教えてくださいm(__)m

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数46
  • ありがとう数2

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • asuca
  • ベストアンサー率47% (11786/24626)

ftp://ftp.jaist.ac.jp/pub/os/linux/Vine/apt/ などのftpサイトを見てやればパッケージが見れますよ。

参考URL:
ftp://ftp.jaist.ac.jp/pub/os/linux/Vine/apt/2.5/SRPMS.main/

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ごめんなさい 良くわからないです。 例えば 「kdeをインストールしたいなあ」 と思った場合、kdeでサーチすると ずらずら、っと出てきてしまいますよね? でも、実際には apt-get install task-kde で言い訳ですよね?? このtask-kde というパッケージ名はどうやって調べたんでしょうか??

関連するQ&A

  • KDEのバージョンアップ方法

    「RH9 + KDE3.13」でLinuxを勉強しています。 aptコマンドで apt-get update apt-get dist-upgrade としてもKDEは、バージョンアップされません。 aptコマンドで、KDEのバージョンアップは、できないのでしょうか? KDEのバージョンアップする方法を アドバイス宜しくお願いします。 参考になるサイトでも結構です。

  • パッケージをインストールしたいのですが(Debian3.0)

    OSはDebian GNU/Linux 3.0です。 debianにはdselect、apt-get、dpkg等 いろいろなインストールの仕方があります。 よく解説でapt-get install (パッケージ名) などとかかれているのですが、 パッケージ名はどこで調べるのでしょうか? 最新のsambaをインストールしたいとき パッケージ名はどのようになるのでしょうか? インストール方法が3つもあるので どれでインストールしようか迷います。 私的には1つだけ使えるようになればよいと思うのですが どれがいいのでしょうか?(違いが分かりません。) ご回答よろしくお願いします。

  • eclipse がインストールできない!

    eclipse を使いたくて、ネットの情報を参考に  apt-get update  apt-get upgrade  apt-get install eclipse-sdk としたのですが、  Reading package lists... Done  Building dependency tree... Done  E: Couldn't find package eclipse-sdk となってインストールできません。 方法はないでしょうか?

その他の回答 (1)

  • 回答No.2
  • asuca
  • ベストアンサー率47% (11786/24626)

参考URLの情報も見てください。

参考URL:
http://www.vinelinux.org/manuals/using_rpm-2.html#ss2.7

共感・感謝の気持ちを伝えよう!

質問者からのお礼

rpmfindコマンドというのがあるそうです。 回答ありがとうございました

関連するQ&A

  • APTでcurl-develパッケージが見つからず

    Ubuntu 10.10にて、curl-develパッケージをAPTでインストールしようと、以下コマンドを実行したのですが、「E:パッケージ curl-devel が見つかりません」となってしまいます。  $ sudo apt-get install curl-devel パッケージ名など、どこか間違っているのでしょうか? 間違っているとしたら、正しいインストール方法をご教示願います。

  • アップグレードコマンド(Red Hat Linux)

    Red Hat Linux9をインストールして、アップグレードをしようとしています。 apt-get updateを実行し、次にアップグレードをしようというところなのですが、 今までアップグレードは、 apt-get upgrde  でやっていたのですが、 あるホームページを見たら apt-get dist-upgrade とかかれてありました。 違いがあるのでしょうか?教えてください

  • パッケージの依存関係を調べるには?

    パッケージの依存関係を調べるには? Ubuntu(10.04)を使い始めたばかりのものです。 $ sudo apt-get install <パッケージ名> あるパッケージをインストールすると、依存関係のあるパッケージも一緒にインストールされると思います。 インストールする前にこの依存関係を調べるには、どのようなコマンドを実行したらよいのでしょうか?

  • apt-getについて

    apt-getについて Ubuntuを使い始めたばかりのものです。 UbuntuにGitというソフトウェアをソースからインストールしたいと思っています。 Gitの書籍によると、次のコマンドを実行して、必要なパッケージをすべてインストールするように記載されています。 $ sudo apt-get build-dep git-core また、パッケージをインストールする時に、次のように apt-get(aptitude?) install を利用する場合があると思います。 $ sudo apt-get install mailutils パッケージをインストール場合で、 "apt-get install"とinstallなしの"apt-get"を利用する場合がありますが、 何が違い、どのように使い分けるのでしょうか?

  • VineLinux3.2 apt-getの設定と PHP,MySQL,PostgreSQLのインストール

    どのディストリビューションを使おうかと悩んだ挙句、 VineLinux3.2に決めました。 簡単にインストールができ、ユーザーインターフェースもなじみます。 簡単を基準にしていましたが、ソフトのインストールでつまづきました。 apt-get update としたのですが、 Can not connect to updates, vinelinux.org:80(133.1.84.71), connection timed out となります。 ※VineLinux4のベータをダウンロードしようとして繋がらなかったので、サイト自体がこけているのかな? PHPとMySQL,PostgreSQLをインストールする予定です。 VineLinux3.2でそれぞれ、バージョンは何になるのでしょうか? apt-get install mysqlとしても、パッケージmysqlが見つかりませんと表示されます。 apt-getを使うとパッケージ管理が楽だと思い込んでいますが、mysqlのtarballをダウンロードして、makeしてインストールする方法は、初心者には向いていないのでしょうか?以前関係などいっさいわからないけど、 最新版が使えたりして融通が効くとおもいますがどうでしょうか? apt-getが肝なので、この場合のように繋がらない場合は、他の場所を設定したいのですが、どうすればよいでしょうか?

  • 「エラー: 依存性の欠如」が出ます!

    apt-get dist-upgrade や apt-get upgrade を(updateのあとに)やると、  エラー: 依存性の欠如:  libruby = 1.6.7-0vl5は ruby-tcltk-1.6.7-0vl5 に必要とされています というメッセージが出ます。 しかし、RUBY 1.6.7-0vl5 に RUBY 1.6.7-0vl5 が必要と言われても、どうしようもありません!! 念のため、apt-get install libruby とかやっても同じでした。 どうすれば良いでしょうか? (なお、この質問は http://okweb.jp/kotaeru.php3?q=1409456 の続きです)

  • apt-get upgradeを時々やるべきでしょうか?

    apt-get upgradeを時々やるべきでしょうか? サーバでapt-get update/upgradeを時々やるべきでしょうか? Ubuntu Server を 認証サーバ&ファイルサーバとして使おうと思っています。 セキュリティーのためには、 # sudo apt-get update # sudo apt-get upgrade を時々やった方が良いとは思います。 しかし、update/upgrade をすると、インストール済みのパッケージの中で新しいバージョンが公開されているときは、最新バージョンをダウンロードしてインストールするのですよね? 自分が構築した認証、NSF等の設定が upgrade で壊れてしまわないか心配です。 質問ですが ● apt-get update/upgrade で、システムの設定ファイルが上書きされる心配はしなくて大丈夫なものでしょうか? ● みなさんはサーバのセキュリティアップデートはどうなさっているでしょうか?

  • VineLinux2.6でのapt-getでのphpのインストールについて

    玄箱でいま、VineLinuxを動かしているのですが、 apt-getでやるとphpパッケージがみつからないようなことが言われます。 玄箱のVineLinuxのベースは2.6だそうで、玄箱をハックしよう!という本の付属のCDでVineをインストールしました。 どうすればphpをaptでインストールできますかね。

  • Debianのアップグレードについて詳しいHPを教えてください。

    Debianのアップグレードについて詳しいHPを教えてください。 つい最近Debianを入れたばかりの初心者です。 慣れて来たので、testingのsqueezeにアップグレードしようと思うのですが、 apt-get update apt-get upgrade apt-get dist-upgrade で、エラー吐いたり、英文の訳の解らん質問が来たりで出来てません。 Debianのアップグレード(できればsqueeze)について詳しいHPや、 備忘録的なHPなどありましたらお教えください。よろしくお願いします。

  • パッケージキャッシュについて

    Linux Mint 13 Mateを使っています。 apt-getからインストールされたパッケージは/var/cache/apt/archives/以下にキャッシュされ、パッケージをアンインストールした後もキャッシュは残ると理解しています。 キャッシュされたdebファイルは、再利用を考慮してキャッシュされるのだと思うのですが、再利用にはどのようなケースがあるのでしょうか? また、インストール済みパッケージに対応するパッケージキャッシュを削除しても、そのパッケージの利用に特に悪影響はないのでしょうか?