• ベストアンサー
  • 困ってます

Debianのアップグレードについて詳しいHPを教えてください。

Debianのアップグレードについて詳しいHPを教えてください。 つい最近Debianを入れたばかりの初心者です。 慣れて来たので、testingのsqueezeにアップグレードしようと思うのですが、 apt-get update apt-get upgrade apt-get dist-upgrade で、エラー吐いたり、英文の訳の解らん質問が来たりで出来てません。 Debianのアップグレード(できればsqueeze)について詳しいHPや、 備忘録的なHPなどありましたらお教えください。よろしくお願いします。

共感・応援の気持ちを伝えよう!

  • 回答数6
  • 閲覧数62
  • ありがとう数5

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.3
  • adkori
  • ベストアンサー率31% (221/705)

#2です。 例としてあげられているganglia-monitorは、単一パッケージを 例にとってapt-getで望んでいる動作ができるかどうかを確認しているもので、 実際のアップグレードは「ソースリストをtestingのラインに修正」して # apt-get update # apt-get dist-upgrade (#2で引用した記述から-sがなくなっていることに注意) 全パッケージを対象にupdateします。 ちょっと読みにくいかもしれませんが、 http://www.debian.org/doc/manuals/apt-howto/ch-apt-get.ja.html このあたりをしっかり読んで理解すると良いでしょう。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

一応、自分は # vi /etc/apt/sources.list でsqueezeに置き換えて、 # apt-get update # apt-get dist-upgrade したのですが、 英文の質問がどんどんと吐き出されて、適当に進めて行ったらエラーで止まってしまいました。 しかし、基本はこの方法でよかったみたいですね。質問に適当に答えすぎたですかね。。。 おお。APTのHOWTOページがあったのですか!ありがとうございます。 しっかり読んでみて、できそうならもう一度トライしてみます。 ありがとうございました。

関連するQ&A

  • アップグレードコマンド(Red Hat Linux)

    Red Hat Linux9をインストールして、アップグレードをしようとしています。 apt-get updateを実行し、次にアップグレードをしようというところなのですが、 今までアップグレードは、 apt-get upgrde  でやっていたのですが、 あるホームページを見たら apt-get dist-upgrade とかかれてありました。 違いがあるのでしょうか?教えてください

  • ubuntu アップグレードしてシャットダウン

    ubuntu で一度に、アップデートして、アップグレードして、シャットダウンするコマンドの記述を教えてください。 sudo apt-get update ; sudo apt-get upgrade -y ; sudo shutdown -h now このコマンドだと、sudo が何度も出てきて冗長だし、shutdown コマンドのころには、最初にsudoを実行した時のパスワードの有効時間が超過して再度パスワードを求められた気がします。 sudo (apt-get update ; apt-get upgrade -y ; shutdown -h now) このように()でくくったら文法エラーになった気がします。

  • Debian(玄箱、woody)についてですが。

    APTリポジトリが古いので、 stableを ・deb ftp://ftp.dti.ad.jp/pub/Linux/debian stable main contrib ・deb ftp://ftp.dti.ad.jp/pub/Linux/debian-jp stable-jp main contrib にして、 #apt-get update #apt-get install ntpdate したところ、まず、「glibc」を今インストールするか、 後でするか、 っていう質問画面が出てきて、英語でよく分からなくて・・・ 「X11」とか怪しいこと書いてあったような気がしたけど、入れとく分には 問題ないだろと、yesを選択したわけですが・・・ なんと、installがErrorで強制終了という素晴らしい事態に・・・_ _;; それで、もう1回 #apt-get install ntpdate したら、なんと Segmentation faultsts... 0% # ・・・いや、これって・・・? 何かやっているときに上から「Segmentation fault」の 文字列が重なったとしか・・・ インターネットで検索しました。しかし、 大体起こるのは、「apt-get update」の時だそうな。 しかも、 #apt-cache show ntpdate でも、上に同じ。 どうやらapt自体に何か問題が起きたらしい。 それ以外のコマンドは全く問題なし。 プログラミングの時なら何となく分かりますけど・・・これはどうしろと? 原因が分かる方、コメントをよろしくお願いします。 これで原因が分からなかったら Debian入れ直し・・・ しかもいまsamba入ってないからファイル転送が・・・うぐぉ!? まだ玄箱のなかにtmpimage.tgzがあると思うので、大丈夫だろうとは思いますけど・・・ 緊急です!!よろしくお願いします orz 補足ですが、 最初の「#apt-get update」ですが、 正確には「#apt-get update -o APT::Cache-Limit=16777216」 です。 ^^;; 関係ないと思いますが一応。 「Segmentation fault」はメモリ参照異常のようですね・・・ この文字列と重なっていた「*sts...0%」は、 「get lists」だと思いました。 リストを取得するときにエラーが起こるそうです・・・

その他の回答 (5)

  • 回答No.6

基本的には、最初紹介した url で 出来ます。 VirtualBox に 5.06 を install した。 gnome と apache2 くらい。database はinstall しなかった。 install してある appli とかで 差があるかも知れない。 最初の状態 $ lsb_release -a Distributor ID: Debian Description: Debian GNU/Linux 5.0.6 (lenny) Release: 5.0.6 Codename: lenny -------- 途中 何かに失敗したと時々あるが致命的ではない。 質問には、適当( 適切 ) に答える。ほとんどは、Yes 何時間もかかった。 $ lsb_release -a Distributor ID: Debian Description: Debian GNU/Linux testing (squeeze) Release: testing Codename: squeeze $ uname -r 2.6.32-5-686

共感・感謝の気持ちを伝えよう!

質問者からのお礼

仮想のほうで試してくれたんですか!? ほんとうに、どうもありがとうございます。 確かにインストールしてあるアプリのどれかが足を引っ張ってるのかもしれません。 公式じゃないものもいくつか適当にいれてしまっているので。。。 自分はまだまだ知識が足りないようなので、もうすこし勉強してから、再チャレンジしてみます。 ご回答、ほんとうにありがとうございました。

  • 回答No.5

No.4 で、誤解を生じる様な書き方を してしまいました。 参照した 日本site の方法でも 出来るのかも知れません。 または、出来る場合もある。 ただし、質問に正しく答えて行けばの話しですが。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

なんだか、本格的なリンクありがとうございます。 自分、英語はちょっと苦手なのですが。。。頑張ります。 この方法だと、aptitudeを使ってるみたいですね。 やっぱり、質問に正しく答えていかないとできないんですね。 あんまり自信がない。。。 APTをもちょっと勉強してみて、できそうだったらここを参考にさせていただきます。 ご回答ありがとうございました。

  • 回答No.4

英文で、問題がありそうな事は見ていたのですが 日本文が、日付が新しいのと自信が有りそうに書いてあった。 ↓ は、sources.list に squeeze の代わりに testing とした例。 http://www.computerbob.com/wp/im-using-debian-squeeze-now.php -------------- Upgrading a production Debian Lenny desktop to Squeeze? I don't recommend it http://www.insidesocal.com/click/2010/03/upgrading-a-production-debian.html ここでは、udev と kernel の関係とある。 It seems that the udev in Squeeze requires a newer kernel than the one in Lenny, yet that kernel either doesn't install before udev, or you have to be actually running that new kernel before doing the full upgrade しかし testing では、と言う話もある。 I have always used the method Debian recommend to upgrade to the latest release when going from stable to testing. Its part of the release notes. でも私は、しばらく待ちますが。

共感・感謝の気持ちを伝えよう!

  • 回答No.2
  • adkori
  • ベストアンサー率31% (221/705)

質問者さんがインストールしているバージョンが不明ですが、 最初の方の引用している方法はある意味バージョン固有の方法なので http://mikilab.doshisha.ac.jp/dia/research/report/2005/0811/001/report20050811001.html こちらの方法を覚えた方が汎用性(どのバージョンでも適用できる)が高い と思われます。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

すいません、書き忘れてしまいました。 バージョン5.0.6のLennyからのグレードアップを目指しています。 恥ずかしながら、一度、適当にアップグレードをしてしまって 全部データが飛んだのでかなり慎重に行こうと思っているところです。 汎用性の高いと思われるアップグレードの方法、ありがとうございます。 そうですね、覚えてしまうことが一番ですよね。 ところで、この場合、やりたいのはディストリビューションのベースのアップグレードなので、 例としてあげられている、ganglia-monitorを dist-upgrade と置き換えてやればいいのでしょうか? 寡聞にして無知なもので。すいません。お暇でしたらお教えください。 ご回答ありがとうございました。

  • 回答No.1

例えば、↓ http://d.hatena.ne.jp/Naruhodius/20100819/1282184016 私は、x-86_64 版 を install してありますが 未だやる気が無いので、未確認です。 あくまで、own your risk で。

共感・感謝の気持ちを伝えよう!

質問者からの補足

自分も、この方のような感じで最初、適当にやってみたのですが、 よくわからない質問やら、止まってしまうわなどで、どうしてもうまくゆきませんでした。 何かやらなければいけないことを忘れていたのかもしれません。 このままあまり自信がつかなければ、Squeezeがstableになるまで待って、クリーンインストールもアリかな?なども考えていたり・・・。 ご回答ありがとうございました。

関連するQ&A

  • 「エラー: 依存性の欠如」が出ます!

    apt-get dist-upgrade や apt-get upgrade を(updateのあとに)やると、  エラー: 依存性の欠如:  libruby = 1.6.7-0vl5は ruby-tcltk-1.6.7-0vl5 に必要とされています というメッセージが出ます。 しかし、RUBY 1.6.7-0vl5 に RUBY 1.6.7-0vl5 が必要と言われても、どうしようもありません!! 念のため、apt-get install libruby とかやっても同じでした。 どうすれば良いでしょうか? (なお、この質問は http://okweb.jp/kotaeru.php3?q=1409456 の続きです)

  • Debianでapt-get updateでエラー

    数年前に玄箱(玄箱HGではありません)にDebian Sargeをインストールしました。 それを etch、lenny、… とupgradeするために、先ず apt-get updateコマンドを実行しましたが、下記のエラーとなります。 /etc/apt/sources.list の内容を色々変更しましたが、同じエラーなります。 対処方法をご教示して頂きたくよろしくお願い致します。 E: Unable to parse package file /var/lib/apt/lists/ftp.dti.ad.jp_pub_Linux_debian_dists_stable_main_binary-powerpc_Packages (1)

  • Debianのインストール

    Debianを標準システムユーティリティだけを選択してデスクトップ環境なしでインストールしました。 インストールが完了したあとコマンドラインでsudo apt updateやsudo apt installをしてもエラーが出て使えません。 どうすればなおりますか?

  • KDEのバージョンアップ方法

    「RH9 + KDE3.13」でLinuxを勉強しています。 aptコマンドで apt-get update apt-get dist-upgrade としてもKDEは、バージョンアップされません。 aptコマンドで、KDEのバージョンアップは、できないのでしょうか? KDEのバージョンアップする方法を アドバイス宜しくお願いします。 参考になるサイトでも結構です。

  • colinux0.7.6にDebian5.0を導入すると、自動でネットワークの設定がされたのですが。

    いつもお世話になっております。 現在、小生WinXPSP3上でcolinux0.7.6上でDebian5.0を起動させて使っている、Debian初学者です。 現在、何の設定もしていないのに、ネットワークに繋がります。 ブリッジ接続の設定もしていないのにネットに繋がります。 これはどうしてなんでしょうか?? 普通にapt-get update、apt-get install gccと入力してもgccがインストールされました。 以上、お忙しい中申し訳ございませんが、先輩方ご教授宜しくお願い致します!

  • apt-get upgradeを時々やるべきでしょうか?

    apt-get upgradeを時々やるべきでしょうか? サーバでapt-get update/upgradeを時々やるべきでしょうか? Ubuntu Server を 認証サーバ&ファイルサーバとして使おうと思っています。 セキュリティーのためには、 # sudo apt-get update # sudo apt-get upgrade を時々やった方が良いとは思います。 しかし、update/upgrade をすると、インストール済みのパッケージの中で新しいバージョンが公開されているときは、最新バージョンをダウンロードしてインストールするのですよね? 自分が構築した認証、NSF等の設定が upgrade で壊れてしまわないか心配です。 質問ですが ● apt-get update/upgrade で、システムの設定ファイルが上書きされる心配はしなくて大丈夫なものでしょうか? ● みなさんはサーバのセキュリティアップデートはどうなさっているでしょうか?

  • linux自動でアップデート

    kali linuxを使ってるのですがwindowsのように自動でアップデートできるようする方法を教えてください。 起動してインターネットにつながったら自動でapt update と apt dist-upgradeをしてほしいです

  • DebianのIceweaselとIcedove

    インストールしてみて知ったのですが、 多くの方はご存じのように Debianでのブラウザとメーラーは商標の問題とやらで FirefoxとThunderbirdでなく IceweaselとIcedove になっています。 いくつかのウェブページの内容を読んでも 自力で判断できなかったのですが、 例えばアップデートが遅れるというようなことで セキュリティの面で IceweaselとIcedoveが FirefoxとThunderbirdよりも 劣っている ということはあるのでしょうか? http://ja.wikipedia.org/wiki/Iceweasel に書いてある 「Debian Projectとしては、Firefoxの商標を使用し、「non-free」と呼ばれる非公式サービスの中でFirefoxを提供するという選択肢もあった。しかしnon-freeサービスはセキュリティサポートの対象外[2]であり、・・・」 というこの文章の意味も分からなかったのですが、 FirefoxのアップデートはMozillaが提供しているので、 Mozillaがきちんとセキュリティの検証を行っていれば アップデートをそのまま sudo apt-get update sudo apt-get upgrade から適用できるようにしておけば ユーザーがセキュリティの心配をする必要はなくなると思うのですが、 Wikipediaの文章はどういうことなのでしょうか? よろしくお願いします。

  • Linux の apt-get dist-upgrade が止まる!

    友達にLinux をすすめられたので、Vine Linux を使い始めました。 Windows Update みたいなことは # apt-get update # apt-get dist-upgrade この2つだけで簡単にできる と聞いたのですが、次のようなエラーが出ます。 <問題1> apt-get update をすると ===================================== ・・・・ 以下の取得に失敗しました: ftp://ftp.jaist.ac.jp/os/linux/Vine/apt/2.6/i386/base/srclist.plus Unable to fetch file, server said '/os/linux/Vine/apt/2.6/i386/base/srclist.plus.bz2: No such file or directory ' パッケージリストを読みこんでいます... 完了 依存情報ツリーを作成しています... 完了 E: いくつかのインデックスファイルのダウンロードに失敗、無視、あるいは古いものが使用されました。 ===================================== のようなエラーが出ます。「取得に失敗しました」が10個あります。 <問題2> つづけて apt-get dist-upgrade をすると、 ====================================== ・・・・ 48 個のアップグレードパッケージ, 0 個の新規パッケージ, 0 個の削除/リプレースパッケージ, 4 個の保留パッケージがあります。 取得パッケージ: 0B/68.0MB のアーカイブを取得します。インストール後は 8614kB が使用されます。 続行しますか? [Y/n]Y RPM コマンドを実行しています (-U)... エラー: 依存性の欠如: libruby = 1.6.7-0vl5は ruby-tcltk-1.6.7-0vl5 に必要とされています E: Sub-process /bin/rpm returned an error code (48) ===================================== のようなメッセージが出てとまります。 どうすればよいでしょうか?

  • aptでアップデートされた日時を知りたい。

    aptでアップデートされた日時を知りたい。 Debian GNU/Linux 5.0(Lenny)を使っています。 "apt-get upgrade"もしくは"aptitude safe-upgrade"によって最後にシステムが更新された日時を知りたいのですが、どこかに記録されていますでしょうか。 2010年7月10日