• ベストアンサー
  • 困ってます

Debianでapt-get updateでエラー

数年前に玄箱(玄箱HGではありません)にDebian Sargeをインストールしました。 それを etch、lenny、… とupgradeするために、先ず apt-get updateコマンドを実行しましたが、下記のエラーとなります。 /etc/apt/sources.list の内容を色々変更しましたが、同じエラーなります。 対処方法をご教示して頂きたくよろしくお願い致します。 E: Unable to parse package file /var/lib/apt/lists/ftp.dti.ad.jp_pub_Linux_debian_dists_stable_main_binary-powerpc_Packages (1)

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数849
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • vaidurya
  • ベストアンサー率45% (2710/5975)

実際にftpサイトへアクセスしてみて 該当ファイルがあるか?それ要確認です。 あるとしたら、一時的にサーバーとの接続に 障害が生じている可能性もあると思います。 記述内容に、細かいミスがあるのかもしれません。 現状は確認していませんが、Sargeはもうかなり古いものですから なんらかの、手間がかかる状況にあるのかもしれません。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

その後、色々調べてみましたが、ご指摘のようにSargeはかなり古いバージョンのため、今はアーカイブされていて通常のミラーからは取得できないようです。 アーカイブ用にapt lineを修正してトライしたいと思います。 早速回答頂きありがとうございました。

関連するQ&A

  • Debian apt-get updateができない

    Debian初心者です。 これからLinuxの勉強を始めようと思い、いろいろとテキストを買ってきて勉強をし始めましたが、早速つまずいてしまいました。 Debianのインストールまではできたのですが、apt-get updateができません。 以下のようになります。 KURO-BOX:/home/tmp-kun# apt-get update Get:1 ftp://ftp.dti.ad.jp woody/main Packages Err ftp://ftp.dti.ad.jp woody/main Packages Unable to fetch file, server said '/pub/Linux/debian/dists/woody/main/binary-p owerpc/Packages.gz: No such file or directory. ' [IP: 202.216.228.228 21] Get:2 ftp://ftp.dti.ad.jp woody/main Release Ign ftp://ftp.dti.ad.jp woody/main Release 省略 Get:8 ftp://ftp.dti.ad.jp woody/contrib Release Ign ftp://ftp.dti.ad.jp woody/contrib Release Hit ftp://ftp.dti.ad.jp woody/non-US/main Sources Hit ftp://ftp.dti.ad.jp woody/non-US/main Release Hit ftp://ftp.dti.ad.jp woody/non-US/contrib Sources Hit ftp://ftp.dti.ad.jp woody/non-US/contrib Release Failed to fetch http://security.debian.org/dists/woody/updates/main/binary-power pc/Packages 404 Not Found [IP: 212.211.132.32 80] Failed to fetch http://security.debian.org/dists/woody/updates/contrib/binary-po werpc/Packages 404 Not Found [IP: 212.211.132.32 80] Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/main/binary-pow erpc/Packages Unable to fetch file, server said '/pub/Linux/debian/dists/woody/ main/binary-powerpc/Packages.gz: No such file or directory. ' [IP: 202.216.228. 228 21] Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/contrib/binary- powerpc/Packages Unable to fetch file, server said '/pub/Linux/debian/dists/woo dy/contrib/binary-powerpc/Packages.gz: No such file or directory. ' [IP: 202.21 6.228.228 21] Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/main/source/Sou rces Unable to fetch file, server said '/pub/Linux/debian/dists/woody/main/sour ce/Sources.gz: No such file or directory. ' [IP: 202.216.228.228 21] Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/contrib/source/ Sources Unable to fetch file, server said '/pub/Linux/debian/dists/woody/contri b/source/Sources.gz: No such file or directory. ' [IP: 202.216.228.228 21] Reading Package Lists... Done Building Dependency Tree... Done E: Some index files failed to download, they have been ignored, or old ones used instead. いろいろと調べてみたりしたのですが、まったくとっていいほど解決策が見つかりません。 この後sambaのインストールも行いたいのですが、進まずじまいです。 以上、解決方法教えて頂きたいです。

  • Debian3.1 sarge で apt-get で接続できません。

    OSはdebian 3.1です。 1週間ぐらい前からapt-getでアップデートできないようになってしまいました。 エラーは dennou-q.geo.kyushu-u.ac.jp:21 へ接続できませんでした。 - connect (111 接続を拒否されました) と表示されます。 下記が/etc/apt/sources.listの設定です。 #deb file:///cdrom/ sarge main deb ftp://dennou-q.geo.kyushu-u.ac.jp/library/Linux/debian/ stable main deb-src ftp://dennou-q.geo.kyushu-u.ac.jp/library/Linux/debian/ stable main deb http://security.debian.org/ stable/updates main どのような対応をすればよいのでしょうか?

  • Debian(玄箱、woody)についてですが。

    APTリポジトリが古いので、 stableを ・deb ftp://ftp.dti.ad.jp/pub/Linux/debian stable main contrib ・deb ftp://ftp.dti.ad.jp/pub/Linux/debian-jp stable-jp main contrib にして、 #apt-get update #apt-get install ntpdate したところ、まず、「glibc」を今インストールするか、 後でするか、 っていう質問画面が出てきて、英語でよく分からなくて・・・ 「X11」とか怪しいこと書いてあったような気がしたけど、入れとく分には 問題ないだろと、yesを選択したわけですが・・・ なんと、installがErrorで強制終了という素晴らしい事態に・・・_ _;; それで、もう1回 #apt-get install ntpdate したら、なんと Segmentation faultsts... 0% # ・・・いや、これって・・・? 何かやっているときに上から「Segmentation fault」の 文字列が重なったとしか・・・ インターネットで検索しました。しかし、 大体起こるのは、「apt-get update」の時だそうな。 しかも、 #apt-cache show ntpdate でも、上に同じ。 どうやらapt自体に何か問題が起きたらしい。 それ以外のコマンドは全く問題なし。 プログラミングの時なら何となく分かりますけど・・・これはどうしろと? 原因が分かる方、コメントをよろしくお願いします。 これで原因が分からなかったら Debian入れ直し・・・ しかもいまsamba入ってないからファイル転送が・・・うぐぉ!? まだ玄箱のなかにtmpimage.tgzがあると思うので、大丈夫だろうとは思いますけど・・・ 緊急です!!よろしくお願いします orz 補足ですが、 最初の「#apt-get update」ですが、 正確には「#apt-get update -o APT::Cache-Limit=16777216」 です。 ^^;; 関係ないと思いますが一応。 「Segmentation fault」はメモリ参照異常のようですね・・・ この文字列と重なっていた「*sts...0%」は、 「get lists」だと思いました。 リストを取得するときにエラーが起こるそうです・・・

  • debian のアップデートについて

    サーバーのアップデートを行うために apptitude update を実行すると以下のように表示されます.これはアップデートに成功しているのでしょうか.また,失敗している場合は対処法を教えてください. Err http://cdn.debian.org stable Release.gpg Could not resolve 'cdn.debian.org' Ign http://ftp.jp.debian.org lenny Release.gpg Ign http://ftp.jp.debian.org lenny Release Ign http://ftp.jp.debian.org lenny/main Packages/DiffIndex Ign http://ftp.jp.debian.org lenny/main Sources/DiffIndex Ign http://ftp.jp.debian.org lenny/main Packages Ign http://ftp.jp.debian.org lenny/main Sources Err http://ftp.jp.debian.org lenny/main Packages 404 Not Found Err http://ftp.jp.debian.org lenny/main Sources 404 Not Found Ign http://security.debian.org lenny/updates Release.gpg Hit http://volatile.debian.org lenny/volatile Release.gpg Ign http://security.debian.org lenny/updates Release Hit http://volatile.debian.org lenny/volatile Release Ign http://security.debian.org lenny/updates/main Packages/DiffIndex Ign http://volatile.debian.org lenny/volatile/main Packages/DiffIndex Ign http://security.debian.org lenny/updates/main Sources/DiffIndex Ign http://volatile.debian.org lenny/volatile/main Sources/DiffIndex Ign http://security.debian.org lenny/updates/main Packages Hit http://volatile.debian.org lenny/volatile/main Packages Ign http://security.debian.org lenny/updates/main Sources Hit http://volatile.debian.org lenny/volatile/main Sources Err http://security.debian.org lenny/updates/main Packages 404 Not Found [IP:...] Err http://security.debian.org lenny/updates/main Sources 404 Not Found [IP:...] Reading package lists... Done

  • apt-get updateするとファイル取得に失敗する。

    apt-get updateするとファイル取得に失敗する。 KNOPPIX5.3.1をCDから起動しています。 apt-get updateを実行すると、以下のようなメッセージが表示されます。   (略) 無視 http://wine.budgetdedicated.com etch/main Translation-ja 98% [ヘッダの待機中です] [ヘッダの待機中です] エラー http://ppa.launchpad.net gutsy/main Sources 403 Forbidden 98% [ヘッダの待機中です] [ヘッダの待機中です]   (略) 11.0kB を 2s で取得しました (3734B/s) W: http://ppa.launchpad.net/kubuntu-members-kde4/ubuntu/dists/gutsy/main/binary-i386/Packages.gz の取得に失敗しました 403 Forbidden W: http://ppa.launchpad.net/kubuntu-members-kde4/ubuntu/dists/gutsy/main/source/Sources.gz の取得に失敗しました 403 Forbidden E: いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、古いものが代わりに使われます。 何日か間をおいて、時間帯も変えて実行してみたのですが、上記のとおり 正常に完了しませんでした。 どのように対処したらよいでしょうか。 ご指導ください。よろしくお願いします。

  • DebianにRをインストールできません。

    いろいろとサイトを見ながら進めたのですが、詰まってしまいました。 具体的には、以下のように行いました。 /etc/sources.listに deb http://cran.md.tsukuba.ac.jp/bin/linux/debian etch-cran/ deb-src http://cran.md.tsukuba.ac.jp/bin/linux/debian etch-cran/ と書き、 apt-get update を実行。ここでは問題なし。その後 apt-get install r-base を実行。すると、 Reading Package Lists... Done Building Dependency Tree... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. Since you only requested a single operation it is extremely likely that the package is simply not installable and a bug report against that package should be filed. The following information may help to resolve the situation: The following packages have unmet dependencies: r-base: Depends: r-base-core (>= 2.7.1-1+lenny1) but it is not going to be installed Depends: r-recommended (= 2.7.1-1+lenny1) but it is not going to be installed E: Broken packages と表示されました。 r-base-coreやr-recommendedをインストールすればいいのかと思い実行すると、同様のエラーが何度も出てくるので、何か違う解決策があるのかと思いました。 たぶん、Debianのバージョンが古いのが原因ではないかと自分では思ってます。 cat etc/issue をすると Debian GNU/Linux 3.1 \n \l と出たので、sargeなのだと思います。 ということはsources.listにetch-cranと書いたのがいけなかったのかと思いsargeに書き換えようかと思いましたが、ミラーサイトにはsargeのファイルは置かれていないようでした。 Debianをバージョンアップする以外にRをインストールする方法はあるでしょうか?

  • apt-getで特定のバージョンをインストール

    [質問] ubuntu16.04のapt-get install nodejs=6.9.0-1nodesource1で、古いバージョンのnodejsをインストールするには、どのようにしたらよいでしょうか。 (dpkg -i nodejs.deb、PPAリポジトリを追加、nvm,nodebrew等のバージョン管理ツールを使わず、公式サイトのリポジトリからapt-get installする方法でお願いします。) [背景] curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash - sudo apt-get update sudo apt-get install nodejs=6.9.0-1nodesource1 では、インストールできませんでした。 sources.list先にhttps://deb.nodesource.com/node_6.x/pool/main/n/nodejs/nodejs_6.9.0-1nodesource1~xenial1_amd64.deb はありますが、 https://deb.nodesource.com/node_6.x/dists/xenial/main/binary-amd64/Packages に Version: 6.9.0-1nodesource1~xenial1 の記載がないので、apt-getでインストールできないと思います。 (postgresの場合は、 http://apt.postgresql.org/pub/repos/apt/dists/xenial-pgdg/main/binary-amd64/Packages に Package: postgresql-9.4 Version: 9.4.10-1.pgdg16.04+1 の記載があり、下記で古いバージョンのpostgresql-9.4はインストールできました。 sudo apt-get update sudo apt-get install postgresql-9.4 ) sources.listをfile:/にして、ローカルにdeb,Packages,Sources,Releaseを配置して、apt-get installで古いバージョンをインストールできましたが、 特定バージョンのPackages,Sources,Releaseのテキストファイルがないと、この方法ができません。 (リポジトリ内に古いPackages,Sources,Releaseのテキストファイルはありませんでした。) また、CentOSの場合は、下記で古いバージョンのnodejsがインストールできました。(yumとapt-getの仕組みの違いと思います。) curl --silent --location https://rpm.nodesource.com/setup_6.x | bash - yum --showduplicates list | grep nodejs yum install nodejs-6.9.0 よろしくお願いします。

  • DebianへGNOMEのインストールでエラーになります。

    どなたか教えて下さい。 Debian Sargeで、GNOMEをインストールすると、うまくいかないため apt-get -f installを実行しました。 しかし、次のメッセージが。 E: 読み込みエラー -read (5 入力/出力エラーです) E: prior errors apply to /cdrom//pool/main/lide/libexif/libexif10_0.6.9-6_i386.deb と多数パッケージのエラーが表示されます。 似たようなエラーはサイト等で調べましたが、原因はわかりませんでした。 わかる方、教えて下さい。

  • 玄箱 debian sargeへアップグレードで。

    玄箱 debian sargeへアップグレードでどうしてもつまずいている部分があります。 E: This installation run will require temporarily removing the essential package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, but if you re ally want to do it, activate the APT::Force-LoopBreak option. E: Internal Error, Could not early remove e2fsprogs 上記エラーがでてインストールがストップしてしまいます。 解決方法をご存知の方ご教授ください・・・ いかんせんsargeへアップグレードは簡単とのことで調べてみたのですが同じ症状の方がいらっしゃらないようで・・・

  • Debianでmediatombが自動起動出来ない。

    debian(etch)を初代玄箱に入れ、mediatombをインストールしたのですが、自動実行されず、起動するたびに手動でmediatombを起動しないといけない状態です。 インストール自体、apt-get installではインストール出来なかったため、apt-get sourceでソースファイルからコンパイル、インストールをしました。 そのためか、いくつかのサイトで自動実行されない場合の方法として書いてある方法では起動されない状態です。(/etc/default/mediatomb、/etc/init.d/mediatomb自体が存在しないため、update-rc.d -f mediatomb defaults が出来ません。) どのようにすればいいかご教示ください。