• ベストアンサー
  • 困ってます

apt-get updateするとファイル取得に失敗する。

apt-get updateするとファイル取得に失敗する。 KNOPPIX5.3.1をCDから起動しています。 apt-get updateを実行すると、以下のようなメッセージが表示されます。   (略) 無視 http://wine.budgetdedicated.com etch/main Translation-ja 98% [ヘッダの待機中です] [ヘッダの待機中です] エラー http://ppa.launchpad.net gutsy/main Sources 403 Forbidden 98% [ヘッダの待機中です] [ヘッダの待機中です]   (略) 11.0kB を 2s で取得しました (3734B/s) W: http://ppa.launchpad.net/kubuntu-members-kde4/ubuntu/dists/gutsy/main/binary-i386/Packages.gz の取得に失敗しました 403 Forbidden W: http://ppa.launchpad.net/kubuntu-members-kde4/ubuntu/dists/gutsy/main/source/Sources.gz の取得に失敗しました 403 Forbidden E: いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、古いものが代わりに使われます。 何日か間をおいて、時間帯も変えて実行してみたのですが、上記のとおり 正常に完了しませんでした。 どのように対処したらよいでしょうか。 ご指導ください。よろしくお願いします。

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数3523
  • ありがとう数9

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • yakan9
  • ベストアンサー率54% (2045/3780)

Synapticパッケージマネージャの取得は成功したようですね。 http://okwave.jp/qa/q6166393.html 今回のこのメッセージは、Warning(W:警告)のため仕方ないことだと思われます。 当方も、検証しましたが、確かに出ます。 多分、Kメニューから「KNOPPIX」-「Configure」-「継続的なKNOPPIXディスクイメージの作成」 を定義していれば、そこに更新されていると思います。 ただし、HDDにインストールしていないため、あまり正しい使い方ではありません。 というのは、 apt-get update apt-get upgrade は、ペアで使用して初めて意味を成すのです。 簡単に違いを言いますと、 updateは、テーブルの更新です。実際のプログラムのダウンロードやインストールはしません。 更新されたものがどれかを識別して、更新すべきものがどれかをリストアップすると考えてください。 upgradeは、更新されているパッケージをインストールすることです。 下記を参考にすると、少し詳しく説明されています。 https://forums.ubuntulinux.jp/viewtopic.php?pid=56609 そこで、"apt-get upgrade"を行ってみると、エラーが発生し、 「アップグレード」は、失敗すると思います。 おそらく、この機能を受け付けないような仕組みを作っているのだと思われます。 よって、どのようなことをやりたいかは明記されていないため、断言はできないのですが、 一部を取り込んでそれをこれから使いたいと思う場合には、synapticパッケージマネージャより検索し、apt-get install xxxxx というコマンドでインストールして使うことは有効ですが、 恒久的に、全パッケージを最新にすることはできないということになります。 それは、HDDにパーティションを定義して、インストールという手順であれば、可能であろうと思われます。 結局は、CD/DVD-ROMからの簡易起動を目的にしたものであるということです。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

以前の質問にも回答してくださいましたね。ありがとうございます。 私は、使おうと思っていたアプリケーションが付属していなかったので、 それをインストールしようと考えていました。 回答を拝見しますと、アプリケーションをインストールすることは できるとのことですので、試してみようと思います。 質問への回答だけでなく周辺の知識の案内まで、丁寧な回答に 感謝しております。ありがとうございました。

関連するQ&A

  • apt-get 失敗

    久しぶりに使用するマシンで、 apt-get でyacc, m4などをインストールしようとしているのですが、 apt-get install m4 としても 404 Not Found のエラーがでます。 よくみると、m4_1.4.10-0ubuntu2_amd64.deb というファイルを取得しようとしていますが、 接続先のサーバーには、上記の名前のファイルは存在せず、 m4_1.4.10-1_amd64.deb というものならあります。 apt-get upgrade や apt-get update を行ってみたものの やはり、同様に Not Found エラーが多発します。 以前は update 等はできていたのですが、久しぶりにおこなったら失敗するようになっていました。このような場合はどのように対処すればよいのでしょうか? マシンは OS : Ubuntu 7.10 CPU: Intel core 2 quad Q6600 Memory: 4Gb

  • Debian apt-get updateができない

    Debian初心者です。 これからLinuxの勉強を始めようと思い、いろいろとテキストを買ってきて勉強をし始めましたが、早速つまずいてしまいました。 Debianのインストールまではできたのですが、apt-get updateができません。 以下のようになります。 KURO-BOX:/home/tmp-kun# apt-get update Get:1 ftp://ftp.dti.ad.jp woody/main Packages Err ftp://ftp.dti.ad.jp woody/main Packages Unable to fetch file, server said '/pub/Linux/debian/dists/woody/main/binary-p owerpc/Packages.gz: No such file or directory. ' [IP: 202.216.228.228 21] Get:2 ftp://ftp.dti.ad.jp woody/main Release Ign ftp://ftp.dti.ad.jp woody/main Release 省略 Get:8 ftp://ftp.dti.ad.jp woody/contrib Release Ign ftp://ftp.dti.ad.jp woody/contrib Release Hit ftp://ftp.dti.ad.jp woody/non-US/main Sources Hit ftp://ftp.dti.ad.jp woody/non-US/main Release Hit ftp://ftp.dti.ad.jp woody/non-US/contrib Sources Hit ftp://ftp.dti.ad.jp woody/non-US/contrib Release Failed to fetch http://security.debian.org/dists/woody/updates/main/binary-power pc/Packages 404 Not Found [IP: 212.211.132.32 80] Failed to fetch http://security.debian.org/dists/woody/updates/contrib/binary-po werpc/Packages 404 Not Found [IP: 212.211.132.32 80] Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/main/binary-pow erpc/Packages Unable to fetch file, server said '/pub/Linux/debian/dists/woody/ main/binary-powerpc/Packages.gz: No such file or directory. ' [IP: 202.216.228. 228 21] Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/contrib/binary- powerpc/Packages Unable to fetch file, server said '/pub/Linux/debian/dists/woo dy/contrib/binary-powerpc/Packages.gz: No such file or directory. ' [IP: 202.21 6.228.228 21] Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/main/source/Sou rces Unable to fetch file, server said '/pub/Linux/debian/dists/woody/main/sour ce/Sources.gz: No such file or directory. ' [IP: 202.216.228.228 21] Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/contrib/source/ Sources Unable to fetch file, server said '/pub/Linux/debian/dists/woody/contri b/source/Sources.gz: No such file or directory. ' [IP: 202.216.228.228 21] Reading Package Lists... Done Building Dependency Tree... Done E: Some index files failed to download, they have been ignored, or old ones used instead. いろいろと調べてみたりしたのですが、まったくとっていいほど解決策が見つかりません。 この後sambaのインストールも行いたいのですが、進まずじまいです。 以上、解決方法教えて頂きたいです。

  • ubuntu8.04 Dell mini9 リポジトリの件

    Dell mini9 で Linux デビューした初心者です。 よろしくお願い致します。 synaptic パッケージ・マネージャでパッケージ情報をダウンロードすると、「全てまたは一部のリポジトリのインデックスファイルがダウンロードできませんでした」というボックスに以下の内容が表示されます。 ーーー GPG error: http://archive.ubuntulinux.jp hardy/ Release: 公開鍵を利用できないため、以下の署名は検証できませんでした: NO_PUBKEY 058A05E90C4ECFECGPG error: http://archive.ubuntulinux.jp hardy-ja/ Release: 公開鍵を利用できないため、以下の署名は検証できませんでした: NO_PUBKEY 058A05E90C4ECFECGPG error: http://packages.medibuntu.org hardy Release: 以下の署名が無効です: BADSIG 2EBC26B60C5A2783 Medibuntu Packaging Team <admin@lists.medibuntu.org>http://ubuntutym.u-toyama.ac.jp/ubuntu/dists/hardy/main/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://ubuntutym.u-toyama.ac.jp/ubuntu/dists/hardy/universe/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://ubuntutym.u-toyama.ac.jp/ubuntu/dists/hardy/restricted/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://ubuntutym.u-toyama.ac.jp/ubuntu/dists/hardy/multiverse/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://ubuntutym.u-toyama.ac.jp/ubuntu/dists/hardy-updates/universe/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://ubuntutym.u-toyama.ac.jp/ubuntu/dists/hardy-updates/main/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://ubuntutym.u-toyama.ac.jp/ubuntu/dists/hardy-updates/restricted/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://ubuntutym.u-toyama.ac.jp/ubuntu/dists/hardy-updates/multiverse/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://security.ubuntu.com/ubuntu/dists/hardy-security/universe/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://security.ubuntu.com/ubuntu/dists/hardy-security/main/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://security.ubuntu.com/ubuntu/dists/hardy-security/restricted/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://security.ubuntu.com/ubuntu/dists/hardy-security/multiverse/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found http://packages.medibuntu.org/dists/hardy/free/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found [IP: 88.191.82.11 80] http://packages.medibuntu.org/dists/hardy/non-free/binary-lpia/Packages.gz の取得に失敗しました 404 Not Found [IP: 88.191.82.11 80] いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、古いものが代わりに使われます。 ーーー リポジトリでダウンロード元の変更をしても、同じ結果になります。 何が問題でダウンロードに失敗しているのか解りません。 何卒よろしくお願い致します。

  • 「apt-get install wget」の実行でエラーが発生

    「apt-get install wget」を実行すると下記のエラーメッセージが 表示されます。 --------------------------------------------------------------- エラー http://ports.ubuntu.com jaunty/main wget 1.11.4-2ubuntu1 'ports.ubuntu.com' を解決できませんでした http://ports.ubuntu.com/pool/main/w/wget/wget_1.11.4-2ubuntu1_armel.deb の取得に失敗しました 'ports.ubuntu.com' を解決できませんでした E: いくつかのアーカイブが取得できません。apt-get update を実行するか --fix-missing オプションを付け て試してみてください。 ----------------------------------------------------------- 解決方法を教えて下さい。宜しくお願いいたします。

  • ubuntu10.04ltsのアップデートマネーの

    ubuntu10.04ltsでアップデートマネーを起動すると「全てまたは一部のリポジトリのインデックスファイルがダウンロードできませんでした」と表示されます。 「ppa launchpad.net/user/ppa-name/ubuntu/dists/lucid/main/binary-i386/packages.gzの取得に失敗しました」が原因のようです。 解決の方法はどの様に操作したら良いのでしょうか? netで調べてみましたが解決に至りません、よろしくお願いします。

  • apache2がrestartできない。

    $ sudo apt update ヒット:1 http://jp.archive.ubuntu.com/ubuntu bionic InRelease ヒット:2 http://jp.archive.ubuntu.com/ubuntu bionic-updates InRelease ヒット:3 http://jp.archive.ubuntu.com/ubuntu bionic-backports InRelease ヒット:4 http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic InRelease 取得:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB] ヒット:6 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu bionic InRelease ヒット:7 http://ppa.launchpad.net/flexiondotorg/audio/ubuntu bionic InRelease ヒット:8 http://ppa.launchpad.net/gnumdk/lollypop/ubuntu bionic InRelease ヒット:9 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease ヒット:10 http://ppa.launchpad.net/hluk/copyq/ubuntu bionic InRelease ヒット:11 http://ppa.launchpad.net/inkscape.dev/stable/ubuntu bionic InRelease ヒット:12 http://ppa.launchpad.net/japaneseteam/ppa/ubuntu bionic InRelease ヒット:13 http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu bionic InRelease ヒット:14 http://ppa.launchpad.net/libreoffice/ppa/ubuntu bionic InRelease ヒット:15 http://ppa.launchpad.net/mc3man/mpv-tests/ubuntu bionic InRelease ヒット:16 http://ppa.launchpad.net/mikhailnov/pulseeffects/ubuntu bionic InRelease ヒット:17 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease ヒット:18 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic InRelease ヒット:19 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu bionic InRelease ヒット:20 http://ppa.launchpad.net/ozmartian/apps/ubuntu bionic InRelease ヒット:21 http://ppa.launchpad.net/peek-developers/stable/ubuntu bionic InRelease ヒット:22 http://ppa.launchpad.net/phoerious/keepassxc/ubuntu bionic InRelease ヒット:23 http://ppa.launchpad.net/rednotebook/stable/ubuntu bionic InRelease ヒット:24 http://ppa.launchpad.net/robert-tari/main/ubuntu bionic InRelease ヒット:25 http://ppa.launchpad.net/rvm/smplayer/ubuntu bionic InRelease ヒット:26 http://ppa.launchpad.net/sicklylife/converseen/ubuntu bionic InRelease ヒット:27 http://ppa.launchpad.net/sicklylife/filezilla/ubuntu bionic InRelease ヒット:28 http://ppa.launchpad.net/sicklylife/fonts-noto-cjk/ubuntu bionic InRelease ヒット:29 http://ppa.launchpad.net/sicklylife/fslint/ubuntu bionic InRelease ヒット:30 http://ppa.launchpad.net/sicklylife/geany/ubuntu bionic InRelease ヒット:31 http://ppa.launchpad.net/sicklylife/gnucash/ubuntu bionic InRelease ヒット:32 http://ppa.launchpad.net/sicklylife/gshutdown/ubuntu bionic InRelease ヒット:33 http://ppa.launchpad.net/sicklylife/libgweather-ja/ubuntu bionic InRelease ヒット:34 http://ppa.launchpad.net/sicklylife/mozc/ubuntu bionic InRelease ヒット:35 http://ppa.launchpad.net/sicklylife/nomacs/ubuntu bionic InRelease ヒット:36 http://ppa.launchpad.net/sicklylife/ppa/ubuntu bionic InRelease ヒット:37 http://ppa.launchpad.net/sicklylife/qtgain/ubuntu bionic InRelease ヒット:38 http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu bionic InRelease ヒット:39 http://ppa.launchpad.net/transmissionbt/ppa/ubuntu bionic InRelease ヒット:40 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic InRelease ヒット:41 http://ppa.launchpad.net/ubuntuhandbook1/apps/ubuntu bionic InRelease ヒット:42 http://ppa.launchpad.net/ubuntuhandbook1/audacity/ubuntu bionic InRelease ヒット:43 http://ppa.launchpad.net/ubuntuhandbook1/avidemux/ubuntu bionic InRelease ヒット:44 http://ppa.launchpad.net/ubuntuhandbook1/cantata-qt/ubuntu bionic InRelease ヒット:45 http://ppa.launchpad.net/ubuntuhandbook1/dvdstyler/ubuntu bionic InRelease ヒット:46 http://ppa.launchpad.net/ubuntuhandbook1/lives/ubuntu bionic InRelease $ sudo systemctl restart apache2 Job for apache2.service failed because the control process exited with error code. See "systemctl status apache2.service" and "journalctl -xe" for details. apache2が異常です。どうしたら正常になるでしょうか? ご回答の程、宜しくお願い申し上げます。

  • vinelinuxでapt-getが使えない。

    現在、vineで自宅サーバをしているのですが、再インストールしたら、apt-getが接続できなくなってしまいました。 インターネットには接続しています。 ネットで検索して、接続先を変更しましたがダメでした。。 エラー内容は ----------------------------------------- エラー http://updates.vinelinux.org 3.2/i386 release Temporary failure resolving 'updates.vinelinux.org' 以下の取得に失敗しました: http://updates.vinelinux.org/apt/3.2/i386/base/release Temporary failure resolving 'updates.vinelinux.org' パッケージリストを読みこんでいます... 完了 依存情報ツリーを作成しています... 完了 W: いくつかのリポジトリのリリースファイルが取得できませんでした。取得できなかっ たリポジトリは無視されます。 W: この問題を解決するためには 'apt-get update' を実行する必要があるかもしれませ ん。 E: いくつかのインデックスファイルのダウンロードに失敗、無視、あるいは古いものが 使用されました。 ------------------------------------- です。 分かる方いましたら、お願いします。 vienLinuxでapt-getが使えないと不便で仕方ありません。

  • 正しくapt-getができるミラーサイト?

    VineLinux4.1をインストール後にapt-getを実行しましたが、以下のエラーが発生します。正しくapt-getができるミラーサイトはあるのでしょうか?ちなみにインターネットは見れています。 取得:1 http://www.t.ring.gr.jp 4.1/i386 release [2255B] エラー http://www.t.ring.gr.jp 4.1/i386 release File was not signed with a known key. Check if the proper gpg key was imported to your keyring. 以下の取得に失敗しました: http://www.t.ring.gr.jp/pub/linux/Vine/apt/4.1/i386/base/release File was not signed with a known key. Check if the proper gpg key was imported to your keyring. 2255B を 0s 秒で取得しました (11.3kB/s) パッケージリストを読みこんでいます... 依存情報ツリーを作成しています... W: いくつかのリポジトリのリリースファイルが取得できませんでした。取得できなかったリポジトリは無視されます。 W: この問題を解決するためには 'apt-get update' を実行する必要があるかもしれません。 E: いくつかのインデックスファイルのダウンロードに失敗、無視、あるいは古いものが使用されました。 以下、/etc/aptにあるsources.listです。 --------------------------------------------------------- # # apt for RPM source.list sample # ## ## Vine Linux 4.1 ## # (master) #rpm [vine] http://updates.vinelinux.org/apt 4.1/$(ARCH) main plus updates nonfree #rpm-src [vine] http://updates.vinelinux.org/apt 4.1/$(ARCH) main plus updates nonfree # # (ring mirror) rpm [vine] http://www.t.ring.gr.jp/pub/linux/Vine/apt 4.1/$(ARCH) main plus updates nonfree rpm-src [vine] http://www.t.ring.gr.jp/pub/linux/Vine/apt 4.1/$(ARCH) main plus updates nonfree # # (jaist mirror) #rpm [vine] http://ftp.jaist.ac.jp/pub/Linux/Vine/apt 4.1/$(ARCH) main plus updates nonfree #rpm-src [vine] http://ftp.jaist.ac.jp/pub/Linux/Vine/apt 4.1/$(ARCH) main plus updates nonfree # # (kddlabs mirror) #rpm [vine] http://ftp.kddlabs.co.jp/pub/Linux/distributions/Vine/apt 4.1/$(ARCH) main plus updates nonfree #rpm-src [vine] http://ftp.kddlabs.co.jp/pub/Linux/distributions/Vine/apt 4.1/$(ARCH) main plus updates nonfree

  • apt-getで特定のバージョンをインストール

    [質問] ubuntu16.04のapt-get install nodejs=6.9.0-1nodesource1で、古いバージョンのnodejsをインストールするには、どのようにしたらよいでしょうか。 (dpkg -i nodejs.deb、PPAリポジトリを追加、nvm,nodebrew等のバージョン管理ツールを使わず、公式サイトのリポジトリからapt-get installする方法でお願いします。) [背景] curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash - sudo apt-get update sudo apt-get install nodejs=6.9.0-1nodesource1 では、インストールできませんでした。 sources.list先にhttps://deb.nodesource.com/node_6.x/pool/main/n/nodejs/nodejs_6.9.0-1nodesource1~xenial1_amd64.deb はありますが、 https://deb.nodesource.com/node_6.x/dists/xenial/main/binary-amd64/Packages に Version: 6.9.0-1nodesource1~xenial1 の記載がないので、apt-getでインストールできないと思います。 (postgresの場合は、 http://apt.postgresql.org/pub/repos/apt/dists/xenial-pgdg/main/binary-amd64/Packages に Package: postgresql-9.4 Version: 9.4.10-1.pgdg16.04+1 の記載があり、下記で古いバージョンのpostgresql-9.4はインストールできました。 sudo apt-get update sudo apt-get install postgresql-9.4 ) sources.listをfile:/にして、ローカルにdeb,Packages,Sources,Releaseを配置して、apt-get installで古いバージョンをインストールできましたが、 特定バージョンのPackages,Sources,Releaseのテキストファイルがないと、この方法ができません。 (リポジトリ内に古いPackages,Sources,Releaseのテキストファイルはありませんでした。) また、CentOSの場合は、下記で古いバージョンのnodejsがインストールできました。(yumとapt-getの仕組みの違いと思います。) curl --silent --location https://rpm.nodesource.com/setup_6.x | bash - yum --showduplicates list | grep nodejs yum install nodejs-6.9.0 よろしくお願いします。

  • また、vineで apt-getができません。他のサイトはありますか?

    VineLinuxをメインに考えましたが、よくダウンするので困ります。 source.listのすべてのコメントを外しましたが、 すべて apt-get updateの取得に失敗します。 以下の4サイト以外に有効なサイトはあるのでしょうか? # # apt for RPM source.list sample # ## ## Vine Linux 3.2 ## 標準では extras カテゴリは除外されています。extras カテゴリ内のパッケージ ## が必要な場合はコンポーネントリストに "extras" を追加してください。 # (masters) rpm [vine] http://updates.vinelinux.org/apt 3.2/$(ARCH) main devel plus updates rpm-src [vine] http://updates.vinelinux.org/apt 3.2/$(ARCH) main devel plus updates # rpm [vine] http://updates1.vinelinux.org/apt 3.2/$(ARCH) main devel plus updates rpm-src [vine] http://updates1.vinelinux.org/apt 3.2/$(ARCH) main devel plus updates # # (ring mirror) rpm [vine] http://www.ring.gr.jp/pub/linux/Vine/apt 3.2/$(ARCH) main devel plus updates rpm-src [vine] http://www.ring.gr.jp/pub/linux/Vine/apt 3.2/$(ARCH) main devel plus updates # # (jaist mirror) rpm [vine] ftp://ftp.jaist.ac.jp/os/linux/Vine/apt 3.2/$(ARCH) main devel plus updates rpm-src [vine] ftp://ftp.jaist.ac.jp/os/linux/Vine/apt 3.2/$(ARCH) main devel plus updates # # (kddlabs mirror) rpm [vine] ftp://ftp.kddlabs.co.jp/pub/Linux/distributions/Vine/apt 3.2/$(ARCH) main devel plus updates rpm-src [vine] ftp://ftp.kddlabs.co.jp/pub/Linux/distributions/Vine/apt 3.2/$(ARCH) main devel plus updates