• ベストアンサー
  • 困ってます

aptでアップデートされた日時を知りたい。

aptでアップデートされた日時を知りたい。 Debian GNU/Linux 5.0(Lenny)を使っています。 "apt-get upgrade"もしくは"aptitude safe-upgrade"によって最後にシステムが更新された日時を知りたいのですが、どこかに記録されていますでしょうか。 2010年7月10日

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数36
  • ありがとう数5

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • t-okura
  • ベストアンサー率75% (253/335)

Ubuntu だと、/var/log/apt/history.log や /var/log/aptitude に 記録されています。 Debian でも同じではないでしょうか。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

t-okuraさま、ありがとうございます。 確認できました。 2010年7月11日

関連するQ&A

  • apt-get upgradeを時々やるべきでしょうか?

    apt-get upgradeを時々やるべきでしょうか? サーバでapt-get update/upgradeを時々やるべきでしょうか? Ubuntu Server を 認証サーバ&ファイルサーバとして使おうと思っています。 セキュリティーのためには、 # sudo apt-get update # sudo apt-get upgrade を時々やった方が良いとは思います。 しかし、update/upgrade をすると、インストール済みのパッケージの中で新しいバージョンが公開されているときは、最新バージョンをダウンロードしてインストールするのですよね? 自分が構築した認証、NSF等の設定が upgrade で壊れてしまわないか心配です。 質問ですが ● apt-get update/upgrade で、システムの設定ファイルが上書きされる心配はしなくて大丈夫なものでしょうか? ● みなさんはサーバのセキュリティアップデートはどうなさっているでしょうか?

  • emesene 1.0 を 1.5 以上のヴァージョンに上げる方法

    emesene 1.0 を 1.5 以上のヴァージョンに上げる方法 OSは、Debian Linux Lenny を使っているのですが、デフォルトの「Lenny」での、「emesene」のヴァージョンが、1.0 です。サーバから、プロトコルがないと言われるのも、そもそも、1.0.1 以下では、プロトコルを既にサポートしないとの情報を得ました。手動でコンパイルするのではなく、「apt-get」、「aptitude」を用いて、最新の「emesene」に、ヴァージョンアップする方法がございましたら、apt-get , aptitude のコマンドを駆使して、最新のemesene を得る方法はないでしょうか? よろしくお願いします。

  • apt-getの一般的な使いかたについて。

    こんばんは。 表題の件について教えてください。 apt-get update にて、aptの構成ファイルに記述されているURLに アクセスし、アップデートがあるものが表示されるかと思います。 そして、表示されている中でアップデートしたいものがある場合、(今回は仮に○○とします) apt-get instal ○○にて、アップデートを実施するかと思います。 私はこの時、アップデート可能として表示されるものを見ても、それが何なのか分かりません。 (sambaとか分かり易い名前がついているものは別ですが) そのため、一気に apt-get upgrade にて表示されているもの全部をアップデートしてしまいます。 通常のLinux使いの方は、どのようにapt-getコマンドを使用されているのでしょうか? また、aptの構成ファイルに記述されているURLにて公開されていないようなマイナーなアプリの バージョンアップはどうするのでしょうか? (わざわざaptの構成ファイルにURLを追記するのは面倒な気がします) しょぼい質問で申し訳ないですが、識者の方、教えてください。 よろしくお願いします。

  • Debianでapt-get updateでエラー

    数年前に玄箱(玄箱HGではありません)にDebian Sargeをインストールしました。 それを etch、lenny、… とupgradeするために、先ず apt-get updateコマンドを実行しましたが、下記のエラーとなります。 /etc/apt/sources.list の内容を色々変更しましたが、同じエラーなります。 対処方法をご教示して頂きたくよろしくお願い致します。 E: Unable to parse package file /var/lib/apt/lists/ftp.dti.ad.jp_pub_Linux_debian_dists_stable_main_binary-powerpc_Packages (1)

  • Debianのアップグレードについて詳しいHPを教えてください。

    Debianのアップグレードについて詳しいHPを教えてください。 つい最近Debianを入れたばかりの初心者です。 慣れて来たので、testingのsqueezeにアップグレードしようと思うのですが、 apt-get update apt-get upgrade apt-get dist-upgrade で、エラー吐いたり、英文の訳の解らん質問が来たりで出来てません。 Debianのアップグレード(できればsqueeze)について詳しいHPや、 備忘録的なHPなどありましたらお教えください。よろしくお願いします。

  • VineLinuxの自動アップデート

    昔LinuxでサーバーでWindowsでいうWindowsUpdateと同じようにOSのパッチを当てる処理をしていたのですが、 自分が書いたにもかかわらず、忘れてしまいました。 cronで午前4時に以下のスクリプトを動作させております。 #!/bin/sh apt-get update apt-get upgrade -y apt-get update これで毎日アップデートしていることでしょうか?

  • aptでインストールオプションの指定は可能なのか?

    Debian GNU/Linuxを使用しています。 apt-get install でApache等、パッケージをインストールする際に、 ./configureでパラメータ追加するのと同様に、モジュールの組み込み等を行いたいと思い しばらく調査しましたが、それらしい記述は見つかりませんでした。 項目の変更を行う際には、tar.gzによるmakeでしか行えないのでしょうか。 手法、もしくは解説サイト等の情報がありませんか? よろしくお願いします。

  • apt-getによるソフトウェアのバージョン指定 Debian3.0

    OSはDebian GNU/Linux 3.0です。 apt-get cache search ruby と実行すると、 ruby - An Interpreter ... と表示されます。 そこで、apt-get install ruby とすると、バージョン1.67がインストールされました。 そこで質問です。 ソフトウェアのバージョン(インストール可能な全てのバージョン)をsearch時に表示させたり、バージョンを指定して インストール出来るのでしょうか? 最低でも、インストールする前にどのバージョンが インストールされるのかは確認したいです。

  • パッケージをインストールしたいのですが(Debian3.0)

    OSはDebian GNU/Linux 3.0です。 debianにはdselect、apt-get、dpkg等 いろいろなインストールの仕方があります。 よく解説でapt-get install (パッケージ名) などとかかれているのですが、 パッケージ名はどこで調べるのでしょうか? 最新のsambaをインストールしたいとき パッケージ名はどのようになるのでしょうか? インストール方法が3つもあるので どれでインストールしようか迷います。 私的には1つだけ使えるようになればよいと思うのですが どれがいいのでしょうか?(違いが分かりません。) ご回答よろしくお願いします。

  • Redhat 7.3でaptを使いたいのですが、upgradeができません

    業務で必要になったので、Redhat 7.3を最近インストールしました。 パッケージのアップデートはaptを使おうと思い、aptのインストールをしました。 apt-get update はうまくいくようで、パッケージリストは取ってきているみたいです。 ただ、 apt-get upgrade を実行すると、 Failed to fetch http://ayo.freshrpms.net/redhat/7.3/i386/RPMS.updates/sendmail-devel-8.11.6-27.73.i386.rpm 404 Not Found のように見つかりませんというエラーがたくさん出て、正常に完了しません。 パッケージが見つからないようなので、実際にブラウザでURLをたどってみると、確かに http://ayo.freshrpms.net/redhat/7.3/i386/RPMS.updates/ というディレクトリは存在していないようです。 ちなみに現在sourses.listの中身はデフォルトのままで、 # Red Hat Linux 7.3 rpm http://ayo.freshrpms.net redhat/7.3/i386 os updates freshrpms rpm-src http://ayo.freshrpms.net redhat/7.3/i386 os updates freshrpms となっています。 apt-upgradeが正常に行える場所をご存知の方がいらっしゃいましたら、教えてください。 もしくはaptの設定をこう変えればうまくいく、といった情報でもかまいません。 よろしくお願いします。