• ベストアンサー
  • 困ってます

あるサーバー間でのみpingが通らない

Windows Server 2008 R2 3台構成 それぞれNIC6枚あり、3枚を使用して通信しています。 各サーバを仮にA、B、Cと呼びます。 また、各ネットワークの名前と設定は以下です。 public IP:10.5.XXX.YYY Subnet:255.255.255.0 DefaultGateway:10.5.XXX.1 DNS設定済み private IP:192.168.1.1 ~ 192.168.1.3 Subnet:255.255.255.0 GatewayとDNSはなし nas IP:192.168.100.1 ~ 192.168.100.3 Subnet:255.255.255.0 GatewayとDNSはなし publicは社内LANに繋がっております。 privateはスイッチを使って、それぞれのサーバ間で通信できるようにしています。 A⇔B、B⇔C、C⇔Aでpingが通ります。 nasはスイッチを使ってそれぞれのサーバ間で繋がっているのと同時に、2台のNASを接続しています。このNASを仮にD,Eと呼びます Dのネットワーク設定 IP:192.168.100.150 Subnet:255.255.255.0 Eのネットワーク設定 IP:192.168.100.151 Subnet:255.255.255.0 ここで、192.168.100.0のネットワークに対して以下のようにpingを飛ばしました。 A⇒D A⇒E B⇒D B⇒E C⇒D C⇒E A⇔B A⇔C はpingが通ります。 しかし、ここで、B⇔Cのpingが通りません。 B⇒CもC⇒Bも通りません。 再起動しても通りませんでした。 原因としては何が考えられるでしょうか。 なんかのミスでしょうか・・・。

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数4214
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • teltel
  • ベストアンサー率48% (41/84)

サブネットマスクの設定ミスとかWindowsファイアウォールの設定は正しいでしょうか。 設定確認のうえ、その他ネットワークの状態確認してみてください。 1)ipconfig /all で設定確認 2)netstat -nr で認識されているネットワーク確認 3)ping実施後にarp -a でarp解決確認。 arpまで解決されていても届かない場合にはFirewallで止められている等が考えられます。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご教授ありがとうございます。Firewallは全て切っていました。 2)まで確認したところ、問題ないようでした。 3)のarp解決を確認したところ、B,C間では解決できていませんでした。 原因がわからず、途方にくれていましたが、なんとMAC ADDRESSが同じであることに気づきました。 NICを変えたらあっさり繋がりました。MACアドレス同じだなんてあるんですね・・・。知らなかったです。 ありがとうございました。調査方法、勉強になりました。

関連するQ&A

  • Pingが飛びません(TT)

    DHCPサーバーよりIPを自動取得したPCから、同一セグメント内のネットワーク機器へのPingが飛びません(TT) DHCPサーバーIP:192.168.0.1 クライアントIP:192.168.0.15 デフォルトゲートウェイ:192.168.0.2 優先DNSサーバー:192.168.0.2 IPを割り当ててくれたはずのDHCPサーバーにすら飛びません… クライアントPCのIP、デフォルトゲートウェイ、DNSサーバーの値はすべて、DHCPサーバーより設定されています。 とある事情により、設定していたデフォルトゲートウェイ、DNSサーバーのIPをもつ機器は既にネットワーク上にありませんが、別のネットワークへPingするわけではないので、関係ないと思っていたのですが… それが原因でしょうか? Pingが飛ばないので、『困っている』という訳ではないのですが、DHCPサーバーの設定を直す前に疑問に思ったので、質問させて頂きました。 何か考えられる原因がありましたら、ご教授下さい。 よろしくお願いします。

  • XPが勝手にサーバーに

    職場内のネットワークで問題が生じています。ネットワークにサーバーがありクライアントは自動にIPアドレス等を取得する設定です。しかし数台のPCが、GateWay・DHCP・DNSともある一定のクライアントのアドレスを認識する現象に悩まされています。そのサーバー化してしまうクライアントとなるのは、決まったPCで、そのマシンのIPを固定しても変更しても、他のクライアントはGateWay等のアドレスを追いかけてしまいます。 このため、原因はそのクライアントにあると思うのですが、その原因が分かりません。マスタブラウザの設定を外してみても効果はありません。勿論、クライアントにサーバーソフトも導入していません。ただ、気になるのは、自宅にYahooBBの回線を引き、無線LANを導入してから、その現象が起きるようになったことです。 コマンドのIPCONFIGを使い、調査すると以下の箇所にのように違いが出ます。 通常  Connection-specfic DNS Suffix : workgroup Default Gateway 192.168.0.1 DHCP Server 192.168.0.1 DNS Server 192.168.0.1 ***.***.*.* Primarywins Server 192.168.0.1 異常 Connection-specfic DNS Suffix :mshome.net IP Address 192.168.0.*** subnet Mask 255.255.255.0 Default Gateway 192.168.0.*** DHCP Server 192.168.0.*** DNS Server 192.168.0.*** Primarywins Server 192.168.0.*** 環境は以下のようになっています。 server samba2.2.8a  address 192.168.0.1(固定) GateWay 192.168.0.1 subnet mask 255.255.255.0 DHCPserver 192.168.0.1 DNSserver 192.168.0.1 サーバーとなってしまうクライアント機 winXP home よろしくお願いします。

  • dnsサーバーについて

    ipを自動取得にしている時にDNSサーバーのアドレスがGateway(ルーター)のアドレスになりますが、ルーターにはDNSサーバーが内臓されているものなのでしょうか? ●ipconfigの内容 IP Address. . . . . . . . . . . . : 192.168.11.2 Subnet Mask . . . . . . . . . . . : 255.255.255.0 Default Gateway . . . . . . . . . : 192.168.11.1 DHCP Server . . . . . . . . . . . : 192.168.11.1 DNS Servers . . . . . . . . . . . : 192.168.11.1 ●下記の順番で接続してます。 yahooBBモデム(ブリッジモード) →バッファローairStation →PC 初歩的な質問で申し訳ありません。

  • Cent OS NIC 片方にPing が通らない

    Cent OSサーバで、NIC 2個に異なるネットワークを設定し、ケーブルを両方接続すると、片方が不通になり、困っております。分かる方おりましたら、教えて頂けないでしょうか? 下記の構成、現象となります。 【構成】 ハードウェア: PowerEdge R610 OS: CentOS 6.0 NIC: Intel 82576 Gigabit 2個口 eth0: IP address: 202.xxx.xxx.xxx Netmask: 255.255.255.240 Gateway: 202.xxx.xxx.xxx eth1: IP address: 192.168.xxx.xxx Netmask: 255.255.255.0 Gateway: 192.168.xxx.1 【現象】 eth0/1ともに一方だけケーブルを挿すとPing/SSH ともに利用できる。 ただし、両方にケーブルを挿して有効にした場合、先に有効だったeth は Ping/SSH が外部から不通になり、後から有効にした方だけ Ping/SSH が通じるようになります。network restart を何度やっても同じ結果でした(何度もやってるとむしろ片方のeth がNetwork Manager から認識しなくなって reboot をかける羽目に)。 サーバ側で、TCPDUMP で eth0 を外部からのPing を監視しながら、eth1 も有効にすると、eth0は外部PCからの Ping が不通になるが、サーバ側のTCPDUMP ではPing を受信している様子。(eth1 にはもちろん外部からPing は通る状態) 要するに後から有効になったeth に外部からPing が通るという状態となります。 分かりにくくて申し訳ないですが、宜しくお願い致します!

  • 起動時に5分ぐらいサーバーへPingが通らない・・・

    環境 クライアントはwindowsXP(SP2)10台 サーバーはwindows2003Serverを使用しています。 同一セグメントにて動いています。 IPはDHCPは未使用です。 現象 クライアント起動時にpingがサーバー向けて通らないことです。しかし、完全に通らないのではなく、起動後5分ぐらい通し続けると通るようになります。(最初はtimeoutエラー)  再度クライアントの電源を落とし、また起動直後にpingをサーバーに向けて飛ばすと同じ現象が起こります。それと、無通信の状態がしばらく続くと同じ現象がおこります。 不可解な現象ですが、起動するクライアントの台数が2,3台ですと永遠にpingが通らないこともありますが、台数がおおいとなぜか早くpingが通るようになります。 インフラ、ハードが原因と思い、LANスイッチを交換したりケーブルを交換したりしましたが改善されなく、サーバーのLANボードも交換しましたが改善されませんでした。 ハード的なのか、設定てきな問題なのかお手上げの状況となっており、現在は業務終了時にpingをとおして画面のスイッチを切っております。 一度通信が通ればpingが切れることがありませんので・・。 解決方法、他解決にむけてこのような調査をしたほうがよいのでは?ということをご教授ください。よろしくお願いいたします。

  • pingで「別アドレスから応答」

    こんにちは、honiyonです。  OCNエコノミーを引き、自前でDNSを立てて使用しています。  つい1,2ヶ月前に気づいたのですが、外部からネットワーク内にpingをかけると、別のIPアドレスから応答があるようなのです。 pingは、Win用の「Internet Test Tools」というものを使用しています。  これが起因して、IPアドレスによってはサーバーを立ててもクライアントから正常に接続出来ません。(でも通信できないだけで接続は出来ているみたい。 netstatで見ると、クライアントとの接続が estanblishedになっている)  これって一体何が原因なのでしょうか?  DNSの設定にはそれらしいミスが見つかりません。  原因がわからないので対処がとれなくて困っています。  以下ネットワークの情報です。 DNSサーバー:VineLinuxCR2.1(bindはVer9にupdate) ルーター:YAMAHA RT52i  *14個のIPのうち、2個をGlobalIP,残りをNAT(ルーターの機能を使用)に割り当てています。  以上、よろしくお願い致します(..

  • 「優先DNSサーバー」、「代替DNSサーバー」の情報を知りたい

     お早う御座います。  Win XPです。  インターネットプロトコルのプロパティ「IPアドレスを自動的に取得する」のチェックを外した場合に、 「次のDNSサーバーのアドレスを使う」の「優先DNSサーバー」、「代替DNSサーバー」はどのようにして分 かるのでしょう。  コマンドプロンプトからipconfigと打っても「IP Address」、「Subnet Mask」、「Default Gateway」の情報しか分かりません。  コマンドプロンプト、または他の方法で「優先DNSサーバー」、「代替DNSサーバー」のアドレスを知る方法はあるのでしょうか。

  • PINGが通らない

    ある特定のIPに対して隣り合ったパソコンで 全く同じDNS、WINS設定、プロキシー設定 (IPアドレス以外のネットワーク設定は同じ)で hostsファイルなどの記述も同じ2台のパソコンで 片方はPINGが通るのに片方は通らない状況です。 このような場合に考えられる問題点は何がありますか。 PING先のパソコンには特に固定パソコンを許可・拒否する 設定はしておりません。 宜しくお願い致します。

  • vmwareから、ホストマシンのIPへのpingがunreachbleに・・・

    自宅PCでvmwareにLINUXを入れ、ネットワークがつながらず、延々となやんでいます。どなたか、ご指導いただけないでしょうか>< 症状はvmwareから、hostのIPへのpingがunreachbleに・・・ 環境は下記です。 ★HOST WINXPの設定 サービス「VMwareDHCPServer」無効 C:>ipconfig Ethernet adapter ワイヤレス ネットワーク接続: Connection-specific DNS Suffix . : IP Address :192.168.0.4 Subnet Mask:255.255.255.0 Default Gateway:192.168.0.1 Ethernet adapter VMware Network Adapter VMnet8: Connection-specific DNS Suffix . : IP Address:192.168.1.253 Subnet Mask:255.255.255.0 Default Gateway : ★VMware workstation 5.0 仮想ネットワークエディタ  VMnet8のサブネット   IP:192.168.1.0   サブネット:255.255.255.0  VMnet8のNAT   GATEWAY:192.168.1.254  DHCP   すべて削除   ★Miracle linuxの設定(Asanux 2.0 kernel2.6 x86)  評価版 #ifconfig eth0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255:255:255:0 inet6 addr: xxxx::xxx:xxxx:xxxx:5512/64 Scope:Link ............... /etc/sysconfig/network-scripts/ifcfg-eth0 DEVICE=eth0 ONBOOT=yes BOOTPROTO=static IPADDR=192.168.1.100 NETMASK=255.255.255.0 GATEWAY=192.168.1.254 /etc/sysconfig/network NETWORKING=yes HOSTNAME=console.jp.oracle.com GATEWAY=192.168.1.254 /etc/hosts 127.0.0.1 localhost.localdomain localhost 192.168.1.100 console.jp.oracle.com console /etc/resolv.conf nameserver 192.168.1.1

  • DNSサーバーにpingが通らない

    OSはWindows98、ブラウザはIE5.5、 パソコンはNECのノートパソコン(LavieNX)です。 ADSL(Yahoo!BBの8M)で接続しています。 わたしのPCから一部のサイトに繋がらない不具合が起きており(閉鎖やアクセス拒否等ではありません)、いろいろと解決方法を模索していたのですが、pingが通るかどうかを調べていたときに、DNSサーバーからの応答がないことに気が付きました。 Yahoo!BBではDNSサーバーの設定は空白にすることになっていますが、IP設定で確認すると2つのDNSサーバーが設定されていました。ひとつは、確か43.224.255.27でした。(もうひとつは忘れました;) 両方を試してもpingが通らなかったので、 http://oshiete1.goo.ne.jp/kotaeru.php3?q=156265 の回答に出ていたサポートメールの内容を参照し、 43.224.255.1 に手動で設定しなおしてみました。 それでも、pingは通りませんでした。 ちなみに、 http://homepage2.nifty.com/winfaq/pinghowto.html を参照してpingのテストを行いました。 自分のPCや、問題なく表示できるサーバーに対しては、pingは通ります。(表示できないページのサーバーには通りません) これが直接、今悩んでいる不具合に関係するのかはわかりませんが、pingが通らないのは問題ありのようですので、質問させていただくことにしました。 どうか、ご助言よろしくお願いします。 一部のサイトが表示できない不具合に関しては、現在までに ・キャッシュと履歴のクリア ・接続の設定の確認 ・WindowsUpdate ・Spybot-Searth&Destroyによるスパイウェアの検索と検出ファイルの削除 ・Nortonのシステムツールによるエラーチェック ・Nortonのシステムツールによるデフラグ ・Nortonのアンチウイルスソフトによるウイルスチェック(問題なし) ・モデムの再起動 ・MTUの確認 等を行いました。不具合が起きたのは10日前です。

    • ベストアンサー
    • ADSL