• ベストアンサー
  • 困ってます

namazu.cgiがインストールされません。

  • 質問No.482960
  • 閲覧数70
  • ありがとう数0
  • 回答数1

お礼率 48% (46/94)

こんにちは。
RedHat8を最近インストールしたばかりです。
自分のマシンにあるドキュメントを全文検索したくて、namazuをインストールしようとしています。
CGIから利用するためにはnamazu.cgiが必要と聞きました。
しかし、必要(とおもわれる)パッケージをインストールしても、namazu.cgiがみつかりませんでした。
findで/に対して検索しましたが、ありません...。
インストールしたパッケージは、以下のとおりです。
kakasi-2.3.4-1.i386.rpm namazu-cgi-2.0.10-1.i386.rpm
kakasi-dict-2.3.4-1.i386.rpm perl-Search-Namazu-0.13-2.i386.rpm
namazu-2.0.12.tar.gz perl-Text-Kakasi-1.05-1.i386.rpm
ちなみにnamazu本体はインストールされてます。(インデックスはつくられました)
どなたか、ご教授願います。
どこのサイトを調べても、あたりまえのようにnamazu.cgiをcgi-binディレクトリにコピーする、と書いてありますので、こまっています。

質問者が選んだベストアンサー

  • 回答No.1
  • ベストアンサー

ベストアンサー率 44% (490/1101)

よく似た質問を Namazu のメーリングリストで見かけました。
namazu.cgi ではなく、namazu-cgi-2.0.10-1 というファイル名でインストールされるようです。

rpm -qlp namazu-cgi-2.0.10-1.i386.rpm | grep namazu-cgi

でインストールされるファイルを調べ、それを namazu.cgi という名前で
cgi-bin ディレクトリにコピーすればいいでしょう。
関連するQ&A

その他の関連するQ&Aをキーワードで探す

ページ先頭へ