• ベストアンサー
  • すぐに回答を!

javaのバージョンについて

javaをデスクトップにあるアイコン(Java SE Runtime Environment)から入れてjavaのhttps://www.java.com/ja/サイトでバージョン確認したらjavaのバージョンを確認しました正常な設定です。と緑のチェック印と推奨バージョンのJavaがインストールされています (Version 7 Update 55). と表示されてるんですけど自分のPCに入ってるjava 7 Update 55とjava (TM) 7 Update5 (64bit)で古いバージョンが入ってると聞いたことあるんですがjava (TM) 7 Update5 (64bit)が古いんですかね・・? 古いバージョンのjavaは消したほうが良いと言われたんですが・・? javaを確認したい理由は最新のウイルス対策ソフトを入れててもjavaが古ければ無意味と言われたんですが? Windows8 PC

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数337
  • ありがとう数2

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.2
  • kazuof23
  • ベストアンサー率34% (1187/3468)

Q:旧バージョンのJavaをアンインストールする必要がありますか。 A:システムから旧バージョンのJavaをすべてアンインストールすることを強くお薦めします。 旧バージョンのJavaをシステム上に残しておくと、セキュリティ上深刻な危険があります。 旧バージョンのJavaをシステムからアンインストールすると、最新のセキュリティ対策とパフォーマンス向上が施されたJavaアプリケーションが確実に実行されます。 プログラムと機能に最新版の Java 7 Update 55 以外、今回は Java 7 Update 5 は古いですからアンインストールしておきましょう。 64bit版のJavaがどうしても必要なら手動で最新版のJava(64ビット)をダウンロードしてインストールします。 https://www.java.com/ja/download/manual.jsp

共感・感謝の気持ちを伝えよう!

質問者からのお礼

回答ありがとうございます! 暇な時間を見つけてやろうと思います

関連するQ&A

  • javaの旧バージョン削除について

    自分のPCにはJava SE Runtime Environmentで入れたjava 7 Update 55とjava (TM) 7 Update5 (64bit)が入ってるんですがjava (TM) 7 Update5 (64bit)は旧バージョンで古いと言われアンインストールを進められたんですけどjava 7 Update 55だけ入ってれば良いんでしょうか? javaのサイトでバージョンを調べると推奨バージョンのJavaがインストールされています (Version 7 Update 60).と表示されるんですがそれでも旧バージョンのjava (TM) 7 Update5 (64bit)のアンインストールは必要ですか? NEC LaVie Windows8 型番PC-LE150JSP2

  • javaのインストールについて

    javaをインストールするとき、デスクトップに元からあるJava SE Runtime Environmentから入れるよりjavaのサイトhttps://www.java.com/ja/ここから直接入れたほうが良いですよね!? Java SE Runtime Environmentから入れると余計な旧バージョンjava (TM) 7 Update5 (64bit)とプログラムのとこに32ビットのjavaが入るんですけど。。。 NEC LaVie Windows8 型番PC-LE150JSP2 64ビット

  • JAVAのバージョンについて

    JAVAのバージョンについて確認しているのですが、 今年の11月でJAVA SE(JRE)6のサポートが切れるようなのですが、 そこで疑問がありまして、、、 以下の2製品は(TM)が有るか無いか、の違いなのですが、何が違うのでしょうか。 また、本製品は両方とも今年の11月でサポート期限が切れるのでしょうか。 ・Java(TM) SE Runtime Environment 6 ・Java SE Runtime Environment 6

その他の回答 (1)

  • 回答No.1

こちら https://www.java.com/ja/download/help/version_manual.xml Java Runtimeはウイルス感染の元凶と言ってしまっても過言でないくらいの存在なので、そうしても必要であるという人以外はアンインストール推奨です。 >ウイルス対策ソフトを入れててもjavaが古ければ無意味と言われたんですが? 違いますね。脆弱性が報告されてる古いバージョンという意味だと思います。対策ソフトはソフトウェアの脆弱性を悪用する攻撃防御がめっちゃ苦手です。つまり、対策ソフトだけに頼る考え方ではいけないということです。 PCセキュリティーの基本はOSやアプリケーションソフトのアップデートを行い、常に最新状態にしておくことです。このベースがないと対策ソフトは生きてこないです。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • Javaのファイル削除について

    ウィンドウズXPを使っています。 PCの動作が重いので不要ファイルを削除したいのですが、 Java(TM)6 update2 Java(TM)6 update3 Java(TM)6 update5 Java (TM)SE Runtime environment6 update1 とあるうちのどれかは削除しても良いものなのでしょうか? また J2SE Runtime environment 5.0 update10 J2SE Runtime environment 5.0 update11 J2SE Runtime environment 5.0 update6 J2SE Runtime environment 5.0 update9 と並んでいるのですが、これも全部必要で無ければ削除したいと思うのですが良いのでしょうか? よろしくお願い致します。

  • javacとjavaのバージョン違い

    失礼致します。 コマンドラインからclassファイルを実行しようとしています。 しかし、実行したところ「java.lang.UnsupportedClassVersionError」というエラーが出ます。コンパイラとjavaのバージョンは次の通りです。 C:\work>javac -J-version java version "1.4.2_12" Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_12-b03) Java HotSpot(TM) Client VM (build 1.4.2_12-b03, mixed mode) C:\work>java -version java version "1.3.1_01" Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1_01) Java HotSpot(TM) Client VM (build 1.3.1_01, mixed mode) このため、バージョンを一致させる必要があるかもしれません。 ですが、あるプロジェクトに関わっており、バージョンを変更するのは容易ではありません。何か、バージョンを変更する以外でよい方法はございますでしょうか? また、バージョンをいじるならどちらを合わせるべきでしょうか?

  • JAVA実行環境が見つからない?

    WindowsXP上で、FreeMindというマインドマップを作成するフリーソフトをインストールしたところ、 FreeMind requires version Java 1.4.0 or higher (your version:1.3.1_01, installed in C:\Program Files\Oracle\jre\1.3.1). というメッセージが表示されて、起動できませんでした。 そこで、ネット上から最新のJRE SE v1.4.2_19をインストールしたのですが、状況は変わりませんでした。 プログラムの追加と削除のインストール済みソフトのリストを見たところ、JAVA関係のRuntimeモジュールが J2SE Runtime Environment 5.0 Update 10 J2SE Runtime Environment 5.0 Update 11 J2SE Runtime Environment 5.0 Update 6 J2SE Runtime Environment 5.0 Update 9 Java 2 Runtime Environment, SE v1.4.2_03 Java 2 Runtime Environment, SE v1.4.2_19 Java(TM) 6 Update 2 Java(TM) 6 Update 3 Java(TM) 6 Update 5 Java(TM) 6 Update 7 Java(TM) SE Runtime Environment 6 Update1 と多数表示されていました。 まず、インストールするJava実行環境を間違えていますでしょうか? また、なぜJavaの実行環境は、こんなにたくさんインストールされているのでしょうか?(同名の古いUpdateを削除しても問題ないでしょうか?) どなたかご教示願えますでしょうか?

  • javaについて

    プログラムの追加と削除を見たら J2SE Runtime Environment 5.0 Update 11 Java(TM)6 Update 2 Java(TM)SE Runtime Environment 6 Update 1 の三つがあったのですが 全部必要なのでしょうか? Java(TM)6 Update 2 以外は削除してもよいのでしょうか?

  • コントロールパネルにJavaが沢山あります。

    WindowsXPを使っています。 コントロールパネルでソフト一覧を確認したところ、Java(TM)の表示がいくつもありました。(添付画像をご覧ください) 今私のPCには、Version 6 Update 11の Java がインストールされています。 Version 6 Update 11以下のJavaは削除してしまってもいいのでしょうか? Java 以外にも、「J2SE Runtime Environment」の項目も同じように重複しています。 これも、現在インストールされているもの意外は削除して問題ありませんか?

  • 名前が似てるからバージョン違いだろうプログラムを削除したいけど自信がないので質問。

    J2SE Runtime Environment, 5.0 update 11 Java2 Runtime Environment, SE v1.4.2 Java(TM) Runtime Environment, 6 update 1 の3ツがあり、内容が同じものでバージョン違いなだけでかぶってるなら削除して1つにしたいです。 どれを消せばいいのか教えて下さい。

  • java -versionで表示される内容について

    Java -vesionコマンドで表示される内容の意味を教えてください。 java version "1.5.0_06" Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05) この場合JREのバージョンは5.0で Update6であるという認識でいいのでしょうか? (※1.5.0_06 の5.0がバージョン、_06がUPDATE) 宜しくお願いします。

    • ベストアンサー
    • Java
  • 「アプリケーションの追加と削除」に表示されているJAVA Updateプログラムの古いものは削除してもいいのでしょうか

    「アプリケーションの追加と削除」を見ると、Updateプログラムがたくさん入っています。これらのうち古いもの(末尾の数字の小さいもの)は削除しても問題ないのでしょうか。 次のようなものが入っていて、かなりの容量を食っています。 J2SE Runtime Environment 5.0 Update 10 J2SE Runtime Environment 5.0 Update 11 J2SE Runtime Environment 5.0 Update 5 J2SE Runtime Environment 5.0 Update 6 J2SE Runtime Environment 5.0 Update 8 J2SE Runtime Environment 5.0 Update 9 Java(TM) SE Runtime Environment 6 Update 1 Java(TM)6 Update 2 Java(TM)6 Update 3 Java(TM)6 Update 5 Java(TM)6 Update 6 Java(TM)6 Update 7 以上のうち下記の3つを残しておけばいいような気がします。 真ん中のものも不要でしょうか? J2SE Runtime Environment 5.0 Update 11 Java(TM) SE Runtime Environment 6 Update 1 Java(TM)6 Update 7

  • Javaについて

    よく「Javaをアップデートしませんか」みたいなのが出るのでその都度アップデートしているせいか同じようなものがプログラムの中にいくつかあります。 2つほど削除しましたがパソコンは正常に使えています。 今でも Java(TM)6Update11 Java(TM)6Update5 Java(TM)6Update7 Java(TM)SE Runtime Environment 6 Update 1 と4つ入っています。 これはWin XPです。 Win Vistaのほうは Java(TM)SE Runtime Environment 6 だけです。 Win XPのほうも Java(TM)SE Runtime Environment 6 Update 1 だけにしてもよいのでしょうか。 どうして何回もアップデートしませんかという表示が出るのでしょうか。 出ないパソコンもあるのですが。 それからこのJavaというソフトは動画のためのものなのでしょうか。 どんな働きをするソフトなのでしょうか。 宜しくお願い致します。

  • JREとJDKについて質問します

    JREとJDKについて質問します。 1)dos窓から、java -version とキーインすると下記の表示となりました。 java version "1.8.0_31" java(TM) SE Runtime Environment(build 1.8.0_31-b13) Q1) これは、JRE の確認(バージョン)と考えて宜しいでしょうか? 2)Windows7のコントロールパネルのプログラムと機能の一覧表の中に下記があります。 Java 8 Update31 Java SE Development kit Update 25 Java SE Development kit Update 31 Q2) 上記の Java 8 Update31 は、JREがインストールされていることを示していますか? そして、JREのバージョンは、前記の1)の 『java version "1.8.0_31"』 と考えて宜しいでしょうか? Q3) 『Java SE Development kit Update 25』の方はバージョンが、古いので 削除しても問題ありませんか? 以上、初歩的な質問ですが、宜しくお願いします。 尚、現在EclipseのPleiades44でソフト開発していますので、この質問をしました。 (JREとJDKのバージョンが一致している必要がある)

    • ベストアンサー
    • Java