締切済み

携帯ソーシャルゲームのFlash Lite

  • すぐに回答を!
  • 質問No.7339948
  • 閲覧数360
  • ありがとう数0
  • 気になる数0
  • 回答数1
  • コメント数0

お礼率 0% (0/2)

携帯電話のソーシャルゲーム開発をするには現状ではFlash Liteのバージョンはどのような物が使われているんでしょうか?
また、その理由や各バージョン(1.1から4)のちがいやコツなどを教えていただけないでしょうか?
また、効率よく技術を取得する方法などはあるんでしょうか?
当方はパソコンでActionScript2.0やAcrionScript3.0でゲームを作成した経験はあります。
よろしくお願いいたします。

回答 (全1件)

  • 回答No.1

ベストアンサー率 80% (21/26)

携帯ソーシャル業界の挿入Flashは大抵バージョン1.1です。1.1ならほとんどのケータイに
対応しているためです。ごく初期(03~04年くらい)の機種は1.0しかダメってのがありますが、
1.0の容量制限がきつすぎるためか、流石にもうどこでもサポートしていないようです。
もしFlashを作りたいのでしたらLite2.0辺りが良いでしょう。AS2やAS3に慣れきった
状態でLite1.xの言語仕様見ると、余りのチープさ加減に軽く発狂できます。
(例:関数作れない、配列ない、オブジェクト指向なにそれ食べれるの)
Lite2.0ならauとsoftbankは割と古くから対応していますし、
docomoも比較的最近の機種なら対応しています。

ただ、まともに携帯ソーシャルゲーを作るためには、Flashの知識だけではなく、
HTMLやサーバサイドプログラムの知識も必要となってくることを忘れてはいけません。

バージョンごとの機能や対応状況は、Wikipediaのページが大変詳しいです。
感謝経済
AIエージェント「あい」

こんにちは。AIエージェントの「あい」です。
あなたの悩みに、OKWAVE 3,500万件のQ&Aを分析して最適な回答をご提案します。

関連するQ&A
こんな書き方もあるよ!この情報は知ってる?あなたの知識を教えて!
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する

特集


感謝指数によるOK-チップ配布スタート!

ピックアップ

ページ先頭へ