• ベストアンサー
  • 困ってます

DMA転送になりません

eitontonと申します。よろしくお願いいたします。 外付けHDDに編集したビデオをAVIで保存後、オーサリングソフトを使って、外付けDVDでビデオDVDを作成しようとしたところ、以下のようなメッセージが出てました。 『My DVDはシステムに接続されている1台以上のレコーディング機器に対してDMAがオフになっていることを検出しました。機器に問題なく書き込むためにDMAをオンにする必要があります。詳細はオペレーティングシステムのマニュアルを参照するか、オンラインヘルプをご覧ください。』 DMA転送に関する質問はいくつかあったので同じようにデバイスマネージャーからIDEチャネルのプロパティを開いて転送モードをDMAに変更しました。 再起動をした後、もう一度IDEチャネルのプロパティを開くと プライマリIDEチャネル デバイス0 転送モード:DMA(利用可能な場合) 現在の転送モード:ウルトラDMAモード4 デバイス1 転送モード:DMA(利用可能な場合) 現在の転送モード:無効 セカンダリIDEチャネル デバイス0 転送モード:DMA(利用可能な場合) 現在の転送モード:PIOモード デバイス1 転送モード:DMA(利用可能な場合) 現在の転送モード:無効 となっています。 やはり、オーサリングソフトを開こうとすると、上記のメッセージが出てDMAモードに変更できていないようです。 DMAモードにする方法を教えていただけないでしょうか。 PC環境は PC:Dynabook:T5/512CME OS:XP/SP2 外付けHDD:BUFFALO HD-HS320U2 外付けDVD:BUFFALO DVM-X16U2 HDD、DVDともにUSB2.0接続 Windows movie Maker で編集後 DVDに同封されていたMyDVDというオーサリングソフトを 開こうとしたらエラーメッセージが出てきました。 ※一度、そのまま書き込みをしたのですが、すぐにフリーズしてしまいました。 子供の成長記録をDVDに残したいと思っているのですが、上手くできずに困っています。よろしくお願いします。

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数518
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1

ノートPCだから通常のデバイス構成とちがうのかなあ・・・ 書き込みから察するに、プライマリに光学ドライブ、セカンダリにHDDですかね。 転送エラー多発でPIO病かなあ。 PIO病でググってみて下さい。限りなくヒットします。 あとは複数USBデバイスに同時転送していますよね? ここに問題があるかもしれません。 USBは結構なCPUパワーが要りますから。 そもそもMy DVDとやらはリムーバブルデバイスに対応しているんですかね? バンドルしてるのだから対応なんでしょうけど。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

どうもありがとうございました。 また、質問させていただくかもしれませんので その時はまたよろしくお願いします。

質問者からの補足

PIO病で調べてみました。 で、書いてあるとおりにデバイス削除→再起動→再起動 したところ、PIOモードからウルトラDMAモード2になりました。 もう少し、自分で調べてみなくてはいけませんね。 どうも、ありがとうございました。

関連するQ&A

  • HDDの転送速度がDMAにならないのですが・・・

    OS:windowsXP HDD:Maxtor 5T040H4 Maxtor 6Y160L0 上記の物を使用しているのですが、デバイスマネージャーで確認してみたところHDDは二つとも、標準デュアルチャネルPCI IDEコントローラーのプライマリIDEチャネルに接続されていて、プロパティーを開き詳細設定で転送モードをデバイス0、1共にDMAにしているのですが、現在の転送モードが二つともPIOモードのままなのですがDMAにすることは出来ないのでしょうか? 他にも、Intel(R) 82801FB Ultra ATA Storange Controllers-2651と Intel(R) 82801FB/FBM Ultra ATA Storange Controllers-266Fがあり、前者には、何も接続されていなく、後者の方のプライマリにはDVDドライブが接続されていて、こちらはプロパティの転送モードはDMAで、現在の転送モードもウルトラDMAモード2となっているのですが、HDDの方もこのようにはならないのでしょうか? どうか回答の方よろしくお願いします。

  • DMAに設定を変更できません

    内蔵のDVDドライブがいつのまにかPIOモードになっており、デバイスマネージャーでDMAモードに変更ができません 現在の環境は WindowsXP sp2 BIOS AMI マシン:Soltek DVD-D LG電子 GSA-4167B(IDEセカンダリマスターに設定) 現在のデバイスマネージャーのIDEコントローラーのセカンダリIDEチャンネルのプロパティを開くと、デバイス0のデバイスの種類は「自動検出」(グレー表示で選択不可)、転送モードは「DMA(転送可能な場合)」、現在の転送モードは「PIOモード」となっています。 プライマリIDEチャネルの転送モードはウルトラDMAモード5に設定されています どうしたらDMA転送に変更できるでしょうか よろしくお願いします

  • DMA転送モードが度々変わるのですが?

    タイトルの通りなのですが、DMA転送モードが起動の度に変わります。 装着しているHDDはATA100の物をプライマリに2基です。起ち上げた直後のBIOSの画面では2基ともDMA5と表示されているのですが、デバイスマネージャIDEチャネル(プライマリ)の詳細設定を見ますと、現在の転送モードが5のときあり、2のときあり、4のときありとまちまちです。デバイス0も1も両方こんな感じです。 同じような経験、対処の方法等ご存じの方がいらっしゃいましたらお願いします。 OSはwindowsXPsp1です。機種はEPSONDIRECT EdiCUBE MX2300ですが、HDDは当初より大容量のものに載せ替えてます。

  • セカンダリIDEチャネルのDMAモードへの変更

    マイコンピュータ - プロパティ - ハードウエア - デバイスマネジャー - IDE ATA/ATAPIコントローラ - セカンダリIDEチャネル - 詳細設定 と操作してきて、 デバイス0が転送モード(T):PIOのみ、現在の転送モード(C):PIOモードとなっているものを、転送モード(T):DMA(利用可能な場合)にして、 再起動しても、現在の転送モード(C)は、PIOモードのままです。 どうしたら、現在の転送モード(C)がDMAモードになるか、教えてください。よろしくお願いいたします。

  • DVD再生時に映像のコマ切れ

    DVDを焼き、いくつかのDVDを再生してみると何枚かに再生中のコマ切れを発見しました。 早送りをしてみても全く動かない状態になってしまい コンピューターのIDE転送モードの確認をしてみたところ セカンダリIDEチャネル(デバイス0、デバイス1共に) <デバイスの種類>  自動検出 <転送モード>    DMA(利用可能な場合) <現在の転送モード> 無効 プライマリIDEチャネル ・デバイス0 <デバイスの種類>  自動検出(選択不可) <転送モード>    DMA(利用可能な場合) <現在の転送モード> ウルトラDMAモード2 ・デバイス1 <デバイスの種類>  自動検出 <転送モード>    DMA(利用可能な場合) <現在の転送モード> 無効 このような状態になっていました。 現在の転送モードが“無効”ということは 転送モードはきちんとDMAにはなっていないということですよね? だとすれば、DMAモードにするには何か方法はありますでしょうか。 長文で読みづらいかとは思いますがご返答お待ちしております。

  • 増設HDDの転送モードがDMAにならない

    増設したHDDの転送モードがDMAになりません。 このサイトなどの関連する情報を元に色々試しましたがだめでした。 (レジストリ操作、IDEチャネルドライバの削除など) ケーブルも問題ありません。 プライマリのデバイス0のHDDはDMA5動いているのですが スレーブに設定してあるデバイス1のHDDはPIOモードです。 増設したHDDもDMA5で動かすにはどうしたらよいのでしょうか? 現在の環境は以下の通りです。 M/B Name INTEL 875P Processor Intel(R) Pentium(R) 4 CPU 2.60GHz VideoCard 128 DDR ATI Radeon 9800 Resolution 1280x1024 (32Bit color) Memory 523,260 KByte OS WindowsXP Home SP1 Intel(R) 82801EB Ultra ATA Storage Controllers プライマリ IDE チャネル IC35L120AVV207-1 <= DMA5で動作中 ST3120026A      <= PIOで動作中 <=これをDMAで動かしたい Intel(R) 82801EB Ultra ATA Storage Controllers セカンダリ IDE チャネル _NEC DVD+RW ND-1100A

  • HDDがDMA転送モードにならない

    HDDがDMA転送モードにならず、そのせいか、タスクマネージャーで モニターするとCPUに負担が掛かっていることが多く、全体のパフォ ーマンスが悪いようです。ウインドウを数個開くと、反応が遅くな ったり、動画再生が途切れ途切れになったりします。 PCの主な構成は以下の通りです。 M/B: ECS L4S5A/DX+ CPU: Celeron 1.7GHz RAM: DDR PC2700 256MB VGA: NVIDIA TNT2 M64(AGP 32MB) HDD: Maxtor 6Y060L0 (Primary Master) CD-RW:AOpen4048 (Secondary Master) OS: WIN2000(SP3) デバイスマネージャーで確認すると、 「IDE ATA/ATAPI コントローラー」の 「SiS PCI IDE UDMA Controller」、 「プライマリ IDE チャンネル」は、 共に正常に作動しているのですが、 「プライマリ IDE チャンネル」の「詳細設定」タブで 「デバイス 0」の「転送モード」を 「DMA(利用可能な場合)」にして再起動しても、 「現在の転送モード」が「PIO モード」のままで、 「DMA モード」になりません。 「システム情報」の「ハードウェア リソース」の 「DMAコントローラー」の状態も「OK」になっています。 M/Bに付属のCD-ROMからIDEのデバイスはインストール済みです。 また、BIOS(Phoenix-Award)の「Integrated Peripherals」の 「SIS OnChip IDE Device」の設定は上から、 「Internal PCI/IDE」は「Both」。 「PIO」「UltraDMA」関連はすべて「Auto」。 「IDE DMA Transfer Access」と「IDE Burst Mode」は 「Enaibled」になっています。 DMA転送が可能になっていい筈だと思うのですが、何かアドバイスが ありましたら宜しくお願いします。

  • DMA転送を有効にしたいのですが

    システムのプロパティ→デバイス マネージャ→ディスク ドライブ→目的のHDDの設定に「DMA転送」の項目が見当たりません。それと関係あるのかよくわかりませんが、「同期データ転送」という項目が有効になっています。使用OSはWindowsMe、Ultla ATA66のHDDを使用しています。 ちなみにデバイス マネージャ→DMA コントローラの設定の「予約メモリ」は32KBにしました。「メモリへのDMA転送を制限」は無効にしています。 よろしくお願いいたします。

  • スーパーマルチドライブのBIOS,DMA設定について教えてください

    MASTERマシン購入時から デバイス0 PHILIPS DVD+-RW DVD8631 転送モード設定  DMA(利用可能な場合)  現在の転送モードウルトラDMAモード2 追加したドライブ SLAVE デバイス1 PIONEER DVD-RW DVR-111Lスーパーマルチドライブ 転送モード設定  DMA(利用可能な場合)  現在の転送モードPIOモード BIOSについて詳しくないのですがハードディスクはIDEではなくSATA?らしいです マシンDELL DIMENSION 8400 OS XP(MediaCenter)です。 DELLのマニュアルには追加したドライブはBIOSをいじるみたいな事を書いていましたがBIOSではIDE SLAVE と表示されるだけで何も出ません。PHILIPS DVD+-RW DVD8631はちゃんと見えます。 しかし、 BUFFALOバッファローのDVSM-XL516FB/BBK [PIONEER製 DVD-RW DVR-111Lスーパーマルチドライブ] はSLAVE設定のみでドライブ名が見えません。 スイッチ?をデバイス0がONになっていたので、 デバイス1もONにしたのですが見つからないみたいな警告?が起動時に出ます。 でもマイコンピュータからは見えるしディスクの読み込みも出来ます。書き込みはまだやってません。できればマルチドライブもDMA設定にしたいのですが。あとちゃんとBIOSでも見えるようにしたいです。どなたかよろしくお願いします。

  • IDE転送モードの設定はこれでいいのでしょうか?

    DVD(内蔵)が遅くなったので「教えて」で過去質問を調べたら、IDEの転送モードをDMAへ設定とのアドバイスが目にとまりました。 PIOの場合は削除、再インストールと書いてありました。 私の現在の転送モードは プライマリIDE デバイス0=ウルトラDMAモード5   デバイス1=無効 セカンダリIDE デバイス0=PIOモード         デバイス1=無効 となっており、この場合、プライマリIDEのデバイス0がウルトラDMAモード5になっているから問題はないのでしょうか? IDEやデバイス0、デバイス1の存在もよくわからない初心者ですが教えて下さい。