• ベストアンサー
  • すぐに回答を!

Movable Typeのインストールについて

Movable Typeをインストールしています。 mt-check.cgiでシステムチェックが完了したのですが、 mt.cgiの画面を開こうとしたら「データベース接続の設定に誤りがあります。」とエラーが出ます。mt-config.cgiの設定がおかしいのでしょうか。初心者なので分かりやすく説明していただけるとありがたいです。よろしくお願いします。 ※データベースはMySQLを使用しています。

noname#19956
noname#19956

共感・応援の気持ちを伝えよう!

  • 回答数3
  • 閲覧数47
  • ありがとう数2

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.2
  • sin11
  • ベストアンサー率32% (21/65)

状況が正確にわからない(MTのバージョンやサーバなど)ので推測ですが、データベースの設定でミスがあると思いますね。 ・データベースがちゃんと作られていない ・ユーザにデータベースの権限が与えられていない などなど サーバが自前のものなら # mysql -u root -p mysql> create database データベース名; mysql> grant all on データベース名.* to ユーザ名@localhost identified by 'パスワード'; とするなど・・。 レンタルサーバを使っているならデータベース使用のヘルプなどを参考にしてください。 あとMTのインストール全般では参考URLのサイトなどを参考にしてください。

参考URL:
http://rebecca.ac/milano/install/

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご回答ありがとうございます! データベースの設定がきちんとできていなかったようです。設定をし直しました。 「データベース接続の設定に誤りがあります」というエラーメッセージは出なくなったのですが、代わりに「ページが見つかりません」というエラーが出るようになってしまいました。考えられる原因って何でしょうか?

その他の回答 (2)

  • 回答No.3
  • sin11
  • ベストアンサー率32% (21/65)

もう少し詳しい情報がないと何もわからないですね。。 ページが見つかりません。ってエラーはほんとそのままで、ブラウザからアクセスしたページがないってエラーですよね。 どのファイルにアクセスしてそのエラーが出たかやMTのバージョンなど補足してください。 とりあえずは、 ・設定ファイル等(mt-*.cgi)が正しくアップロードされているか ・ブラウザでアクセスしたURLがあっているか(mt-check.cgiにアクセスできるかなどで確かめてください)

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご回答ありがとうございました! やはりファイルの設定がおかしかったようです。 なんとかMovable Typeをインストールすることができました。 どうもありがとうございます☆

質問者からの補足

ご回答ありがとうございます! 使っているのはIIS、MySQL。MTのバージョンは3.3です。 mt.cgiにアクセスすると「ページが見つかりません」というエラーが出ます。mt-check.cgiにはアクセスできます。 ファイルが見つかりませんと出るのでファイルの設定がおかしいと思われます。また見直してみます。

  • 回答No.1
  • Muller3
  • ベストアンサー率81% (800/979)

私もシステム的なことは初心者なので基本的なことしか確認できないのですが、 頭の#は取ってありますか? Database(データベースの名前) DBUser(ユーザーアカウント) DBPassword(MYSQLに接続するパスワード) DBHost(ホスト名) は合っていますか? http://www.sixapart.jp/movabletype/manual/3.3/02_system_admin_guide/installation/database_option_mysql.html#database-mysql

共感・感謝の気持ちを伝えよう!

質問者からの補足

早速の回答ありがとうございます! #は全部取っていますし、データベース名等も合っています。

関連するQ&A

  • Movable Type の設置方法がわかりません。

    Movable Type の設置方法がわかりません。 mt-check.cgiを開くと、最下部に、 「Movable Typeのシステム・チェックは、無事に完了しました。」 「準備が整いました。 サーバーには必要なモジュールがすべて揃っています。追加のモジュールのインストールは必要ありません。インストールの説明に従って、次の手順に進んでください。 」 と表示されますが、mt.cgiを開く(ログインをクリックする)と、 「Got an error: データベース接続の設定に誤りがあります: エラーが発生しました: Can't connect to MySQL server on 'www4.pf-x.net' (111)」 というエラーが出てしまいます。 サーバーはPF-X.netさんを使っています。 mt-config.cgiは以下の設定になっています。 ##### MYSQL ##### ObjectDriver DBI::mysql Database mt DBUser (アカウント名) DBPassword (パスワード) DBHost www4.pf-x.net

  • Movable Typeの設定

    初心者です。お助け下さい。 Movable Type3.2jを設置中、なんとかアップロードまで進み、 Mt-check-cgiでは、 ・ ・のシステムチェックは無事終了しました までは至りました。 Index.htmlのログインを 押すと Got an error: データベース接続の設定に誤りがあります。 設定を確認してください。 のメッセージが出ます。 どこを直せばよいのか検討がつきません。

  • Movable Typeインストール

    Movable Typeをインストールしています。 mt-check.cgiでシステムのチェックも終わり、いざmt.cgiを実行すると、「ページが見つかりません」とエラーメッセージが出ます。 考えられる原因は何でしょうか。 漠然とした質問ですみませんが、よろしくお願いします。

  • Movable Type4.1インストールがはじまらない

    mt-check.cgiは正常に終了します。 しかし、その後mt.cgiにアクセスするとアカウント作成画面になり、 入力を完了し、インストールに進むと インストールを開始しています・・・ のまま、何の画像も表示されず(赤い×マークは出ています)、 ここから先進めません。 mt-wizard.cgiにアクセスすると、「エラー: '~~~/mt-static/'が見つかりませんでした。ファイルをmt-staticディレクトリに移動するか、設定を修正してください。 」 と出たので、手動でmt-config.cgiを作りましたが、 再度mt.cgiにアクセスしても、やはりインストールが始まりません。 どなたか詳しい方教えてください。

  • Movable Typeのインストールについて

    Movable TypeをWebサーバーに入れ、Movable Typeシステム・チェック [mt-check.cgi]画面でMovable Typeに必要なコンポネントがサーバーに入っていることをチェックしてOKでした。 そしてmt/index.htmlよりインストールを行おうとしたのですが、 Got an error: Unsupported driver MT::ObjectDriver::DBM: Can't locate DB_File.pm in @INC (@INC contains: C:\***\cgi-bin\mt\extlib lib C:/Perl/lib C:/Perl/site/lib .) at lib/MT/ObjectDriver/DBM.pm line 10. BEGIN failed--compilation aborted at lib/MT/ObjectDriver/DBM.pm line 10. Compilation failed in require at (eval 6) line 1. BEGIN failed--compilation aborted at (eval 6) line 1. とエラーが出てしまいます。mt-config.cgiの設定が間違っているのでしょうか? どなたか教えてください。よろしくお願いします。

  • Movable Type3.35のブログの初期設定についてのトラブル

     Movable Type 3.3 マニュアルのオンラインマニュアルに 従いサーバーに導入・設定しました。  mt-check.cgiのシステム・チェックもmt.cgiによる管理者登録 も済みインストール後に、Movable Typeにログインして管理画面 に入りました。  ところが、”はじめにブログを設定してください。”の欄を クリックすると、このようなエラーが返されました。   Can\'t locate object method \"get_handle\" via package \"StyleCatcher::L10N\" at lib/MT/Plugin.pm line 459. これは、どのようなエラーで、どうすれば解決できるの でしょうか。 環境は以下の通りです。 サーバー: XREA+ データベース:MySQL

  • MovableType インストール

    MovableTypeをインストールしようとしています。 mt-config.cgi等の各設定も終わり、Movable Typeのシステムチェックは完了しました。 しかしログインしようとするとInternal Server Errorの画面になり インストールができません。 マニュアルを載せたサイト等も見ましたが原因がよくわかりません。 この場合の考えられるエラーの原因は何でしょうか? また対処法も教えて頂きたいです。

  • Movabletypeをインストールできない

    インストールに挑戦しています。本を見ながらやってますが、うまくいかずに困っています。 サーバにUPする前の設定をして、初めてのログイン画面で、Movable Type システム・チェック (mt-check.cgi) をしました。 特に異常はなく、「準備が整いました。」となります。 index.htmlからログインして、インストールを進めようとしましたが 「Movable Typeへようこそ」の画面が出ますが、ロゴなどは【x】になり表示されず、ステータスバーにはエラーが表示されて、 【ライン:68 文字:5 エラー:'getByID'は宣言されていません。コード:0】となり、そのまま進めると「データベースを初期化中...」となったまま進みません。。 どなたか解決方法をご存知の方、宜しくお願い致します。 MT Var.3.35-ja です。

  • movable typeのデータ移行について

    Movable Typeを使用して個人的にブログサイトを運営しています。今回、Movable Typeのデータを移行するために作業を実施しているのですが、日本語文字コードのところで行き詰まっております。 ○移行元 OS : Fedora Core 3 Movable Type : 3.31 phpmyadmin : 2.11.6 mysql : 3.23.58 MySQL の文字セット: Shift-JIS Movable Typeのmt-config.cgiに以下の記載がされている PublishCharset Shift_JIS ○移行先 OS : Fedora 12 Movable Type : 5.01 phpmyadmin : 3.2.5 mysql : 5.1.4.2 MySQL の文字セット: UTF-8 Unicode (utf8) ○作業内容 1.移行元でphpmyadminによりデータベースのエクスポート  データベース名をクリックして、『エクスポート』をクリック。  全選択をクリック、SQLを選択し、『DROP TABLEを追加』をチェックし、『ファイルに保存する』をチェックする。その下は「non」のままで実行するをクリックして、データベース名.sqlというファイル名で保存する。保存したファイルの文字コードはSHIFT-JISになっている。 2.移行先の設定 Movable Typeのmt-config.cgiのPublishCharsetは記載なし。 文字コードをUTF-8としてデータベース作成 $ mysql -u root -pXXXXXX mysql> create database mt character set utf8; mysql> grant all on mt.* to mtuser@localhost identified by 'mtpasswd'; 3.移行先でphpmyadminによりデータベースのインポート  データベース名をクリックして、『インポート』をクリック。  インポートするファイルに移行元で作成した、データベース名.sqlを選択し、ファイルの文字セットをsjisし、その他は変更せずに実行するをクリックする。  その後、Movable Typeのmt/mt.cgiよりサインインをするとデータベースのアップグレードが実施される。  ブログが新しくできているが、日本語が一切表示されていない。 インターネットの検索でいろいろと調べてみたのですが、結局原因が分からず、行き詰まっております。 お手数ですがよろしくお願い申し上げます。

  • Movable Typeをwakwakで設定

    Movable Typeを設定についての質問です。 mt-check.cgiの動作は完了したのですが、mt.cgiがうまく動作しないのです。 「Movable Typeへようこそ ブログを始める前に、データベースを初期化してインストール作業を完了する必要があります。」と表示はされるのですが、“topnav-logo.gif”が表示されないのと、スタイルシートが適応されないのです。 “インストールを続行”ボタンは表示されます。 リンク先が間違ったのかと、ソースを見たのですが画像とスタイルシートのリンク先にはファイルがあるのです。 プロバイダがwakwakでどなたかMovable Typeを利用している方おりませんか? 知り合いのを頼まれたものでよくわかりません。 自分が契約しているプロバイダのサーバで試して大丈夫だったのでできるのかと思ったら・・・。 cgiに関しての制限があるようでして。 みなさんよろしくお願いいたします。