• 締切
  • すぐに回答を!

EclipseにAndroidツールを導入できない

  • 質問No.6367280
  • 閲覧数239
  • ありがとう数2
  • 気になる数1
  • 回答数3
  • コメント数0

お礼率 40% (6/15)

windows7 アルティメット 32bit
Eclipse 3.2
(VE-runtime-1.2.1 
NLpack1-eclipse-SDK-3.2.1-win32
GEF-runtime-3.2.1
emf-sdo-runtime-2.2.1 導入済み)
android-sdk_r07-windows 済み

プログラミング初心者です。
Androidアプリを作ろうと、ネットで調べて以下の方法をやろうとしたのですが

ソフトウェア更新 → 新規インストール →
https://dl-ssl.google.com/android/eclipse/ を追加
でAndroidDevelopmentToolsを入手しようとすると

Android Development Tools (0.9.9.v201009221407-60953) 必須: プラグイン "org.eclipse.wst.sse.core"

と出て失敗します。
そこでorg.eclipse.wst.sse.coreで調べたりしたのですが、
同じようなエラーが出てる人はいたのですが、
自分の力不足なためか、詳しい入手方法や解決方法や原因がよく分かりませんでした。
(自分のexlipseにはなぜか項目が無かったりしました。
たとえばhttp://d.hatena.ne.jp/Ninnya/20090623/1245772368を見たのですが、
Discovery site に Android という項目が無かったり。)

具体的な解決策が分かる方がいらっしゃいましたら教えてください。
よろしくお願いします。

回答 (全3件)

  • 回答No.3

ベストアンサー率 22% (102/446)

>これはEclipse単体ではなく、Eclipse for Java EE Developersというパッケージで利用します
利用しません。
そもそもJavaEEとはJava Platform, Enterprise Editionの略。
Androidで使われるのはJavaSE(Java Platform, Standard Edition)。

それと
http://developer.android.com/intl/ja/sdk/eclipse-adt.html
ここに
>For Eclipse 3.5 or newer, the "Eclipse Classic" version is recommended. Otherwise, a Java or RCP version of Eclipse is recommended.
と書かれています。
推奨するのはEclipse Classicとなっています。
自分自身もEclipse Classicを利用していますが問題ありません。

Eclipse for Java EE Developersを使うことによって無駄な必要もないプラグインが
インストール済みの状態になります。Eclipseを無駄に不安定にする要素です。
  • 回答No.2

ベストアンサー率 22% (102/446)

>Eclipse 3.2
そもそもADTは3.2は対応してなかったはずだけど
  • 回答No.1
まず、Androidのプラグインですが、これはEclipse 3.4以降対応です。したがって、3.2では動かないはずです。
それから、これはEclipse単体ではなく、Eclipse for Java EE Developersというパッケージで利用します。これはEclipseにJava EE開発のプログラムが組み込み済みのパッケージです。

まずは、最新のEclipse for Java EE Developersパッケージを手に入れるところからやってみてください。

http://eclipse.org/downloads/
http://developer.android.com/sdk/eclipse-adt.html
お礼コメント
sacana

お礼率 40% (6/15)

ありがとうございます。
試してみます。
投稿日時:2010/12/07 02:32
結果を報告する
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。
AIエージェント「あい」

こんにちは。AIエージェントの「あい」です。
あなたの悩みに、OKWAVE 3,600万件のQ&Aを分析して最適な回答をご提案します。

関連するQ&A

その他の関連するQ&Aをキーワードで探す

ピックアップ

ページ先頭へ