• ベストアンサー
※ ChatGPTを利用し、要約された質問です(原文:Linux上でのrpmパッケージを使う方法について。H8マイコンの開発)

Linux上でのrpmパッケージを使う方法について

このQ&Aのポイント
  • Linux上でのrpmパッケージを使う方法についての質問です。H8マイコンの開発環境を作るため、設定等を行っていますが、rpmのインストールで問題が発生しています。
  • 質問者は端末上でrpmコマンドを実行したところ、「rpm: please use alien to install rpm packages on Debian, if you are really sure use --force-debian switch. See README.Debian for more details.」というエラーが表示されました。そのため、別の方法でrpmをインストールする必要があります。
  • 質問者は既にalienを利用してrpmをインストールしようとしましたが、同じエラーが表示されるだけで解決できませんでした。質問者が使用しているのはUbuntuです。そのため、何が問題なのか、解決策を教えてほしいとのことです。

質問者が選んだベストアンサー

  • ベストアンサー
noname#116115
noname#116115
回答No.1

メッセージ通り sudo alian --force-debian -i h8-binutils-2.13-1.i386.rpm でいかがでしょうか。

全文を見る
すると、全ての回答が全文表示されます。

関連するQ&A

  • RPMパッケージのアップグレードについて

    APACHEをRPMパッケージの最新版(apache-1.3.22-5.7.1)にアップグレードしたいのですが、 現在下記の様な状態で悩んでいます。 # rpm -Fvh apache*.rpm でアップグレードしようとすると、 エラー:依存性の欠如 mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています mod_putは apache-1.3.22-5.7.1 に必要とされています mod_throttleは apache-1.3.22-5.7.1 に必要とされています というエラーが出ます。 次に、依存性の欠如で指摘されたファイルも一緒にアップグレードしようと、 以下のコマンドを入力しました。 # rpm -Fvh apache-*.rpm mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3 .i386.rpm mod_put-1.3-2.i386.rpm そしたら、またしても エラー: 依存性の欠如: mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています mod_putは apache-1.3.22-5.7.1 に必要とされています mod_throttleは apache-1.3.22-5.7.1 に必要とされています と表示されてしまいました。 インストールされているか、rpm -q で確認すると、 インストールされていません と返ってきました。 じゃあ、インストールしよう、と思って #rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3.i386.rpm mod_put-1.3 -2.i386.rpm と入力したら エラー: 依存性の欠如: apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します apache < 1.3.22-1 mod_throttle-3.1.2-3 と競合します apache < 1.3.22-1 mod_put-1.3-2 と競合します と、返ってきました。 一体、どのようにしたら無事アップグレードできるのでしょうか? それとも、現バージョンのAPACHEを削除してから新バージョンのインストールを するしかないのでしょうか? 使用OS:Redhat Linux 7.1J

  • Vine Linux 3.2 で vnc-server-4.1.2-0vl2.i386.rpm がインストールできない

    以下の事情により Vine Linux 3.2 をインストールしているマシンは インターネットに接続できません。 インターネット回線は母屋の家の Windows XP をインストールしてい るマシンのそばに引き込んでいます。 (マシンは 1 台しかありません) Vine Linux 3.2 をインストールしているマシンは物理的に離れてい る別棟の家に完全に閉じた LAN に接続しています。 (インターネットにはつながらない) そこで、インターネットに接続できる Windows XP で、 http://ftp.kddilabs.jp/pub/Linux/packages/Vine/VineSeed/i386/pool/ から、vnc-server-4.1.2-0vl2.i386.rpm をダウンロードし CD-R に 焼きVine Linux 3.2 をインストールしているマシンにコピーしま した。 CUI でマシンを起動し root で login し、 rpm -ivh vnc-server-4.1.2-0vl2.i386.rpm を実行すると画面に以下のメッセージが表示されました。 エラー:依存性の欠如: libXau.so.6 は vnc-server-4.1.2-0vl2 に必要とされています libXdmcp.so.6 は vnc-server-4.1.2-0vl2 に必要とされています vnc-server-4.1.2-0vl2.i386.rpm 以外に何が必要なのか? rpm -ivh vnc-server-4.1.2-0vl2.i386.rpm を実行する前にどんな準 備が必要なのか? Vine Linux 3.2 をインストールしたマシンは、 http://ftp.kddilabs.jp/pub/Linux/packages/Vine/Vine-3.2/CDIMAGE/ から、Vine32-i386.iso を CD-R に焼いた媒体からインストールした だけの状態です。

  • Redhat-Linux7.1J で「zlib」パッケージを正常にインストールしたい

    Redhat-Linux7.1JのOSを導入完了しています。 Redhat-Linux7.1JのCDROM(1枚目)から 「zlib」パッケージをインストールしようとすると、 次のようなエラーがでて、結果的にはインストールできません。 このzlibがインストールできないと、 あるパッケージがインストールできないので、とても困っています。 どうすれば、「zlib」パッケージを正常にインストールできるでしょうか? 教えてください! <コマンド>  # rpm -ivh zlib-1.1.3-22.i386.rpm <実行結果> Preparing... #######################[ 100%] 1:zlib エラー: unpacking of archive failed on file /usr/share/doc/zlib-1.1.3/README: cpio: MD5 sum mismatch

  • LINUXでのインストールについて

    RED HAT LINUX 9 を入れたんですが、フリーのソフトウェアをインストールしようとして、エラーが起こります。ターミナルからインストールしようとして、依存関係で必要って表示されるものをそろえても、最後には 警告: R-1.8.1-2.i386.rpm: V3 DSA signature: NOKEY, key ID 97d3544e エラー: cannot get 除外 lock on /var/lib/rpm/Packages エラー: cannot open Packages index using db3 - 許可されていない操作です (1) エラー: cannot open Packages database in /var/lib/rpm と出てしまいます。RPMに問題があるのでしょうか??LINUXをインストールしたらRPMもつかえるはずなのではないでしょうか??教えて下さいm(_ _)m

  • j2sdk-1_4_2_15-linux-i586-rpm.binインストールできません。

    ご存知の方いらっしゃいましたらj2sdk-1_4_2_15-linux-i586-rpm.binのインストール時のエラー対処方法教えてもらえませんでしょうか。 環境は、Redhat linux ES4.5です。 /usr/localへ移してchmod 755 に変更し、 . j2sdk-1_4_2_15-linux-i586-rpm.bin を実行しました。 以前はこのやり方でインストールできましたが、ライセンスの同意箇所でyes [enter]すると、以下のメッセージが表示されてインストールできません。 =========== 途中略 ============== Do you agree to the above license terms? [yes or no] yes Unpacking... tail: オプションが違います -- b 詳しくは `tail --help' を実行して下さい. Checksumming... 1 The download file appears to be corrupted. Please refer to the Troubleshooting section of the Installation Instructions on the download page for more information. Please do not attempt to install this archive file. ==================================== しかもrootから一般ユーザに勝手に戻ってしまいます。 詳しい方教えていただけませんでしょうか。 宜しくお願い致します。

  • rpmでのインストール

    自作PCに Red Hat Linux release9 (shrike) kernel 2.4.20-8 on an i686 をインストールしています。 rpmパッケージで postgreSQL mySQL Perl PHP Apache をインストールしたいのですが 検索をしても 『Fedora』というLinuxのrpmは見つかるのですが ttp://ftp.kddilabs.jp/Linux/packages/fedora/core/2/i386/os/Fedora/RPMS/ 自分が使っているLinux版のが見つかりません。 URLなどを教えて戴ければ幸いです。 宜しくお願いします。

  • ネットワークが認識できない

    RedHatLinux9.0をインストールしました。 しかしLANが認識されていません。 マザーボード(P4P800)のCDをみると linux用のドライバがあったので Readme(下記)をみたのですが 1)のkernel sourceがよくわからないのと 6)のvmlinuz.version.h と /boot/vmlinuz.autoconf.hが 存在しませんでした。 どなたか教えてください。 ----------------READMEの内容-------------------- 1) Make sure that the kernel source is installed in /usr/src/linux or /usr/src/linux-2.4. 2) Copy the file /Linux/3c2000.tar.gz from the 3Com driver CD to your hard drive. 3) Change to the directory containing 3c2000.tar.gz 4) Type 'tar zxvf 3c2000.tar.gz' 5) Type 'cd 3c2000' Note: on SuSE systems since 7.1, you will have to execute the following commands before running make: cp /boot/vmlinuz.version.h /usr/src/linux/include/linux/version.h cp /boot/vmlinuz.autoconf.h /usr/src/linux/include/linux/autoconf.h For more details se http://sdb.suse.de/en/sdb/html/mwalter_kernel_24.html 6) Type 'make load' to load the driver.

  • fedora14 postgresqlをいれる

    いつもお世話になっております。 fedora14デスクトップ版にpostgresqlをインストールしようとrpmパッケージを探しているのですが、見つかりません。 下記サイトでrpmを配布しているようなのですが、メールアドレスの入力を求められるため 利用できませんでした。 http://www.openscg.org/se/postgresql/packages.jsp システム->設定->ソフトウェアの追加と削除を起動し postgresql と入力するとかなりたくさんの項目がでてきてどれをいれたらよいのかわかりませんでした。 下位サイトから postgresql-9.1.2-1-linux.runをダウンロードしてsh ./postgresql-9.1.2-1-linux.run とターミナルでにゅうりょくしたのですが、 「./postgresql-9.1.2-1-linux.run: ./postgresql-9.1.2-1-linux.run: バイナリファイルを実行できません」 となり実行できませんでした。 http://www.enterprisedb.com/products-services-training/pgdownload postgresqlをfedoraに簡単にインストールするインストーラーのようなものはないのでしょ うか。 どなたかご教授よろしくお願いいたします。

  • FedoraCore6のインストール

    はじめまして。 雑誌付録のCD-ROMを使ってFedoraCore6をインストールしようとしたの ですが、CDドライブを認識しないせいか「CD Found」と表示されず、 「Choose a Language」の画面が表示されてしまいます。症例は下記の ものと一緒です。 http://oshiete1.goo.ne.jp/qa1564164.html そこで、CD-ROMからのインストールを諦め、HTTPからインストールしようと ftp.kddilabs.jp Linux/packages/fedora/core/6/i386/os/Fedora/ と入力し、Enterキーを押すとしばらくしてから「Unable to retrieve http://ftp.kddilabs.jp//Linux/packages/fedora/core/6/i386/os/Fed ora…」となり、うまくインストールできません。jpとLinuxの間に/が 2つも入っている(勝手に入ってしまう)ところが原因?なのでしょうか。 どうにかインストールを成功させたいのですが、どなたか解決法をご教 授願います。どうぞよろしくお願いいたします。 マザボ:IntelDQ963FX

  • Centos7にChrome

    Centos7にChromeをインストールするとしたら、 64 bit .rpm (Fedora/openSUSE 版) で合ってますか? https://www.google.co.jp/chrome/browser/desktop/ Chrome for Linux をダウンロード ダウンロード パッケージを選択してください: 32 bit .deb (Debian/Ubuntu 版) 64 bit .deb (Debian/Ubuntu 版) 32 bit .rpm (Fedora/openSUSE 版) 64 bit .rpm (Fedora/openSUSE 版)

このQ&Aのポイント
  • 名刺1シートで複数のデザインを採用する方法について教えてください。
  • 市販名刺のシートに付属するアプリでは細かい選択ができないため、筆まめを使用して同一シート内に複数のデザインを作りたいです。
  • 現在は筆まめで同一デザインをシート内の指定の箇所にコピーすることはできますが、複数デザインを作る方法が分かりません。
回答を見る