• ベストアンサー
  • 困ってます

Redhat-Linux7.1J で「zlib」パッケージを正常にインストールしたい

Redhat-Linux7.1JのOSを導入完了しています。 Redhat-Linux7.1JのCDROM(1枚目)から 「zlib」パッケージをインストールしようとすると、 次のようなエラーがでて、結果的にはインストールできません。 このzlibがインストールできないと、 あるパッケージがインストールできないので、とても困っています。 どうすれば、「zlib」パッケージを正常にインストールできるでしょうか? 教えてください! <コマンド>  # rpm -ivh zlib-1.1.3-22.i386.rpm <実行結果> Preparing... #######################[ 100%] 1:zlib エラー: unpacking of archive failed on file /usr/share/doc/zlib-1.1.3/README: cpio: MD5 sum mismatch

noname#2802
noname#2802

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数158
  • ありがとう数3

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • ojin
  • ベストアンサー率43% (280/638)

ファイルが壊れています。 Check SumがMismatchで解凍できません。 たとえば、次のftpサイトから、ダウンロードされたらと思います。 "#"を表示するのは、-ivhの"h"を指定したので、ハシュで進行状況をしめしていますが、最後で、チェックサムの不一致です。 http://ftp.dti.ad.jp/pub/OpenBSD/distfiles/rpm/

参考URL:
http://ftp.dti.ad.jp/pub/OpenBSD/distfiles/rpm/

共感・感謝の気持ちを伝えよう!

質問者からのお礼

無事、インストールできました。ありがとうございました。

その他の回答 (1)

  • 回答No.2
  • mph
  • ベストアンサー率54% (39/72)

CD-ROMは売られている(RedHat純正)ものでしょうか?それとも雑誌の付録や自分で焼いたものでしょうか? バイナリの中身がおかしいので普通の方法ではそのパッケージはインストールできません。 強制インストールもできますが、パッケージ管理がおかしくなる可能性があるのであまりおすすめできません。 SRPMSを用いてソースから入れるのが一番平和のような気がします。 0) rootになる 1) ソースCDなりを探して、zlib-1.1.3-22.src.rpmを発見する。 2) rpm -i zlib-1.1.3-22.src.rpm でソースを展開する3) cd /usr/src/redhat/SPECS 4) rpm -ba zlib.spec 5) cd /usr/src/redhat/RPMS/i386 (たぶんここにzlib-1.1.3-22.i386.rpmがある) 6) rpm -Uvh zlib-1.1.3-22.i386.rpm 以上でできると思います。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

参考になりました。ありがとうございました。

質問者からの補足

ちなみに。CDROMは、雑誌の付録でした。

関連するQ&A

  • redhat系Linuxで、Sambaをインストールしたいのですが、、

    redhat系Linuxで、Sambaをインストールしたいのですが、、、 以下の様なエラーが出てしまい、libcom_err.so.3をダウンロードしようとしてもできません。。。このエラーの意味が分かりません。どなたか詳しい方がいらっしゃいましたら、教えて頂けませんか? [root@abc /]# rpm -ivh samba-3.0.0-2iconv.i386.rpm エラー: 依存性の欠如: libcom_err.so.3 は samba-3.0.0-2iconv.i386 に必要とされています libiconv.so.2 は samba-3.0.0-2iconv.i386 に必要とされています liblber.so.2 は samba-3.0.0-2iconv.i386 に必要とされています libldap.so.2 は samba-3.0.0-2iconv.i386 に必要とされています libreadline.so.4 は samba-3.0.0-2iconv.i386 に必要とされています

  • RedhatLinux7.1J-apacheのアップグレード失敗します

    RedhatLinux7.1Jを使用しています。 http://www.jp.redhat.com/support/errata/RHSA/RHSA-2001-126J.html 以上のサイトから、7.1用のApache最新版を入手し、 インストールしようとした所、以下のエラーが表示されて インストールに失敗してしまいます。 apache本体を導入しようとすると、「mod_~.rpm」がないって怒られて、 「mod_~.rpm」を導入しようとすると、apacheと競合すると怒られ、 結局アップグレードできないんです・・・。 <その1>  rpm -Fvh apache-1.3.22-1.7.1.i386.rpm   ↓  エラー: 依存性の欠如:   mod_bandwidthは apache-1.3.22-1.7.1 に必要とされています   mod_putは apache-1.3.22-1.7.1 に必要とされています   mod_throttleは apache-1.3.22-1.7.1 に必要とされています <その2>  rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm  rpm -ivh mod_put-1.3-2.i386.rpm  rpm -ivh mod_throttle-3.1.2-3.i386.rpm   ↓  エラー: 依存性の欠如:   apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します

  • Linux のパッケージインストールとは?

    Miracle Linuxにソフトをインストールしようとしていますが、パッケージ ソフト(.rpm)の場合、パッケージインストールすれば、make、make install はしなくてもよいのでしょうか? 以下のような場合。 rpm -ivh nkf-1.71-2.src.rpm よろしくお願いします。

  • Linux 6.2 でパッケージインストール RPM コマンドを使用した時にエラーがでる

    OS Linux6.2 で rpm コマンドを使用した時にエラーになる # rpm -Uvh bind-8.2.2_P7-1.i386.rpm をすると以下のエラーが出る メジャー番号<=3のパッケージのみこのバージョンのRPMはサポートされています エラー:bind-8.2.2_P7-1.i386.rpm cannot be installed 以上のメッセージが出てパッケージをインストールできないので 教えてください

  • RedHat9 Linuxでvsftpdを上書きインストールしたいです。

    RedHat9 Linuxでvsftpdをインストールしました。 ファイルをいろいろいじってしまったので、再度、インストールしたいのですが、どのようにしたらよいでしょうか?rmp -ihv vsftpd-1.1.3-8.i386.rpm とやっても上書きインストールはされないようなんです。

  • kernelのバージョンアップについて

    RedHat7.3をインストールしております。 今回kernelのバージョンをアップしようと思い試行錯誤しながら行っておりますが、上手くいきません。何卒よろしくご指導の程お願いいたします。 rpm -qa | grep kernel でインストールされいるバージョンと種類を確認しました その結果 kernel-pcmcia-cs-3,1,27-18 kernel-2.4.18-3 が表示されましたので ダウンロードサイトより  kernel-2.4.20-20.7.i386.rpmをダウンロードして rpm - U kernel-2.4.20.7.1386.rpm でインストールしたところ error:unpacking of archive failed on file /boot/system.map-2.4.20-20.7;3fa5114c:cpio:MD5 sum mismatch と表示され上手い行きません どこが悪いのでしょうか、またどのようにすればバージョンアップできるのでしょうか よろしくお願いいたします。

  • RedHat9 Linuxのアンインストールコマンドについて

    RedHat9 Linuxでvsftpdとlibcapをインストールしました。 インストールしなおそうと思い、 vsftpdの方は、 rpm -e vsftpd でアンインストール、 rpm -ihv vsftpd-1.1.3-8.i386.rpmでインストールできました。 しかし、livcapの方は、 rpm -e libcap や、 rpm -e libcap-1.10-15.i386.rpm ではアンインストールできません。何が原因でしょうか? また、vsftpd のアンインストールは、 rpm -e vsftpd-1.1.3-8.i386.rpm とやるとうまくいきませんが、ファイル名まで指定しないものなんでしょうか? コマンド表にはファイル名まで指定するようになっているようなんですが。。

  • Linux(RedHat7.2)にvncを入れたのですが・・・

    こんにちわ。あつしといいます。 Linux初心者です。 RedHat7.2にVNCを入れ、windows98からリモートでコントロールしようと インストールしたのですが、うまくいきません。 色々試したのですがどうも・・・ 実施した事は次の通りです。 インストールはRedhatのCDに入っていたrpmを使用しました。 vnc-3.3.3r2-18.i386.rpm vnc-server-3.3.3r2-18.i386.rpm インストール後に“vncserver”とコマンドを入力しパスワードの設定をしました。 vncをレベル3・5で自動起動に設定。 vncserverを起動しました。 ネットで調べても微妙にインストールされるファイルが違い しまいにいは訳がわかりません。 Windows側は問題ないと思います。(windows同士ではうまくいきました) 申し訳ないですが宜しくお願いします。

  • rpmパッケージからspecファイルだけを抽出するには?

    皆様   こんにちは、表題通り、rpm(src.rpmではない)からspecファイルを 抽出するのに、どうすれば良いかを教えて頂ければと思います。  これまで調査した内容です。 rpm2cpio xxxxx.i386.rpm | cpio -ivd で解凍できるが、もちろん肝心なspec fileが入っていないので、 あるHPの説明による rpm2cpio xxxxx.i386.rpm | cpio -i "*.spec" と、src.rpmなら抽出できるそうだが、rpmなら実際実行してみても何も抽出され ません でした。他のrpmパッケージでも全く抽出されませんでした。  よろしくお願い致します。

  • RPMパッケージのアップグレードについて

    APACHEをRPMパッケージの最新版(apache-1.3.22-5.7.1)にアップグレードしたいのですが、 現在下記の様な状態で悩んでいます。 # rpm -Fvh apache*.rpm でアップグレードしようとすると、 エラー:依存性の欠如 mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています mod_putは apache-1.3.22-5.7.1 に必要とされています mod_throttleは apache-1.3.22-5.7.1 に必要とされています というエラーが出ます。 次に、依存性の欠如で指摘されたファイルも一緒にアップグレードしようと、 以下のコマンドを入力しました。 # rpm -Fvh apache-*.rpm mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3 .i386.rpm mod_put-1.3-2.i386.rpm そしたら、またしても エラー: 依存性の欠如: mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています mod_putは apache-1.3.22-5.7.1 に必要とされています mod_throttleは apache-1.3.22-5.7.1 に必要とされています と表示されてしまいました。 インストールされているか、rpm -q で確認すると、 インストールされていません と返ってきました。 じゃあ、インストールしよう、と思って #rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3.i386.rpm mod_put-1.3 -2.i386.rpm と入力したら エラー: 依存性の欠如: apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します apache < 1.3.22-1 mod_throttle-3.1.2-3 と競合します apache < 1.3.22-1 mod_put-1.3-2 と競合します と、返ってきました。 一体、どのようにしたら無事アップグレードできるのでしょうか? それとも、現バージョンのAPACHEを削除してから新バージョンのインストールを するしかないのでしょうか? 使用OS:Redhat Linux 7.1J