• ベストアンサー
  • 困ってます

SATAのHDDでOSが起動しない

2年ほど使ったPATA接続のHDDの6Y160POの調子が悪くなったため 新しく買ってきたSATA2のST3320620ASというHDDを購入しました。 そのHDD一基でXPのインストールを行ったのですが、インストール途中でフリーズしてしまい、リセットボタンでもう一度 やり直そうとしたのですが、 Press any key to boot from CD…でキーを押すと 反応はするのですが、何度やっても フォーマットなどを行う青い画面に行く前の 黒い画面で動かなくなるようになりました。 そこで、もともと使っていて既にXPのインストールをしてある 6Y160POを接続して、HDD二基の状態で再び行ったところ 無事に青い画面に行き、ST3320620ASの方にXPをインストールすることができました。 このHDDを二基接続している状態であれば 起動時にST3320620ASと6Y160POでOSの選択画面がでますが、 ST3320620ASを選んでも起動することができます。 そのときHDDは両方二つのパーティションに区切っていて Cドライブが6Y160PO (OS) DドライブがST3320620AS (OS) Eドライブが6Y160PO FドライブがST3320620AS  という状態になってます。 ですが、6Y160POのHDDの接続を外しST3320620AS一基の状態にして 起動しようとすると Boot Failure reboot and select proper Boot Device... などと表示され起動することができません。 マザーボード:865PE Neo2-P Platinum Edition 下の状態で起動可能で Primary IDE Master : 6Y160PO (PATA) Primary IDE Slave : HL-DT-ST DVDRAM (PATA) Secondary IDE Master :ST3320620AS (SATA) 下の状態だと起動できません Primary IDE Master : 無し Primary IDE Slave : HL-DT-ST DVDRAM (PATA) Secondary IDE Master :ST3320620AS (SATA) BIOSをアップデートしたりいろいろ弄ってみたりしたのですが 自分では直すことができませんでした。 アドバイスがあればよろしくお願いします。

共感・応援の気持ちを伝えよう!

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1

SATAHDDの物理的故障は疑いましたか? チェックツールで確認してみるといいかも知れません。 あと、PrimarySlaveに光学ドライブってのも少し気になります。 ジャンパがCableSelectになってたりしませんか?たまにMasterSlaveの設定をしっかりしてやるだけで不具合が直ることがあります。 インストール中のフリーズですがメモリーのDualChannelの同期が原因でとまったのと、AHCIドライバがだめで止まったことがあります。 メモリはクロックを落として解決しました。ドライバは標準でもいくところをF6でGIGABYTEから落としたやつを入れて解決しました。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

光学ドライブのジャンパがSlaveになっていたため Masterに変更しHDD一基でOSを再びインストールしたところ 起動するようになりました。 ジャンパの設定がどう影響してるのか よくわかりませんが、無事直りました^^ アドバイスどうも本当にどうもありがとうございました。

その他の回答 (1)

  • 回答No.2

共感・感謝の気持ちを伝えよう!

質問者からのお礼

無事、直すことができました。 どうもありがとうございます。

関連するQ&A

  • SATAとPATAのHDDを同時接続し、SATAを起動ディスクにしたいです。

    今までPATAのHDDをシステムディスク(起動ディスク)として使用していましたが、新しくSATAのHDDを購入したため、そちらを新しくシステムディスクにして、元のPATAのデータを新たなSATAの方に移したいたいと思っております。現在のところ、 1.元のシステムディスクであるPATAのHDDを取り外す。 2.新しくSATAのHDDを装着する。 3.SATAのHDDにWindowsXPをインストールする。 4.元のPATAのHDDをパソコンに戻す。 上記の4.までの操作を行ったのですが、3.の段階では新たなシステムディスクであるSATAのOSを読み込みできていたのに、4.の操作で元のPATAのHDDをパソコンに戻し、SATAとPATAのHDDを共存させると、元のシステムディスクであるPATAの方のOSを読み込んでしまいます。 これはBIOSの設定でSATAのHDDをFirst Bootに設定できていないからでは・・・?と思い、下記のサイト http://kokujin.web.infoseek.co.jp/op/settei1.htm などを参考にBIOSの設定を行おうと思いましたが、私が使用しているマザーボードAX4PE MaxのBIOSでの上記のサイトのような最初に読み込むHDDを設定するような部分がよくわかりません。 どなたかSATAのOSの方を最初に読み込む方法が分かる方がおられましたら、教えていただけると助かります。どうぞよろしくお願いします。 私のPC構成は以下の通りです。 OS:Windows XP Home SP2 マザーボード:AOpen AX4PE Max(チップ:Intel 845PE) CPU:Pentium4 2.53GHz メモリ:DDR333 512MB×1 HDD:Seagate Barracuda ATA V、HGST Deskstar T7K250 グラボ:NVIDIA GeForce4 Ti4200 8x ドライブ:Pioneer DVR-105 (DVD±R/RW) IDE Primary Master:Seagate Barracuda ATA V IDE Primary Slave :None IDE Secondary Master:Pioneer DVR-105 IDE Secondary Slave :None SATA port1:HGST Deskstar T7K250 (HDT722525DLA380 (250G SATAII 7200))

  • SATAのHDDからOSの起動ができません

    今までSATAのHDDにWindowsXPをいれて使っていたのですが、HDDの調子が悪く新しいSATAのHDDを買いました。 CDからBOOTしてWindowsXP Professionalをインストールしたのですが、その後新しいHDDを使って起動ができません。 (OSのインストールは旧HDDがつながった状態でおこないました) マザーボードはASUSのP5Bを使っており、次のようなエラーメッセージがでます。 Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key 勿論何かキーを押しても同じエラーがでますし、再起動しても症状は改善されません。 また、BOOT画面からHDDは認識しており、またBOOTの順番を新しいHDDが一番になるようにしても同様の症状です。 旧HDDも繋げてみたところ、(完全に壊れたわけではなかったので) どちらのOSを起動できるか選ぶ画面となり、(どちらも同じOSだったため区別はできませんでした) またどちらを選んでもこの場合はちゃんと起動ができました。 マイコンピュータから確認したところ、旧HDDは必ずCドライブとして、 新HDDはEドライブとして認識されていました。 長くなりましたが、SATAのHDDを用いてBOOTができない場合、 どのように対処すればよろしいのでしょうか。 ご回答、よろしくおねがいいたします。 旧HDD:Maxtor 6V250F0(Serial ATA) 新HDD:Seagate ST3320620AS(Serial ATA) マザーボード:ASUS P5B CPU:Intel Core 2 Duo E6300

  • SATAからのOSの起動

    SATAのHDDからOSを起動したいと思っています。とりあえず試しにIDEのHDDを外してSATAのみとし、OSをインストールして起動しようとしたのですが失敗しました。起動しかけてWindowsのロゴとメモリの画面が一瞬出たのちリブートしてしまいます。環境は以下の通りです。 PC本体:Sofmapチーズバーガーパソコン(2005年夏モデル) OS:Windows XP SP2 CPU:Pen4 2.66GHz メモリ:768MB マザーボード:MSI PM8M2-V ビデオボード:Aeolus FX5200-DV128 LP(GeForce FX 5500、128MB) サウンドボード:ONKYO SE-150PCI SATA拡張ボード:SATARAID-PCI(これにSATAのHDD接続) インストールCD:リカバリーディスク(Symantecのゴーストの出るやつ) プライマリIDEマスター:120GB(24GB←システムドライブ + 96GB) プライマリIDEスレーブ:300GB SATAのHDD:500GB(HITACHI HDT725050VLA360、24GB←OSインストール済み + 476GB) 以上の環境でSATAから起動することは可能でしょうか?SATAのHDDのboot.iniをいじくれば何とかなるかもしれないとも思いましたが、boot.iniの構文(?)の意味を忘れてしまいました。。。 どなたかご教示下さい。

  • BIOSでSATAが認識しない

    OSが壊れて起動できなくなってしまったので 新規にHDDを購入し、構成を変更しました。 <旧構成> OS:WindowsXP SP1 M/B :GIGABYTE 8IPE1000PRO2 IDE プライマリ マスタ    HDD(1)(BOOT)[OS壊] IDE プライマリ スレーブ   なし    IDE セカンダリ マスタ    DVDドライブ IDE セカンダリ スレーブ   なし SATA0            HDD(2) SATA1            HDD(3)  まずはHDDをすべて取り外し、新規に購入した HDDにOSをインストール。その後、下の構成にて HDD(1)を復旧しました。 <新構成> IDE プライマリ マスタ    HDD(新)(BOOT) IDE プライマリ スレーブ   HDD(1)[復旧] IDE セカンダリ マスタ    DVDドライブ IDE セカンダリ スレーブ   なし  SATA0             なし SATA1             なし その後、SATA0にHDD(2)を接続すると普通に認識してOSもきちんと起動するのですが、さらにSATA1にHDD(3)を接続するとBIOSで認識しなくなり、OS起動前にフリーズしてしまいます。 SATA0からHDD(2)をはずすと、逆にHDD(3)だけ認識して起動できます。 <現状> IDE プライマリ マスタ    HDD(新)(BOOT) IDE プライマリ スレーブ   HDD(1)[復旧] IDE セカンダリ マスタ    DVDドライブ IDE セカンダリ スレーブ   なし  SATA0   同時接続× どちらかのみ○ SATA1   同時接続× どちらかのみ○ 旧構成ではどちらのSATAも認識していたのですが IDEへの増設が原因でしょうか? ご教授くださいますようよろしくお願いします。

  • windowsが起動しません

    windowsが起動しません(電源スイッチを何回も押しているとたまに起動します) 起動しないときは Secondary IDE Slave : None First SATA Master : ST3250824AS 3.AAEssor 3200+ Second SATA Master : None K Third SATA Master : None Dual Channel . 128-bit Fourth SATA Master : None Primary IDE Master None Primary IDE Slave :None Secondary IDE Master : H という表示が出ます。 CMOSクリア、windowsの再インストールを試してみましたがだめでした。何か解決法はありますでしょうか。

  • HDD増設とIDE&SATAコネクタの接続について

    HDD増設とIDE&SATAコネクタの接続について 富士通のスリム型デスクトップ「FMV-E5220」を使用しています。 マザーボードにはIDEコネクタ1基とSATAコネクタ1基があります。 現在、P-ATAのHDDとIDE接続のDVDマルチは1本のフラットケーブルで マザーボードのIDEコネクタに接続しています。 HDDのジャンパーピンはプライマリ・マスター、DVDマルチはプライマリ・スレーブです。 この接続状態をBIOSで確認すると・・・ プライマリ・マスターがHDD。プライマリ・スレーブがDVDマルチと認識されてます。 現在、搭載のHDDは1台で、80GBと容量が少なく、WindowsXPがインストール されている起動用C:とは別に、デター保存用のSATA・HDDを増設したいと思っています。 手持のSATA-HDD:WD2500AAJS/250GBをSATAコネクタに挿し BIOSで確認すると・・・ SATA Port 1 WD2500AAJS-(PO)と認識されています。 ご質問したい事は、 1)IDE接続で1本のフラットケーブル上にHDDと光学ドライブの様な 転送速度が異なるドライブを接続しても問題が起こらないですか? (元々メーカーの標準接続で、一般的なM/Bの様にIDEコネクタが2基あれば 接続変更出来ますが、1基ではこれしか無いです。) 2)WindowsXPがインストールされている起動ドライブがIDE接続で、 データー保存用に増設するHDDがSATA接続(SATA150)となりますが、 転送速度は体感できるほど違いますか? パソコン構成 概略 ●OS:windows XP Professional SP3 ●CPU:Pentium4 660 3.6GHz/2M/800/LGA775 プレスコ ●M/B:Gigabyte GA-945GPTR-RH Intel945G+ICH7 ●メモリ:2GB 1GBX2 DDR2/PC2-4200 ●HDD:80GB 7200rpm、U-ATA ●薄型コンボドライブ U-ATA ●電源ユニット Max250W

  • winXP(IDE)からSATA-HDDを使いたい

    [M/B] GA-G31M-S2L [chipset] INTEL G31+ICH7 [OS] Windows-XP(SP2) IDE Channel0 master [HDD] ST340015A -- windowsXP IDE Channel0 slave [DVD] パイオニア製DVD IDE Channel1 master [HDD] HDP725050GLA360 (SATA300) IDE Channel1 slave none この構成で電源を入れると、windowsの起動選択画面(win2000とwindowsXPのデュアルブートにしています)が表示されます。そしてwindowsXPを選ぶと一瞬xpの起動中画面が表示された後、リセットされてしまいます。この現象を回避する方法はあるのでしょうか? 希望としては SATA-HDD(HDP725050GLA360)をwindowsXPからデータディスクとして使用したいです。 ちなみに、IDE-HDD(ST340015A)を外して IDE Channel0 master none IDE Channel0 slave [DVD] パイオニア製DVD IDE Channel1 master [HDD] HDP725050GLA360 (SATA300) IDE Channel1 slave none の構成で、IDE-DVDからwindowsXPをSATA-HDDにインストールすると問題なくXPが立ち上がります。また、SATAのケーブルをSATAII0(上の場合はSATAII1接続)に接続して IDE Channel0 master [HDD] HDP725050GLA360 (SATA300) IDE Channel0 slave none IDE Channel1 master none IDE Channel1 slave [DVD] パイオニア製DVD の構成でwindowsXPは問題なく立ち上がります。

  • SATA?接続のHDDが認識されない

    SATA?接続のHDDが認識されない 5年ほど前からIDE接続のHDDを使っていましたが、新しいHDDに引っ越そうとSATA?接続のHDD(Seagate ST3500418AS)を繋いだのですが、なぜかOS上で認識されません。 PC起動直後のBIOS画面では認識されるのですが、OS上では「デバイスマネージャー」上には確認できるものの、「マイコンピュータ」や「コンピュータの管理」上には表示されません。 BIOSの更新、MBの更新などをやりましたが、未だにこの状態が続いています。 解決方法を存知の方がいらっしゃいましたら、御教示願えませんでしょうか。 【PC構成】 ・ペンティアム4 ・GA-G31M-ES2L ・Maxtor 6Y160p0(旧HDD、IDE接続、現在のシステムドライブ) ・Seagate ST3500418AS (新機購入のHDD、SATA?接続、問題のHDD)

  • SATAカードからのHDDブートについて

    こんにちは。よろしくお願いします。 先日、4~5年前のPCと思われる、 ・Compaq Evo Desktop D320 ST/CT ・DELL Dimension 2400 の二つのPCについて、知人の依頼により、リカバリーしました。 =================================== マザーのHDDコントローラーが、IDE(PATA)だったのは、 最近にしては、逆に、新鮮でした。(^^) それで思いついたのは、SATAカードを使って、 SATAのHDDを付けた場合のことなんですが、 ●新規にクリーンインストールするのは、 F6キーを押して・・・。と言う手順は、理解出来ます。 そうではなくて、 ●IDEのHDDでまず、SATAカードを認識(ドライバ入れる)して、 IDE(HDD) → SATA(HDD) と、HDDコピーを行って、そのSATA(HDD)からブート出来たでしょうか? どうなのかなぁ?と、疑問に思いつつ、 それが可能なら、HDDが壊れる前に、SATA(HDD)に換装するのが、 簡単で良いと考えております。よろしくご教授の程お願いします。

  • SATAからの起動

    早速ですが、内蔵IDEと内蔵SATAとのデュアルブートをすべく、M/Bのマニュアルやネットで調べたりしたのですが、どうも要領を得ないので具体的な手順を教えて下さい。 M/B:ASUS P4P800-DELUX IDE1:Master80GB Slave40GB IDE2:光学ドライブ2機 SATA1:160GB SATA2:NONE という構成でIDE1のMasterにWinXP-Pro(SP2)がインストールされているのですが、今までデータ用に使っていたSATA-HDDに違ったOSを入れ、起動時に選択できるようにしたいと思っております。 BIOSのUPDATEは約2年前の購入時から行っておりません。また、BIOSの項目は、日付、オンボードサウンド、キーボード位しか変更したことがありません。 低レベルですが宜しくご教授下さい。