• ベストアンサー
  • すぐに回答を!

スクリプトエラーについて

ビルダー11でサイトを作成し、まだ転送作業までは至っていないのですが、アンケートに関して質問がありますので、どうぞよろしくお願い致します; サイト内でアンケートを作成し、プレビューで確認しようとしたところ、スクリプトエラーが発生しました。 ライン;44 文字;1 エラー;オブジェクトを指定してください。 ソースを調べたところ、44行目は<BODY onload="HpbELQInit();">です。類似の質問と回答を拝見した際、onload="HpbELQInit();"を消去してしまうとう対処法がありましたが、消してしまってよいのでしょうか?何か後で不具合は生じませんか? そしてonloadの意味が不明ですので、それに関しても少しご指導頂けたら幸いです;

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数127
  • ありがとう数0

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
noname#39970
noname#39970

<script> </script> の内側に function HqbELQInit(){ } という部分が無いと思われる。

共感・感謝の気持ちを伝えよう!

質問者からの補足

ありがとうございました^^何とか44列目は解決致しました! が、また違う箇所でスクリプトエラーが出てしまいました; <DIV id="_HPB_ELQNRDIV"><IMG src="logo2.gif" width="363" height="31" border="0" alt="ご売却予定の不動産について"> となっていますが、こちらはそのように対処したらよいのか、 宜しければご指導お願い致します; また、プレビューでエラーが出る場合、実際のページでも同じ現象が起こってしまうのでしょうか?;

関連するQ&A

  • スクリプトエラー

    HP作成は超初心者です。 スクリプトエラーというのが分からず困ってます。 HPはHPビルダーで作ってますが、プレビューでスクリプトエラーが出ます。 ・以下エラー内容 ライン:15 文字:1 エラー:オブジェクトを指定してください コード:0 と表示されますが、初心者の私には意味が分かりません。どうすれば良いでしょうか?ラインが15なので15行目に何か間違いがあるのかも知れませんがそれも分かりません。 ちなみに15行目は、 <BODY bgcolor="#C0C0C0" background="sozai/backpic.JPG" onload="HpbELQInit();"> となっています。

  • ホームページビルダー11 スクリプトエラー 

    ホームページを作成していますが、編集画面からプレビュー画面へ移行すると スクリプトエラーが出てきます。 トップ画面の為に内容が濃く、全部一から作成し直すのは辛すぎます。 どうしたらエラーは消せるでしょうか? エラーの内容が分かりません。ライン3とは3行目のことでしょうか? 文字1とは? オブジェクト指定してくださいとありますがどうすれば良いでしょうか? スクリプトエラー ライン 3 文字  1 オブジェクトを指定してください。 ちなみに3行目は onload="HpbSlideInit(false, 10000, '_HPB_WPG_SLIDE15', 'LAYER_HPB_WPG_SLIDE15_0', 'LAYER_HPB_WPG_SLIDE15_0');"> こちらを全部削除してもエラーは消えませんでした。 更新したいのに出来なくて困っています。 初心者で全く分かりませんのでご丁寧に 教えていただきたいです。 宜しくお願いいたします。

  • サイト作成編集中、トップページをプレビューするとスクリプトエラーが出る

    サイト作成編集中、トップページをプレビューするとスクリプトエラーが出るようになりました。 編集を破棄して、それまでアップロードしてたHTMLを落として編集し直しても、未編集のままでもプレビューするとエラーが出ます。それまでは、まったくスクリプトエラーなど出ませんでした。 他のフリーのエディタも色々と試しましたが、それでも同じでした。 アップしたサイトをブラウザで見てもエラーが出ないことと、それまでエラーが出ることもなかった状態に戻してもエラーが出るので参ってます。 過去ログなども色々と見てみましたがわからないので、解決方法教えてください。 スクリプトエラーの内容は『ライン13 文字2 オブジェクトを指定してください コード0 dhtmld1:』となってます。 編集時に見やすくするようにと思って(タグを使わず)改行しまくってるので、ライン13がどこを指してるのかもわからなくて・・・。 ソースをそのまま載せると長くなるので、URLを書いておきます。 ソースはアップしてるのを落とし直してるので、そちらと変わりません。 http://s1.shard.jp/mikage/ わかる方お願いします

  • ホームページビルダーのスクリプトエラーについて

    ホームページビルダーでアンケートフォームを作成したのですが、 送信しようとすると このページのスクリプトエラーが発生しました。 ライン:98 文字:1 エラー:オブジェクトを指定してください コード:0 とでました。 アンケ-トの答えを必須にして入力をしなくてもエラーがかかりません。どうしたらよいでしょうか?

  • ビルダーで見るソースとネット上で見るソースの違い

    よろしくおねがいいたします。 ビルダー9でHPを作成してしていますが、ビルダーでソースを見ると最後は </BODY> </HTML> で終わっています。 ネット上で見ると</BODY></HTML>の後に <script language="JavaScript"> <!-- var SymRealOnLoad; var SymRealOnUnload; 中略 SymRealOnLoad = window.onload; window.onload = SymOnLoad; //--> というのが並んでいるのですがこれは問題ないでしょうか?

  • ビルダー編集プレビューでスクリプトエラーがでます。

    ホームページビルダー15で編集プレビューにすると、スクリプトエラーが出ます。 このページのスクリプトでエラーが発生しました。 ライン:24 文字:1 エラー:プロパティ'MM_swapImage'の値は Nullまたは未定義で、Fuctionオブジェクトではありません。 コード:0 と出ます。 テンプレートを使用して、ビルダーで編集していて、いままでは全く出なかったんですが、 どうすれば良いでしょうか? 対処できる方がいらっしゃいましたら、教えてください。

  • スクリプトエラーを修正できません。

    スクリプトエラーがでて困っています。 オブジェクトを指定してください。 とのこと。 エラーのラインのタグは以下です。 どうしたらいいのか、どなたか教えてください。 <BODY bgcolor="#FFFFFF" onload="MM_preloadImages('images/side_otoiawase2.gif','images/side_kaisya2.gif','images/side_tokutei2.gif','images/bottan_seikaino2.gif');" <a name="top"><!--アクセス解析タグ ここから--><script language="JavaScript" src="http://analyzer2.fc2.com/analyzer.js?uid=777967"></script>

  • 指定サイズウィンドウが開かない

    ビルダーでサイトを作成しているのですが JAVAスクリプトを使用したサイズ指定ウィンドウが ビルダーのプレビューではちゃんと開くのにFTPツールで転送し、ネット上で開こうとすると開きません。 タグの書いてあったサイトのサンプルでもちゃんと開きます。 タグは <A href="javascript:void(0);" onClick="window.open('file:///○○.html', 'newwin', 'width=900,height=600')" ><IMG src="○○.gif" width="68" height="79" border="0"></A> です。これを<BODY></BODY>に埋め込んでいます。 ○○はファイル名です。一体何処が悪いのでしょうか? 教えてください。

  • このページでスクリプトエラーが発生しました。

    このページでスクリプトエラーが発生しました。 ライン:576 文字:7 エラー:引数が無効です コード:0 URL:http://www-open-opensocial.googleusercontent.com/gadgets/js/core:core.io:rpc.js?container=open&nocache=0&debug=0&c=0&v=f91ddc00fbca6d6c16f12eb2a393dea1 上記のエラーメッセージはGoogleの「カスタム検索エンジンのコード」をビルダーの「HTMLソース」にコピーして「プレビュー」したときに出るものです。 サーバーにアップロードするとこのメッセージは表示されません。検索エンジンは無事に作動しています。 これは何故でしょうか?何か間違いが有るんでしょうか? HTMLがさっぱり分からない者です。よろしくお願いします。

  • 転送したサイトの文字化け対策

    ホームページビルダーでサイトを作成しています。転送すると文字の部分が化けてしまいます。画像はきちんと表示されるのですが、文字だけが化けてしまいます。ビルダーのプレビューではきちんと表示されるのですが、どうして転送すると化けてしまうのでしょうか。  原因は何でしょうか。対策を教えてください。

専門家に質問してみよう