-PR-
解決済み

TCP/IPの速度

  • 暇なときにでも
  • 質問No.22297
  • 閲覧数313
  • ありがとう数5
  • 気になる数0
  • 回答数7
  • コメント数0

 つい先日、古いパソコンを親戚のおじさんにもらったので家庭内LANを組みました。
 ボードは10ベース/100ベース両対応のもので、機種名は忘れてしまいましたがこないだ新宿のDOS/Vパラダイスで1000円で売ってた奴です(と言って分かる人なんかいますかね?(^_^;)

 で、問題はその速度なんですけど、妙に遅いんです。TCP/IPだと特に遅いです。毎秒16KB/Sしか出ません。こんなもんなんでしょうか?

 なお、マシンはピア・トゥ・ピアで、スペックは下記の通りです。

1.CPU 300MHz、Mem128MB、BIOS BX(たしかABIT)
2.CPU 120MHz、Mem48MB、BIOS FM/V

 設定としては、TCP/IPとNetBEUIをプロトコルとして導入しており、デフォルトはNetBEUIにしています。
 遅いなら遅いで別にかまわないんですけど、何か解決方法があるのであれば教えてください。
 よろしくお願いします。
通報する
  • 回答数7
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.1
レベル12

ベストアンサー率 65% (242/372)

ネットワークが遅くなる原因はいくつか考えられるのですが、支障がなければプロトコルを1つにされることをオススメします。

NetBEUIだけだとインターネットに接続できなくなるでしょうから、1つにするならTCP/IPですね。

参考まで
補足コメント
noname#25358

 ありがとうございます。

 もともとTCP/IPだけを入れてました。
 それでコピーがあまりにも遅いのでNetBEUIを入れたんです。それでも秒間100Mビットもいってないです(^_^;
投稿日時 - 2000-12-26 17:17:14
-PR-
-PR-

その他の回答 (全6件)

  • 回答No.3
レベル3

ベストアンサー率 0% (0/4)

もしかするとイーサーカードのスピードがオートネゴシエーションになっていませんか?
1.ネットワークから該当するボードを選択
2.詳細設定でLink Speed/Duplexを選択
  
そこの値がAUTOなら一度10half modeにしてリブート
してみてください。

世の中には、ドライバーの問題でネゴできないことがあります。
また、接続している機器の相性もあります。
補足コメント
noname#25358

 ありがとうございます。

 それは俺も考えました。で、今は手動で100Fullにしてあるんですが……でも全然変わりませんでした(^_^;
投稿日時 - 2000-12-26 17:22:24


  • 回答No.2
レベル11

ベストアンサー率 35% (162/461)

ハブを介してるのでしょうか?それともクロスケーブルで直付けなのでしょうか?
あと、どちらの機械のLANボードも100BASE-TX対応なのでしょうか?

16kb/sというのはどこに出ている数字なのでしょうか?
補足コメント
noname#25358

 ありがとうございます。

 まず、ケーブルはクロスです。
 で、LANボードは同じメーカーの同じ型番の物で、2つ同時に買いました。100BASE対応を大きく謳ってあります。
 それから速度は、フリーのFTPソフト(RootFTP)でファイルをアップロードしたときの平均値です。
投稿日時 - 2000-12-26 17:20:03
  • 回答No.4
レベル12

ベストアンサー率 39% (264/666)

・どちらのPCからも対向側のPCにPINGはしっかりと通りますか?
パケットがロストしているようなことはないですか?

・FTPソフトに転送速度の上限のようなものは在りませんか?

・マイクロソフトファイル共有を利用しても転送は遅いですか?

・NetBEUIだけでもやっぱり遅いですか?

以上の事はどうでしょう?
補足コメント
noname#25358

 ありがとうございます。

 試してみました。
1.試しました。ロストはなかったです。
2.特にないようです(^_^;
3.はい。
4.はい。遅かったです。
投稿日時 - 2000-12-27 00:07:32
  • 回答No.5

ケーブルがカテゴリ5であり、断線もしていない
のなら、お互いのLANボードの設定を疑ってください。
100BASE-TXとかAuto Negoとかいう設定ではなくて、
それ以外の設定項目です。(ネットワークのプロパティ
のネットワークアダプタのプロパティですね)
これはボードによって違うので
どれをどうこうするとは言えませんが、この設定が
邪魔をしている可能性があります。いろいろ変更して
みて試していくというのはどうでしょう。
補足コメント
noname#25358

 ありがとうございます。

 カテゴリ5ってなんでしょう?
 いちおーパッケージにはカテゴリ5って書いてありましたけど。
 ちなみにそれ以外の設定項目はスピードに関係するようなのはないんですけど……邪魔するってことあるんでしょうか(^_^;
投稿日時 - 2000-12-27 00:11:28
  • 回答No.6
レベル11

ベストアンサー率 36% (86/235)

クロスケーブルをやめてください。
10/100のNICは、きちんとLINKしないとまともに動きませんよ。
2000円くらいで、10MのHUBでも買ってきたほうがいいと思います。
データ転送に失敗して再送の連続だと思います。
ケーブルもほんとに100Mで使おうと思ったら、きちんとした製品を使用するべきです。
100MのHUBと、製品版のカテゴリー5のストレートケーブル2本を購入してください。
補足コメント
noname#25358

 ありがとうございます。

 クロス駄目なんですか?
 やっぱスピードの原因はケーブルなんでしょうか。
 それ、ありそうですけどねぇ……。でもHUB買うほど財布の余裕が(^_^;
投稿日時 - 2000-12-27 00:19:30
  • 回答No.7
レベル13

ベストアンサー率 31% (311/992)

ken2さんの書き込みに補足。
予算が有るので有れば、100M対応のスイッチングパブを、お使い下さい。
スイッチング付きHUBは、最近600円ぐらいから出ています。
少ない予算で、猛スピードか、手にはいると思います。
二代だと、あまり効果が無いように思えますが、使ったら、普通のHUBはもう使えません。
あとTCP/IPでぜひ使ってください。
あくまで 補足です。
クール
補足コメント
noname#25358

 ありがとうございます。

 HUBが600円ですか!? それは安いですね。それくらいだったら買ってもいいなぁ。
 それ使えば早くなるんでしょうかね。
投稿日時 - 2000-12-27 00:23:00
このQ&Aで解決しましたか?
AIエージェント「あい」

こんにちは。AIエージェントの「あい」です。
あなたの悩みに、OKWAVE 3,500万件のQ&Aを分析して最適な回答をご提案します。

関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


専門家があなたの悩みに回答!

-PR-

ピックアップ

-PR-
ページ先頭へ