• ベストアンサー
  • 困ってます

pppoe接続について

linuxサーバーを使用して、pppoe接続しております。 しかしmessagesログを見ると以下のようなログが記録されておりますが、原因がよく分かりません。(一部数字等を変更しております) pppd[10000]: LCP: timeout sending Config-Requests pppd[10000]: Connection terminated. pppd[10000]: Modem hangup pppd[10000]: PPP session is 111111 pppd[10000]: Using interface ppp1 pppd[10000]: Connect: ppp1 <--> eth1 これを見る限り、ppp1で接続出来てないような感じなのですが、現在の接続はppp0でeth1を使用して接続出来ております。 もちろん/etc/sysconfig/network-scripts/内にppp1の設定ファイルもございません。 このような場合、どこの設定を見ればいいのでしょうか。 どなたかよろしくお願いいたします。

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数838
  • ありがとう数2

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • onosuke
  • ベストアンサー率67% (310/456)

設定やコマンドをやりすぎて、 pppoe接続を二重に接続しようとして接続先から拒否されているだけような気がします。 ちなみに、ppp0やppp1は仮想IFです。 例えば、ppp接続コマンドを2つ同時実行すると、 最初のはppp0。2つ目はppp1と順番に使っていきます。 従って >もちろん/etc/sysconfig/network-scripts/内にppp1の設定ファイルもございません といった設定ファイルとも直接関連ありません。 これは、番号を決められないので便宜上、 ifcfg-ppp0という名前で設定ファイルを作成する場合がよくあるだけです。

共感・感謝の気持ちを伝えよう!

質問者からの補足

詳しく教えていただきありとうございます。 ifcfg-ppp0とifconfigで表示されるppp0が関連しているものと思っていたのですが、違うのですね。 ppp0やppp1が作られるルールが分かり、やっと納得できました。 ありがとうございました。

関連するQ&A

  • vine3.1でPPPoEサーバのログインパスワードは何処に記述する?

    こんばんは。 RedHat9(XWindow有り)で使用していた/etc/sysconfig/network-scripts/ifcfg-ppp0 を フロッピーに録って置いてvine3.1をインストール(XWindow無し)でPPPoEサーバに接続したく、 /etc/sysconfig/network-scripts/下に下記のような ifcfg-ppp0 を起きました。 所で、何故かパスワードが記載されてないのに何故かRedHat9では接続出来てました。 (RedHat9はX Windows付属の接続ツールにパスワードを入力してました) PPPoEサーバのパスワードは何処のファイルにどのように記述すればいいのでしょうか? USERCTL=yes PEERDNS=no ONBOOT=yes TYPE=xDSL DEVICE=ppp0 BOOTPROTO=dialup PIDFILE=/var/run/pppoe-adsl.pid FIREWALL=NONE PING=. PPPOE_TIMEOUT=80 LCP_FAILURE=3 LCP_INTERVAL=20 CLAMPMSS=1412 CONNECT_POLL=6 CONNECT_TIMEOUT=60 PERSIST=no SYNCHRONOUS=no DEFROUTE=yes USER='hoge@isp.co.jp' PROVIDER=BBisp ETH=eth0 DEMAND=no

  • pppoeをカーネルモードで動作させたい

    Red Hat Linux8.0にて kernel2.4.20を再構築しPPPoEサーバを 構築しています。 pppoeのmakeで /etc/ppp/rp-pppoe.soを /usr/lib/pppd/2.4.2b3/rp-pppoe.soにリンクする。 とあったので行ったのですが、 ここが正しく出来ているかわかりません。 行ったのは # ln -s /usr/lib/pppd/2.4.2b3/rp-pppoe.so /etc/ppp/rp-pppoe.so です。 pppoe-serverの実行でpppoe-server -I eth1 or eth2 -k と行いましたが、 PPPoEの状態が 確立(AC=pppoe.hyouka.co.jp) PPPの状態が LCP中 で停止してしまいます。 ACは発見できてセッションは開始できている ユーザ認証がうまくいっていないのでしょうか? ユーザモードならばうまく認証を完了します。 どの辺りが怪しげかご指摘いただけないでしょうか? よろしくお願い致します。

  • rp-pppoeとBフレッツベーシックを用いたマルチセッション接続について

    こんにちは。 ある一台のIAサーバー(Fedora core4)にイーサネットカードを4枚刺し、そのうち2枚(eth0とeth2)には、ONU直後にHUBで分岐したWAN側に接続され、残りの2枚(eth1とeth3)にはローカルネット側に接続されています。 NTT側 - ONU - HUB-+- eth0(ppp0) eth1-+ HUB-LAN側          +- eth2(ppp1) eth3-+ 今、eth0とeth2をpppoeでISP1とISP2に2セッション接続をしています(ISP1とISP2はフレッツスクエアではありません)。 ここで、 eth1に到達したアクセスはppp0へ、 eth3に到達したアクセスはppp1へ割り振るにはどのような設定をしたらよろしいでしょうか。 市販の”ブロードバンドルーター”2台を1台のサーバーにさせる感じなのですが、 サーチエンジンによる検索でマルチセッション接続について調べると、 メインで使用するISPと静的NATでフレッツスクエアに接続する解説が多く、なかなか資料がないようです。 よろしくお願いいたします。

  • ADSL回線が自動的に切断され、また再接続され、繰り返す.....

    Dell Optiplex150+Fedora3+FletsADSLでInternetルータを立ち上げましたが、IPアドレスは毎日20回ぐらい変更されています。/var/log/messagesを見ると、(時刻省略) test-srv pppd[23322]: No response to 3 echo-requests test-srv pppd[23322]: Serial link appears to be disconnected. test-srv pppd[23322]: Connection terminated. test-srv pppd[23322]: Connect time 52.3 minutes. test-srv pppd[23322]: Sent 771 bytes, received 5256 bytes. test-srv pppoe[23323]: read (asyncReadFromPPP): Session 4058: Input/output error test-srv pppoe[23323]: Sent PADT test-srv pppd[23322]: Connect time 52.3 minutes. test-srv pppd[23322]: Sent 771 bytes, received 5256 bytes. test-srv pppd[23322]: Exit. test-srv adsl-connect: ADSL connection lost; attempting re-connection. test-srv pppd[23983]: pppd 2.4.2 started by root, uid 0 test-srv pppd[23983]: Using interface ppp0 test-srv pppd[23983]: Connect: ppp0 <--> /dev/pts/0 test-srv pppoe[23984]: PPP session is 5132 test-srv pppd[23983]: CHAP authentication succeeded test-srv pppd[23983]: local IP address XXX.XXX.XXX.XXX test-srv pppd[23983]: remote IP address YYY.YYY.YYY.YYY 時刻は殆ど深夜(12:00~06:00)、Optiplex150のBiosの SuspendModeをS3からS1に変更しても、変わりません。因みにOptiplex150のBiosはS0に変更できません。 Fedora3でどうやって、直せます?acpiかな? よろしくお願いします。

  • 無線LANの設定を保存する方法

    無線LANの設定を保存したいと思い、下記URLを読んだのですが、 「設定ファイルをCUIで作成する場合は、rootで/etc/sysconfig/network-scripts/ifcfg-eth1に以下の記述を行う。」 の部分で、etcの下にsysconfigというディレクトリは今無いのですがこれはsysconfig/network-scriptsというディレクトリを作成した上で、ifcfg-eth1というファイルに記述するということでしょうか? また、ifcfg-eth1というファイルに拡張子がないのですが、何もいらないのでしょうか? http://www.atmarkit.co.jp/flinux/rensai/linuxtips/762usewlan2.html

  • なぜ、ADSL接続不安定、ppp0のinet IPアドレスはよく変わる?

    最近、Redhat8.0でInternetServerを作って、FLetsADSLを接続して、公開したいですけど、なかなか不調でした。症状はADSL接続不安定で最初にきちんと接続したけど、しばらくコンピュータ自身は接続を切って、すぐもう一度接続して、そのような感じでちらついて接続してます。だから、ppp0のinetIPはよく変わります?すごく困っています。よろしくお願いします。 システム構成: OS:Redhat Linux 8.0 eth0(unactivate):->ADSL接続 eth1(192.168.10.16)->LAN /etc/sysconfig/network NETWORKING=yes HOSTNAME=XXXX GATEWAY=192.168.10.16 GATEWAYDEV=eth0 FORWARD_IPV4=yes 因みにiptablesを使っています iptables -A INPUT -p all -s 192.168.10.0/24 -j ACCEPT iptables -A INPUT -p all eth1 -192.168.10.0/24 -j ACCEPT iptables -A INPUT -i ppp0 -p tcp --dport XXX -j ACCEPT iptables -A INPUT -i ppp0 -m state --state RELATED,ESTABLISHED -j ACEPT iptables -A INPUT -i ppp0 -m state --state NEW,INVALID -j DROP iptables -A FORWARD -j ACCEPT -i eth1 -o ppp0 -s 192.168.10.0/24 iptables -A FORWARD -j ACCEPT -o eth1 -i ppp0 -s 0.0.0.0/0

  • AirMacにしたらPPP接続が出来なくなりました

    こんにちは。PismoとiBook(366Mhz 256MB Graphite)にAirMacカードを入れて、一昨日から快適なケーブルワイヤレス接続を始めました。しかし、一旦AirMac環境を構築した途端に、昨日まで問題の無かったダイアルアップ接続が不可能になり、途方に暮れています。両ノートとも、旅程で使用する頻度が高く、ダイアルアップ接続が出来ないとなると致命的です。もちろん経由先などは全てPPP接続にして、マシンをセミリセットしています。AirMacを切っても、(AirMac)関連書類を一時的に消してもうまく行きません。 接続ログの一部を引用します。 01.1.13 11:30 LCP: Sending Configuration Ack. 01.1.13 11:30 LCP: Sending Configuration Request. 01.1.13 11:30 LCP: >> Async Map = 0x00000000. 01.1.13 11:30 LCP: >> Magic Number = 0x449B1739. 01.1.13 11:30 LCP: >> Protocol Compression On 01.1.13 11:30 LCP: >> Address/Control Compression On 01.1.13 11:30 LCP: Received Configuration Ack. 01.1.13 11:30 01.1.13 11:30 遠隔側から、中断の要請がありました。 01.1.13 11:30 CCL write: "+++ATH\13" 01.1.13 11:30 CCL write: "+++ATH\13" 01.1.13 11:30 CCL match: "OK\13\10" 01.1.13 11:30 CCL write: "AT&F\13" 01.1.13 11:30 CCL match: "OK\13\10" 01.1.13 11:30 接続が、予期しないうちに中断しました。 01.1.13 11:30 接続は中断されました。 接続先アクセスポイントを変えても全く同じ状況です。 つい最近までまで問題無かっただけに大変気になります。 お気づきの点等、ありましたらアドバイス頂けますと幸いです。 よろしくお願いいたします。

    • 締切済み
    • Mac
  • Vine4.2+rp-pppoe フレッツ接続切断(NETDEV WATCHDOG)

    おわかりになる方御教授お願いいたします。 Vine4.2にてrp-pppoeを使用し、フレッツに接続した際に 大きなデータをやり取りすると以下のエラーを表示し、 全てのネットワークデバイスの応答が無くなってしまいます。 しばらくすると復帰するのですが、やはり大きめなデータの やり取りで再発いたします。 ちなみにその他Linuxカーネル2.6.16でも同じ現象が起きます。 NIC:RealTek RTL-8139 PCI Fast Ethernet Adapter --ERROR-- NETDEV WATCHDOG: eth1: transmit timed out eth1: Transmit timeout, status 0d 0000 c07f media 10. eth1: Tx queue start entry 4 dirty entry 0. eth1: Tx descriptor 0 is 000843e9. (queue head) eth1: Tx descriptor 1 is 000803e9. eth1: Tx descriptor 2 is 000803e9. eth1: Tx descriptor 3 is 00080106. eth1: link up, 100Mbps, full-duplex, lpa 0x45E1 NETDEV WATCHDOG: eth0: transmit timed out eth0: Transmit timeout, status 0d 0000 c07f media 10. eth0: Tx queue start entry 588 dirty entry 584. eth0: Tx descriptor 0 is 000c456d. (queue head) eth0: Tx descriptor 1 is 000e0106. eth0: Tx descriptor 2 is 0010004a. eth0: Tx descriptor 3 is 0010003c. eth0: link up, 100Mbps, full-duplex, lpa 0x41E1 --pppoe.conf-- ETH='eth1' USER='XXXXXXX' DEMAND=no DNSTYPE=SERVER PEERDNS=yes DNS1= DNS2= DEFAULTROUTE=yes CONNECT_TIMEOUT=30 CONNECT_POLL=2 ACNAME= SERVICENAME= PING="." CF_BASE=`basename $CONFIG` PIDFILE="/var/run/$CF_BASE-pppoe.pid" SYNCHRONOUS=no CLAMPMSS=1412 LCP_INTERVAL=20 LCP_FAILURE=3 PPPOE_TIMEOUT=80 FIREWALL=NONE LINUX_PLUGIN=/usr/libexec/ppp/rp-pppoe.so PPPOE_EXTRA="" PPPD_EXTRA="" --iptables-- /sbin/iptables -F /sbin/iptables -F -t nat /sbin/iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT /sbin/iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT /sbin/iptables -A INPUT -i lo -j ACCEPT /sbin/iptables -A INPUT -i eth0 -j ACCEPT /sbin/iptables -A INPUT -i tap0 -j ACCEPT /sbin/iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE /sbin/iptables -A FORWARD -o ppp0 -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu /sbin/iptables -A FORWARD -o ppp0 -j ACCEPT /sbin/iptables -P FORWARD DROP /sbin/iptables -P INPUT DROP 宜しくお願いいたします。

  • PPPoEマルチセッションでフレッツスクエアにアクセスできません;

    PPPoEマルチセッションでフレッツスクエアにアクセスできません; ○やりたいこと ・インターネットとフレッツスクエアにアクセスしたい。(PPPoEマルチセッション機能を利用して。) ○困っていること ・フレッツスクエアにアクセスできない。 ・WBR-g54の設定topページに CHAP認証失敗 と出ている。 WBR-G54のログ 2010/05/09 20:06:41 PPPoE CHAP authentication failed 2010/05/09 20:06:41 PPPoE Remote message: Authentication failure 2010/05/09 20:06:39 PPPoE Connect: ppp1 -> eth1 2010/05/09 20:06:39 PPPoE Connecting PPPoE socket: 00:12:44:46:c1:a3 0c47 eth1 0x10012000 2010/05/09 20:06:39 PPPoE Got connection: 470c 2010/05/09 20:06:39 PPPoE recv PADS 2010/05/09 20:06:39 PPPoE Sending PADR 2010/05/09 20:06:39 PPPoE recv PADO 2010/05/09 20:06:39 PPPoE Sending PADI ○環境 | [回線終端装置:PR-200NE] | [自前のルータ:Buffalo Airstation WBR-G54] | [有線LAN接続でPCが2台のみ。無線pc無し。]  ⇒PR-200NE   - NTT東日本の設定ページより、「IPv6ブリッジ(有線LAN)」の【使用する】に設定済み  ⇒WBR-G54   - ファームバージョン Ver.2.23   - WAN設定でPPPoE接続先リストにfletsを追加済み     - ID/PASS:guest@flets/guest     - 接続先経路に以下を設定 1 *.flets 2 172.26.0.0/16   - DHCPサーバ機能を使用しないに設定 【キャリア/ISP】Bフレッツ/ぷらら 【PC】自作pc,win xp professional いろいろと探してみたのですが、なぜCHAP認証失敗と出てしまうのか。なぜ、接続できないのか、何が問題なのかわからず困り果てております。申し訳ございませんが、有識者様ご指導いただけないでしょうか。どうぞよろしくお願いいたします。

  • pppoeでマルチセクション時のルーティングについて

    Linuxでルーターを構築しており、pppoeでマルチセクションでの接続でハマっております。 現在、pppoeにて、WAN側のppp0とppp1にISPのIPが割り当てられております。 で、LAN内のPC2台をWAN側のそれぞれのデバイス(PC1=ppp0とPC2=ppp1経由)でインターネット出来るようにしたいと考え試行錯誤しております。 ・LAN側PC1(IP=192.168.1.11ネットワーク構成:192.168.1.0/25)→ppp0経由でインターネット出来ます ・LAN側PC2(IP=192.168.1.130ネットワーク構成:192.168.1.128/25)→ppp1経由でインターネットできずはまっています ▼行なった事1 ・仮想NICの設定 # ifconfig eth1:1 192.168.1.129 netmask 255.255.255.128 broadcast 192.168.1.255 up ・参照 # ifconfig ... #●下記eth1:1が追加されました。 eth1:1 Link encap:Ethernet HWaddr 00:90:99:7D:8B:42 inet addr:192.168.1.129 Bcast:192.168.1.255 Mask:255.255.255.128 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:21 errors:0 dropped:0 overruns:0 frame:0 TX packets:3 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:100 RX bytes:1800 (1.7 Kb) TX bytes:30 (30.0 b) Interrupt:11 Base address:0x6000 ppp0 Link encap:Point-to-Point Protocol inet addr:202.***.***.**1 P-t-P:124.***.***.1 Mask:255.255.255.255 UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1454 Metric:1 RX packets:3460 errors:0 dropped:0 overruns:0 frame:0 TX packets:3067 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:3 RX bytes:2764597 (2.6 Mb) TX bytes:402575 (393.1 Kb) ppp1 Link encap:Point-to-Point Protocol inet addr:202.***.***.**2 P-t-P:124.***.***.2 Mask:255.255.255.255 UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1454 Metric:1 RX packets:21 errors:0 dropped:0 overruns:0 frame:0 TX packets:3 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:3 RX bytes:1800 (1.7 Kb) TX bytes:30 (30.0 b) ・ネットワークを追加 # route add -net 192.168.1.128 netmask 255.255.255.128 metric 0 dev eth1 # route 192.168.1.128 * 255.255.255.128 U 0 0 0 eth1・・・ここが追加 ※この時点で、PC2からインターネット出来なかったのが、【●】PC2からインターネット出来るようになりました ですが、WAN側のppp0経由からPC1/PC2共インターネット出来る状態です その為、PC1(IP=192.168.1.11/25)はppp0経由で外部へ、PC2(IP=192.168.1.130/25)はppp1経由で外部へ出れるように iptablesを設定しているのを適用する為、実行します # . /etc/rc.d/iptables-ppp01 ※上記適用後、【●】PC1はインターネットできます。【×】PC2はインターネットできません ・PPP1のIPをルーティングテーブルに追加 # route add default gw 202.***.***.**2 metric 0 ppp1 ・参照 # route ... default x097045.ppp.asa 0.0.0.0 UG 0 0 0 ppp1・・・ここが追加 default kzgnia6.asahi-n 0.0.0.0 UG 0 0 0 ppp0 ※この時点で  【×】PC1はインターネット出来なくなりました  【●】PC2はPPP1経由でインターネット出来ました(ppp1のIPによる接続を確認) ・削除 # route del default gw 202.***.***.**2 metric 0 ppp1 ・参照 # route kzgnia6.asahi-n * 255.255.255.255 UH 0 0 0 ppp0 kzgnia4.asahi-n * 255.255.255.255 UH 0 0 0 ppp1 192.168.1.0 * 255.255.255.128 U 0 0 0 eth1 192.168.1.128 * 255.255.255.128 U 0 0 0 eth1 169.254.0.0 * 255.255.0.0 U 0 0 0 eth1 127.0.0.0 * 255.0.0.0 U 0 0 0 lo default kzgnia6.asahi-n 0.0.0.0 UG 0 0 0 ppp0 ※元に戻り  【●】PC1からインターネット出来ます(ppp0のIPによる接続を確認)  【×】PC2からインターネット出来ません どうやればPC1はWANのppp0経由で、PC2はppp1経由でインターネット出来るように両立させる事が可能なのかわからず、はまっております どうか先生方からご教授頂けますよう宜しくお願い致します