締切済み

MT5のブログで画像挿入を選ぶとエラーが発生

  • すぐに回答を!
  • 質問No.7336442
  • 閲覧数2747
  • ありがとう数1
  • 気になる数0
  • 回答数3
  • コメント数0

お礼率 25% (8/31)

Movable Type5.13でブログを作り、記事を書き、
画像を入れようとしたところでエラーが起こりました。

MT5のブログ記事編集画面において「画像の挿入」アイコンを
クリックすると『エラーが発生しました』と書かれたウィンドウが出て来て
画像を入れる事ができません。「ファイルの挿入」アイコンをクリックしても同じです。

「イメージ」アイコンから画像は入れられるのですが、
サムネイル設定ができず、原寸表示になるのでとても不便です。

cgiやプラグインはいじってませんし、
どのブラウザでMT5を起動しても変わりませんでした。


どなたかご存知の方が居られましたら、お力を貸していただきたいです。

回答 (全3件)

  • 回答No.3

ベストアンサー率 63% (14/22)

前回の記事で、恐らくサムネイル生成時にエラーが発生し、
そのままそのエラーをひきずっているっぽいです。

同じ現象が起きたのですが、

mt-config.cgi 内のImageDriverの指定を1度変更しアップ、
再度戻してアップしたら治りました。

参考までに試していただければと思います。

こちら検証した手順。

---------------------
修正前のmt-config.cgi
ImageDriver GD
ImageDriver NetPBM
---------------------
何故2つ記述されているか記憶にありませんが、
ImageDriver NetPBM
を削除し、
ImageDriver GD
だけにしアップ。

確認すると治ったので、
修正前の状態に戻し、再度アップ。
問題なく動作しました。

※原因として日本語で画像をアップしていたのが原因でないかと考えたりしてます。
Be MORE 7・12 OK-チップでイイコトはじまる
  • 回答No.2

ベストアンサー率 45% (5062/11035)

だとすると、とりあえず
画像ファイルをアップロードすると 500 エラーが発生します。 | Movable Type 4 FAQ ( http://www.movabletype.jp/faq/image-500.html )
の対策をするか、アップロードする画像のサイズを小さくしてみてください。

別に、imageMagckを使う簡単なCGIで、テストしてみる。

 いずれにしても、imageMagickがきちんと動作していないようです。

 また、プロバイダーに確認してみてください。たぶん、前例がありそうなトラブルです。
  • 回答No.1

ベストアンサー率 45% (5062/11035)

サーバーにimageMagickがインストールされていますか?また、PerlのモジュールであるImage::Magickはインストール済みですか?

ImageDriver | 環境変数リファレンス ( http://www.movabletype.jp/documentation/appendices/config-directives/imagedriver.html )
Movable Type 3.3 マニュアル - 画像の埋め込み ( http://www.sixapart.jp/movabletype/manual/3.3/04_user_guide/inserting_images.html )
画像ファイルをアップロードすると 500 エラーが発生します。 | Movable Type 4 FAQ ( http://www.movabletype.jp/faq/image-500.html )

たとえばNiftyなどでは、用意されています。
※インストーラーでウェブアプリケーションを簡単設置 : @niftyホームページサービス ( http://homepage.nifty.com/_service/webapps.htm )

 コマンドラインから様々な処理--それもPhotoShop並みの機能を持っているので、とても便利なアプリケーションです。、重宝しています。
★ImageMagick - Wikipedia ( http://ja.wikipedia.org/wiki/ImageMagick )
補足コメント
ebiebi56

お礼率 25% (8/31)

多くの参照リンクと丁寧な解説ありがとうございます。

しかしながら、現在契約している「さくらインターネット」には
imageMagickが標準装備されているようでして…

http://support.sakura.ad.jp/manual/ms/tech_server.html#ac05


それと「画像(ファイル)の挿入」アイコンをクリックした段階で
「エラーが発生しました」とだけ表示されるため、サムネイル生成時の500エラーでは無いと思います。

お手数おかけします
投稿日時 - 2012-03-02 13:54:53
AIエージェント「あい」

こんにちは。AIエージェントの「あい」です。
あなたの悩みに、OKWAVE 3,500万件のQ&Aを分析して最適な回答をご提案します。

関連するQ&A
このやり方知ってる!同じこと困ったことある。経験を教えて!
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。
このQ&Aのテーマ

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する

特集


より良い社会へ。感謝経済プロジェクト始動

ピックアップ

ページ先頭へ