• 締切済み
  • 暇なときにでも

開くたびにページの最下部が表示されてしまいます

友人のホームページの修正を頼まれたのですが、原因が分からず困っています。 ネットスケープナビゲーターだと、開くたびに必ずページの最下部が表示されてしまい、困っています。 インターネットエクスプローラーではちゃんと最上部が表示されるのですが・・・ ソースを見ても何が原因なのかよく分からないんです。 お分かりになる方、宜しくお願いします。

共感・応援の気持ちを伝えよう!

  • HTML
  • 回答数4
  • 閲覧数234
  • ありがとう数11

みんなの回答

  • 回答No.4
noname#151056
noname#151056

問題はご指摘のページにあるのではなく、このページを指定した方法にあるのでは ないかと思います。Netscape Navigator(以下NN)とInternet Explorer(以下IE)で 違う点の一つに、存在しないキーワード指定時の動きがあります。たとえばご指摘 のページには<a name="taiiku">というキーワードがありますが、このページに対 して http://...html#taiku というように存在しないキーワードで読み込みを実行 すると、IEではページの先頭に、NNではページの末尾に移動します。

共感・感謝の気持ちを伝えよう!

質問者からの補足

これだ!と思ったのですが、存在しないキーワードは無かったんです。 結局原因はわかりませんでした。

  • 回答No.3
  • kamuy
  • ベストアンサー率32% (51/156)

今確認してみたのですが、既に対策済なのでしょうか? 何カ所かのリンクを戻ってみたのですが、 別段最下部に飛ぶということはないようです。 ちなみに当方の環境は  Win98  Netscape 4.7 という感じです。

共感・感謝の気持ちを伝えよう!

  • 回答No.2

補足のURLはFetchErrorということでした、サーバは年末休暇でしょうか? リンクページと言うことで、アドバイスさせていただきますと、同じページで リンク先を表示させるのではなく、新規のページを開いたらいかがでしょう? <A HREF="リンク先" TARGET="_blank">リンク</A> というタグパラメータを追加すれば、別のウィンドウが新規作成されますので リンクページは残ったままですから戻るボタンを押す必要もありません。 TARGETパラメータに、特定の名前を付けると、別ウィンドウが増殖することを 抑えられます。 <A HREF="リンク先1URL" TARGET="LinkTarget">リンク先1</A> <A HREF="リンク先2URL" TARGET="LinkTarget">リンク先2</A> お試しください。 TARGETパラメータは他にも色々な使い方ができますので、HTMLのリファレ ンスブックなどでお調べください。

共感・感謝の気持ちを伝えよう!

  • 回答No.1
  • kamuy
  • ベストアンサー率32% (51/156)

具体的なURLを「補足」してください。 実際のソースを見て判断材料としたいので。

共感・感謝の気持ちを伝えよう!

質問者からの補足

http://www.yokohamafutaba.naka.yokohama.jp/link/link.htm こちらです。 リンクからリンク先へジャンプして、ブラウザの戻るボタンで戻ったときに必ず最下部が表示されます。 宜しくお願いします

関連するQ&A

  • インターネットエクスプローラーの最下部の表示

    インターネットエクスプローラーの最下部の表示がなくなってしまいました。メールアドレスとかの上にマウスポインタをおくとそのメールアドレスが表示される部分というか、ちょっと重たいページに接続しようとすると「…に接続しています」という表示などが出る部分です。デスクトップから突然、インターネットエクスプローラーのアイコンが消えてしまったと同時にブラウザの最下部の表示もなくなってしまいました。すごく不便なので元に戻したいのですが方法がわかりません。どなたか教えてください。

  • IEでのランタイムエラー表示

    最近、インターネットエクスプローラーでページを開くたびに、エラーが出てデバックするように表示されます。いいえを押すと続けて3回ぐらい表示されておさまるのですが、原因や対処方法がわかりません。アドバイスしていただけますか? なお、オペラやネットスケープではエラー表示は出ません。

  • ホームページビルダー9で編集の際ソースも表示される

    ホームページビルダー9を使用していて パソコンを入れ替えて 新しいパソコンでホームページビルダー9を 起動したのですが 今までは ページの編集をする際 ページだけしか表示されなかったのですが 新しいパソコンで起動すると ページとソースが 一緒に表示されてしまうようになってしまいました 画面上部に ページが表示されて 画面下部に ソースが表示されています 編集のたびに ソースも表示されると 時間がかかるので その設定を ページだけの表示にしたいのですが わかりませんでした おそらく オプションから行うと思うのですが どうやったらいいのでしょうか? わかりにくい表現などあるかと思いますが よろしくお願いします

  • 毎日、ほぼ同じHPで「ページを表示できません」と出ます。

    インターネットエクスプローラーで、「ページを表示できません」と出ます。 だいたいがヤフーのオークションのページを閲覧する時です。 1クリック目はOKでも、2クリック目くらいにはもう表示できなくなります。 同じようにネットスケープは、ずっと見ててもほとんどエラーは出たことがありません。 OSはXPです。 ウイルス対策に、ノートンを毎日チェック、スキャンディスク、デフラグなどの簡単なメンテナンスもしています。 イベントビューアにも、警告が連続出ているような形跡もありません。 原因は何でしょうか? また、どうすれば解決しますでしょうか? お詳しい方、やさしく教えてくださると助かります。よろしくお願いします。

  • ウェブページが表示しない

     パソコンの電源を入れインターネットエクスプローラーを起動した際、「同エクスプローラーでこのページは表示できません」のメッセージがでます。診断後はページ表示します。  起動後1回でホームページが表示される方法を教えてください。

  • 履歴のページが表示できないんです。

    iMacを使っています。インターネットエクスプローラーでホームページをみた履歴はちゃんとのこっているのに、接続を切ったあとで履歴のページを表示させようとすると「指定されたページがみつかりません」とのコメントがでてきて、ページが表示されません。どうしてでしょうか?

  • ホームページの表示が真っ白?

    ホームページビルダーでつくったホームページが、インターネットエクスプローラー6.0で見ると真っ白でなにも表示されません。 全てではなく、数十ページ作ったうちの3ページだけです。 正常に表示されているページのHTMLと比べてみても特に問題はありません。 ソースを見るとちゃんとHTMLが書かれているのに、インターネットエクスプローラーでは表示されません。 サーバにアップしてもやはり表示されません。 ですが、違うパソコンから見ると正常に表示されるのです。 HTMLを確認しても問題ないし、原因が分かりません。 少し前に、インターネットエクスプローラーのホームの設定がMSNのサイトから変更できないというトラブルがありましたが現在は解決しています。 この問題がかんけいあるのでしょうか。 ウイルスまたはスパイウェアーのような感じがするのですが、わかりません。 詳しい方がいらっしゃいましたらアドバイスよろしくお願いします。 OSはウインドウズXPPROのサービスパック2 セキュリティソフトはノートンのインターネットセキュリティ2006です。

  • 各ブラウザの表示について(文字の大きさ)

    代表的なブラウザとしてインターネットエクスプローラ(以下、IE)、 ネットスケープナビゲーター(以下、NN)がありますが、 ホームページを作成した場合、IEとNNのデフォルトの文字の表示の大きさが違うため、苦労しています。 iモードやDC、また非GUI環境のブラウザは足切りするとして、 フォントの大きさを揃える良い方法はないでしょうか。 宜しくお願いします。

  • ページ更新の度に変わる画像を上部と下部の中央に表示させるには?

    アフィリエイトをやっておりまして、ページを表示するたびにバナーが変わるようにしたいと思っております。Googleで検索しましたところ下のようなJavaScriptを使うことが分かりました。ですがこれは<head>と</head>の間に書かなければなりませんよね?これをページ上部中央と、また下部中央に表示させたいのですが、何を加えればよろしいのでしょうか。また、各画像にリンクをつけるにはどのようにすればよろしいのでしょうか。よろしくおねがいします。 <SCRIPT LANGUAGE = "JavaScript"> myImageCnt = 15; myImage = new Array( "01.jpg", (途中省略) "15.jpg"); myRnd = Math.floor(Math.random()*myImageCnt); document.write("<img src='",myImage[myRnd],"' border='0' >"); </SCRIPT>

  • IE6で一部のページが表示されない

    インターネットエクスプローラの6.0なのですが、一部のページが表示されません。真っ白な画面で、エラーも表示されません。 IEで表示されなくてもネットスケープでは表示できます。なにか設定が悪いのでしょうか?? OSはWinXP-proです。詳細設定で[規定値に戻す]をしてみましたが、治りませんでした。 セキュリティーソフトはウイルスセキュリティー2005を使っています。