• ベストアンサー
  • 困ってます

apt-getのdebファイルをダウンロードしたい

会社での勉強目的で、VMwarePlayer2.5.5上でUbuntu8.0.4を動かしています。 Subversionをインストールしたくてapache2とsubversionのパッケージを apt-get installでインストールしたいんですが、 Ubuntu環境はネットワークに繋がないというルールになっているので、 パッケージを自動ダウンロードできないでいます。 欲しいパッケージのdebファイルをUbuntu内にコピーすれば良いというところまでは分かったのですが、 どこにdebファイルがあるのか教えていただきたいと思います。 よろしくお願いします。

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数1241
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1

Ubuntu8.0.4(hardy)であれば、下記からパッケージアーカイブが入手可能です。 http://packages.ubuntu.com/ apache2であれば下記ですね。 http://packages.ubuntu.com/hardy/web/apache2 subversionはこちら。 http://packages.ubuntu.com/hardy/devel/subversion 但し、apache2だけではなく関連するパッケージも大量(?)にインストールする必要があるので注意が必要です。 以上、ご参考まで。

共感・感謝の気持ちを伝えよう!

質問者からの補足

回答していただきありがとうございます。 リンク先からダウンロードしたファイル内にdebファイル(拡張子がdeb)が見つからなかったのですが、 apt-get installで、これらをインストールできるのでしょうか? 基本的なことが分かっていないのでこれから調べるつもりですが、 ヒントなどあればお願いしたいと思います。

関連するQ&A

  • apt-getについて

    apt-getについて Ubuntuを使い始めたばかりのものです。 UbuntuにGitというソフトウェアをソースからインストールしたいと思っています。 Gitの書籍によると、次のコマンドを実行して、必要なパッケージをすべてインストールするように記載されています。 $ sudo apt-get build-dep git-core また、パッケージをインストールする時に、次のように apt-get(aptitude?) install を利用する場合があると思います。 $ sudo apt-get install mailutils パッケージをインストール場合で、 "apt-get install"とinstallなしの"apt-get"を利用する場合がありますが、 何が違い、どのように使い分けるのでしょうか?

  • LinuxのApacheについて教えてください

    Apache2のインストールを検索してみました。 centOSでは、「yum -y install httpd」などとなっていて、パッケージが「httpd」のようです。 ubuntuでは、「apt install apache2」などとなっていて、パッケージが「apache2」のようです。 この「httpd」と「apache2」はまったく別物なのでしょうか? 尚、centOSの「httpd」がApacheであることは理解してます。

  • apt-get 失敗

    久しぶりに使用するマシンで、 apt-get でyacc, m4などをインストールしようとしているのですが、 apt-get install m4 としても 404 Not Found のエラーがでます。 よくみると、m4_1.4.10-0ubuntu2_amd64.deb というファイルを取得しようとしていますが、 接続先のサーバーには、上記の名前のファイルは存在せず、 m4_1.4.10-1_amd64.deb というものならあります。 apt-get upgrade や apt-get update を行ってみたものの やはり、同様に Not Found エラーが多発します。 以前は update 等はできていたのですが、久しぶりにおこなったら失敗するようになっていました。このような場合はどのように対処すればよいのでしょうか? マシンは OS : Ubuntu 7.10 CPU: Intel core 2 quad Q6600 Memory: 4Gb

その他の回答 (1)

  • 回答No.2
  • vaidurya
  • ベストアンサー率45% (2710/5975)

8.0.4なんてバージョンはありませんけどね。 8.04LTSのリポジトリーの現状は知りませんが… 正常に機能するのであれば… 自宅のPCなどに8.04LTSの環境を別途作って そこで追加インストールをした上で /var/cache/apt/archives/の中身を 全部外付けHDDなどにコピーして持ち込むのが手っ取り早く確実な手順だと思います。 Windowsに比べると、Linuxでは配布パッケージ再構築の自由があるため 依存関係を補うことも、dpkgやaptの重要な役割として機能しています。 ですから、ある一つのパッケージを持ってきても 依存関係のために、別のパッケージが必要という状況もよくあります。 そのくりかえしで、何度も作業する必要が生じるかもしれません。 aptでは前述のディレクトリーにあるパッケージについては そこから読みだしてくるので、ネットワークにつながっていなくてもインストールができます。 ただし、そのためにはaptのリポジトリーの情報も更新しないとうまく機能しないはずです。 ですから、たぶん/var/cache/apt/pkgcache.binもコピーしてやる必要があると思っています。 ただ、apt-get updateによって、どのファイルが変更されるのかは把握していません。 pkgcache.binがそれだと思っていますが、実践したことが無いのでわかりません。 archivesディレクトリーのファイルをコピーしてインストールするという運用は LANにつながっていないPCを、USBアダプターでインターネットにつなげた状態で ダウンロードファイルを抑えつつupgradeするために、何度か使ったことがあります。 依存関係は、実際には満たしていなくても、強制インストールすれば動くこともあります。 ただ、異常動作の原因特定に手間取る原因にもなるので 依存関係にあるパッケージはすべてダウンロードし導入するのが基本です。 また、サーバー版としては8.04LTSもサポート中ですが 10.04LTSか12.04LTSに切り替えるほうが より現代的な学習ができるはずです。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

回答いただきありがとうございます。 >/var/cache/apt/archives/の中身を >全部外付けHDDなどにコピーして持ち込むのが手っ取り早く確実な手順だと思います。 こんな方法もあるんですね。 後で試して見ます。

関連するQ&A

  • apt-get install apache2

    Debianにapache2をインストールしてみたいのですが KURO-BOX:~# apt-cache search apache apache - Versatile, high-performance HTTP server apache-common - Support files for all Apache webservers apache-dev - Apache webserver development kit ・ ・ パッケージのapache2は存在しないようです。 KURO-BOX:~# apt-cache search apache2      # apache2のapt-getコマンドでのインストールの準備はなされていないのでしょうか?

  • apt-getで特定のバージョンをインストール

    [質問] ubuntu16.04のapt-get install nodejs=6.9.0-1nodesource1で、古いバージョンのnodejsをインストールするには、どのようにしたらよいでしょうか。 (dpkg -i nodejs.deb、PPAリポジトリを追加、nvm,nodebrew等のバージョン管理ツールを使わず、公式サイトのリポジトリからapt-get installする方法でお願いします。) [背景] curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash - sudo apt-get update sudo apt-get install nodejs=6.9.0-1nodesource1 では、インストールできませんでした。 sources.list先にhttps://deb.nodesource.com/node_6.x/pool/main/n/nodejs/nodejs_6.9.0-1nodesource1~xenial1_amd64.deb はありますが、 https://deb.nodesource.com/node_6.x/dists/xenial/main/binary-amd64/Packages に Version: 6.9.0-1nodesource1~xenial1 の記載がないので、apt-getでインストールできないと思います。 (postgresの場合は、 http://apt.postgresql.org/pub/repos/apt/dists/xenial-pgdg/main/binary-amd64/Packages に Package: postgresql-9.4 Version: 9.4.10-1.pgdg16.04+1 の記載があり、下記で古いバージョンのpostgresql-9.4はインストールできました。 sudo apt-get update sudo apt-get install postgresql-9.4 ) sources.listをfile:/にして、ローカルにdeb,Packages,Sources,Releaseを配置して、apt-get installで古いバージョンをインストールできましたが、 特定バージョンのPackages,Sources,Releaseのテキストファイルがないと、この方法ができません。 (リポジトリ内に古いPackages,Sources,Releaseのテキストファイルはありませんでした。) また、CentOSの場合は、下記で古いバージョンのnodejsがインストールできました。(yumとapt-getの仕組みの違いと思います。) curl --silent --location https://rpm.nodesource.com/setup_6.x | bash - yum --showduplicates list | grep nodejs yum install nodejs-6.9.0 よろしくお願いします。

  • apt install でキャッシュを残すには?

    apt install でキャッシュを残すにはどう設定すればよいでしょうか? ふだんは、アプリを追加するときは「ソフトウェア」や「Synaptic」からインストールしているのですが、きのう、archivesディレクトリ(/var/cache/apt/archives)をファイルマネージャで表示させ、ターミナルとを観察しつつ、ターミナルからいくつかのアプリをインストールしてみたところ、インストール終了後に「/var/cache/apt/archives」内のキャッシュファイル(.deb)が、自動で消去されました。 いままでは、「ソフトウェア」や「Synaptic」しか使っていなかったので、キャッシュは残るものだと思っていたので不思議に思い、ターミナルからいろいろなアプリをインストールしてみましたが、アプリの種類にかかわらず、インストール直後にキャッシュが削除されてしまう(archivesディレクトリがカラになる)ことが確認できました。 あらためて「ソフトウェア」や「Synaptic」を使っていくつかのアプリをインストールしてみましたが、インストール後も、archivesディレクトリ内にはキャッシュファイル(deb)が残りました。 そこで質問なのですが、 ・アプリを、ターミナルから「apt install」でインストールした場合、インストール直後にキャッシュファイルが削除されてしまうのは、Ubuntuの仕様なのでしょうか? ・また、ターミナルから「apt install」を実行したときに、キャッシュファイルを残しておくようにする設定方法、オプションはあるのでしょうか?。もしあるとしたら、どのような設定をするでしょうか? よろしくい願いいたします。

  • APTでcurl-develパッケージが見つからず

    Ubuntu 10.10にて、curl-develパッケージをAPTでインストールしようと、以下コマンドを実行したのですが、「E:パッケージ curl-devel が見つかりません」となってしまいます。  $ sudo apt-get install curl-devel パッケージ名など、どこか間違っているのでしょうか? 間違っているとしたら、正しいインストール方法をご教示願います。

  • apt-get install でのインストール先

    基本的な質問ですが、 apt-get install でインストールしたアプリケーションのインストール先(設定ファイル、ドキュメント、実行ファイルなどそれぞれ)を調べる方法はないでしょうか? (実行ファイルは、たとえば which emacs などとすれば分かる場合がありますが・・・) apt-cache show でパッケージの情報が見れると書いてあったので試しに apt-cache show emacs としたのですが、何も出てきません!

  • 玄箱をdebian化後aptが最新にならない

    玄箱をdebin化したのですがapt-updateしても apacheは1.3 perlは5.6 phpは4 mysqlは4 など、旧バージョンはあるのですがapache2、perl5.8などがみあたりません。 どうすればこのような最新のaptをインストールすることができるのでしょうか? ご教授いただければ幸いです。

  • apt-get upgradeを時々やるべきでしょうか?

    apt-get upgradeを時々やるべきでしょうか? サーバでapt-get update/upgradeを時々やるべきでしょうか? Ubuntu Server を 認証サーバ&ファイルサーバとして使おうと思っています。 セキュリティーのためには、 # sudo apt-get update # sudo apt-get upgrade を時々やった方が良いとは思います。 しかし、update/upgrade をすると、インストール済みのパッケージの中で新しいバージョンが公開されているときは、最新バージョンをダウンロードしてインストールするのですよね? 自分が構築した認証、NSF等の設定が upgrade で壊れてしまわないか心配です。 質問ですが ● apt-get update/upgrade で、システムの設定ファイルが上書きされる心配はしなくて大丈夫なものでしょうか? ● みなさんはサーバのセキュリティアップデートはどうなさっているでしょうか?

  • Linux初心者です。

    Linux初心者です。 ubuntuインストール時に入っていたapache2を色々カスタマイズしていたのですが、 途中で分からなくなり/etc/apache2を削除後、再インストールをして最初からやり直そうと思いました。 ですがSynapticパッケージマネージャでインストールすると、apache2のフォルダは出来るのですが、 中身を見るとconf.dなどのフォルダが5つとhttpd.confファイルがひとつあり、 いずれも中身がありませんでした。 元々あったapache2.confなどのファイルはどのようにすれば初期状態に復元することが可能でしょうか?

  • 「apt-get install wget」の実行でエラーが発生

    「apt-get install wget」を実行すると下記のエラーメッセージが 表示されます。 --------------------------------------------------------------- エラー http://ports.ubuntu.com jaunty/main wget 1.11.4-2ubuntu1 'ports.ubuntu.com' を解決できませんでした http://ports.ubuntu.com/pool/main/w/wget/wget_1.11.4-2ubuntu1_armel.deb の取得に失敗しました 'ports.ubuntu.com' を解決できませんでした E: いくつかのアーカイブが取得できません。apt-get update を実行するか --fix-missing オプションを付け て試してみてください。 ----------------------------------------------------------- 解決方法を教えて下さい。宜しくお願いいたします。

  • ubuntu でのredmineインストール

    ubuntu 13.10 でredmineをインストールしようとしていますが、うまくいきません 以下のURLに沿ってインストールを進めています。 http://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_in_Ubuntu apache2とmysqlのインストールまではうまくいきましたが、肝心のredmineのインストールを試すと以下のようなエラーが出てしまいます。 ================================ xxxxxi@xxxxxxx:~$ sudo apt-get install redmine パッケージリストを読み込んでいます... 完了 依存関係ツリーを作成しています 状態情報を読み取っています... 完了 インストールすることができないパッケージがありました。おそらく、あり得 ない状況を要求したか、(不安定版ディストリビューションを使用しているの であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移 動されていないことが考えられます。 以下の情報がこの問題を解決するために役立つかもしれません: 以下のパッケージには満たせない依存関係があります: redmine : 依存: ruby-railties-3.2 (>= 3.2.16-1~) しかし、インストールされようとしていません E: 問題を解決することができません。壊れた変更禁止パッケージがあります。 ================================ 上記のエラーでの依存関係の解消を図るために、 $ sudo apt-get -f install や $ sudo apt-get install ruby-railties-3.2 などをためしてもうまくいきません。 ググってみても手詰まってきましたので、アドバイス・解決方法をいただけませんでしょうか