• ベストアンサー
  • 暇なときにでも

PHP+Linuxについて質問です

現在CentOS+PHP5.2.1の構成でプログラムを組んでいるのですが、 今までwindowsローカルにxamppを入れて組んでいたので、Linuxに 環境移動しなければならなくなりました。 pearやらgdなどはすべてxamppがやってくれてたのを自分でやらなければなりません(当然ですがw) で、smartyや、pearのライブラリまでは入れ終わったのですが、zip関数を使うのにpecl系のzipライブラリの入れ方がどうしてもわかりません。 php.iniを見た限りでは、/etc/php.d/にある各extension用のiniファイルを読んで、/php/module/野中にあるsoファイルをextensionとして見に行ってるみたいです。 なのでxamppで使っていたextension_zip.dllファイルを/php/module/ に移してphp.iniに、extension=php_zip.dll と苦し紛れに書き込んでリコンパイルしてみましたが、やはり意味なかったらしく。 普段使っているのがdllファイルなのに対し、今回はsoファイルなので、どうすればいいか検討がつきません。どうやったらこれをインストールできれば教えていただければと思います。 ちなみに、私が使いたいと思っているのは、こちら↓ http://php.tonnikala.org/manual/ja/ref.zip.php です。 よろしくお願いします。

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数147
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.2
  • tecinfo
  • ベストアンサー率52% (32/61)

再コンパイル可能なら、configure時にオプションを付けて、 ./configure --enable-zip --他のオプション とするか、 あるいは、Pecl経由なら % pecl install zip じゃダメなのかしら?

参考URL:
http://php.tonnikala.org/manual/ja/install.pecl.pear.php

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • php.iniでどちらが正規かな!?

     現代版のXAMPP Control Panel v3.2.1 セットアップしました。  教本の内容は古くて、xampp-win32-1.7.3.exeとの内容で書かれています。    すると、php.iniのプログラムの中身と教本と書いてあることが違います。    「php.ini」ファイルで795行目あたりですが   ; Windows: "\path1;\path2" include_path=".;C:\xampp\php\PEAR" C:\xampp\php\includes" 以上のプログラムで\PEAR"の最後に"ダブルクォーテーション(") で区切られています。   しかし、教本には \PEAR;の最後はセミコロン(;)にと印刷されています。 セットアップしたての(")か、教本の(;) どちらが正規でしょうか  実際のphp.iniが以下で見れます。 最後のアドレスかは、php.iniをZIPで圧縮したファイルが取れます。 参考にされてください。  http://homepage3.nifty.com/mtaiyo/php.ini http://homepage3.nifty.com/mtaiyo/php.zip

    • ベストアンサー
    • MySQL
  • ライブラリをプログラムで追加する方法

    WindowsXPのPHP5(xampp)にて、php.iniではなく、プログラムから、ライブラリの追加をしたいのですが、「ini_set('extension', '../xxx/xxx.dll');」と書いてもうライブラリを見つけられないようです。 書き方を間違えていますでしょうか? また、良い方法はありますか?

    • ベストアンサー
    • PHP
  • ★xamppでGDを使いたいです。

    ★xamppでGDを使いたいです。 (※ Windowsへのインストール) \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ まずはXAMPP[バージョン:PHP: 5.3.1]をインストールして、phpなどいろいろなものが一括インストールされる。 C:\xampp 内のxampp-controlでApacheを起動する。 インターネットエクスプローラでXAMPPが正しくインストールされていれば、 http://localhost/xampp/ のページが表示される。 ↓階層はこんな感じです。 C:\xampp\htdocs\index.html C:\xampp\htdocs\index.php C:\xampp\htdocs\xampp\???(PHPファイルやフォルダ C:\xampp\apache C:\xampp\php ・ ・ ・ \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ C:\xampp\phpの場所にphp.ini(構成設定)があります。 ↓内容 (略) extension=php_bz2.dll ;extension=php_curl.dll ;extension=php_dba.dll ;extension=php_dblib.dll extension=php_mbstring.dll extension=php_exif.dll extension=php_fileinfo.dll extension=php_gd2.dll   //コメントは最初からありませんでした。 extension=php_gettext.dll ;extension=php_gmp.dll extension=php_imap.dll (略) php.ini の場所は↓の通りです。 Loaded Configuration File | C:\xampp\php\php.ini \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ http://tsuttayo.jpn.org/php/gd/ このサイトで、 GDが利用できるか確認 phpinfo()で「GD Support」が「enabled」になっているか確認してください。こうなっていればGDが利用できます。 とありますが、「GD Support」が見当たりません・・・ \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ 不備な点があると思うので「ここはどうなっていますか」などの回答もお願いします。

    • ベストアンサー
    • PHP

その他の回答 (1)

  • 回答No.1

完全に違うOSですから、windowsのdllファイルはそのままLinuxで使えないです。やはりLinux系OS用のものを探せばよいと思います。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • xampp phpエラーについてです。

    PHP初心者ですがご回答宜しくお願い致します。 xamppをインストールした後、smartyをインストールし、「php.ini」ファイルをinclude_path = ".;d:¥php¥includes"からinclude_path = ".;C:\xampp\php\includes;C:¥Smarty¥libs"に書き換えて保存。その後xamppコントロールパネルからapacheとmysqlを起動させるとphpエラーとして syntax error, unexpected TC_LABEL, expecting '=' in C:\xampp\php\php.ini on line 1 とエラーが出ました。 調べてみましたがわかりませんでした・・・。 原因解明の手掛かりでもお教え頂きたく思います。 因みに、環境はOS Windows7 xampp、smartyは現在最新のものです。 ファイルを書き換える前は普通に作動してました。 お手数ですが、何卒よろしくお願い致します。

    • 締切済み
    • PHP
  • PEARでrequestする方法

    PEARのインストールを終え pere listで確認をしたのですが requestでしていた場所のphpをうまく読み込んでくれません。 ソースでは ini_set('include_path', ".:/PEAR"); require( "Cache.php" ); require( "Services/AmazonECS4.php" ); とあります 実際のファイルは C:\xampp\php\PEAR\PEAR にあります。 php.iniの;extension=の;をはずしたりしないといけないのでしょうか?

    • 締切済み
    • PHP
  • php.iniの設定 

    php.iniの設定が上手くいきません。 環境は windowsXp php5.0.5 mysqlserver5 php.iniはC\windowsフォルダ に入れています。 php5ts.dllもsystem32に入れています。 php.iniファイルの extension系の";" は参考書通りにはずしています。 extension=php_mysql.dllが有効にならず。 mysql サポートが enabledになりません。 お答えいただけましたら幸いです。

    • 締切済み
    • PHP
  • MySQL、php.ini の設定

    PHP、勉強中の者です。 参考書を見て、MySQLをインストールしました。(インストールはOKのようです。) php.iniの設定で「;extension=php_mysql.dll」を「extension=php_mysql.dll」に変更しましたが、<?php phpindo() ?>でMySQLの確認ができません。 他にも設定しなければいけないところがあるのでしょうか? なお、良く覚えていませんが、.iniのファイルは簡易版?をコピーしてます。(php.ini-distでしたっけ?)

    • ベストアンサー
    • PHP
  • PHPグラフ作成について

    今PHPでGDを使い円グラフを作成しようとしていますが うまくいきません. 環境はwindowsで,PHPversion 5.2.3です. GDを使うためには, PHP.iniの extension=php_gd2.dllの行からコメントをはずして Apacheを再起動すると本に書いてありましたので, PHP.iniの extension=php_gd2.dll extension=php_gettext.dll extension=php_gmp.dll extension=php_ifx.dll extension=php_imap.dll extension=php_interbase.dll extension=php_ldap.dll extension=php_mbstring.dll extension_dir=C:\program Files\PHP\ext extension=php_mcrypt.dll extension=php_mhash.dll extension=php_mime_magic.dll extension=php_ming.dll extension=php_msql.dll extension=php_mssql.dll extension=php_mysql.dll extension=php_mysqli.dll extension=php_oci8.dll extension=php_openssl.dll extension=php_pdo_firebird.dll extension=php_pdo_mssql.dll extension=php_pdo_mysql.dll extension=php_pdo_oci.dll extension=php_pdo_oci8.dll extension=php_pdo_odbc.dll extension=php_pdo_pgsql.dll extension=php_pgsql.dll extension=php_pspell.dll extension=php_shmop.dll extension=php_snmp.dll extension=php_soap.dll extension=php_sockets.dll extension=php_pdo.dll extension=php_pdo_sqlite.dll extension=php_sqlite.dll extension=php_sybase_ct.dll extension=php_tidy.dll extension=php_xmlrpc.dll extension=php_xsl.dll extension=php_zip.dll のコメントをはずし, Apacheをrestartしました. しかし,グラフをつくるプログラムを書いて実行すると, Warning: require_once(jpgraph/jpgraph.php) [function.require-once]: failed to open stream: No such file or directory in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\prog\traning\piegraph.php on line 11 Fatal error: require_once() [function.require]: Failed opening required 'jpgraph/jpgraph.php' (include_path='.;C:\Program Files\PHP\pear') in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\prog\traning\piegraph.php on line 11 のようなエラーが出てしまいます. これはGDがきちんとインストールされていないから, このようなエラーがでるのでしょうか? もしそうであればGDをインストールする方法をご存知の方や 解決方法をご存知の方いらっしゃいましたら いらっしゃいましたら教えていただけないでしょうか? お願いします.

    • 締切済み
    • PHP
  • PHP5.3.0のSQlite関数に必要なDLL

    以前PHP5.0.4で動作していたSQLiteを利用したプログラムが Apacheでエラーが返ってきます。 現在の環境:PHP5.3.0 Apache2.2 php.iniに以下のようにつけくわえてもだめでした。 extension=php_pdo.dll extension=php_sqlite.dll 両方、5.3.0のextディレクトリにはなかったので、どっかから ダウンしましたが、このdllがいけないのか、php.iniの extensionが間違っているのかわからないという状態です。 ちなみにphp_pdo_sqlite.dllというファイルは、5.3.0のextフォルダに 最初からあったみたいなので、 extension=php_pdo.dll extension=php_pdo_sqlite.dll にしてみたのですが、これでもsqlite_open()関数をコールするところで、undefined function call というエラーがApacheから返ってきます。 いったいどうすればいいのでしょうか。

  • いつもお世話になっております。

    いつもお世話になっております。 小生、只今WindowsXPSP3上でXAMPP1.7.1を使用し、PHPを勉強しているPHP初心者です。 今回皆様にご質問させて頂きたい内容はXAMPPにSmatyをインストールするべきかしないべきかです。 私の環境でXAMPPのフォルダ内で「smarty」というキーワードを入れ、検索してみたところ、以下のファイルが検出されました。 smarty ディレクトリ     C:\xampp\htdocs\xoops\class Smarty.class.php       C:\xampp\htdocs\xoops\class\smarty Smarty_Compiler.class.php   C:\xampp\htdocs\xoops\class\smarty Smarty-2.6.0 ディレクトリ  C:\xampp\php\PEAR\PhpDocumentor\phpDocumentor core.assign_smarty_interface.php C:\xampp\htdocs\xoops\class\smarty\core core.smarty_include_php.php  C:\xampp\htdocs\xoops\class\smarty\core SmartyTask.php C:\xampp\php\PEAR\phing\tasks\ext smarty ディレクトリ C:\xampp\htdocs\extras\extra_languages\pt_utf8\html\class Smarty ディレクトリ C:\xampp\php\PEAR\PhpDocumentor\phpDocumentor\Converters\HTML Smarty.class.php C:\xampp\php\PEAR\PhpDocumentor\phpDocumentor\Smarty-2.6.0\libs Smarty_Compiler.class.php C:\xampp\php\PEAR\PhpDocumentor\phpDocumentor\Smarty-2.6.0\libs HTMLSmartyConverter.inc C:\xampp\php\PEAR\PhpDocumentor\phpDocumentor\Converters\HTML\Smarty core.assign_smarty_interface.php C:\xampp\php\PEAR\PhpDocumentor\phpDocumentor\Smarty-2.6.0\libs\core core.smarty_include_php.php C:\xampp\php\PEAR\PhpDocumentor\phpDocumentor\Smarty-2.6.0\libs\core 以上のファイルがあっても、XAMPPにSmartyをインストールしなければ、Smartyの機能は使えないのでしょうか?? また、上記の設定(Smartyをインストールしていない状態)でC:\xampp\sample\templatesフォルダを作成し、以下の.tplファイルを作成しました。 -----.tplファイル------ <html> <head> <title>smatyのテスト</title> </head> <body> ようこそ、($name)さん<br/> Hello World! </body> </html> そしてその上位フォルダにindex.phpを作成しました。 -----index.php----- <?php require_once "Smarty.class.php"; $smarty = new Smarty; $smarty->assign('name', '桃太郎'); $smarty->;display('index.tpl'); ?> 上記の2ファイルを作成し、http://localhost/sampleにアクセスしても、 「Parse error: parse error, expecting `T_STRING' or `T_VARIABLE' or `'{'' or `'$'' in C:\xampp\htdocs\sample\index.php on line 6」のエラーが出現し、正確に表示されません。 お忙しい中、大変申し訳ございませんが、先輩方アドバイス宜しくお願い致します。

    • ベストアンサー
    • PHP
  • smartyの設定 include?path以下の設定がわからない

    独学でPHPを学んでいます。 PHPの基本はひととおり理解はできました。 開発環境・最新のXAMPP導入。 windows、OSはVISTA smartyをインストールしましたが、その設定につまずいています。 Smarty.class.phpが存在するパス(D:\xampp\libs)をphp.iniファイル447行目を下記のように設定しましたが、うまくいきません include_path=D:\xampp\libs\ xamppフォルダの下にlibsフォルダを入れたので上のパス指定で問題ないと思うのですが、どこが間違っているのでしょうか。 ちなみに、libs以下の\も不要だろうと思い、消したりして試してみましたが、結果は同じ。下記のように表示がなされます。 Warning: require_once(local/xampp/libs/Smarty.class.php) [function.require-once]: failed to open stream: No such file or directory in D:\xampp\htdocs\lesson\smarty1.php on line 3 Fatal error: require_once() [function.require]: Failed opening required 'local/xampp/libs/Smarty.class.php' (include_path='.;D:\xampp\php\pear\') in D:\xampp\htdocs\lesson\smarty1.php on line 3 上の文章ですが、3行目後半”Smarty.class.php' (include_path='.;D:\xampp\php\pear\')”の部分ですが、php.iniからinclude_pathを変更したりしているのですが、一向に表示が変わりません。 もしかしたらphp.iniファイルは二つあったりするのでしょうか。 php.iniのファイルはPHPフォルダに入っているものでよろしいですよね? もちろんアパッチは再起動させています。 なのにできません・ あと、ロジックファイルの require _once()の()内はSmarty.class.phpだけでもよろしいのでしょうか。 もう悩みすぎて頭がおかしくなりそうですね。 ちなみにsmartyがなくても、アプリケーション開発に支障はありませんでしょうか。 あくまで個人で趣味の範囲でアプリケーションを作成したいと感じています。

    • ベストアンサー
    • PHP
  • windowsからlinuxに移行php動作

    現在、windowsサーバーからlinuxサーバーに移行しようとしています。 実際にlinux上でPDOを利用してDB接続を行いたいと思っていますが、 以下のようなエラーがでています。 ■エラー内容 PHP Fatal error: Uncaught exception 'PDOException' with message 'could not find driver' PDOモジュールはインストール済です。(以下、php -mコマンド実施) [PHP Modules] ctype curl date filter gd gettext libxml mbstring mysql mysqli openssl pcre PDO Reflection session SimpleXML SPL standard zip zlib [Zend Modules] ■/usr/local/php/etc/extensions.iniの設定 ※「;」はコメント ;Unix Extensions extension=spl.so extension=simplexml.so extension=session.so ;extension=iconv.so ;extension=bcmath.so ;extension=bz2.so ;extension=calendar.so ;extension=chasen.so extension=ctype.so extension=curl.so ;extension=dba.so ;extension=dbase.so ;extension=dom.so ;extension=exif.so ;extension=ftp.so extension=gd.so extension=gettext.so ;extension=gmp.so ;extension=hash.so ;extension=imap.so ;extension=json.so ;extension=kakasi.so extension=mbstring.so ;extension=mcrypt.so ;extension=mhash.so extension=mysql.so extension=mysqli.so ;extension=namazu.so ;extension=oci8.so extension=openssl.so extension=pdo.so extension=pdo_mysql.so ;extension=pdo_oci.so ;extension=pdo_pgsql.so ;extension=pdo_sqlite.so ;extension=pgsql.so ;extension=posix.so ;extension=pspell.so ;extension=soap.so ;extension=sockets.so ;extension=sqlite.so ;extension=tokenizer.so ;extension=xml.so ;extension=xmlreader.so ;extension=xmlrpc.so ;extension=xmlwriter.so ;extension=xsl.so extension=zip.so extension=zlib.so ちなみにですが、php.iniの方は何か設定する必要があるのでしょうか? 大変申し訳ありませんが、 ご教授の方、宜しくお願い致します。

    • 締切済み
    • PHP
  • Call to undefined function mysql_connect() が出て、つながりません

    お世話になります。 先日PHPをはじめたばかりの初心者です。 xamppを使用せず、個別にPHPとMySQLをインストールしたのですが、 表題のエラーが出て、つながりません。ネットで調べてみましたが、 php.iniというものもどこにもなく、それに似たphp.ini-distという ファイルも、extension=php_mysql.dll、extension=php_mysqli.dllの 二行のコメントをはずすなどをやってみたのですが、いまだに つながりません。 ユーザ名やパスワードも、何度も確認しました。 原因と対策をお教えください。 尚、PHPは5.2.12、MySQLは5.1.42です。 以上、宜しくお願いいたします。

    • 締切済み
    • PHP