• ベストアンサー
  • 困ってます

sambaについて

Linux初心者です。 Redhat7.2にsambaをインストールしました。 sambaは samba-2.2.2.ja-10.i386.rpm を ftp://ftp.samba.gr.jp/ からダウンロードしました。 # rpm -ivh samba-2.2.2.ja-10.i386.rpm でインストール後、 # rpm -qa | grep samba とコマンドをうつと samba-2.2.2.ja-10 しか表示されません。 普通、samba-client とか samba-common も表示されるはずなのでは? 表示されないという事は、インストールされてないという事なのでしょうか? 以前、雑誌の付録CDからsambaをインストールしたときは、表示されていたと思います。(バージョン低かったと思いますが。。) もろもろの設定をすませると、windowsマシンからLinuxのディレクトリに、ちゃんと接続できました。SWATも接続できました。 と、言う事は、samba-client とか samba-common は不要なのでしょうか? 一体、このふたつは何なのでしょうか? あと、samba-swat っていうのも聞いたことがあるような。。。 でも、SWATつかえるしな~。。。 こんなヘンな質問で申し訳ありませんが、わかる方いれば、ぜひ教えてください。 よろしくお願いします。

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数207
  • ありがとう数2

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.2

>samba-client と samba-common の役割や、単品でのインストール方法 >など、補足していただければうれしいです。 samba-client は smbclient をインストールするのでしょう。のでクライアント系のプログラムをインストールするもの。 samba-common は smbd nmbd をインストールするのでしょう。のでサーバ系のプログラムをインストールするもの。 samba-2.2.2.ja-10.i386.rpm では単品のインストールは出来ません。 自分で samba-client samba-common の rpm を作成するば出来るでしょう。 rpm の作り方は調べてください。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ありがとうございました。 もう少し勉強してみます。

関連するQ&A

  • samba インストール方法お願いします

    環境 Fedora 2 sambaをインストールしたいのですが手順おねがいします。 まず自分のシステムへ #rpm -qa samba と打つと何も表示しなかったのではいってないため FTPサーバーより samba-3.0.2a-6.FC1.i386.rpm samba-common-3.0.2a-6.FC1.i386.rpm を/home/user へダウンロード。 [root@localhost usre]# rpm -ivh samba-common-3.0.2a-6.FC1.i386.rpm はOKだったのですがつぎに [root@localhost usre]# rpm -ivh samba-3.0.2a-6.FC1.i386.rpm 実行すると エラー: Failed dependencies: samba-common = 3.0.2a is needed by samba-3.0.2a-6.FC1 とでます、解決方法おねがいします。

  • Sambaが非常に不安定です。

    CentOS4.4を使っています。 sambaは以下のようなものを使っています。 (CentOSのパッケージでは最新と思います) #rpm -qa|grep samba samba-swat-3.0.10-1.4E.9 samba-3.0.10-1.4E.9 system-config-samba-1.2.21-1 samba-common-3.0.10-1.4E.9 samba-client-3.0.10-1.4E.9 sambaで共有ディレクトリにファイルやフォルダを置き、 WindowsXPからアクセスするのですが、頻繁にエクスプローラーが 応答なしになってしまいます。サーバーの負荷は [root@linux ~]# uptime 12:51:07 up 8 days, 11:31, 4 users, load average: 0.00, 0.01, 0.00と高くありません。 どのあたりに問題がありそうでしょうか?

  • ftp で samba のrpmパッケージを入手したいのですが不明な点があります

    centOS5を利用しています。 sambaのrpmパッケージを入手したいのですが http://www.samba.gr.jp/project/samba-ja/download_2.2.html のページの情報を参照し ftp で ftp.ring.gr.jp にアクセスし匿名ユーザでログインするところまでは 成功しました。 しかし、肝心な samba-2.2.11.ja-1.rh60.i386.rpm が見つかりません。 ここからファイルを入手するまでの手順をご紹介いただけませんでしょうか? よろしくお願い致します。

その他の回答 (1)

  • 回答No.1

samba-2.2.2.ja-10.i386.rpm はすべて含んだ物でしょう。 RedHat とかは必要な物のみインストール出来るように 別々にしてあるだけです。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

回答ありがとうございます。 ちょっと意味がわからないのですが、要するにsamba-2.2.2.ja-10.i386.rpm には samba-client とか samba-common も含んでる、ということですよね。 セット物みたいなものなのかな? じゃあ、単品でインストールするやり方もあるのでしょうか!? うーん。。。 よろしければもう少し詳しく教えてください。 samba-client と samba-common の役割や、単品でのインストール方法 など、補足していただければうれしいです。

関連するQ&A

  • redhat系Linuxで、Sambaをインストールしたいのですが、、

    redhat系Linuxで、Sambaをインストールしたいのですが、、、 以下の様なエラーが出てしまい、libcom_err.so.3をダウンロードしようとしてもできません。。。このエラーの意味が分かりません。どなたか詳しい方がいらっしゃいましたら、教えて頂けませんか? [root@abc /]# rpm -ivh samba-3.0.0-2iconv.i386.rpm エラー: 依存性の欠如: libcom_err.so.3 は samba-3.0.0-2iconv.i386 に必要とされています libiconv.so.2 は samba-3.0.0-2iconv.i386 に必要とされています liblber.so.2 は samba-3.0.0-2iconv.i386 に必要とされています libldap.so.2 は samba-3.0.0-2iconv.i386 に必要とされています libreadline.so.4 は samba-3.0.0-2iconv.i386 に必要とされています

  • SAMBAのSWATが起動できません。

    red hat 7.0にsambaをインストールしようとしています。 ftp.samba.orgからSamba2.0.9をダウンロードして、解凍した後、 sourceディレクトリー内で、 ./configure make make install のコマンドでsambaを所定のディレクトリに(/usr/local/samba)インストールしました。 /etc/servicesを確認すると、 以下のエントリがありました。 901/tcp しかしながら、 http://ホスト名:901/ でswatが起動しません。 日本sambaユーザ会などのホームページでも調べてみたのですが、決定的な解決方法は載っていませんでした。 http://begi.net/linux/reading/samba_begin/ http://www.a-yu.com/tools/swat.html http://www2s.biglobe.ne.jp/~maeda/vaio/samba.html http://www.pixy.ne.jp/~miyamae/tech/linux/samba_redhat.html 等のホームページによれば、 /etc/xinetd.d/ のディレクトリのswatファイルを編集すると説明されているのですが、swatファイル自体が存在しません。 解決策を教えていただきますよう宜しく御願いします。

  • Sambaのインストールについて

     今晩は。kennkennと言うものです。Sambaについて困っています。ただいまVine Linux2.1.5を使っています。パソコンはNECのValueStar NXです。よろしくお願いします。問題はSambaがインストールできません。一旦、もともとインストールされていたSamba(多分samba-commmonとsamba-clientだけでした。)をアンインストールしました。そして rpm -qa | grep samba として、Sambaがインストールされていないことを確かめました。そのあと、インターネットで最新のSambaをダウンロードした後、Sambaをsamba-common,samba-client,sambaの順でインストールしようとしたところ、samba-commonとsamba-clientは無事エラーは出ずにインストールできたのですが、sambaは次のような指示が出てインストールできませんでした。 #################################アーカイブの展開に失敗:cpio:不正なマジック 意味がわかりません。cpioはファイルの展開、圧縮に関するコマンドだと言うのは調べましたが、これでもよくわかりません。。解決法をご存知の方、どうか教えていただけないでしょうか。よろしくお願いします。

  • FreeBSDにSambaがインストールできません

    Linuxは詳しいのですがBSDはさっぱりです。 FreeBSD4.5へSambaをインストールしたいのですが ↓のリンクが切れていてパッケージを入手できません。 http://www.samba.gr.jp/project/samba-ja/download_2.2.html 又、BSDはパッケージをどうやってインストールすれば良いのでしょうか? 両刀使いの方がいらしたら教えてほしいのですが、 ソースからインストールする場合はLinuxと方法でいける同でしょうか?

  • さんばを復活する方法・・・

    http://www.okweb.ne.jp/kotaeru.php3?q=427686 で日本語版Sambaのインストールにトライしていたのですが・・・。 rpm -e Samba したまではよかったんです。 rpm -i samba-2.2.4-ja_1.0.rpm したときにsamba-common-2.2.7とconflictしてるとか言うので、 rpm -e samba-common してみました。 そのあと rpm -i samba-2.2.4-ja_1.0.rpm しましたが、まず根本的に package samba-2.2.4-ja_1.0 is for a different architecture らしい・・・。 ちゃんとRedhatのi686パッケージを選んできたのに・・・。 しようがないので元に戻そうと思い、2.2.7を入れようとしたら、samba-commonがないそうで・・・。 てっきり中に入ってるものだと思ったのに・・・。 こいつはもう復活できないのでしょうか? Sambaが死んだ現在、ファイルを取り入れる手段はないです。 Telnetしかできません。 CD-ROMもフロッピーもありません。 あとはコピーしたけどインストールのしかたが分からないpro-ftpくらいしか・・・。 ○ samba-commonを外部から持ってくる方法はないでしょうか? ○ それともまだ中に眠っている? ○ なんでpackage samba-2.2.4-ja_1.0 is for a different architectureなんでしょう? Samuel2はi686じゃないんでしょうか。 やっぱりlinuxは分かりません・・・。

  • ●経緯

    ●経緯 3年以上前にsambaをインストールしました。 しかし、うまくWindowsから参照できないので、このときは断念しました。 3年ぶりに、挑戦しようとしました。 3年も経っているので、sambaをバージョンアップしようとしました。 そこで、いまインストールしているsambaを削除(アンインストール)しようとしました。 しかし、うまく削除できませんでした。 ●うまくいかない症状 (1)インストールしているsambaを調べる。 コマンド:rpm -qa | grep samba (2)コマンドの出力内容 samba-libsmbclient-3.0.23d-0vl1.5 samba-client-3.0.23d-0vl1.5 samba-common-3.0.23d-0vl1.5 (3)コマンドで出力した内容を削除する rpm -e samba-libsmbclient-3.0.23d-0vl1.5 (*) rpm -e samba-client-3.0.23d-0vl1.5 rpm -e samba-common-3.0.23d-0vl1.5 (*) (*)はコマンド実行時にエラーになったコマンドです。 (4)エラーが発生とその内容(このエラーの解消方法を御教示願います) rpm -e samba-libsmbclient-3.0.23d-0vl1.5 エラー: 依存性の欠如: libsmbclient.so.0 は (インストール済み)gnome-cups-manager-0.31.0.20060307-0vl2.1.i386 に必要とされています libsmbclient.so.0 は (インストール済み)gnome-vfs2-smb-2.14.2-0vl4.i386 に必要とされています rpm -e samba-common-3.0.23d-0vl1.5 エラー: 依存性の欠如: samba-common = 3.0.23d-0vl1.5 は (インストール済み)samba-libsmbclient-3.0.23d-0vl1.5.i386 に必要とされています samba-common >= 3.0.7 は (インストール済み)gnome-vfs2-smb-2.14.2-0vl4.i386 に必要とされてい ます (5)その他(もう一つ質問があります) 上記のエラーなど気にしなくても、最新のsambaをインストールして、問題なく動作するのでしょうか? ●関連情報 バージョンなど、うる覚えなのです。しかし、調べられる範囲で調べました。 sambaバージョン:3.0.23 コマンド「rpm -qa | grep samba」で以下のように表示されたため、バージョンを判断しました。 samba-libsmbclient-3.0.23d-0vl1.5 samba-client-3.0.23d-0vl1.5 samba-common-3.0.23d-0vl1.5 Linux:Vine Linux バージョン:2.4 調べ方がわからないので、おそらく?と言ったレベルです。 長文の質問ですが、よろしくお願いします。

  • Vine LinuxでSanbaサーバーを使いたい

    Linux初心者です。 自宅で4台のPCをLAN接続してWindowsファイルを共有しています。(ブロードバンドルーター1台、スイッチングハブ1台) Sambaを使用しようと思いGnomeメニューをくまなく探したのですが見つからなかったのでネットでいろいろと調べましたらシェルでインストールされているか調査できると書いて有りましたので実行してみました。 Gnomeターミナルより rpm -qe | grep samba で samba-2.0.10_ja_1.2-0v013.26 とインストールされていることがわかりました。 次にSwatを起動させようと思ったのですがインストールされていないのではと思い、持っていたRed Hat 9のCDからSamba-swat-2.2.5-10.i386.rpmを右クリックrpmよりインストールでインストールしました。 日本Sambaユーザー協会ーSambaで始めるWindowsファイルサーバー入門のサイトで SWATを利用するには、Sambaが動いているサーバーのポート901番にWebブラウザでアクセスします。 http://samba.begi.net:901/ と書かれていましたので実行してみましたがつながりませんでした。 そこでもう一度調べると ★もしSWATにアクセスできない時には もしかすると、ダイアログが出てこず、SWATにアクセスできなかったかもしれません。もしその場合には、サーバーの設定を変更しなくてはいけません。サーバーマシンにrootでログインするか、telnetなどでサーバーに一般ユーザーとしてリモートログイン後にsuコマンドでスーパーユーザーとなり、まず/etc/inetd.confというファイルを編集します。ファイル中にある以下の行を探しましょう。 #swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat と書かれていましたがサーバーマシンとは何なのか分からず先に進めなくなってしまいました。 長々と書きましたが以上の内容を含み置きの上、ご教示お願いします。

  • RPMでインストールできない

     Red Hat Linux 6.2Jでrpm-3.0.4-0.48がインストールされています。以下のようにsambaを入れようとしたら、メジャー番号3以下のものしかサポートされていないとメッセージが出て、うまく動いてくれません。どのように対処すればいいでしょうか? # rpm -ivh samba-2.0.10-ja_1.2.i386.rpm only packages with major numbers <= 3 are supported by this version of RPM error: samba-2.0.10-ja_1.2.i386.rpm cannot be installed

  • CentOS5.4 でsamba-swat の日本語表示ができずに困っ

    CentOS5.4 でsamba-swat の日本語表示ができずに困っています。 初めまして、 CentOS5.4 にsamba を yum でインストールしました。 続いて、swat も yum -y install samba-swat でインストールしました。 WinXPのパソコンから、swatを開いたのですが、 「Welcome to SWAT!」の様に表示され、日本語になりません。 書籍などでは「ようこそ…」とかそれ以外の部分も日本語の表示になっています。 大変困っています。 どうやったら、swat の 表示を日本語にできますか。 インストールした samba のバージョンは 3.0.33 samba-swat のバージョンも 3.0.33です。 どうか、よろしくお願いします。

  • CentOS4付属のsamba3で日本語ファイル名を使用する場合の修正要否

    日本SAMBAユーザ会の下記記述によると  ftp://ftp.samba.gr.jp/pub/samba-jp/samba-3.0-ja/README.TXT >CP932やEUCJP-MSを利用するにはglibcもしくはlibiconvに修正を加える必要があり、 >Samba 3.0のRPMにはglibc版とlibiconv版の2つが存在します。 とあるのですが、サーバ側のファイル名にCP932やEUCJP-MSを使う場合、CentOS4に含まれているsamba-3.0.10にも修正を行う必要があるという事なのでしょうか。  http://ftp.yz.yamagata-u.ac.jp/pub/linux/centos/4.4/os/SRPMS/samba-3.0.10-1.4E.9.src.rpm またサーバ側ファイル名の文字コードをUTF8とする場合には上記の修正は必要ないという事なのでしょうか。