• ベストアンサー
  • 困ってます

CentOSのセキュリティパッチについて

CentOS6.9およびCentOS7を使用していますがyumコマンドで セキュリティパッチの適用はできなくなったのでしょうか? 以下のURLの”CentOS 7でyumからSecurityUpdateを行えるようにする” ”https://orebibou.com/2016/09/centos-7でyumからsecurityupdateを行えるようにする/#comment-166410” では、”CentOSのリポジトリではセキュリティアップデートの情報が提供されていないことが原因”と書いておりリポジトリの作成方法が紹介されています。 (記述通りやりましたが、うまく機能しませんでした…) 実際”yum --security check-update”では、パッチの一覧が表示されますが ”yum --security update”を実行すると ------------------------------ここから 読み込んだプラグイン:fastestmirror, langpacks Loading mirror speeds from cached hostfile * base: centos.usonyx.net * extras: centos.usonyx.net * nux-dextop: li.nux.ro * updates: centos.usonyx.net No packages needed for security; 0 packages available No packages marked for update ---------------------------------------ここまで とupdateが無いと返されます。 本当にセキュリティパッチの提供をやめてしまったのでしょうか? ご教示をお願いいたします。

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数1201
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • agehage
  • ベストアンサー率22% (1771/7818)

yum --security check-update での最後の一行になんて書いてあるでしょうか? 私の場合はずらずら出ますが最後は「No packages needed for security; 0 packages available」 つまりアップデートが必要なものはない、という意味で終わっています アップデートが必要なものがないのであればアップデートされません 補足お願いします

共感・感謝の気持ちを伝えよう!

質問者からの補足

早速の回答ありがとうございます。 最後の1行は、agehage さんの指摘通り ”No packages needed for security; 0 packages available” でした。 アップデートが必要なものがないという事なのでしょう。 納得がいかないのが、RedHatも使用しているのですが RedHat側では 毎日Red Hat Eratta Notificationが通知されてきています。 いくらCentOSのアップデート対応が遅いといってもこのような差が あるのもなのでしょうか?

関連するQ&A

  • centOS5.3 インストール後の設定 yum

    linuxに関して完全に初心者です。ネットワークの知識なんかもほぼありません。 今、 http://centossrv.com/centos5-init.shtml このサイトを参考にして設定を進めているのですが、いきなりつまづいてしましました。 (4)rootになれるユーザを管理者のみにする までは進めたのですが、(5)以降ができません。 色々といじってしまったかもしれなくてわけがわからない状態です…。最初どんな表示がでたのかは覚えていませんが、今現在は /etc/rc.d/init.d/yum-updatesd stop を実行すると -bash: /etc/rc.d/init.d/yum-updatesd: No such file or directory(そのようなファイルはフォルダにない?) と表示されます。 yum -y remove yum-updatesd を実行すると Loaded plugins: fastestmirror Setting up Remove Process No Match hor argument: yum-updatesd No Packages marked for removal と表示されます。 yum -y install yum-fastestmirror を実行すると Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=5&arch=i386&repo=os error was [Error 4] IOError: <urlopen error (-3, 'temporary failure in name resolution')> Error: Cannot find a valid baseurl for repo: base と表示されます。 yum -y update を実行すると yum -y install yum-fastestmirrorの時と同じ結果が返ってきます。 yum -y install yum-cron を実行すると yum -y install yum-fastestmirrorの時と同じ結果が返ってきます。 /etc/rc.d/init.d/yum-cron start を実行すると -bash: /etc/rc,d/init.d/yum-cron: No such file or directory と表示されます。 chkconfig yum-cron on を実行すると error reading information on service yum-cron: No such file or directory と表示されます。 インストールの時点のホスト名やIPアドレスに関しては、 http://centossrv.com/centos5.shtml と同じように設定しました。 こんな序盤でつまづくなんて恥ずかしいですが、全く意味がわからず本当に困っています…。そもそもパッケージというものが何なのかすら分かっていません。 こんな状態ですが、どうか助けていただけないでしょうか?よろしくお願いします。

  • Linux CentOS6.3 aptインストール

    先日CentOS 6.3 Final (kernel-2.6.32-279.11.1.el6.i686)を ノートPCにインストールしました yum仕様だったのでUbuntu等で使っていたapt-getコマンドをインストールしようとしたら (管理権限) # yum install apt Loaded plugins: fastestmirror, refresh-packagekit, security Loading mirror speeds from cached hostfile * base: ftp.iij.ad.jp * extras: ftp.iij.ad.jp * updates: ftp.iij.ad.jp Setting up Install Process No package apt available. Error: Nothing to do と出ました。どうすればaptをインストールできるでしょうか? 追加するリポジトリなど必要なことがあれば教えていただきたいです

  • CentOS5,2 / yum-cron を入れられない

    http://centossrv.com/ を参考にしつつ、 CentOS5.2を使って、yum-cron を入れようとしたのですが、以下のように入れられません、 どうすればいいのでしょうか? (別のレポジトリを追加する必要があるのでしょうか?・・・ただその方法は分かりません) なお、CentOS5.3からは、yum-cronが削除されたと、たまたま見かけたのですが、 特に問題ないのでしょうか?あるいは今後どのように対応すべきでしょうか? よろしくお願いします。 [root@centos52 var]# yum install yum-cron Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: www.ftp.ne.jp * updates: www.ftp.ne.jp * addons: www.ftp.ne.jp * extras: www.ftp.ne.jp Setting up Install Process Parsing package install arguments No package yum-cron available. Nothing to do [root@centos52 var]#

  • さくらVPS初期設定エラー

    yum updateを実行したところ、 エラーになりました。 現在は、お試し期間中のため、エラーになっているのでしょうか。 また、契約をしたばかりで、 なにもインストール等も行っていないところです。 ]# yum update Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile Error: File /var/cache/yum/x86_64/6/epel/metalink.xml is not XML

  • CentOS yumについて

    http://ftp.riken.jp/Linux/centos/5/isos/i386/ で"CentOS-5.3-i386-bin-DVD.iso"をインストールし http://centossrv.com/centos5-init.shtml を参照しながらOSをインストールしていますが yum -y install yum-fastestmirror ↑を実行したところ [root@host203 ~]# yum -y install yum-fastestmirror Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: ftp.nara.wide.ad.jp * updates: ftp.nara.wide.ad.jp * addons: ftp.nara.wide.ad.jp * extras: ftp.nara.wide.ad.jp Setting up Install Process Parsing package install arguments Package yum-fastestmirror-1.1.16-13.el5.centos.noarch already installed and latest version Nothing to do [root@host203 ~]# と表示されインストールが出来ません。 別の方法などがございましたら教えていただけないでしょうか? よろしくお願いいたします。

  • CentOS6.0でyum updateができない

    一ヶ月くらい前から、CentOS 6.0 でyum update すると、no packages marked for update 言われるのですか私だけですか?

  • インストールできないパッケージ?

    ログ監視ツールを入れたいので # yum -y install swatch と、入力したのですが [root@△△~]# yum -y install swatch Loaded plugins: fastestmirror, refresh-packagekit Loading mirror speeds from cached hostfile * base: rsync.atworks.co.jp * extras: rsync.atworks.co.jp * updates: rsync.atworks.co.jp Setting up Install Process No package swatch available. Error: Nothing to do と、出ます 一応 rpm -q swatch でチェックしましたが インストールされてません 以前、別のパッケージの時で解決した方法で yum remobe swatch をやりましたが これでも Loaded plugins: fastestmirror, refresh-packagekit Setting up Remove Process No Match for argument: swatch Loading mirror speeds from cached hostfile * base: rsync.atworks.co.jp * extras: rsync.atworks.co.jp * updates: rsync.atworks.co.jp No Packages marked for removal と、出ます swatch を インストールするには特別な方法があるのでしょうか??? ちなみに、このサイトを参考にしました・・・ http://centossrv.com/swatch.shtml yum update もやりました・・・

  • CentOS5.5でUpdate.Upgrade.

    いつも教えてくださりありがとうございます。 標記の件。 Ubuntuだとapt-get update apt-get upgradeで できていました。 CentOS5.5でUpdateを試みました。 http://mizushima.ne.jp/Linux/yum/CentOS-update.php のURLを参照に致しました。 結果は以下の通りです。 [root@localhost kouzou]# yum -y update Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * addons: ftp.tsukuba.wide.ad.jp * base: ftp.tsukuba.wide.ad.jp * extras: ftp.tsukuba.wide.ad.jp * updates: ftp.tsukuba.wide.ad.jp Setting up Update Process No Packages marked for Update [root@localhost kouzou]# additional pacckages that extend functionality of existing packages bash: additional: command not found [root@localhost kouzou]# rpm --import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt エラー: http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt: インポート読み込みに失敗しました(-1)。 警告: u 0xd1e5e60 ctrl 0xd1e7160 nrefs != 0 (dag.wieers.com http) 何か重要かことを知らないようです。 どなたかアドバイスを頂きたく 宜しくお願い申し上げます。

  • CentOS7にchromeインストール。

    [root@localhost kouzou]# vi /etc/yum.repos.d/google-chrome.repo [root@localhost kouzou]# yum install -y google-chrome-stable 読み込んだプラグイン:fastestmirror, langpacks File contains no section headers. file: file:///etc/yum.repos.d/google-chrome.repo, line: 2 'google-chrome]\n' [root@localhost kouzou]# yum install epel-release 読み込んだプラグイン:fastestmirror, langpacks File contains no section headers. file: file:///etc/yum.repos.d/google-chrome.repo, line: 2 'google-chrome]\n' いつも教えていただきありがとうございます。 以前は簡単に出来ていたのに最近難しいです。 どなたか教えてください。 ご回答のほど、宜しくお願い申し上げます。

  • これはどういう状況ですか?

    いつも大変お世話になっております。 FireFoxが使えず、chromeをインストールしようとしたら 下記のようになりました。 #vi /yum.repo.d # yum install google-chrome-stable 読み込んだプラグイン:fastestmirror,langpacks File contains no section headers. file: file:///etc/yum.repos.d/google.chrome.repo, line 1 'google.chrome.repo\n' #vi /yum.repo.d # yum install google-chrome-stable 読み込んだプラグイン:fastestmirror,langpacks File contains no section headers. file: file:///etc/yum.repos.d/google.chrome.repo, line 1 'google.chrome.repo\n' #vi /yum.repo.d # yum install google-chrome-stable 読み込んだプラグイン:fastestmirror,langpacks File contains no section headers. file: file:///etc/yum.repos.d/google.chrome.repo, line 1 'google.chrome.repo\n' #vi /yum.repo.d # yum install google-chrome-stable 読み込んだプラグイン:fastestmirror,langpacks File contains no section headers. file: file:///etc/yum.repos.d/google.chrome.repo, line 1 'google.chrome.repo\n' #vi /yum.repo.d # yum install google-chrome-stable 読み込んだプラグイン:fastestmirror,langpacks File contains no section headers. file: file:///etc/yum.repos.d/google.chrome.repo, line 1 'google.chrome.repo\n' CentOS-1511は古すぎますか? このマイナスイメージのメッセージは何でしょうか? ご多忙中恐れ入ります。 ご回答のほど、宜しくお願い申し上げます。