• ベストアンサー
  • すぐに回答を!

Linuxのパッケージインストール

CentOSにおいて、以下のパッケージをrpmコマンドを使用してインストールしようとしてますが、依存性の欠如でインストールすることができません。 依存性が欠如しているパッケージ名は表示されるのですが、その名前のパッケージ名はCentOSのisoファイルの中には見受けられません。 どのようにしてインストールすべきかご教授下さい。 ■環境  CentOS release 6.4 (Final)  64bitOS   ■インストールしたいパッケージ  compat-libstdc++-33-3.2.3-69.el6.i686.rpm  glibc-2.12-1.107.el6.i686.rpm  libstdc++-4.4.7-3.el6.i686.rpm  libstdc++-devel-4.4.7-3.el6.i686.rpm   ■目的  Oracle Database 12c Release 1 (12.1.0.1) 導入/検証のため  http://www.oracle.com/technetwork/jp/database/enterprise-edition/documentation/db121linux-x64-ja-v10-1984264-ja.pdf     ■インストールされていないパッケージをインストールした際に表示されるメッセージ  # rpm -ivh compat-libstdc++-33-3.2.3-69.el6.i686.rpm 警告: compat-libstdc++-33-3.2.3-69.el6.i686.rpm: ヘッダ V3 RSA/SHA256 Signature, key ID c105b9de: NOKEY エラー: 依存性の欠如: libc.so.6 は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.0) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.1) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.1.3) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.2) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.3) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libm.so.6 は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています # # rpm -ivh glibc-2.12-1.107.el6.i686.rpm 警告: glibc-2.12-1.107.el6.i686.rpm: ヘッダ V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY エラー: 依存性の欠如: libfreebl3.so は glibc-2.12-1.107.el6.i686 に必要とされています libfreebl3.so(NSSRAWHASH_3.12.3) は glibc-2.12-1.107.el6.i686 に必要とされています # # rpm -ivh libstdc++-4.4.7-3.el6.i686.rpm 警告: libstdc++-4.4.7-3.el6.i686.rpm: ヘッダ V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY エラー: 依存性の欠如: ld-linux.so.2 は libstdc++-4.4.7-3.el6.i686 に必要とされています ld-linux.so.2(GLIBC_2.3) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6 は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.0) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.1) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.1.3) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.2) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.3) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.3.2) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.4) は libstdc++-4.4.7-3.el6.i686 に必要とされています libm.so.6 は libstdc++-4.4.7-3.el6.i686 に必要とされています libm.so.6(GLIBC_2.0) は libstdc++-4.4.7-3.el6.i686 に必要とされています # # rpm -ivh libstdc++-devel-4.4.7-3.el6.i686.rpm 警告: libstdc++-devel-4.4.7-3.el6.i686.rpm: ヘッダ V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY エラー: 依存性の欠如: libstdc++(x86-32) = 4.4.7-3.el6 は libstdc++-devel-4.4.7-3.el6.i686 に必要とされています libstdc++.so.6 は libstdc++-devel-4.4.7-3.el6.i686 に必要とされています #

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数17964
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • ki073
  • ベストアンサー率77% (491/634)

CentOS一般に言えるのですが、まずyumコマンドでインストールしてみてください。依存関係も解消してくれます。 CentoOSと同じRedHat系のScientific Linuxを使っていますが、yumコマンドで確認したところ、 compat-libstdc++-33.x86_64 3.2.3-69.el6 glibc.x86_64 2.12-1.132.el6 libstdc++.x86_64 4.4.7-3.el6 libstdc++-devel.x86_64 4.4.7-3.el がインストールできます。.i686も同じバージョンになっているはずです。 sudo yum install glibc のようにパッケージ名でインストールで可能です。 またgccをインストールすると、compat-libstdc++以外はは同時にインストールされるかも知れません。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • RHEL6.1 パッケジ追加時のエラー

    RHEL6.1をインストしております。追加でcompat-libstdc++-33-3.2.3-69.el6.i686をrpm -ivhを使用して追加使用とするとエラーメッセージが出て追加できません。 エラーメッセージは下記のような感じです。 下記のパッケージを先に入れておかないといけないみたいなのですが、下記のパッケージの入手方法及びインスト方法を分かりやすくご説明願いませんでしょうか? rpm程度しか使用したことが無く、その他がよくわかりません。 よろしくお願い致します。 libc.so.6 is needed by XXXX-gcc_XXXX.i686 libc.so.6(GLIBC_2.0) is needed by XXXX-gcc_XXXX.i686 libc.so.6(GLIBC_2.1) is needed by XXXX-gcc_XXXX.i686 libc.so.6(GLIBC_2.1.3) is needed by XXXX-gcc_XXXX.i686 libc.so.6(GLIBC_2.2) is needed by XXXX-gcc_XXXX.i686 libc.so.6(GLIBC_2.2.3) is needed by XXXX-gcc_XXXX.i686 libc.so.6(GLIBC_2.3) is needed by XXXX-gcc_XXXX.i686

  • rpmファイルがインストールできずエラーを起こします。

    あるrpmファイルをインストールしようとしたところ、下記のようにエラーが表示されました。 環境:Red Hat Linux 9 ターミナルにて****.rpmファイルをインストール実行 -------------------------------------------------- # rpm -ivh ****.rpm エラー:Failed dependencies: libc.so.6(GLIBC_2.3.4) is needed by **** libc.so.6(GLIBC_2.4) is needed by **** libstdc++.so.6 is needed by **** libstdc++.so.6(CXXABI_1.3) is needed by **** libstdc++.so.6(GLIBCXX_3.4) is needed by **** -------------------------------------------------- libc.so.6(GLIBC_2.3.4),libc.so.6(GLIBC_2.4)などのファイルがないためインストールできないといってるようですが、初心者のためわかりません。対処法に詳しい方いらっしゃいましたらご回答よろしくお願いいたします。

  • ubuntuにFCS

    ubuntu server 6.10にFlash Communication Server(以下FCS)をインストールしようとしています。 FCSのインストールスクリプト「installFCS」を実行したところ、 ./fcsconfig: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory というエラーが出てしまいます。で、 # ldd fcsconfig したところ、 libstdc++-libc6.2-2.so.3 => not found と表示されます。 libstdc++-libc6.2-2.so.3を含むパッケージを探したところ、libstdc++2.10-glibc2.2 のようなのですが、 # apt-get install libstdc++2.10-glibc2.2 Reading package lists... Done Building dependency tree Reading state information... Done E: Couldn't find package libstdc++2.10-glibc2.2 というように、インストールしようにも入ってくれません。 この場合、どういった解決方法がありますでしょうか。手順レベルでご教示いただければと思います。よろしくお願いいたします。

その他の回答 (1)

  • 回答No.2

インストール用isoイメージに収録されていないパッケージは、ネット上のリポジトリから取得しましょう。 google検索結果から、該当するであろう記事を見つけましたので、参考urlに挙げておきます。

参考URL:
http://d.hatena.ne.jp/ka_zoo_key/20110713/1310576132

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • gcc-3.2-7のインストールについて

    Linux初心者です。 LinuxはRedHat7.3を使用しています。 gcc-3.2-7.i386.rpmをインストールしようとしていますが、依存性の欠如エラー ・kernel-headersはglibc-devel-2.2.93-5に必要 ・kernel-headers 2.2.1はglibc-devel-2.2.93-5に必要 ・glibc 2.2.93はglibc-devel-2.2.93-5に必要 が出ます。 これらのモジュールはどこで探せばいいのでしょうか? モジュールダウンロードのよいサイトがあれば教えてください。ちなみにRedHatのホームページには見つかりませんでした。

  • gccのインストール

    RedHatLinux5.2です。 gccをインストールしようとして gcc-4.4.1.2-9.i386.rpmをダウンロードしました。rpm -Uvhすると、 依存性の欠如として binutils >= 2:2.16.90.0.1-0.3 libc.so.6(GLIBC_2.3) libgcc4 = 5:4.1.2-9 rpnlib(PartialHardlinkSets) <= 4.0.4-1 が必要とされているとでます。 (1)binutilsの入手方法を教えてください。 (2)GLIBCのインストールにgccが必要だと言われたのでgccを入れているのですが、gccのインストールにGLIBCが必要だと言われています。どうしたらよいのでしょうか? Linux初心者です。よろしくお願いします。

  • libuuid1のインストール失敗

    CentOS5.6(32bit)にlibuuid1のrpmパッケージをインストールしたいと考えております。 ※本当はlibuuid-develをインストールしたいのだが、依存関係でerrになるため ※更に言うと、apr-develをインストールしたが、libuuid-develが必要なため rpmの実行でwarningが出るものの、errorは発生しておりません。 - - - # rpm -ivh libuuid1-1.41.1-16.3.i386.rpm warning: libuuid1-1.41.1-16.3.i386.rpm: Header V3 DSA signature: NOKEY, key ID bb935b28 Preparing... ########################################### [100%] file /lib/libuuid.so.1.2 from install of libuuid1-1.41.1-16.3.i386 conflicts with file from package e2fsprogs-libs-1.39-33.el5.i386 - - - 実行後、「rpm -qa | grep libuuid」を実行しても表示されないのは、正しい挙動なのでしょうか? ※的外れな事を聞いてたらすみません。。。 その後、本来インストールしたかったlibuuid-develをインストールしても、やはり失敗します - - - # rpm -ivh libuuid-devel-1.41.1-16.3.i386.rpm warning: libuuid-devel-1.41.1-16.3.i386.rpm: Header V3 DSA signature: NOKEY, key ID bb935b28 error: Failed dependencies: libuuid1 = 1.41.1 is needed by libuuid-devel-1.41.1-16.3.i386 - - - libuuid1のsrcファイルも見つけられず、八方塞がりです。 どなたか、ご教授頂けないでしょうか?

  • LinuxへのMySQLのインストール

    RedHat Linux 5.2です。 MySQL5.1.31をインストールしたいのですが上手くいきません。 1.rpmでインストール 2.non rpmでインストール いずれもためしてみたのですがどちらも以下のエラーが出ます。アドバイスよろしくお願いします。 ---------------------------------------------------------------- 1.rpmでインストール 警告:Expecetd Size: 7600697 警告: Actual Size: 7600729 エラー:依存性の欠如     ・・・としてlibc.so.6(GLIBC_2.3、GLIBC_2.3.4、GLIBC_2.4) libpthread.so.0(GLIBC_2.3.2) rtld(GNU_HASH)           coreutils が必要とされています、と出ます。 2.non rpmでインストール # ./scripts/mysql_install_db --user=mysqlとすると →”Please configure the 'hostname' command to return a correct hostname.”と出ます。 そのエラーの最後に--force optionでrestartしたら解決できるという風に書いてあったので # ./scripts/mysql_install_db --user=mysql --force optionとしました。すると ./bin/mysqld:error while loading shared libraries: libstdc++.so.6: cannot open shared object file:No such file or directoryと出て、 shell> ./bin/mysqld --skip-grant & を試してくださいと出ます。 そこでそれを試すと ./bin/mysqld:error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directoryと出ます。 ---------------------------------------------------------------- LinuxへのMySQLのインストールってこんなに大変なものなのでしょうか?アドバイスよろしくお願いします。

  • パッケージの依存関係をインストールするコツ

    例えば、avidemux-2.5.6-30.1.el6.i686.rpmをインストールしようとすると 以下のような依存ファイルがありませんとでてきました。 ------------------------------------------------------------------------------------------- libSDL-1.2.so.0 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libartsc.so.0 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libesd.so.0 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libfaac.so.0 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libfaad.so.2 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libjack.so.0 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libmp3lame.so.0 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libopencore-amrnb.so.0 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libopencore-amrwb.so.0 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libx264.so.118 は avidemux-2.5.6-30.1.el6.i686 に必要とされています libxvidcore.so.4 は avidemux-2.5.6-30.1.el6.i686 に必要とされています -------------------------------------------------------------------------------------------- このようにでてきた場合どう調べるのがいいんでしょうか? いつもいちいちネットで調べてそのライブラリ等をインストールしているのですが、ライブラリ名とパッケージ名が違うことが多いようで、よくわかりません。 必要なものだけインストールしたいのですが、いつもわからないのでいらないものまでインストールしてしまいます。 なにか依存パッケージを見つけるいい方法を知っていましたら、ご教授お願い申し上げます。

  • MySQLがインストールされているかわかりません

    当方、初心者です。 訳あって、古いバージョンのMySQLをインストールすることになりました。 MySQLのサイトからバージョンが5.1.68の mysql-server mysql-client mysql-devel mysql-shared をダウンロードして、 #rpm -ivh mysql-server-5.1.68-1.glibc23.x86_64.rpm #rpm -ivh mysql-client-5.1.68-1.glibc23.x86_64.rpm #rpm -ivh mysql-devel-5.1.68-1.glibc23.x86_64.rpm #rpm -ivh mysql-shared-5.1.68-1.glibc23.x86_64.rpm とコマンドをうちました。 それぞれ100%となり、エラーメッセージは出ませんでした。 その後 #rpm -qa │ grep mysql と打っても何も表示されませんでした。 /etc/init.d/にmysqlはありますが、mysqldはありません。 mysql startとうつとOKと表示され showdatabaseもできました。 これでインストールは完了しているのでしょうか? OSはCentOS5.9です。 構成管理のパッケージソフトをインストールするために 前提としてMySQLが必要と記載されていたのみなので どのMySQLをインストールすれば良いかもわかりません。 心優しい方のアドバイスをお待ちしております。

  • パッケージのインストールでエラーが出たのですが、これはどういう意味ですか?

    [root@localhost ~]# rpm -ivh rpmfusion-free-release-stable.noarch.rpm 警告: rpmfusion-free-release-stable.noarch.rpm: ヘッダ V3 DSA signature: NOKEY, key ID 49c8885a エラー: 依存性の欠如: system-release >= 10 は rpmfusion-free-release-10-5.noarch に必要とされています 1.これはどのパッケージをインストールすればいいのでしょうか? 2.足りないパッケージはこれだけですか?(必要とされているのを入れたらさらに他のが必要だとなる) 3.fedora用のパッケージはcentOSでも実行可能でしょうか?(これは本来fedora用のパッケージなのですが、centOSでもできるかと思ったのですが、yumではできなかった?ので・・・)

  • CentOSにMySQLをインストール

    CentOS6.2にMySQL5.0.37をインストールをしたいのですが、 旧バージョンのMySQLをアンインストールする方法がわかりません。 以下のようにアンイストール作業を行ったのですが、依存関係がありアンイストール できません。ご経験のある方何かアドバイスを頂けますか? (アンインストール後はソースからmakeコマンドでインストールする予定です。) <経過> [root@TARO ~]# rpm -qa | grep mysql mysql-libs-5.1.52-1.el6_0.1.x86_64 [root@TARO ~]# rpm -e mysql-libs エラー: 依存性の欠如: libmysqlclient.so.16()(64bit) は (インストール済み)postfix-2:2.6.6-2.2.el6_1.x86_64 に必要とされています libmysqlclient.so.16(libmysqlclient_16)(64bit) は (インストール済み)postfix-2:2.6.6-2.2.el6_1.x86_64 に必要とされています mysql-libs は (インストール済み)postfix-2:2.6.6-2.2.el6_1.x86_64 に必要とされています [root@TARO ~]# rpm -e postfix エラー: 依存性の欠如: /usr/sbin/sendmail は (インストール済み)cronie-1.4.4-7.el6.x86_64 に必要とされています [root@TARO ~]# rpm -e cronie エラー: 依存性の欠如: cronie = 1.4.4-7.el6 は (インストール済み)cronie-anacron-1.4.4-7.el6.x86_64 に必要とされています /etc/cron.d は (インストール済み)crontabs-1.10-33.el6.noarch に必要とされています [root@TARO ~]# rpm -e crontabs エラー: 依存性の欠如: crontabs は (インストール済み)cronie-anacron-1.4.4-7.el6.x86_64 に必要とされています [root@TARO ~]# rpm -e cronie-anacron エラー: 依存性の欠如: dailyjobs は (インストール済み)cronie-1.4.4-7.el6.x86_64 に必要とされています [root@TARO ~]# rpm -e cronie エラー: 依存性の欠如: cronie = 1.4.4-7.el6 は (インストール済み)cronie-anacron-1.4.4-7.el6.x86_64 に必要とされています /etc/cron.d は (インストール済み)crontabs-1.10-33.el6.noarch に必要とされています 以下ループ

  • fedora core6にOracle9iをインストール

    質問されていただきます。 Linux fedora core6にoracle9iをCDからインストールしようとしてるのですが、マウントして/mnt/cdrom/runInstaller & と入力すると、 Initializing Java Virtual Machine from /tmp/OraInstall/jre/bin/jre. Please wait... /tmp/OraInstall/jre/bin/../lib/i686/green_threads/libzip.so: symbol errno, version GLIBC_2 .0 not defined in file libc.so.6 with link time reference (libzip.so) Unable to initialize threads: cannot find class java/lang/Thread Could not create Java VM というエラーが出て、そのまま止まってしまいます。 現在行っている設定は ・oracleユーザの環境設定 ・上記の該当スレッドにtouchでファイル作成(libzip.so、libc.so.6) ・LD_KARNEL_PASHは設定するとエラーが出る為行っていません。 上記エラーに出てるパッケージの検索結果 $ rpm -qa | grep libc glibc-common-2.5-3 libcap-devel-1.10-25 libcroco-0.6.1-2.1 glibc-headers-2.5-3 glibc-2.5-3 libcap-1.10-25 libcroco-devel-0.6.1-2.1 glibc-2.5-10.fc6 glibc-common-2.5-10.fc6 glibc-devel-2.5-3 少ない情報で申し訳ありません。 必要な情報があれば調べてお知らせします。 何卒お知恵をお貸しください。 よろしくお願いします。

  • glibcバージョンアップ

    RedHat2.1の環境でglibcを2.3以上にアップデートを行ってます。 ただし、アップデートできません。 RedHat4にあったGlibcらしきPRMを走らせたら下記のようになりました。 2.3へのアップデートの方法をご存知の方がいたら教えて下さい。 もしくはRPMがダウンロードできるサイトがあれば教えて下さい。 [root@test01 Redhut4 glib]# rpm -ivh glibc-2.3.4-2.i386.rpm エラー: 依存性の欠如: glibc-common = 2.3.4-2は glibc-2.3.4-2 に必要とされています shadow-utils < 2:4.0.3-20 glibc-2.3.4-2 と競合します nscd < 2.3.3-52 glibc-2.3.4-2 と競合します glibc > 2.2.4 glibc-common-2.2.4-32.18 と競合します