• ベストアンサー
※ ChatGPTを利用し、要約された質問です(原文:CentOS X Window Systemエラー)

CentOS X Window Systemエラー

このQ&Aのポイント
  • CentOS6.2をインストールして問題なくstartxでデスクトップを使えていたのですが、yum updateで6.4にアップデートし再起動するとエラーが出てX Window Systemが起動しなくなりました。
  • X Window Systemのログファイルを開いて(EE)の部分だけ抜き出すと、明らかに(EE) open /dev/fb0: No such device が気になります。ググると、ビデオカードが認識できないことによるエラーだという記事が見つかりましたが、このエラーには該当しない可能性があります。
  • ハードウェアに詳しくないため、X Window Systemの起動エラーの原因を特定できません。解決策を知っている方がいれば教えていただきたいです。

質問者が選んだベストアンサー

  • ベストアンサー
  • A1200hd40
  • ベストアンサー率51% (336/647)
回答No.2

(EE) open /dev/fb0: No such device fb0:=フレームバッファデバイス 「そのようなデバイスは有りません。」と、蹴っています。 思いっきりVGA関係ですが? (EE) 3: /usr/lib/xorg/modules/drivers/sis_drv.so (0x3fd000+0x4fdad) [0x44cdad] (EE) 4: /usr/lib/xorg/modules/drivers/sis_drv.so (0x3fd000+0x35ad9) [0x432ad9] (EE) 5: /usr/lib/xorg/modules/drivers/sis_drv.so (0x3fd000+0x292d3) [0x4262d3] sisのVGAドライバを呼び出している様子ですが、失敗しています。 古い設定ファイルが生きていて、アップグレード後のソフトウェア環境との間で齟齬が発生し、VGAドライバが使用不能になっている可能性を感じます。 最近のメジャーなディストリビューションでは、bootオプションX11failsafeを指定してやれば、vesaモードVGAを含めた最低限環境の動作でXが起動出来たりします。 オプションを指定してboot出来る仕様ならば、その入力欄で。 そうでなければ、bootメニューの中身を編集して、オプション指定をかけてみましょう。 残念ながら、自分は別のディストロを利用しているので、この程度の助言しか出来ません。

全文を見る
すると、全ての回答が全文表示されます。

その他の回答 (1)

  • yakan9
  • ベストアンサー率54% (2215/4075)
回答No.3

なかなか的確な回答がないようですね。 何故か。 マシン環境を記載していない。 いろいろ質問しているようですが、その全てにマシン環境の記載がないこと。 また、どこまで調査済みなのか不明。 その他、 *** ここから *** cenosでキーボードの開始括弧が入力できない http://okwave.jp/qa/q8077725.html また、/etc/X11/xorg.confはじめから存在していませんでした。ネットに書いてあったので 勝手にファイルを新規作成して *** ここまで *** 基本的には、「CentOS6.4リリーズノート」は調べているか、リリーズノートも日本語版ではあまり意味はなく、英文で「英和辞典」を片手に少しは調べているかです。 結論を言います。 > startxするとエラーが出てX Window Systemが起動しなくなりました。 どんなエラーメッセージが出たか、 WEB検索したか、 どんな環境か、 /etc/X11/xorg.conf入れているか、 入れていればその内容は、 CentOS6.2のままか、 もしそうであれば、 CentOS6 の画面サイズの設定 http://okwave.jp/qa/q8037424.htm ここに当方が記載した、回答番号5のような現象ではないか。 もしそうであれば、xorg.confの一部手直しで直る可能性がある。 xorg.confの内容の補足を待って、回答予定。

全文を見る
すると、全ての回答が全文表示されます。

関連するQ&A

  • WACOMのタブレットがうまく動きません

    CentOS 5.1でWACOMのタブレットを使おうとしているのですが、 うまく動いてくれません。 Linux Wacom Projectのサイトをみながら ドライバのインストールを試みたりしてみたのですが、 うまく動きません。 とりあえずペンの動きにはマウスカーソルが反応します。 しかし本当にとりあえず反応するだけです。 タブレット付属のマウスには反応してくれません。 xorg.confの設定はLinux Wacom Projectを 参考に設定しました。 私はXが悪いのではないかと推測しています。 $ grep -i wacom /var/log/Xorg.0.log (II) LoadModule: "wacom" (II) Loading /usr/lib64/xorg/modules/input/wacom_drv.so (II) Module wacom: vendor="X.Org Foundation" (II) UnloadModule: "wacom" (II) Unloading /usr/lib64/xorg/modules/input/wacom_drv.so (EE) Failed to load module "wacom" (module requirement mismatch, 0) (EE) No Input driver matching `wacom' (EE) No Input driver matching `wacom' (EE) No Input driver matching `wacom' (EE) No Input driver matching `wacom' の様なエラーがログに出力されていましたので。 しかし対処方法がわかりません。 $ uname -a Linux hostname 2.6.18-53.1.4.el5 #1 SMP x86_64 x86_64 x86_64 GNU/Linux WACOM Intuos PTZ-930 X Window System Version 7.1.1 です。 私の推測通りXが原因なのかあるいはそれ以外なのかわかりませんが、 アドバイスをいただけませんでしょうか。 よろしくお願いします。

  • X Window Systemが起動しない

    Debianをインストールしましたが、GUIが起動しません。 ためしに、CUIなのでログインし、「startx」としたところ、、 X.Org X Server 1.4.2 Release Date: 11 June 2008 X Protocol Version 11, Revision 0 Build Operating System: Linux Debian (xorg-server 2:1.4.2-10.lenny3) Current Operating System: Linux buffalo 2.6.26-2-686 #1 SMP Thu Jan 27 00:28:05 UTC 2011 i686 Build Date: 25 September 2010 12:05:44PM Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. Module Loader present Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (==) Log file: "/var/log/Xorg.0.log", Time: Mon May 2 21:28:57 2011 (==) Using config file: "/etc/X11/xorg.conf" (II) Module "ramdac" already built-in (II) Module "ddc" already built-in (EE) SIS(0): ************************************************** (EE) SIS(0): ERROR: (EE) SIS(0): Virtual screen too big for memory; 4800K needed, 4096K available (EE) SIS(0): END OF MESSAGE (EE) SIS(0): ************************************************** (EE) Screen(s) found, but none have a usable configuration. Fatal server error: no screens found giving up. xinit: Connection reset by peer (errno 104): unable to connect to X server xinit: No such process (errno 3): Server error. とでてきました。 どうすれば起動するのでしょうか? Debian 5.0.3 lenny メモリ 256MB HDD 40GB 一応、VNCをインストールしてWindowsから操作はできるようになっています。 (しかし、タスクバーなどが表示されていません。) 宜しくお願いします。

  • CentOs5.8Apacheのリビルド

    CentOS5.8でSNIを使おうと思っています。 そのためのOpenSSL1.0.1eはインストールできました そのOpensslをApacheに適用させるために既存のApacheのリビルドをしたいと思っています ですが、現在のApacheの設定をそのままにリビルドする方法はありますか? 現在1日はまってしまい、非常に困っています。 下記OpenSSLの更新作業 ===================================================== # wget http://www.openssl.org/source/openssl-1.0.1e.tar.gz # tar zxvf openssl-1.0.1e.tar.gz # cd openssl-1.0.1e # ./config enable-tlsext -fPIC shared # make # make test # make install ※デフォルト/usr/local/ssl/にインストールされるみたいです。 ・まずはパスを認識させます # echo /usr/local/ssl/lib > /etc/ld.so.conf.d/openssl.conf # ldconfig ・既存のopensslの実行ファイルを今回インストールした物と変更します。 # cd /usr/bin # mv openssl openssl.old # ln -s /usr/local/ssl/bin/openssl ・シェアードライブラリが正しくリンクできているか確認 # ldd /usr/local/ssl/bin/openssl linux-vdso.so.1 => (0x00007fff49bf2000) libssl.so.1.0.0 => /usr/local/ssl/lib/libssl.so.1.0.0 (0x00002b5327442000) libcrypto.so.1.0.0 => /usr/local/ssl/lib/libcrypto.so.1.0.0 (0x00002b53276a7000) libdl.so.2 => /lib64/libdl.so.2 (0x0000003f36000000) libc.so.6 => /lib64/libc.so.6 (0x0000003f35400000) /lib64/ld-linux-x86-64.so.2 (0x0000003f34c00000) =================================================================================== 宜しくお願い致します。

  • ALL IN WONDERでX-Window

    ALL-IN-WONDER128PROで、X-Windowを使える 用にしたいのですが、うまくいきません。 動作してる方が居られましたら、ご教授ください。 http://www.linuxvideo.org/gatos/のr128_drv.oを /usr/X11R/lib/modules/driversに置いてもうまくい きませんでした。 ディストリビュショーン: kondara2.0 XFree86 4.0.3 glibc 2.2.2

  • PHP5インストール時にlibphp5.soが作成されない

    こんにちは。 CentOS3、Apache/2.0.46 の環境で、PHP5をインストールしようとしています。 VPSでレンタルしたもので、すでにPHP4が入っていたものを、PHP4.4.4にバージョンアップし使っていましたが、5を使いたいと思いインストールを試みたのですが、configure、makeが終わり、make installの段階で以下のようなエラーがでて終了していまいます。 ーーーーーーーー Installing PHP SAPI module: apache2handler /usr/lib/httpd/build/instdso.sh SH_LIBTOOL='/usr/bin/libtool' libphp5.la /usr/lib/httpd/modules /usr/bin/libtool --mode=install cp libphp5.la /usr/lib/httpd/modules/ cp .libs/libphp5.lai /usr/lib/httpd/modules/libphp5.la cp .libs/libphp5.a /usr/lib/httpd/modules/libphp5.a ranlib /usr/lib/httpd/modules/libphp5.a chmod 644 /usr/lib/httpd/modules/libphp5.a libtool: install: warning: remember to run `libtool --finish /etc/php-5/libs' Warning! dlname not found in /usr/lib/httpd/modules/libphp5.la. Assuming installing a .so rather than a libtool archive. chmod 755 /usr/lib/httpd/modules/libphp5.so chmod: failed to get attributes of `/usr/lib/httpd/modules/libphp5.so': No such file or directory apxs:Error: Command failed with rc=65536 . make: *** [install-sapi] Error 1 ---------------------------- configureは --with-apxs2=/usr/sbin/apxsのオプションだけで行い、とりあえずlibphp5.soファイルを作ろうとしているのですが、作成されません。 ネットをしらべたところ大抵のサイトでは--with-apxs2=/usr/sbin/apxsをだけつけてconfigureすれば生成される、と書かれていたのですが。。。。 よろしくお願いいたします、

  • X WINDOW起動失敗

    REDHAT LINUX7Jの起動の際、X WINDOWを起動しようとしたところ、以下のメッセージが発生しました。機種はFMV56533を使用しております。 何かご存知の方、教えて頂けませんでしょうか。 (EE) Failed to load module "v4l" (module does not exist, 0) (II) LoadModule: "r128" (II) Loading /usr/X11R6/lib/modules/drivers/r128_drv.o (II) Module r128: vendor="The XFree86 Project" compiled for 4.0.1a, module version = 3.1.1 Module class: XFree86 Video Driver ABI class: XFree86 Video Driver, version 0.2 (II) LoadModule: "mouse" (II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o (II) Module mouse: vendor="The XFree86 Project" compiled for 4.0.1a, module version = 1.0.0 Module class: XFree86 XInput Driver ABI class: XFree86 XInput driver, version 0.1 (II) r128: Driver for ATI Rage 128 chipset: ATI Rage 128 RE (PCI), ATI Rage 128 RF (AGP), ATI Rage 128 RK (PCI), ATI Rage 128 RL (AGP), ATI Rage 128 Pro PF (AGP), ATI Rage 128 Mobility LE (PCI), ATI Rage 128 Mobility LF (AGP), ATI Rage 128 Mobility MF (AGP), ATI Rage 128 Mobility ML (AGP) (II) Primary Device is: PCI 01:00:0 (--) Assigning device section with no busID to primary device (EE) No devices detected. Fatal server error: no screens found When reporting a problem related to a server crash, please send the full server output, not just the last messages. This can be found in the log file "/var/log/XFree86.0.log". Please reports problems to xfree86@xfree86.org.

  • アボートの原因をさかのぼる方法

    こんにちは。 C++で作ったプログラムをコンパイルし、 何事もなかったので、 さて、実行でもしようかな。と、 実行させていたですが、 「memory corruption」ということで、 「Backtrace」やら、 「Memory map」やらと、 色々とログみたいなのが ズラリと表示されて、 最後に、「アボートしました」の表示の後、 勝手に終了してしまいました。 どこかが悪いから修正しないといけないのでしょうが、 言葉らしき言葉などはなく、 数字などで占められているので、 どうしていいか?が全くといい見当がつかないでいます。 こうゆう場合と言うのは、 どのように問題箇所を探し出して、 トラブルシュートに入るのでしょうか? 教えてもらえると嬉しいです。どうぞ宜しくお願いします。 *** glibc detected *** ./simulation: malloc(): memory corruption: 0x7f000630 *** ======= Backtrace: ========= /lib/libc.so.6[0x92a596] /lib/libc.so.6(__libc_malloc+0x95)[0x92bce5] /usr/lib/libstdc++.so.6(_Znwj+0x27)[0x4826167] ./simulation[0x80c6011] ./simulation[0x80c6099] ./sim[0x81075fd] ./sim[0x809f2c4] ./sim[0x809738d] ./sim[0x8097b30] ./sim[0x80981fa] ./sim[0x809c371] ./sim[0x805a33a] ./sim[0x805a3ef] ./sim[0x808128f] ./sim[0x808130c] ./sim[0x80813d6] ./sim[0x8096ba2] ./sim[0x806b812] ./sim[0x8053811] ./sim[0x806f2ae] ./sim[0x806f2f7] ./sim[0x806f343] ./sim[0x8096f7e] ./sim[0x806c8fb] ./sim[0x8063db2] ./sim[0x8070778] ./sim[0x8070808] ./sim[0x8078948] ./sim[0x8054665] ./sim[0x8076eb8] ./sim[0x8077bc8] /lib/libpthread.so.0[0xa3232f] /lib/libc.so.6(clone+0x5e)[0x99820e] ======= Memory map: ======== 003f5000-0042f000 r-xp 00000000 fd:00 5006557 /usr/lib/sse2/libgmp.so.3.4.2 0042f000-00430000 rw-p 00039000 fd:00 5006557 /usr/lib/sse2/libgmp.so.3.4.2 006df000-00816000 r-xp 00000000 fd:00 7577755 /lib/libcrypto.so.0.9.8g 00816000-0082a000 rw-p 00136000 fd:00 7577755 /lib/libcrypto.so.0.9.8g 0082a000-0082d000 rw-p 0082a000 00:00 0 0089a000-008b6000 r-xp 00000000 fd:00 7577631 /lib/ld-2.8.so 008b6000-008b7000 r--p 0001c000 fd:00 7577631 /lib/ld-2.8.so 008b7000-008b8000 rw-p 0001d000 fd:00 7577631 /lib/ld-2.8.so 008ba000-00a1d000 r-xp 00000000 fd:00 7577638 /lib/libc-2.8.so 00a1d000-00a1f000 r--p 00163000 fd:00 7577638 /lib/libc-2.8.so 00a1f000-00a20000 rw-p 00165000 fd:00 7577638 /lib/libc-2.8.so 00a20000-00a23000 rw-p 00a20000 00:00 0 00a25000-00a28000 r-xp 00000000 fd:00 7577646 /lib/libdl-2.8.so 00a28000-00a29000 r--p 00002000 fd:00 7577646 /lib/libdl-2.8.so 00a29000-00a2a000 rw-p 00003000 fd:00 7577646 /lib/libdl-2.8.so 00a2c000-00a41000 r-xp 00000000 fd:00 7577642 /lib/libpthread-2.8.so 00a41000-00a42000 r--p 00014000 fd:00 7577642 /lib/libpthread-2.8.so 00a42000-00a43000 rw-p 00015000 fd:00 7577642 /lib/libpthread-2.8.so 00a43000-00a45000 rw-p 00a43000 00:00 0 00a47000-00a6e000 r-xp 00000000 fd:00 7577664 /lib/libm-2.8.so 00a6e000-00a6f000 r--p 00026000 fd:00 7577664 /lib/libm-2.8.so 00a6f000-00a70000 rw-p 00027000 fd:00 7577664 /lib/libm-2.8.so 00a72000-00a85000 r-xp 00000000 fd:00 7577648 /lib/libz.so.1.2.3 00a85000-00a86000 rw-p 00012000 fd:00 7577648 /lib/libz.so.1.2.3 00a88000-00a90000 r-xp 00000000 fd:00 7577644 /lib/librt-2.8.so 00a90000-00a91000 r--p 00007000 fd:00 7577644 /lib/librt-2.8.so 00a91000-00a92000 rw-p 00008000 fd:00 7577644 /lib/librt-2.8.so 00c21000-00c2e000 r-xp 00000000 fd:00 7577652 /lib/libgcc_s-4.3.0-20080428.so.1 00c2e000-00c2f000 rw-p 0000c000 fd:00 7577652 /lib/libgcc_s-4.3.0-20080428.so.1 0476b000-04852000 r-xp 00000000 fd:00 3588124 /usr/lib/libstdc++.so.6.0.10 04852000-04856000 r--p 000e6000 fd:00 3588124 /usr/lib/libstdc++.so.6.0.10 04856000-04858000 rw-p 000ea000 fd:00 3588124 /usr/lib/libstdc++.so.6.0.10 04858000-0485d000 rw-p 04858000 00:00 0 40239000-4023a000 ---p 40239000 0アボートしました

  • rmicが通りません(初心者です)

    下のURLのHelloWorld.javaとHelloWorldObj.javaをコピペしてコンパイルしようとしたのですがrmicでエラーがでます。何が悪いのか分からず困っています。どうか教えて下さい。osはlinuxでjavaはjdk1.5.0_07です。 http://www.hellohiro.com/rmi.htm $ rmic HelloWorldObj java.lang.NullPointerException at 0x40268de4: java.lang.Throwable.Throwable() (/usr/lib/./libgcj.so.3) at 0x4025bcaf: java.lang.Exception.Exception() (/usr/lib/./libgcj.so.3) at 0x4025f56f: java.lang.RuntimeException.RuntimeException() (/usr/lib/./libgcj.so.3) at 0x4025ec67: java.lang.NullPointerException.NullPointerException() (/usr/lib/./libgcj.so.3) at 0x4021b627: _Jv_ThrowNullPointerException (/usr/lib/./libgcj.so.3) at 0x403202cb: ?? (??:0) at 0x4031c817: gnu.java.rmi.rmic.RMIC.generateStub() (/usr/lib/./libgcj.so.3) at 0x4031b6ed: gnu.java.rmi.rmic.RMIC.processClass(java.lang.String) (/usr/lib/./libgcj.so.3) at 0x4031b644: gnu.java.rmi.rmic.RMIC.run() (/usr/lib/./libgcj.so.3) at 0x4031b507: gnu.java.rmi.rmic.RMIC.main(java.lang.String[]) (/usr/lib/./libgcj.so.3) at 0x40242dd8: gnu.gcj.runtime.FirstThread.call_main() (/usr/lib/./libgcj.so.3) at 0x402ad02d: gnu.gcj.runtime.FirstThread.run() (/usr/lib/./libgcj.so.3) at 0x4024fc4c: _Jv_ThreadRun(java.lang.Thread) (/usr/lib/./libgcj.so.3) at 0x4021c8ac: _Jv_RunMain(java.lang.Class, byte const, int, byte const, boolean) (/usr/lib/./libgcj.so.3) at 0x4021c9cd: JvRunMain (/usr/lib/./libgcj.so.3) at 0x080485a8: ?? (??:0) at 0x42015704: __libc_start_main (/lib/tls/libc.so.6) at 0x080484f5: ?? (??:0)

    • ベストアンサー
    • Java
  • CENTOS libsocket.so がない

    同僚がVMでCENTOS入れてくれたので、それを用いて ネットワークのテストモジュールを作ろうとしたところ、 == [@localhost test]$ gcc -lsocket main.c /usr/bin/ld: -lsocket が見つかりません collect2: エラー: ld はステータス 1 で終了しました [@localhost test]$ == となり、 /usr/lib /usr/lib64 をあさったところ、 確かにlibsocket.so* 自体が無い事がわかりました。 はて?と、yumの状態はというと == yum list installed | grep glibc glibc.x86_64 2.17-222.el7 @anaconda glibc-common.x86_64 2.17-222.el7 @anaconda glibc-devel.x86_64 2.17-222.el7 @anaconda glibc-headers.x86_64 2.17-222.el7 @anaconda == libsocket って、何か別のパッケージだったっけ? と、ネットで探し始めて少々途方にくれております。 このパッケージに入ってるよーなどの情報がありましたら 教えていただきたく。 よろしくお願いします。

  • centos5.3にてrpmを実行したところ、/var/tmp/rpm

    centos5.3にてrpmを実行したところ、/var/tmp/rpm-tmp.20324: /usr/shovel/application/bin/portscan: /lib/ld-linux.so.2: bad ELF interpreter: そのようなファイルやディレクトリはありません /var/tmp/rpm-tmp.20324: /usr/shovel/mysql/bin/mysql: /lib/ld-linux.so.2: bad ELF interpreter: そのようなファイルやディレクトリはありません とでました。 何が原因かわかる方教えて下さい!

このQ&Aのポイント
  • ScanSnapで読み取った名刺を他の方法で活用するための方法について質問があります。
  • 上司が別の会社で名刺データを閲覧・活用したい場合、どのような方法があるか教えてください。
  • ScanSnap Homeで保存している名刺データを他の名刺管理ソフトへ移行する方法について知りたいです。
回答を見る