• 締切済み
  • 困ってます

RedHat Linux7.2でCD-ROMを認識させるには

RedHat Linux 7.2をインストールしました。その後CD-ROMから追加のプログラムを投入しようとしてCD-ROMをいれてmount /mnt/cdromあるいはmount -t iso9660 -o ro /dev/cdrom /mnt/cdromとしましたが認識されませんでした。2台の異なるマシーンで試しましたが同様に読み込めませんでした。その他の機能は全く問題がなくサーバとして作動しています。wu-ftpを投入しようとしてCD-ROMを入れたら認識しなかったというわけです。どなたか同じような環境からCD-ROMを読めるようにされた経験がございましたら、ご教授御願いします。X WindowやGnomeは使用していません。超初心者です。

共感・応援の気持ちを伝えよう!

  • 回答数3
  • 閲覧数307
  • ありがとう数3

みんなの回答

  • 回答No.3
  • misoka
  • ベストアンサー率35% (56/160)

もう質問は閉めるとのことですが、情報がありましたので、 余計なこととは思いましたが、一応投稿させていただきます。 雑誌「UNIX User」の1月号を見ていましたら、IDEのCD-ROMドライブの場合、 環境によってはドライブが認識されなくなることもあるようなことが かかれていました。 カーネルを更新すると改善されるみたいです... (「UNIX User」に収録されているカーネルは、2.4.9-13) 以上です。失礼しました。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

有り難うございました。結局RedHat Linux v.7.1でしばらく構築して、原因が判明した時点で変更しようと思います。一種のバグかもしれません。

  • 回答No.2
  • juna
  • ベストアンサー率42% (8/19)

情報不足です エラーメッセージやCD-ROMドライブの種類(SCSI等)や機種も書いてください ドライブを認識できていますか(dmesg等) /dev/cdromはマウントされるブロックスペシャルデバイスノード (またはそれへのリンク)になっていますか fstabの記述は正しいですか

共感・感謝の気持ちを伝えよう!

質問者からのお礼

有り難うございました。エラーメッセージは mount: /dev/cdrom is not valid block device.でした。他の機体でも試しましたが、同じ結果でした。いずれにせよこの質問はこれで閉めさせていただきます。

  • 回答No.1
  • jakarta
  • ベストアンサー率38% (607/1597)

読み込めない場合はエラーが表示されると思うのですが その際のエラーは何とでますか? 多分デバイス名の指定がまちがっている可能性が高いです。 おそらく何かの書籍を参考にコマンドを入力されているのではないか と思いますがSCSIやIDE(ATA)などによりデバイス名の指定は 異なります。(例えばSCSIであればscd、ATAならhdcなど) $cat /etc/fstab で/mnt/cdromにわりあてられているデバイス名を確認して下さい。 仮に /dev/scd0 /mnt/cdrom iso9660 user,noauto,ro 0 0 であれば $mount /dev/scd0 /mnt/cdrom といった具合になります。 Redhatはインストールしてないのでどうかわかりませんが fstabの記述内容によってはSU(root)しかmountの権限がない 場合がありますので御注意ください。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • RedHat Linux 7.2とCD-ROMのマウント

    以前に全く同じ質問をしたものですが、再度御願いします。 RedHat Linux 7.2を投入しまして正常に作動を確認後、必要が在ってCD-ROMのマウント使用としたのですが、マウントされません。 mount: /dev/cdrom is not a valid block deviceと表示されます。ちなみにfstabの関連のラインは次の通りです。 /dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu 0 0となっています。mount -t iso9660 -o ro /dev/cdrom /mnt/cdromも作動しませんでした。どなたか解決策が在りましたら、教えてください。

  • CD-ROMのマウントが・・・

    RedHat Linux8.0のX Windowから、アイコンを使っても、コマンドプロンプト からもCDROMがマウントできません。以前はちゃんと出来たのですが、ハード を追加してからおかしくなりました。 本来なら、追加したハードを外して動作確認したいところなのですが、現状 ではすぐにそう言った事が出来ないもので・・・。 何か策はありませんでしょうか・・・。 # mount -t iso9660 /dev/cdrom /mnt/cdrom とコマンドを打つと、下記のメッセージが返ってきます。 mount : 間違ったファイルシステムタイプ、不正なオプション、      /dev/cdromのスーパーブロックが不正、或いはファイルシステム      のマウントが多すぎます      (could this be the IDE device where you in fact use ide-scsi sothat sr0 or sda or so is need ? ) fstabには下記のように記述されていて他のマシンと見比べても同じです。 /dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0 マウントはrootで行っていましたが、試しに一般ユーザーで入り、suになっ て、mountコマンドでマウントしようとしても同じエラーが返ってきました。 CDのメディアは、他のマシンではマウントされましたので、それ自体には問 題無さそうなのです。 $eject や、eject -v /dev/cdrom 等のコマンドや再起動、接触等の確認も 行いましたが、効果が無く、どうもに手詰まりです・・・。 ただ、dmesgに、 「scsi1 : SCSI host adapter emulation for IDE ATAPI devices Vendor: COMPAQ Model: CRN-8245B Rev: 2.19 Type: CD-ROM ANSI SCSI revision: 02 」 と書かれていた部分がありました。これが気になってはいるのでが・・・。 よろしくお願いいたします。

  • Red Hat Linux 9でcd-romをマウントできません

    超初心者です。 Red Hat Linux 9 をインストールしてApacheをCD-ROMからインストールしようとしているのですが、CD-ROMをマウントできません。 su でログイン後、マニュアルに書いてある通り、 cd /mnt/cdrom mount /dev/cdrom /mnt/cdrom/ と入力しても”mount: /dev/cdrom はブロックデバイスではありません”とはねられてしまいます。 ちなみに、OSをインストールした状態では/mnt/cdromも/dev/cdromも存在しておらず、自分で作成しました。 また、マウントが成功した時に anacnda-ks.cfg install.log install.log.syslog と言うファイルが出来ていたことから、そのファイルを/root 以下に見つけ、 mount /root /mnt/cdrom/ /rootのファイルを/dev/cdromへコピーしてから再度 mount /dev/cdrom /mnt/cdrom/ を行いましたが結果は同じでした。 何卒、よろしくお願いします。

  • Linuxを使っていてCD-ROMのマウントができません

    Linux MLD4を使っていてCD-ROMのマウントができません。 コマンドを実行すると下記のようなメッセージが出ます。 #mount -t iso9660 /dev/cdrom/mnt/cdrom mount:invalid option --l Usage:mount [-hv] mount -a[-nfFrsvw] [-t vfstypes] mount [-nfrsuw][-o options] special | node mount [-nfrsvw][-t vfstype][-o options] special node A special device can be indicated by -[label or -U unid . [root@localhost /root]#df /cdrom df: /cdrom:No such file or directory Filesystem 1k-blocks Used Available Use% Mounted on 対処方法など分かる方がいましたら教えて下さい。

  • CDROMの利用

    VAIOノートパソコン(Z505GR/K)にRedHatLinux9を インストールしました。 インストール時には何の手も加える事なく認識して使用できたCDROM(PCGA-CDR51)をインストール後にはどのようにCDROMを認識させればよいかわからずに困っています。 mount /mnt/cdrom mount /dev/cdrom /mnt/cdrom などで"スペシャルデバイスCDROMが見つかりません。" とエラーメッセージがでます。 超初心者ですが宜しくお願いします。

  • mountできなくなりました

    ノートPCのCD/RW使えるようにしたくて、まず /etc/conf.modulesに alias scsi_hostadapter ide-scsi alias block-major-11 ide-scsi 次に cd /dev mv cdrom cdrom.org ln -s scd0 cdrom 次に /etc/fstabのcdromを /dev/scd0 /mnt/cdrom iso9660 noauto,owner,ro,user 0 0 にして mountしようとしたら このカーネルは /dev/cdromをブロックデバイスとしては認識しませんと表示されます。どうしたら元に戻りますか?改善しますか?

  • RedHat9のディスククォータの設定方法

    いつもお世話になります。 RedHat9のディスククォータをしたいのですが、参考にしている本には、 /etc/fstab の中には /dev/hda3 /home ext3 defaults 1 1 というものがあって、defaults を usrquota に変更しなさいと書いてあるのですが、私のサーバーの/etc/fstab の中には、存在しません。 どこを変更すればよいのでしょうか。 私のサーバーの /etc/fstab の中は以下のとおりです。 LABEL=/ / ext3 defaults 1 1 LABEL=/boot /boot ext3 defaults 1 2 none /dev/pts devpts gid=5,mode=620 0 0 none /proc proc defaults 0 0 none   /dev/shm tmpfs defaults 0 0 /dev/hda3 swap swap defaults 0 0 /dev/cdrom /mnt/cdrom udf,iso9660 nouto,owner,kudzu,ro 0 0 /dev/fd0 /mnt/floppy auto oauto,owner,kudzu 0 0 見づらくてすいません。お願いします。

  • ドライブが空だとRedHat9 起動しません

    HL-DT-ST DVDRAM GMA-4020BというIDEのMULTIドライブ に、CDやDVD(中身問わない)が入っていないと、Boot時に、 Updating /etc/fstab で止まりOS(RedHat9)が起動しません。ドライブが空でも起動するにはどうすれば良いのでしょうか?(T_T) ■/etc/fstabは以下です。 LABEL=/ / ext3 defaults 1 1 LABEL=/boot /boot ext3 defaults 1 2 none /dev/pts devpts gid=5,mode=620 0 0 none /proc proc defaults 0 0 none /dev/shm tmpfs defaults 0 0 /dev/sda3 swap swap defaults 0 0 /dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0 /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0 ■df -k /dev/sda2 7637400 1478344 5771088 21% / /dev/sda1 101089 14521 81349 16% /boot none 127632 0 127632 0% /dev/shm

  • マウントでドライブが認識されない(FedoraCore6)

    私は、Let's noteCF-Y4をサーバーにしたいと思っています。 そこで中身は全て消し、FedoraCore6をインストールしました。 さらに、WEBサーバーとしてCDからインストールしたいのですが、 CDドライブが認識されなくなってしまいました。 mountをしても、何も出ません。 (gnome-mount -d /dev/cdrom) ブートのときはドライブは普通に利用できたのですが。。。 サーバーについては初心者ですが、 ぜひとも、よろしくお願いします。

  • umountせずに、CD-ROMを取り出したら再起動後にCD-ROMをmountできなくなりました。

    こんにちは Linuxを使用時にCD-ROMをマウントし、用が済んだのでumountせずに、取り出してOSを終了させました. 翌日、OSを起動して、再度mountしたところ、 "mount: マウントポイント /mnt/cdrom が見つかりません"とでました。 この場合、どうしたら正常にマウントできるようになるのでしょうか。