• ベストアンサー
  • すぐに回答を!

謎!? /etc/rc.d/init.d/qmail.shのtcpserverでのpop3dの起動でホスト名が反映されない?

宜しくお願い致します。 RedHat9、qmail-1.03でdaemontools-0.76を使用しています。 以前はold.co.jpという名称でメールtcpserverを運営してました。 こないだ、new.dyndns.comに切換えようとしたのですが # hostname new.dyndns.com # grep -lr old.co.jp /etc/rc.d # grep -lr new.dyndns.com /etc/rc.d /etc/rc.d/init.d/qmail.sh #cat /etc/rc.d/init.d/qmail.sh | grep -v ^# | grep -v ^$ PATH=/var/qmail/bin:/usr/local/bin:/bin:/usr/bin [ -f /var/qmail/rc ] || exit 0 case "$1" in start) : #For POP3 echo -n 'qmail-pop3d starting.' /usr/local/bin/tcpserver -x /etc/tcpserver/pop3d_rules.cdb 0 \ pop-3 /var/qmail/bin/qmail-popup new.dyndns.com /bin/checkpassword \ /var/qmail/bin/qmail-pop3d Maildir 2>&1 | /var/qmail/bin/splogger pop3d 3 & echo touch /var/lock/qmail ulimit -a ;; : となっているにも拘らずリブートしても何故か # ps ax | grep pop 7315 ? S 0:00 supervise qmail-pop3d 7864 ? S 0:00 /usr/local/bin/tcpserver -x /etc/tcpserver/pop3d_rule s.cdb 0 pop-3 /var/qmail/bin/qmail-popup old.co.jp /bin/checkpassword /var/qmai l/bin/qmail-pop3d Maildir 16439 pts/1 S 0:00 grep pop と以前のホスト名のままです。何か他にも設定必要なのでしょうか?? # kill -HPU 7864 としても相変わらずなのです。

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数186
  • ありがとう数2

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.2
  • Lean
  • ベストアンサー率72% (435/603)

以下を実行した場合、何かヒットするファイルがありますか? # grep -lr old.co.jp /service もしくは、svscanbootから起動されているはずのsvscanの引数に指定されているディレクトリに対して「grep -lr old.co.jp」を実行したら何かヒットするファイルがありますか?

共感・感謝の気持ちを伝えよう!

質問者からのお礼

大変有難うございます。 お陰さまで解決いたしました。m(_ _)m

質問者からの補足

有難うございます。 > もしくは、svscanbootから起動されているはずのsvscanの引数に指定されているディ > レクトリに対して「grep -lr old.co.jp」を実行したら何かヒットするファイルがあ > りますか? よくよく調べてみましたら # cat /command/svscanboot : /command/svc -dx /var/service/* /var/service/*/log env - PATH=$PATH svscan /var/service 2>&1 | \ env - PATH=$PATH readproctitle service errors: ................................................................................................................................................................................................................................................................................................................................................................................................................ となっていまして、 # cat /var/qmail/supervise/qmail-pop3d/run | grep old.co.jp pop-3 /var/qmail/bin/qmail-popup old.co.jp /bin/checkpassword \ となっていました!!!これが原因でした!!! それで、 daemonツールを停止して # cat /var/qmail/supervise/qmail-pop3d/run | grep new.dyndns.com pop-3 /var/qmail/bin/qmail-popup new.dyndns.com /bin/checkpassword \ と書換えて、 aemonツールを起動させて # ps ax | grep pop 7315 ? S 0:00 supervise qmail-pop3d 27238 ? S 0:00 /usr/local/bin/tcpserver -x /etc/tcpserver/pop3d_rules.cdb 0 pop-3 /var/qmail/bin/qmail-popup new.dyndns.com /bin/checkpassword /var/qmail/bin/qmail-pop3d Maildir 27252 pts/9 S 0:00 grep pop となり、「new.dyndns.com」が反映されました。

その他の回答 (1)

  • 回答No.1
  • Lean
  • ベストアンサー率72% (435/603)

見当違いになるかも知れませんが。 各ランレベル用ディレクトリ(/etc/rc.d/rc2.dとか)配下にqmail起動用スクリプトは存在しないのですか? それぞれのランレベル用に起動スクリプトが存在するはずなのですが、存在するならその中の記述はどうですか?

共感・感謝の気持ちを伝えよう!

質問者からの補足

有難うございます。 > 見当違いになるかも知れませんが。 > 各ランレベル用ディレクトリ(/etc/rc.d/rc2.dとか)配下にqmail起動用スクリプトは > 存在しないのですか? 確認してみましたが特に見当たりません。 もしあれば # grep -lr old.co.jp /etc/rc.d でヒットするはずですよね。 よくよく調べてみましたらdaemonツールでの起動のようです。 # cat /etc/inittab | grep -v ^# | grep -v ^$ id:3:initdefault: : SV:123456:respawn:/command/svscanboot という風になっています。ランレベル3でブートしてます。 # ls -l /command 合計 4 lrwxrwxrwx 1 root root 41 3月 26 2004 envdir -> /package/admin/daemontools/command/envdir* lrwxrwxrwx 1 root root 44 3月 26 2004 envuidgid -> /package/admin/daemontools/command/envuidgid* lrwxrwxrwx 1 root root 41 3月 26 2004 fghack -> /package/admin/daemontools/command/fghack* lrwxrwxrwx 1 root root 43 3月 26 2004 multilog -> /package/admin/daemontools/command/multilog* lrwxrwxrwx 1 root root 43 3月 26 2004 pgrphack -> /package/admin/daemontools/command/pgrphack* lrwxrwxrwx 1 root root 48 3月 26 2004 readproctitle -> /package/admin/daemontools/command/readproctitle* lrwxrwxrwx 1 root root 42 3月 26 2004 setlock -> /package/admin/daemontools/command/setlock* lrwxrwxrwx 1 root root 44 3月 26 2004 setuidgid -> /package/admin/daemontools/command/setuidgid* lrwxrwxrwx 1 root root 44 3月 26 2004 softlimit -> /package/admin/daemontools/command/softlimit* lrwxrwxrwx 1 root root 44 3月 26 2004 supervise -> /package/admin/daemontools/command/supervise* lrwxrwxrwx 1 root root 38 3月 26 2004 svc -> /package/admin/daemontools/command/svc* lrwxrwxrwx 1 root root 39 3月 26 2004 svok -> /package/admin/daemontools/command/svok* lrwxrwxrwx 1 root root 41 3月 26 2004 svscan -> /package/admin/daemontools/command/svscan* lrwxrwxrwx 1 root root 45 3月 26 2004 svscanboot -> /package/admin/daemontools/command/svscanboot* -rwxr-xr-x 1 root root 748 3月 26 2004 svscanboot~* lrwxrwxrwx 1 root root 41 3月 26 2004 svstat -> /package/admin/daemontools/command/svstat* lrwxrwxrwx 1 root root 41 3月 26 2004 tai64n -> /package/admin/daemontools/command/tai64n* lrwxrwxrwx 1 root root 46 3月 26 2004 tai64nlocal -> /package/admin/daemontools/command/tai64nlocal* # grep -lr old.co.jp /package/admin/daemontools/command でもヒットしませんでした。 > それぞれのランレベル用に起動スクリプトが存在するはずなのですが、存在するなら > その中の記述はどうですか? ファイル名頭にSフラグが付いているのが起動されるのですよね。 再度、チェックしてみましたがどうも見当たりません。 お手数お掛けしてしてスミマセン。

関連するQ&A

  • rc.localを使ってのqmailの起動失敗します

    http://www.stackasterisk.jp/tech/systemConstruction/qmail01_01.jsp ↑ここを参考にqmailをインストールしました。 OSはREDHAT7.3です /etc/rc.d/rc.localの設定です csh -cf '/var/qmail/rc &' /usr/local/bin/tcpserver -u qmaild -g nofiles -x /var/qmail/control/tcprules.dat 0 25 /var/qmail/bin/qmail-smtpd & /usr/local/bin/tcpserver 0 110 /var/qmail/bin/qmail-popup hoge.net /bin/checkpas sword /var/qmail/bin/qmail-pop3d Maildir & /etc/rc.d/rc.localすると tcpserver: fatal: unable to bind: address already used tcpserver: fatal: unable to bind: address already used このようなエラーがでます。 原因わかるかたいましたらよろしくおねがいします

  • qmailのpop3が authorization faild

    只今、qmailの構築中ですが、サーバ単体でのテストで どうしても受信がエラーになってしまします どなたか助けてください qmail自体というよりも、shellの使い方が間違っている 気がします 環境: redhat6.2、qmail-1.03、 tcpserver(ucspi-tcp-0.88)、 checkpassword-0.81、 Maildir形式、pop(apopではない) 現象: (1)qmail(qmail-inject)にて自分宛に送る /home/user/Maildir/new/にデータ存在確認(成功) (2)スクリプトを/var/qmail/rc(後述)にて作成 (3)自分自身でメール受信 (失敗) > telnet localhost pop3 Trying 127.0.0.1... Connected to localhost.localdomain. Escape character is '^]'. +OK <812.998537941@l2.sunam.com> >user yamada +OK >pass **** -ERR authorization failed Connection closed by foreign host. /var/log/maillogには、 -ERR this user has no $HOME/Maildir ? と出力される ※尚、ユーザホームに、Maildirは作成済 ※スクリプトの内容を直接手入力するとなぜか正常に 受信できます!? スクリプトの問題? どなたか、お助けください よろしくお願いします ※/var/qmail/rc(起動スクリプト) #!/bin/sh exec env - PATH="/var/qmail/bin:$PATH" \ qmail-start ./Maildir/ splogger qmail & #qmail for tcpserver /usr/local/bin/tcpserver -x /etc/tcp.smtp.cdb -v \ -u 506 -g 505 0 smtp /var/qmail/bin/qmail-smtp \ 2>&1 | /var/qmail/bin/splogger smtpd 3 & #qmail-pop3d for tcpserver /usr/local/bin/tcpserver -x /etc/tcp.pop3.cdb \ -v 0 pop-3 /var/qmail/bin/qmail-popup \ www.doamin.com /bin/checkpassword \ /var/qmail/bin/qmail-pop3d Maildir 2>&1 \ | /var/qmail/bin/splogger pop3d 3 & 以上

  • qmailの送受信が遅くて困っています

    qmailをインストールしたのですが、メーラーでの送受信が、送信時で約90秒、受信時で約60秒かかってしまい困っています。 SSHでログインして【echo to:example@com | /var/qmail/bin/qmail-inject】とコマンドを叩いた場合は遅延なく受信できている状態です。 サーバーに関する設定情報は以下のようになっております。 ■DNS正引き mail.hoge.jp A 1xx.xxx.xxx.xxx hoge.jp MX mail.hoge.jp hoge.jp A 1xx.xxx.xxx.xxx www.hoge.jp A 1xx.xxx.xxx.xxx ■DNS逆引き 1xx.xxx.xxx.xxx hoge.jp ※DNS確認ツールで確認済み ■/var/qmail/control/defaultdomain hoge.jp ■/var/qmail/control/defaulthost hoge.jp ■/var/qmail/control/locals localhost hoge.jp mail.hoge.jp ■/var/qmail/control/me mail.hoge.jp ■/var/qmail/control/plusdomain hoge.jp ■/var/qmail/control/rcpthosts localhost hoge.jp mail.hoge.jp ■/etc/tcp.smtp 127.:allow,RELAYCLIENT="" 192.168.0.:allow,RELAYCLIENT="" :allow,RELAYCLIENT="" ■/etc/tcp.pop3 :allow ■/var/qmail/rc #!/bin/sh exec env - PATH="/var/qmail/bin:$PATH" \ qmail-start ./Maildir/ splogger qmail & /usr/local/bin/tcpserver -H -R -v \ -x /etc/tcp.smtp.cdb 0 25 \ /usr/local/bin/rblsmtpd -r bl.spamcop.net -r list.dsbl.org -r sbl-xbl.spamhaus.org \ /var/qmail/bin/qmail-smtpup mail.hoge.jp \ /var/qmail/bin/checkpassword \ /var/qmail/bin/qmail-smtpd 2>&1 \ | /var/qmail/bin/splogger smtpd & /usr/local/bin/tcpserver -H -R -v \ -x /etc/tcp.pop3.cdb 0 110 \ /var/qmail/bin/qmail-popup mail.hoge.jp \ /var/qmail/bin/checkpassword \ /var/qmail/bin/qmail-pop3d Maildir 2>&1 \ | /var/qmail/bin/splogger pop3d & ■ps ax | grep qmail 結果 26580 pts/0 S 0:00 qmail-send 26581 pts/0 S 0:00 /usr/local/bin/tcpserver -H -R -v -x /etc/tcp.smtp.cdb 0 25 /usr/local/bin/rblsmtpd -r bl.spamcop.net -r list.dsbl.org -r sbl-xbl.spamhaus.org /var/qmail/bin/qmail-smtpup mail.hoge.jp /var/qmail/bin/checkpassword /var/qmail/bin/qmail-smtpd 26582 pts/0 S 0:00 /var/qmail/bin/splogger smtpd 26584 pts/0 S 0:00 splogger qmail 26585 pts/0 S 0:00 qmail-lspawn ./Maildir/ 26587 pts/0 S 0:00 qmail-rspawn 26588 pts/0 S 0:00 qmail-clean 26705 pts/0 S+ 0:00 grep qmail 問題点等、何かご教示いただければと思いますのでよろしくお願いいたします。

  • qmai-smtpup エラー

    qmail-1.03 qmail-vida-0.53 ucspi-tcp-0.88 checkpassword-0.90 を普通にインストールしました。 qmail-1.03にqmail-date-localtime.patchをあてました。 特に難しいことはしていないつもりです。 以下のコマンドでsmtpを起動しました。 exec env - ALLOWPLAIN="" DOMAINOWNER="" /usr/local/bin/tcpserver -R -H -l0 -v -x /etc/tcp.smtp.cdb 0 smtp /var/qmail/bin/qmail-smtpup DOMAIN.jp /bin/checkpassword DOMAIN.jp 2>&1 | /var/qmail/bin/splogger smtpd 4 & すると warning: dropping connection, unable to run /var/qmail/bin/qmail-smtpup: file does not exist とmaillogに残ります。 /var/qmail/binにqmail-smtpupがありません。 qmail-popupはあります。 どうしたらいいのでしょうか? また、起動コマンドの最後の"4"という数字の意味はどのようないみなのでしょうか? よろしくお願いします。

  • POP before SMTPがうまくいかない

    現在、solaris9+qmail1.03+tcpserver+relay-ctrl3.1.1+daemontools0.76でpop before smtp に対応したサーバを構築しています。POPでアクセスすると、/var/spool/relay-ctrl/allow にアクセスしてきた端末のIPアドレスが格納されるようにはなりました。しかし、 事前にPOPをしないユーザ(先のディレクトリにIPアドレスが格納」されていないユーザ) でもSMTPができてしまいます。 ちなみに、qmail-smtpのRUNスクリプトは以下のようになっています。 exec /usr/local/bin/envdir /etc/relay-ctrl /usr/local/bin/relay-ctrl-chdir /usr/local/bin/tcpser ver -vR -c40 -x /etc/tcp.smtp.cdb -u 110 -g 107 0 25 /usr/local/bin/relay-ctrl-check /var/qmail/ bin/qmail-smtpd 2>&1 どこかおかしいところがあるのでしょうか?

  • qmail Part2

    /var/qmail/rc の中身を ./Maildir に変更しました。 #/var/qmail/bin/maildirmake /etc/skel/Maildir を実行して #useradd user00 を作成し中身を確認すると /home/user00/Maildir /home/user00/.qmail は正常に作成されておりました。 #/var/qmail/rc & を実行すると 「1」 685 #PATH=/var/qmail/bin:/bin:/sbin:/usr/bin:/var/sbin:/usr/local/bin:/usr/local/sbin:/usr/bin/X11:/usr/X11R6/bin と出ます。(これって動いていないんですよね?) BINDは動作している様子です。

  • qmail 587にすると外部から受信が出来なくなる

    こんばんわ。 運用の方にも書いたのですが、 纏まってなかったので、消せるようになったら、 そちらは削除しておきます。 それまでマルチになりますが、すいません。。。 現象としては、 OP25Bの対策として587でqmailを起動すると、 外部からのメールが受信出来なくなります。 25に戻すと外部からも送受信出来ますので、 587に変更した箇所が問題点と思われます。 回避方法は御座いませんでしょうか? 環境 Fedora7 qmail+vpopmail+qmail-vida-0.53+ucspi-tcp-0.88 .qmail-defaultの中身は、 | /var/qmail/bin/fastforward -p -d /etc/aliases.cdb | /var/qmail/bin/dot-forward `/home/vpopmail/bin/vuserinfo -d $EXT@$HOST`/.forward | /home/vpopmail/bin/vdelivermail '' delete 変更した点、 # vi /etc/init.d/qmail 上略 # SMTP tcpserver -qv -l0 -HR -u `id -u vpopmail` -g `id -g vpopmail` \ -x /home/vpopmail/etc/tcp.smtp.cdb 0 smtp \ qmail-smtpd `hostname` /home/vpopmail/bin/vchkpw /bin/true 2>&1|\ splogger smtp & 下略 から 上略 # SMTP tcpserver -qv -l0 -HR -u `id -u vpopmail` -g `id -g vpopmail` \ -x /home/vpopmail/etc/tcp.smtp.cdb 0 587 \ qmail-smtpd `hostname` /home/vpopmail/bin/vchkpw /bin/true 2>&1|\ splogger smtp & 下略 に変更しました。 -x /home/vpopmail/etc/tcp.smtp.cdb 0 smtp \ qmail-smtpd の一行のsmtpを587に変更しただけです。 # /etc/init.d/qmail restart 確認した事は下記です。 # ps aux | grep qmail qmails 4821 0.0 0.0 1768 416 pts/0 S 19:29 0:00 qmail-send vpopmail 4822 0.0 0.0 1616 324 pts/0 S 19:29 0:00 tcpserver -qv -l0 -HR -u 89 -g 89 -x /home/vpopmail/etc/tcp.smtp.cdb 0 587 qmail-smtpd localhost.localdomain /home/vpopmail/bin/vchkpw /bin/true vpopmail 4824 0.0 0.0 1796 532 pts/0 S 19:29 0:00 tcpserver -qvRH -u 89 -g 89 0 pop3 qmail-popup localhost.localdomain /home/vpopmail/bin/vchkpw qmail-pop3d Maildir qmaill 4833 0.0 0.0 1732 480 pts/0 S 19:29 0:00 splogger qmail root 4834 0.0 0.0 1732 328 pts/0 S 19:29 0:00 qmail-lspawn |dot-forward .forward?./Maildir/ qmailr 4835 0.0 0.0 1728 332 pts/0 S 19:29 0:00 qmail-rspawn qmailq 4836 0.0 0.0 1720 348 pts/0 S 19:29 0:00 qmail-clean root 4840 0.0 0.0 1952 536 pts/0 S+ 19:29 0:00 grep qmail # /usr/sbin/lsof -i:587 tcpserver 4822 vpopmail 3u IPv4 9725221 TCP *:submission (LISTEN) # /usr/sbin/lsof -i:25 tcpserver 4824 vpopmail 3u IPv4 9725242 TCP *:pop3 (LISTEN) # view /var/log/maillog Jul 29 19:31:57 localhost pop3: 1217327517.240915 tcpserver: pid 4975 from 外部IP Jul 29 19:31:57 localhost pop3: 1217327517.242517 tcpserver: ok 4975 :サーバーIP:110 :外部IP::1916 Jul 29 19:31:57 localhost pop3: 1217327517.354649 tcpserver: end 4975 status 256 Jul 29 19:31:57 localhost pop3: 1217327517.354704 tcpserver: status: 0/40

  • qmailを起動するとプロンプトが帰ってこない。

    Linux初心者です。OSはFedora core3です。 qmailをインストール中ですが、シェルコマンドでqmailを起動すると#プロンプトが戻ってこない状態になってしまいます。 コマンド # csh -cf `/var/qmail/rc &` rcは/var/qmail/homeからcpして.Mailboxを./Maildir/に変更しています。 内容 exec env - PATH="/var/qmail/bin:$PATH" \ qmail-start ./Maildir/ splogger qmail です。 一度、シェルを終了して、また、起動して、ps auxでqmailの動作状態を確認すると、 qmail-send, splogger qmail, qmail-lspawn ./Maildir/ , qmail rspawn, qmail-clean が動作中となっています。どのような原因でqmailを起動するとプロンプトが帰ってこない状態になっていまっているのでしょうか。ご教授よろしくお願いします。 情報不足もあると思います。必要な情報はご要求願います。

  • tcpserverのオプションの意味

    tcpserverを使ってqmailを起動する際に、 tcpserver -HR -x /etc/tcp.smtp.cdb -u 1001 -g 1001 0 smtp /var/qmail/bin/qmail-smtpd & のようにコマンドを入れますが、GIDの「1001」とポート番号「smtp」の間の「0」は何のオプションなのでしょう? いろいろと調べましたが、「0」以外のものが見当たらないのです。 よろしくお願いします。

  • /etc/rc.d/rc.localの書き方

    Linux初心者で操作を勉強しています。 Linuxの起動時にgnome-terminalを起動させたいと思っています。 /etc/rc.d/rc.localにコマンドを記述すれば良い というところまで調べ、 このファイルに gnome-teriminal と記述しました。 /etc/rc.d/rc.local ------------------------------------------------- #!/bin/sh # # This script will be executed *after* all the other init scripts. # You can put your own initialization stuff in here if you don't # want to do the full Sys V style init stuff. gnome-terminal    ←これを追加 touch /var/lock/subsys/local ------------------------------------------------ 上記のようにしましたが、・・・gnome-terminalが起動しません。 書き方間違っているのでしょうか。 起動時にgnome-terminal を起動させる方法を教えてください。 よろしくお願いします。 環境:CentOS6