• ベストアンサー
  • 困ってます

LinuxにOracle10のExpress無料版をインストールで依存性の欠如: libaio

LinuxにOracle10のExpress無料版をインストールするために rpm -Uvh oracle-xe-univ-10.2.0.1-1.0.i386.rpm としましたが、 エラー:依存性の欠如: libaio >= 0.3.96 は oracle-xe-univ-10.2.0.1-1.0.i386に必要とされています。 と依存関係でエラーになりました。 どうすれば良いのでしょうか?

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数354
  • ありがとう数0

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.2

distribution を書かないと 適当な、libaio のrpm を入手して install して下さいとなります。 CentOS が、5 になったので 毎日整備している所ですが libaio は、特にrepository を増やさなくても CentOS5では、pirut でinstall 出来ます。 rpmforge は追加しましたが。 rpm だから fedora,CentOS,OpenSUSE,Vine あたりになりますが

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • apacheのアップデートで依存性の欠如

    RedHatLinux7.0でapache1-3-22へアップデートしようと思い、rpmファイルをgetしました。 下記の様にしたところ、メッセージが出ました。 # rpm -Uvh /tmp/rpm/apa* エラー: 依存性の欠如: mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています mod_putは apache-1.3.22-5.7.1 に必要とされています mod_throttleは apache-1.3.22-5.7.1 に必要とされています libexpat.so.0 は apache-1.3.22-5.7.1 に必要とされています libmm.so.11 は apache-1.3.22-5.7.1 に必要とされています この内の、mod*の3つのrpmは見つけてきたのですが、libexpat.so.0,libmm.so.11というのが見つかりませんでした。 これらは一般的にどこから見つければいいのでしょうか。 また、過去の質問で、httpdを止めてやるとうまくいく様なのでやってみましたところ下記のようでした。 # rpm -Uvh /tmp/rpm/mod* /tmp/rpm/apa* エラー: 依存性の欠如: libexpat.so.0 は apache-1.3.22-5.7.1 に必要とされています libmm.so.11 は apache-1.3.22-5.7.1 に必要とされています やはり、この2つのファイルが欠如として出てしまいます。 過去のアップデートのrpmを全てgetして、rpm -Uvh等とすれば解決するのでしょうか? また、インストールしたLinuxは、できるLinuxサーバという本についていた物ですが、そもそもこれが問題で正式な物でインストールするべきなのでしょうか? 宜しくお願いいたします。

  • Vine4.2へのOracle10gXEのインストールでエラー

    こんにちは。 現在、Vine4.2へのOracle10g XEをインストールしたいのですが rootでインストール時に 「エラー:%pre(oracle-xe-univ-10.2.0.1-1.0.i386)スクリプトの実行に失敗しました。」 というメッセージが表示されますがなぜでしょうか? 事前にlibaio-0.3.104-2.i386.rpmのインストールは完了しています。 どなたかご教授下さい。

  • MySQL5.0.11のインストールでcoreutils依存のエラー

    VineLinux 2.6に MySQL5.0.11をインストールしようとしましたが coreutils依存のエラーが発生した。 ・uname -aの結果 Linux localhost.localdomain 2.4.22-0vl2.10 #1 2004年 1月 9日 金曜日 23:08:04 EST i686 unknown ・ダウンロードしたRPM http://dev.mysql.com/downloads/mysql/5.0.html Linux x86 RPM downloads MySQL-bench-5.0.11-0.i386.rpm MySQL-client-5.0.11-0.i386.rpm MySQL-devel-5.0.11-0.i386.rpm MySQL-embedded-5.0.11-0.i386.rpm MySQL-server-5.0.11-0.i386.rpm MySQL-shared-5.0.11-0.i386.rpm MySQL-shared-compat-5.0.11-0.i386.rpm ・MySQL-shared-5.0.11-0.i386.rpmでcoreutilsの依存エラーが発生する。 rpm -Uvh MySQL-shared-5.0.11-0.i386.rpmとしたところ、 エラー: 依存性の欠如: coreutilsは MySQL-server-5.0.11-0 に必要とされています coreutilsとは何でしょうか? これは rpmなどのでインストールできるのでしょうか? 入手先も知りたいです。

    • ベストアンサー
    • MySQL

その他の回答 (1)

  • 回答No.1
  • koko_u_
  • ベストアンサー率18% (459/2509)

>どうすれば良いのでしょうか? libaio パッケージをどこかから探してきてインストールする。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • PHP4インストール エラー: 依存性の欠如:

    CentOS5.2にphp-4.2.2-17.1.i386.rpmをダウンロードして、 rpm -ivh php-4.2.2-17.2.i386.rpmでインストールしようとしましたが、エラーが発生しました。正常にインストールするにはどうしたらいいのでしょうか? エラー: 依存性の欠如: httpd-mmn = 20020628 は php-4.2.2-17.2.i386 に必要とされています libcom_err.so.3 は php-4.2.2-17.2.i386 に必要とされています libcrypto.so.4 は php-4.2.2-17.2.i386 に必要とされています libcurl.so.2 は php-4.2.2-17.2.i386 に必要とされています libdb-4.0.so は php-4.2.2-17.2.i386 に必要とされています libgd.so.1.8 は php-4.2.2-17.2.i386 に必要とされています libltdl.so.3 は php-4.2.2-17.2.i386 に必要とされています libpspell-modules.so.1 は php-4.2.2-17.2.i386 に必要とされています libpspell.so.4 は php-4.2.2-17.2.i386 に必要とされています libssl.so.4 は php-4.2.2-17.2.i386 に必要とされています libstdc++.so.5 は php-4.2.2-17.2.i386 に必要とされています libttf.so.2 は php-4.2.2-17.2.i386 に必要とされています 参考サイト http://tech.firebird.gr.jp/firebird/index.php?firebird_xsite=66

  • redhat系Linuxで、Sambaをインストールしたいのですが、、

    redhat系Linuxで、Sambaをインストールしたいのですが、、、 以下の様なエラーが出てしまい、libcom_err.so.3をダウンロードしようとしてもできません。。。このエラーの意味が分かりません。どなたか詳しい方がいらっしゃいましたら、教えて頂けませんか? [root@abc /]# rpm -ivh samba-3.0.0-2iconv.i386.rpm エラー: 依存性の欠如: libcom_err.so.3 は samba-3.0.0-2iconv.i386 に必要とされています libiconv.so.2 は samba-3.0.0-2iconv.i386 に必要とされています liblber.so.2 は samba-3.0.0-2iconv.i386 に必要とされています libldap.so.2 は samba-3.0.0-2iconv.i386 に必要とされています libreadline.so.4 は samba-3.0.0-2iconv.i386 に必要とされています

  • インストールの際の依存関係

    私はRedHat Linux 8.0にて自宅Webサーバを運用しています。このたび、PHP+MySQLで動作するWeblogを導入しようと思いました。このWeblogではPHP ver.4.3以上が奨励されているので、いろいろと探してみたところ、次の場所にrpmパッケージが置かれているのを見つけました。 http://www.btree.org/linux/packages/redhat/8.0/i386/php-4.3.1-1/ しかし、インストールしようとすると、次のように「依存関係があるからダメです。」というメッセージが出てきます。 [root@hogehoge root]# rpm -Uvh http://www.btree.org/中略/php-mysql-4.3.1-1.i386.rpm http://www.btree.org/中略/php-mysql-4.3.1-1.i386.rpm を取得しています エラー: Failed dependencies: libmysqlclient.so.10 is needed by php-mysql-4.3.1-1 また、同様にhttpd-2.0.45-1も公開されていたのでアップデートを試みましたが、同じく依存関係の問題でインストールできませんでした。 [root@nadia root]# rpm -Uvh http://www.btree.org/中略/httpd-2.0.45-1/httpd-2.0.45-1.i386.rpm http://www.btree.org/中略/httpd-2.0.45-1.i386.rpm を取得しています エラー: Failed dependencies: libapr.so.0 is needed by (installed) mod_perl-1.99_05-3 libaprutil.so.0 is needed by (installed) mod_perl-1.99_05-3 このような場合、rpm --force 指定で強制インストールして良いのでしょうか(良くないから警告されているんでしょうけど^^;)。セキュリティ上の観点からも新しいものに更新しておきたいんですが、ソースからビルドする力量はないので、何とかrpm(またはapt-get)で対処したいのです。 よろしくお願いします。

  • RPMパッケージのアップグレードについて

    APACHEをRPMパッケージの最新版(apache-1.3.22-5.7.1)にアップグレードしたいのですが、 現在下記の様な状態で悩んでいます。 # rpm -Fvh apache*.rpm でアップグレードしようとすると、 エラー:依存性の欠如 mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています mod_putは apache-1.3.22-5.7.1 に必要とされています mod_throttleは apache-1.3.22-5.7.1 に必要とされています というエラーが出ます。 次に、依存性の欠如で指摘されたファイルも一緒にアップグレードしようと、 以下のコマンドを入力しました。 # rpm -Fvh apache-*.rpm mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3 .i386.rpm mod_put-1.3-2.i386.rpm そしたら、またしても エラー: 依存性の欠如: mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています mod_putは apache-1.3.22-5.7.1 に必要とされています mod_throttleは apache-1.3.22-5.7.1 に必要とされています と表示されてしまいました。 インストールされているか、rpm -q で確認すると、 インストールされていません と返ってきました。 じゃあ、インストールしよう、と思って #rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3.i386.rpm mod_put-1.3 -2.i386.rpm と入力したら エラー: 依存性の欠如: apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します apache < 1.3.22-1 mod_throttle-3.1.2-3 と競合します apache < 1.3.22-1 mod_put-1.3-2 と競合します と、返ってきました。 一体、どのようにしたら無事アップグレードできるのでしょうか? それとも、現バージョンのAPACHEを削除してから新バージョンのインストールを するしかないのでしょうか? 使用OS:Redhat Linux 7.1J

  • opensshのアップグレート

    RH7.3を使用しています。 openssh-3.1p1-14からopenssh-3.7.1p2へアップグレード をする為にrpmを探して、以下のrpmをダウンロードしました。 openssh-3.7.1p2-rbt.rh73.1.i386.rpm openssh-server-3.7.1p2-rbt.rh73.1.i386.rpm openssh-clients-3.7.1p2-rbt.rh73.1.i386.rpm 以下の操作をすると rpm -Uvh openssh*-3.7.1p2-rbt.rh73.1.i386.rpm エラー: 依存性の欠如: openssh = 3.1p1-14は openssh-askpass-gnome-3.1p1-14 に必要とされています openssh = 3.1p1-14は openssh-askpass-3.1p1-14 に必要とされています と表示されます。とりあえず分からないので openssh-askpass-3.7.1p2-2.i386.rpm openssh-askpass-gnome-3.7.1p2-2.i386.rpm を入れたらどうにかなるかな?と思い rpm -Uvh openssh-askpass*-3.7.1p2-2.i386.rpm を実行してみると エラー: 依存性の欠如: openssh = 3.7.1p2-2は openssh-askpass-3.7.1p2-2 に必要とされています openssh = 3.7.1p2-2は openssh-askpass-gnome-3.7.1p2-2 に必要とされています と表示されます。 依存性の欠如を解決してopensshをアップグレードするには、どうしたら良いでしょうか?宜しくお願いします。

  • RedhatLinux7.1J-apacheのアップグレード失敗します

    RedhatLinux7.1Jを使用しています。 http://www.jp.redhat.com/support/errata/RHSA/RHSA-2001-126J.html 以上のサイトから、7.1用のApache最新版を入手し、 インストールしようとした所、以下のエラーが表示されて インストールに失敗してしまいます。 apache本体を導入しようとすると、「mod_~.rpm」がないって怒られて、 「mod_~.rpm」を導入しようとすると、apacheと競合すると怒られ、 結局アップグレードできないんです・・・。 <その1>  rpm -Fvh apache-1.3.22-1.7.1.i386.rpm   ↓  エラー: 依存性の欠如:   mod_bandwidthは apache-1.3.22-1.7.1 に必要とされています   mod_putは apache-1.3.22-1.7.1 に必要とされています   mod_throttleは apache-1.3.22-1.7.1 に必要とされています <その2>  rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm  rpm -ivh mod_put-1.3-2.i386.rpm  rpm -ivh mod_throttle-3.1.2-3.i386.rpm   ↓  エラー: 依存性の欠如:   apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します

  • PostgreSQLのアンインストール方法

    PostgreSQLの削除手順を教えてください。 rpmコマンドで削除してもエラーになります。 ■環境 RedhatLinux 5.4 PostgreSQL8.4 ■実施手順 # rpm -qa |grep post postgresql-libs-8.1.11-1.el5_1.1 # rpm -e postgresql-libs-8.1.11-1.el5_1.1 エラー: 依存性の欠如: libpq.so.4 は (インストール済み)apr-util-1.2.7-7.el5.i386 に必要とされています # rpm -e apr-util-1.2.7-7.el5 postgresql-libs-8.1.11-1.el5_1.1 エラー: 依存性の欠如: libaprutil-1.so.0 は (インストール済み)httpd-2.2.3-22.el5.i386 に必要とされています libaprutil-1.so.0 は (インストール済み)mod_perl-2.0.4-6.el5.i386 に必要とされています libaprutil-1.so.0 は (インストール済み)subversion-1.4.2-4.el5.i386 に必要とされています # rpm -e --force postgresql-libs-8.1.11-1.el5_1.1 rpm: インストール、アップグレード、ソース削除、スペックファイル削除時のみ強制できます。 以上、よろしくお願いいたします。

  • Linux 6.2 でパッケージインストール RPM コマンドを使用した時にエラーがでる

    OS Linux6.2 で rpm コマンドを使用した時にエラーになる # rpm -Uvh bind-8.2.2_P7-1.i386.rpm をすると以下のエラーが出る メジャー番号<=3のパッケージのみこのバージョンのRPMはサポートされています エラー:bind-8.2.2_P7-1.i386.rpm cannot be installed 以上のメッセージが出てパッケージをインストールできないので 教えてください

  • gccのインストール

    RedHatLinux5.2です。 gccをインストールしようとして gcc-4.4.1.2-9.i386.rpmをダウンロードしました。rpm -Uvhすると、 依存性の欠如として binutils >= 2:2.16.90.0.1-0.3 libc.so.6(GLIBC_2.3) libgcc4 = 5:4.1.2-9 rpnlib(PartialHardlinkSets) <= 4.0.4-1 が必要とされているとでます。 (1)binutilsの入手方法を教えてください。 (2)GLIBCのインストールにgccが必要だと言われたのでgccを入れているのですが、gccのインストールにGLIBCが必要だと言われています。どうしたらよいのでしょうか? Linux初心者です。よろしくお願いします。

  • Linuxのパッケージインストール

    CentOSにおいて、以下のパッケージをrpmコマンドを使用してインストールしようとしてますが、依存性の欠如でインストールすることができません。 依存性が欠如しているパッケージ名は表示されるのですが、その名前のパッケージ名はCentOSのisoファイルの中には見受けられません。 どのようにしてインストールすべきかご教授下さい。 ■環境  CentOS release 6.4 (Final)  64bitOS   ■インストールしたいパッケージ  compat-libstdc++-33-3.2.3-69.el6.i686.rpm  glibc-2.12-1.107.el6.i686.rpm  libstdc++-4.4.7-3.el6.i686.rpm  libstdc++-devel-4.4.7-3.el6.i686.rpm   ■目的  Oracle Database 12c Release 1 (12.1.0.1) 導入/検証のため  http://www.oracle.com/technetwork/jp/database/enterprise-edition/documentation/db121linux-x64-ja-v10-1984264-ja.pdf     ■インストールされていないパッケージをインストールした際に表示されるメッセージ  # rpm -ivh compat-libstdc++-33-3.2.3-69.el6.i686.rpm 警告: compat-libstdc++-33-3.2.3-69.el6.i686.rpm: ヘッダ V3 RSA/SHA256 Signature, key ID c105b9de: NOKEY エラー: 依存性の欠如: libc.so.6 は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.0) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.1) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.1.3) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.2) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libc.so.6(GLIBC_2.3) は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています libm.so.6 は compat-libstdc++-33-3.2.3-69.el6.i686 に必要とされています # # rpm -ivh glibc-2.12-1.107.el6.i686.rpm 警告: glibc-2.12-1.107.el6.i686.rpm: ヘッダ V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY エラー: 依存性の欠如: libfreebl3.so は glibc-2.12-1.107.el6.i686 に必要とされています libfreebl3.so(NSSRAWHASH_3.12.3) は glibc-2.12-1.107.el6.i686 に必要とされています # # rpm -ivh libstdc++-4.4.7-3.el6.i686.rpm 警告: libstdc++-4.4.7-3.el6.i686.rpm: ヘッダ V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY エラー: 依存性の欠如: ld-linux.so.2 は libstdc++-4.4.7-3.el6.i686 に必要とされています ld-linux.so.2(GLIBC_2.3) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6 は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.0) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.1) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.1.3) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.2) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.3) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.3.2) は libstdc++-4.4.7-3.el6.i686 に必要とされています libc.so.6(GLIBC_2.4) は libstdc++-4.4.7-3.el6.i686 に必要とされています libm.so.6 は libstdc++-4.4.7-3.el6.i686 に必要とされています libm.so.6(GLIBC_2.0) は libstdc++-4.4.7-3.el6.i686 に必要とされています # # rpm -ivh libstdc++-devel-4.4.7-3.el6.i686.rpm 警告: libstdc++-devel-4.4.7-3.el6.i686.rpm: ヘッダ V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY エラー: 依存性の欠如: libstdc++(x86-32) = 4.4.7-3.el6 は libstdc++-devel-4.4.7-3.el6.i686 に必要とされています libstdc++.so.6 は libstdc++-devel-4.4.7-3.el6.i686 に必要とされています #