• 締切済み
  • すぐに回答を!

IP Network Multipathingを設定をしたが、障害時にIPを引き継げない

下記の状態で方系のケーブルを抜いたのですが、障害発生を検知せず、IPが引き継げません。 ※抜線後も ifconfig -a の内容は変更なし IPの引継ぎを行う様にする為には、他に留意する点はございますでしょうか。 ご教授の程、宜しくお願いします。 ----- 【OS】 Solaris8 【/etc/default/mpathd】 FAILURE DETECT10N TIME=10000 FAILBACK=yes TRACK_INTERFACES_ONLY_WITH_GROUPS=yes 【NICの設定内容】 serveri# ifconfig -a lo0: flags=1000849<UP,L00PBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index 1 inet 127.0.0.1 netmask ff000000 bge0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2 inet 192.168.114.l netmask ffffffc0 broadcast 192.168.114.63 groupname test ether XX:XX:XX:XX:XX:XX bge0:1: flags=904083<UP,BROADCAST,RUNNING,MULTICAST,DEPRECATED,IPv4,NOFAILOVER> mtu 1500 index 2 inet 192.168.114.11 netmask ffffffcO broadcast 192.168.114.63 bge1: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 3 inet 192.168.114.2 netmask ffffffc0 broadcast 192.168.114.63 groupname test ether YY:YY:YY:YY:YY:YY bge1:1: flags=904083<UP,BROADCAST,RUNNING,MULTICAST,DEPRECATED,IPv4,NOFAILOVER> mtu 1500 index 3 inet 192.168.114.12 netmask ffffffcO broadcast 192.168.114.63

共感・応援の気持ちを伝えよう!

みんなの回答

  • 回答No.2

記憶があいまいですが、抜線後に10秒以上経過しても検知しませんか?

共感・感謝の気持ちを伝えよう!

質問者からの補足

検知しませんでした。

  • 回答No.1

もう参照されているかと思いますが、私はこのマニュアル通りで問題ありませんでした。 まさかとは思いますが、in.mpathdが動いてないとかはないですよね?

参考URL:
http://docs.sun.com/app/docs/doc/816-1250

共感・感謝の気持ちを伝えよう!

質問者からのお礼

回答ありがとうございます。 私もマニュアル通りに行ったのですが、うまく行きませんでした。 抜線したI/FにPINGが通るのですが、 その為に障害と認識せずにfailoverしないのでしょうか? ※mpathdは起動しています。

関連するQ&A

  • VirtualBox ルータの設定。

    いつもお世話になりありがとうございます。 表記の件。 $ ifconfig enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 inet 10.0.2.15 netmask 255.255.255.0 broadcast 10.0.2.255 inet6 fe80::1ac0:f545:676e:e271 prefixlen 64 scopeid 0x20<link> ether 08:00:27:16:81:2d txqueuelen 1000 (Ethernet) RX packets 838 bytes 211270 (206.3 KiB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 884 bytes 106098 (103.6 KiB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 prefixlen 128 scopeid 0x10<host> loop txqueuelen 1000 (Local Loopback) RX packets 0 bytes 0 (0.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 0 bytes 0 (0.0 B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 virbr0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500 inet 192.168.122.1 netmask 255.255.255.0 broadcast 192.168.122.255 ether 52:54:00:28:d1:a6 txqueuelen 1000 (Ethernet) RX packets 0 bytes 0 (0.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 0 bytes 0 (0.0 B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 VirtualBoxのルーターの設定する元資料が上記になります。 MACアドレス、ipアドレスが分かりません。 どれを設定すればいいのでしょうか? 御多忙中恐れいります。 ご回答のほど、宜しくお願い申し上げます。

  • ネットワークカードの認識確認

    IntelSolarisでネットワークが繋がらずはまってます。 Webで調べて,Freeのドライバをインストールして色々設定してみたのですが、別のマシンやルータへのpingも通りません。 LANはマザボについてるもので,VIA VT6103Lというチップセット使ってるみたいですが、まずこれがSolarisに対応して認識できるものかどうか分からないので、認識できてるかどうかの確認方法を教えてください。 一応、一致しそうなVIA Rhine family fast ethernet chipsのドライバをインストールして、ifconfigとnetstatでは次のように表示されます。 (これで,ネットワークが認識出来てるか確認と書いてあったHPがありましたが,出力情報が良いのかどうかわかりません) ifconfig rh0 で rh0: flags=1000843<UP,BROAFCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2 inet 192.168.11.2 netmask ffffff00 broadcast 192.168.11.255 ether x:xx:xx:xx:xx:xx(セキュリティ上問題あるかもしれないので伏せてます) netstat -rnで Routing Table: IPv4 Destination Gateway Flags Ref Use Interface --------------- -------------- ------ ----- ----- -------- 192.168.11.0 192.168.11.2 U 1 46 rh0 244.0.0.0 192.168.11.2 U 1 0 rh0 ・・・ どうかよろしくお願いします.

  • 【ネットワーク障害】Solaris10と外部の通信不可能

    お世話になります。 Solaris10のネットワーク障害について、解決策を探しております。 ご存知の方がいらっしゃれば、どうぞお力添えをお願いいたします。 【環境】  ■ホストA   機種名:自作PC   OS:デュアルブートOS(WindowsXP, Solaris10)   NIC:マザーボード(ASUS M2N-E)上のオンボードNIC   IP:192.168.1.254 / 255.255.255.0  ■ホストB   機種名:NEC VersaPro VY10M/BH-T   OS:WindowsXP   NIC:マザーボード上のオンボードNIC   IP:192.168.1.100 / 255.255.255.0 【詳細】  ホストA(Solaris10)とホストBの間で相互にping到達不可能です。  しかし、ホストAがWindowsXPで起動した場合は、ホストBとの間で相互にping到達可能です。  このため、NICやケーブルの物理的破損はありえません。    以下、Solaris10のコマンド実行結果です。  #ifconfig -a  lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL>mtu 8232 index 1    inet 127.0.0.1 netmask ff000000  nge0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2    inet 192.168.1.254 netmask ffffff00 broadcast 192.168.1.255    ether 0:1b:fc:fc:f0:a3  #netstat -rn  Routing Table: IPv4   Destination Gateway    Flags Ref Use Interface   192.168.1.0 192.168.1.254 U   1  20  nge0   224.0.0.0  192.168.1.254 U   1   0  nge0   default   192.168.1.1  UG   1   0     127.0.0.1  127.0.0.1   UH   1   4  lo0  #svcs inetd  STATE  STIME   FMRI  online 21:30:59 svc:/network/inetd:default 【その他】  以前、ホストAにSolaris10だけ入れて動かした時には、ping疎通可能でした。  その後HDDのパーティーションを切り直し、現在は「WindowsXP → Solaris10」の順番でインストールされています。  再度Solaris10だけ入れなおせば疎通可能かもしれませんが、それは出来れば避けたいと考えています。

  • ibook に固定ipアドレスを設定する方法は?

    全くの初心者で申し訳ありません。 ご存知の方よろしくお願いします。 ibook dual USB から自宅の Linux fedora core 4 に クロスケーブルでssh で接続しようと考えています Linux のアドレスは 192.168.0.1(wanには繋いでません)で ibook のアドレスをシステム環境設定のネットワークで手入力で192.168.0.2 と入力すると、 en0: アドレス設定なしです ppp0: flags=8011<UP,POINTOPOINT,MULTICAST> mtu 1492 inet 192.168.0.2 --> 10.112.112.112 netmask 0xffffff00 の様に、ppp0のアドレスが変わりました。 これで ibook ターミナルから、ping -c 10 192.168.0.1 すると反応しません なので sudo ifconfig en0 192.168.0.2 すると en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 inet 192.168.0.2 netmask 0xffffff00 broadcast 192.168.0.255 ether 00:03:93:cf:3b:9e media: autoselect (100baseTX <full-duplex>) status: active supported media: none autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 100baseTX <half-duplex> 100ba の様に、en0のアドレスが変わりました。 これで ibook ターミナルから、ping -c 10 192.168.0.1 するときちんと反応します。 これでよいのでしょうか? しかし再起動するともとの設定に戻ってしまいます システム設定パネルからen0のアドレスを変更はできないのでしょうか?(再起動しても設定が反映) それとも他に良い方法がありますか? よろしくお願いします。

    • 締切済み
    • Mac
  • 18.04の固定IPアドレス。

    「http://Ubuntu Server 18.04の固定IPアドレス/wordpress」 のページを開け! と記載がありますが、Ubuntu Server 18.04の固定IPアドレス って、どこを指すのですか? kouzou@GD348ZZD9:~$ ifconfig eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 inet 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255 inet6 fe80::87c4:3af1:7d91:d942 prefixlen 64 scopeid 0x20<link> ether 4c:cc:6a:ec:34:3e txqueuelen 1000 (イーサネット) RX packets 1547555 bytes 2031515116 (2.0 GB) RX errors 0 dropped 1 overruns 0 frame 0 TX packets 757583 bytes 84466484 (84.4 MB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 device interrupt 16 memory 0xdf000000-df020000 lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 prefixlen 128 scopeid 0x10<host> loop txqueuelen 1000 (ローカルループバック) RX packets 18955 bytes 2015280 (2.0 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 18955 bytes 2015280 (2.0 MB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

  • LANが繋がらない(再)

    以前、以下のような質問をしました。 --------------------- FreeBSD初心者です。 FreeBSD(4.2R)マシンとWin98マシンをLANで繋ぎたいのですがうまくいきません。 BSDマシンにLANカード(3CXE589ET)を入れ、 IP Address:192.168.10.13 Netmask:255.255.255.0 に設定して自分自身にpingしたところ、 ping: sendto: No route to host ....... 9 packets transmitted, 0 packets received, 100% packet loss となりました。 ifconfig ep0では、 ep0: flags=8802<BROADCAST,SIMPLEX.MULTICAST> mtu 1500 ether 00:00:86:61:e0:2d media 10baseT/UTP supported media: 10base2/BNC 10baseT/UTP 10base5/AUI とあります。 BSD側に問題があるのでしょうか? よろしくお願い致します。 ------------------------- それで、 ifconfig ep0 up ifconfig inet 192.168.10.13 netmask 255.255.255.0 とやったら解決したのですが、 rebootすると、 ep0: flags=8802<BROADCAST,SIMPLEX.MULTICAST> mtu 1500 ether 00:00:86:61:e0:2d media 10baseT/UTP supported media: 10base2/BNC 10baseT/UTP 10base5/AUI のように「UP」の文字やIPアドレス、マスクの記述が消えて元に戻ってしまいます。どうしたら設定が残るのでしょうか? よろしくお願いします。

  • HP-UXのネットワーク設定

    知識不足で質問の仕方が適切でない、情報が不足している場合は何卒ご容赦ください。 ■質問 NICを2つ搭載したHP-UXサーバがあり、同一セグメントIPアドレスが割り当てられています。 そのうち、1つのIPを別セグメントのIPアドレスに変更したいのですが、変更方法が分かりません。 お詳しい方、変更方法をご教示頂けますと幸いです。 不足情報あればご指摘いただけますと幸いです。 lan0 10.111.1.22/24 ⇒ 10.222.2.22/24(ゲートウェイ:10.222.2.254) lan1 10.111.1.23/24 ⇒ 変更無し ■OS情報 HP-UX 11iv3 ■現状設定(lanscan、netstat、ifconfigの結果) # ifconfig lan0 lan0: flags=1843<UP,BROADCAST,RUNNING,MULTICAST,CKO> inet 10.111.1.22 netmask ffffff00 broadcast 10.111.1.255 # ifconfig lan1 lan1: flags=1843<UP,BROADCAST,RUNNING,MULTICAST,CKO> inet 10.111.1.23 netmask ffffff00 broadcast 10.111.1.255 # lanscan Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI Path Address In# State NamePPA ID Type Support Mjr# 1/0/1/1/0/6/0 0x000000000001 0 UP lan0 snap0 1 ETHER Yes 119 1/0/1/1/0/6/1 0x000000000002 1 UP lan1 snap1 2 ETHER Yes 119 LinkAgg0 0x000000000000 900 DOWN lan900 snap900 4 ETHER Yes 119 LinkAgg1 0x000000000000 901 DOWN lan901 snap901 5 ETHER Yes 119 LinkAgg2 0x000000000000 902 DOWN lan902 snap902 6 ETHER Yes 119 LinkAgg3 0x000000000000 903 DOWN lan903 snap903 7 ETHER Yes 119 LinkAgg4 0x000000000000 904 DOWN lan904 snap904 8 ETHER Yes 119 # netstat -rn Routing tables Destination Gateway Flags Refs Interface Pmtu 127.0.0.1 127.0.0.1 UH 0 lo0 32808 10.111.1.23 10.111.1.23 UH 0 lan1 32808 10.111.1.22 10.111.1.22 UH 0 lan0 32808 10.111.1.0 10.111.1.23 U 2 lan1 1500 10.111.1.0 10.111.1.22 U 2 lan0 1500 127.0.0.0 127.0.0.1 U 0 lo0 32808 default 10.111.1.254 UG 0 lan1 1500 ■現状設定(netconf) HOSTNAME="xxxxxxx" OPERATING_SYSTEM=HP-UX LOOPBACK_ADDRESS=127.0.0.1 INTERFACE_NAME[0]="lan0" IP_ADDRESS[0]="10.111.1.22" SUBNET_MASK[0]="255.255.255.0" BROADCAST_ADDRESS[0]="10.111.1.255" INTERFACE_STATE[0]="up" DHCP_ENABLE[0]="0" INTERFACE_MODULES[0]="" INTERFACE_SKIP[0]="" INTERFACE_NAME[1]="lan1" IP_ADDRESS[1]="10.111.1.23" SUBNET_MASK[1]="255.255.255.0" BROADCAST_ADDRESS[1]="10.111.1.255" INTERFACE_STATE[1]="up" DHCP_ENABLE[1]="0" INTERFACE_MODULES[1]="" INTERFACE_SKIP[1]="" ROUTE_SOURCE[0]="" ROUTE_SKIP[0]="" GATED=0 GATED_ARGS="" RDPD=0 RARPD=0 DEFAULT_INTERFACE_MODULES="" ROUTE_MASK[0]=255.255.255.255 ROUTE_GATEWAY[0]=10.111.1.254 ROUTE_COUNT[0]=1 ROUTE_DESTINATION[0]=default ROUTE_DESTINATION[1]="default" ROUTE_GATEWAY[1]="10.111.1.254" ROUTE_COUNT[1]="1" ROUTE_MASK[1]="" ROUTE_ARGS[1]="-p 1500"

  • アクティブなインターフェースのシステム情報の取得方法につきまして

    FreeBSD(MacOS X)を使用しています。 >netstat -rnf inet を実行します。結果は次のようになります。 ******************************** Routing tables Internet: Destination  Gateway  Flags  Refs  Use  Netif  Expire default 11.33.55.7 UGSc 38 469 en0 11.22.33/44 link#4 UCS 1 0 en0 11.22.33.4 0:0:11:22:33:44 UHLW 30 0 en0 「Netif」が「en0」か「en1」になっていたら、 アクティブと判定し、この全体を配列に入れます。 => my @NS=`netstat -rnf inet`; 次に、 $NS[0]=Routing tables $NS[1]=空白 $NS[2]=Internet: $NS[3]=Destination  Gateway  Flags  Refs ・・・ $NS[4]=default 11.33.55.7 UGSc ・・・ $NS[5]=11.22.33/44 link#4 UCS ・・・ ・・・ と別々の配列か変数に入れて散らばっている文字列をキチンと 格納したいのですが、その仕方がまず分かりません。 格納したら、 分岐で「en0」があればそれに対する情報を引出したいのです。 やっかいなのが、ipはnetstatでは無くifconfigなのです。 >ifconfig -aで、 ********************** en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> inet 11.22.33.44 netmask 0xffffff00 broadcast 11.22.255.255 ether 00:11:22:33:44:55 と表示されるのですが、,や:や;とバラバラの文字列群を どう処理したら良いのかも分からないのです。 いったん全部を配列に入れて、各行を別々の配列に入れて、 ソートして、ifで分岐して・・としているですが、成功しません。 よろしくお願いいたします。

    • ベストアンサー
    • Perl
  • eth0にPingが通らない

    初めて投稿させて頂きます。 tatty4444です。 下記内容で非常に作業が進まずに困っています。 どなたかご存知の方、ご教授の方をお願い致します。 内容としては、DB用に別サーバーを立てたのですが、 OSと各アプリケーション導入後にクライアントから「Ping」にて導通確認を行おうとしたらPingが通らない現象が発生しました。 状況その(1) クライアントからサーバーへ この場合、全て「Request Timeout」となってしまいます。 状況その(2) サーバーからクライアントへ この場合、全て「Destination Host Unreachable」となってしまいます。 ifconfigにて情報をみたら下記のようになっていました。 eth0 Link encap:Ethernet HWaddr 00:D0:B7:4A:01:C7 inet addr:192.168.1.13 Bcast:192.168.1.255 Mask:255.255.255.0 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 b) TX bytes:0 (0.0 b) eth1 Link encap:Ethernet HWaddr 00:90:FE:03:0D:16 inet6 addr:fe80::290:feff:fe03:d16/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:50 dropped:0 overruns:0 carrier:0 collisions:850 txqueuelen:1000 RX bytes:0 (0.0 b) TX bytes:12568 (12.2 KiB) Interrupt:185 Base address:0xccc0 また各ethの設定状況を確認したら以下のようになっていました。 vi /etc/sysconfig/network-scripts/ifcfg-eth0 DEVICE=eth0 BOOTPROTO=static BROADCAST=192.168.1.255 HWADDR=00:D0:B7:4A:01:C7 IPADDR=192.168.1.13 NETMASK=255.255.255.0 NETWORK=192.168.1.0 ONBOOT=yes vi /etc/sysconfig/network-scripts/ifcfg-eth1 DEVICE=eth1 ONBOOT=yes BOOTPROTO=dhcp HWADDR=00:90:fe:03:0d:16 上記の内容で、「UP BROADCAST MULTICAST」の部分が「UP BROADCAST RUNNING MULTICAST」にならないといけないと思うのですが、どのように設定していいのか分かりません。 どなたか解決策のお分かりになる方! ご教授をお願い致します。 【システム構成】  ・CentOS 5(テキストモードにてインストール)  ・Apache2.0.55  ・PHP5.1.2  ・Postgresql8.1.3  ・MySQL5.0.18

  • CentOSにて、eth0でPingが通らない。。

    初めて投稿させて頂きます。 tatty4444です。 下記内容で非常に作業が進まずに困っています。 どなたかご存知の方、ご教授の方をお願い致します。 内容としては、DB用に別サーバーを立てたのですが、 OSと各アプリケーション導入後にクライアントから「Ping」にて導通確認を行おうとしたらPingが通らない現象が発生しました。 状況その(1) クライアントからサーバーへ この場合、全て「Request Timeout」となってしまいます。 状況その(2) サーバーからクライアントへ この場合、全て「Destination Host Unreachable」となってしまいます。 ifconfigにて情報をみたら下記のようになっていました。 eth0 Link encap:Ethernet HWaddr 00:D0:B7:4A:01:C7 inet addr:192.168.1.13 Bcast:192.168.1.255 Mask:255.255.255.0 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 b) TX bytes:0 (0.0 b) eth1 Link encap:Ethernet HWaddr 00:90:FE:03:0D:16 inet6 addr:fe80::290:feff:fe03:d16/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:50 dropped:0 overruns:0 carrier:0 collisions:850 txqueuelen:1000 RX bytes:0 (0.0 b) TX bytes:12568 (12.2 KiB) Interrupt:185 Base address:0xccc0 また各ethの設定状況を確認したら以下のようになっていました。 vi /etc/sysconfig/network-scripts/ifcfg-eth0 DEVICE=eth0 BOOTPROTO=static BROADCAST=192.168.1.255 HWADDR=00:D0:B7:4A:01:C7 IPADDR=192.168.1.13 NETMASK=255.255.255.0 NETWORK=192.168.1.0 ONBOOT=yes vi /etc/sysconfig/network-scripts/ifcfg-eth1 DEVICE=eth1 ONBOOT=yes BOOTPROTO=dhcp HWADDR=00:90:fe:03:0d:16 上記の内容で、「UP BROADCAST MULTICAST」の部分が「UP BROADCAST RUNNING MULTICAST」にならないといけないと思うのですが、どのように設定していいのか分かりません。 どなたか解決策のお分かりになる方! ご教授をお願い致します。 【システム構成】  ・CentOS 5(テキストモードにてインストール)  ・Apache2.0.55  ・PHP5.1.2  ・Postgresql8.1.3  ・MySQL5.0.18