• ベストアンサー
  • 困ってます

Rlogin でMySQLのインストール

RloginでMySQLをインストールしたいのですが、うまく行きません。 yum install mysql-server と入力すると、mariadb がインストールされてしまいます。これで良いのでしょうか?

共感・応援の気持ちを伝えよう!

  • MySQL
  • 回答数3
  • 閲覧数63
  • ありがとう数5

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.3

>回答ありがとうございます。ディストリはcent OS です。サードパーティリポジトリについては何も知らなかったので、試してみます。 あ~それなら、確実にOracleのMySQL入りますよ!。 私が業務でセットアップした奴、MariaじゃなくOracleの MySQLにしてますんで。(バージョンMySQL8) 単にサードパーティリポジ追加するだけで行けますよ!

共感・感謝の気持ちを伝えよう!

質問者からのお礼

どうもありがとうございます。やってみたところ、GPGキーが正しくない旨表示されました。どうしたら良いのでしょう

その他の回答 (2)

  • 回答No.2

Rloginって、TTYですよね? ディストリは?何を? 一般的にはサードパーティリポジトリを追加して MySQL Communityを入れるんですが。 ただ、全ディストリをサポートしてるわけじゃないので、 何ともですがね。 https://dev.mysql.com/downloads/mysql/ こちらから、各ディストリ用を落とせることは落とせますが。 普通はリポジ追加するのが、ベターです (yum updateで落ちてくるため) あと、mariaが居座ってると、重なってしまうので、 やるときはmariaを確実に抜いてからの方が、安定します。 私の方は、Fedoraなんですが、Fedora36から デフォルトのリポジにMySQLが入ったので、 だいぶ楽になりました^^ 35までは、先ほどの手動リポジ追加が必須だったので!。 などなどを、お試しください。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

回答ありがとうございます。ディストリはcent OS です。サードパーティリポジトリについては何も知らなかったので、試してみます。

  • 回答No.1
  • t_ohta
  • ベストアンサー率38% (4580/11791)

MySQLはオラクルの方針により商用ライセンスがメインに移行しているため、無償利用の場合は完全互換のMariaDBが利用されるケースが多いですね。 YUMもMySQLをインストールすると実態としてはMariaDBがインストールされるようになっています。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

回答ありがとうございます。そうなんですね。理由がわかって安心しました。

関連するQ&A

  • 【CentOS3.7】MySQL4.1.22、php-mysql4.3.2のインストールについて

    Linux及び、MySQL初心者です。 ソフトウェア開発会社で勤務して1年半ほどになりますが、 以前テスト用に使用していたサーバの内容を、別機に移行する作業を まかされることになりました。 PHPとMySQLが使用できるWEBサーバです。 元サーバに CentOS3.7、Apache2.0.46、PHP4.3.2、MySQL4.1.21 がインストールされていることを確認。 移行後サーバにCentOS3.7をインストールし、 その際にそれぞれのソフトウェアもデフォルトでインストールしたところ、 MySQLだけ「3.23.58-16」と古いバージョンになっていました。 そこで yum remove mysqlとし、 ・mysql-bench-3.23.58-16.RHEL3.1 ・mod_auth_mysql-20030510-2.ent ・libdbi-dbd-mysql-0.6.5-5 ・mysql-devel-3.23.58-16.RHEL3.1 ・php-mysql-4.3.2-39.ent ・mysql-3.23.58-16.RHEL3.1 ・mysql-server-3.23.58.16.RHEL3.1 を削除。その後、mysql-4.1.22.tar.gzをダウンロードし、 ソースからインストールしました。 しかしこれでは、php-myadminが消えてしまうため、 yum install php-mysqlを実行したところ、 ・mysql-3.23.58-16.RHEL3.1 も一緒にインストールされます。 mysqlがダブってインストールされてしまうということでしょうか。 (ちなみに、元サーバで「rpm -qa | grep mysql」とすると、  ・php-mysql-4.3.2.26.ent  と表示されます。  php-mysqlだけrpmインストールされているということですよね?) どのようにインストールしたら、この問題を解決できるでしょうか。 (既に2日ほどこの問題で詰まっています) 要点がまとまっていない質問で申し訳ありませんが、 回答をお願いできませんでしょうか。 足りない情報がありましたら、追記しますので、よろしくお願いいたします。

  • CentOS7にMariaDBのインストール

    CentOS7のサーバーにMariaDBをインストールしたいと思っています。 RPMパッケージは配布されているのでしょうか。 インターネットを検索するとどのサイトもyumを使用してインストールが 行われています。対象のサーバーからインターネットにはつながらないので 「rpm -ivh xxxxx.rpm」 みたいな感じでコマンドを実行してMariaDBの インストールを行いたいと思っています。

  • MySQLにインストールについて

    お世話になっております。 Linuxを勉強しようと思い、VMwareエミュレータを使用してWindows上でCentosを動かしています。 そこで、PHPとApacheとMySQLが必要になったのでyumレポジトリからapache、Mysqlをインストール。PHPはソースをダウンロードしインストールしました。 MySQLのインストールで実行したスクリプト [root@localhost~#]yum -y install mysql mysql-server [root@localhost~#]vi /etc/my.cnf [mysqld] default-character-set = utf8 |_____この1行を追加しました。 [root@localhost~#]/etc/rc.d/init.d/mysqld start |_____MySQLの起動が確認できました。 [root@localhost~#]/usr/local/mysql/bin/mysql_install_db --user=mysql |_____MySQLの初期化を行いました。 [root@localhost~#]mysql -u root |_____ERROR 1045(28000):Access denied for user 'root'@'localhost'(Using Password:NO) というエラーが返されてしまいます。初期rootのパスワードは設定されていないと調べてわかったので、-pオプションはつけませんでした。 また、「my.cnf」ファイル内の[mysqld]フィールドに「skip-grant-tables」と追加記述しMySQLを再起動致しました。 するとログインできますが、rootユーザーのパスワードをアップデートしようと試みましたが、上記「「skip-grant-tables」とMySQLサーバが一緒に起動しています!とのエラーが出てしまい、結局rootユーザから接続できない状態です。 どなたか解決方法をご存知の方いらっしゃいましたら、アドバイスをお願い致します。

  • CentOS5でyumを使ってMysql4やphp4のインストール

    CentOS5にyumコマンドでMYSQLやphpをインストールしようとするとデフォルトではmysql5やphp5が入ると思います。 そこでリポジトリなどの変更によりyumにてmysql4やphp4をインストールすることは可能なのでしょうか? 可能であればやり方もご教授願います。 宜しくお願いいたします。

  • CentOS5.5でMySQL5.5のインストール

    Linux初心者です。どなたかご教示いただけましたら助かります。 CentOS5.5にMySQL5.5を入れました。 こちらを参考にしました↓ http://yktweb.sakura.ne.jp/blog/home-server/188.html しかし、startしたらFAILEDとなったので、MySQL5.1にしようと思って 一度 # yum remove mysql として、再度 # yum install mysql mysql-server としました。 すると、以下のようなエラーが大量発生して、インストールができなくなりました。 Transaction Check Error: file /etc/my.cnf from install of mysql-5.0.77-4.el5_5.5.x86_64 conflicts with file from package mysql-libs-5.5.11-1.el5.remi.x86_64 file /usr/share/mysql/charsets/Index.xml from install of mysql-5.0.77-4.el5_5.5.x86_64 conflicts with file from package mysql-libs-5.5.11-1.el5.remi.x86_64 file /usr/share/mysql/charsets/cp1250.xml from install of mysql-5.0.77-4.el5_5.5.x86_64 conflicts with file from package mysql-libs-5.5.11-1.el5.remi.x86_64 ・・・ こういった場合は、どうしたらいいのでしょうか? ゴミが残っているような感じでしたので、上記ファイルを少し消してみた のですが、特に変化がありませんでした。 普段Windowsしか使っていないので、どうなれば完全アンインストールされた ことになるのかよく分かっていません・・ 何でも結構ですのでアドバイスいただけましたらと思います。 よろしくお願いしますm(_ _)m

  • Postfixをインストールしたら、MySQLが起動しなくなった

    いつもお世話になっております。 Linuxの環境構築を行っているのですが、MySQLをインストール後、Postfixをインストールしたところ、MySQLが起動しなくなってしまいました。 具体的な手順としては、 mysqld_safe & として、MySQLサーバを起動し、その後確認のために mysqladmin ping とコマンドを入力してみると、 mysqladmin: connect to server at 'localhost' failed error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111)' Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists! とのエラーメッセージが出力されます。 自分なりに調べたところ、Postfixをインストールすると、/etcの中に勝手にmy.cnfが出来るらしかったので、とりあえずmy.cnfを別の名前にして、Linuxを再起動してみたのですが、同じ現象でした。 何か解決策がお分かりでしたら、教えて下さい。 宜しくお願い致します。 環境は、以下のとおりです。 OS:CentOs 5.3 MySQL:5.1.35 Postfix:2.3.3 MySQLはソースファイルから、Postfixはyumコマンドにてインストールしました。

    • ベストアンサー
    • MySQL
  • CentOS5環境で、MySQL4・PHP4を動かすには?

    現在運用しているサーバ(CentOS4、MySQL4.1.20、PHP4.3.9)を、訳あって引越ししなければならなくなりました。 引越し先はOSが、CentOS5です。互換性等々が心配なため、MySQL4.x・PHP4.x環境にしたいのですが、最も確実に行うにはどうしたらいいでしょうか? これまで、パッケージ管理はyumに任せてきたきたので、ちょっと心配です。 新サーバのMySQLとPHPをyumで削除してから、インストールしたいバージョンのrpmを拾ってインストール・・・だけで問題なく動くでしょうか?

  • MySQLについて教えてください

    この間FC4をフルインストールしたのですが、 いまいちmysqlのなにが入っているのかが理解できません。 rpm -qa | grep mysqlとrpm -qa | grep MySQLのコマンドでは、出てくる結果がちがいます。 調べたい内容としましては、以下の4つが入っているのか、それとVerはいくつなのか調べたいのですが・・・。 MySQL-server MySQL-client MySQL-devel MySQL-shared-compat yum apdateとyum upgradeはしました(関係あるのかよくわかってないのですが)。 どなたかご教授願います。

  • MySQLのインストール

    今MySQLをインストールしているんですが、 MySQL Server Datafilesというのは何でしょうか?

  • MYSQLインストールについて

    MY SQLをダウンロードしょうと思いサイトへ行きました。 Download MySQL Community Server からインストール版(64bit)版をインストールしようとしましたがzip版しかなく仕方なくzip版をダウンロードしました。そしてダウンロードをしましたがなかなかうまくインストールされません。 binホルダーに行きmysql.exeでインストールしましたが上手くいきません。 MySQL Community Server 5.5.29は今一番新しいバージョンですが、依然のようにはいきません。 どうすればインストールされるか教えてください。

    • ベストアンサー
    • MySQL