• 締切済み
  • すぐに回答を!

VMware Playerでネットワークカードが認識されない。

はじめまして。 最近、VMware Playerを使い始めたのですが、 どうもネットワークカードを認識しないようです。 (Miracle Linux 4.0) 【現状】 /etc/modprobe.conf →ネットワークカードのaliasがありません。 lsmod →モジュールなし /etc/sysconfig/network-scripts/ifcfg-eth0 →このファイルはない。ifcfg-loのみ存在。 /etc/resolv.conf →cat /etc/resolv.conf で見てみたが、何も書かれていない。 kudzu →何も検出せず。 もし情報をお持ちの方がいましたら 教えていただけないでしょうか?

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数1443
  • ありがとう数3

みんなの回答

  • 回答No.2

エミュレート するNIC は決まっているのですから、 私は、下記でやっています。// いました。今は、VMWare Server Ethernet0.present = "TRUE" ethernet0.addressType = "generated" ethernet0.connectionType = "nat" or "bridged" or "hostonly" ethernet0.generatedAddress = "00:0c:29:38:11:d8" ethernet0.generatedAddressOffset = "0"

共感・感謝の気持ちを伝えよう!

  • 回答No.1

Miracle Linux については、何とも言えませんが VMWare Player、VMWare Server で NIC を認識しなかったdistribution は 10個以上install してますが、ありませんでしたが xxx.vmx のnetwork の所を書いてないですが 自信があるのでしょうか。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

>cynthia4さん cynthia4さん、はじめまして! ご回答ありがとうございます。 >xxx.vmx のnetwork の所を書いてないですが 自信があるのでしょうか。 いえ、自信はありません・・ あれから ethernet0.virtualDev = "e1000" としたところ無事にNICを認識してくれました。 お騒がせしてすみませんでした。

関連するQ&A

  • インターフェイスが認識しない

    Redhat 2.4.20-8をインストールしています。 ifconfig -a を打ってもインターフェイスはloしか認識していない状態です。 ln -s /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/networking/ifcfg-eth0 でシンボリックリンクを作成しましたが認識されません。 何が問題なのでしょうか? 助言頂けると助かります。

  • 追加ネットワークカードのドライバのインストール

    OSはFedoraCore4です。 マシンにオンボードのNICに追加でメルコのLGY-PCI-GTを装着しました。 装着後、lspciコマンドで確認すると 01:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10) と表示されるので認識はされているようです。 このカードのドライバをインストールするにはどのようにすれば良いのでしょうか?付属のCD-ROMは使うのでしょうか? 現在、ifconfigではeth0、loのみ結果が表示されます。 /etc/sysconfig/network-scriptsにはifcfg-eth0、ifcfg-loの2つがあります。 (ドライバインストールすればifcfg-eth1が生成される?) オンボードのネットワークカードは正常に使えている状態です。 よろしくお願い致します。

  • CentOS7 ネットワーク設定に関して

    CentOS7 ネットワーク設定で困っています。 CentOS7 ネットワーク設定を手動で行うと管理対象外になってしまう。 /etc/resolv.confの内容が勝手に書き換わって困っていました。 /etc/sysconfig/network-scripts/のifcfg-???? ファイルに NM_CONTROLLED="no" の設定を記述すると/etc/resolv.confの内容は書き換わらなくなるという事を知り、その対応を行いました。 しかし、それを行い再起動すると、ネットワークに繋がらなくなります。 GUI上で見ると 有線 管理対象外 となっており、「プロファイルの追加」でプロファイルの追加を行っても、 /etc/sysconfig/network-scripts/ifcfg-???? を直接書き換えてもダメです。 オンとかオフのレベルではなく、管理対象外なのでどうにもなりません。 /etc/sysconfig/network-scripts/ifcfg-???? ファイルを削除して、マシンを再起動しないと直りません。 GUIから、あるいはnmtuiから再度登録するとネットワークが有効になります。 しかし、 /etc/sysconfig/network-scripts/ifcfg-???? ファイルに NM_CONTROLLED="no" を追記するとまた 有線 管理対象外 になります。 どうしたものでしょうか?

  • resolv.conf が勝手に書き換わる

    haluと言います。 よろしくお願いします。 環境:FreeBSD 5.3 RELEASE dhcp使用 問題点 resolv.confが毎回書き換えられ 手動で直しています。 原因として、/sbin/dhclient-script が書き換えているのは わかっているんですが 単純に書き換えているコードを コメントアウトしていいのでしょうか? ちなみに、linuxの場合は /etc/sysconfig/network-scripts/ifcfg-eth0 を PEERDNS=no にするとresolv.confの書き換えを止めることが出来るのはわかったのですが FreeBSD の場合どうすればいいのかわからないので質問しました。 何かわかりましたら アドバイスよろしくお願いします。

  • VineLinu3.1でethの設定

    LANボードを2枚挿してから、ethの認識がおかしくなりました。 VinLinuxの起動ログの画面では eth0   [ok] と表示されます。eth1は出ません。 起動後にGNOMEのメニューから「ネットワークの設定」を開くと、eth0だけがあります。 eth0のチェックボックスはoffです。 /etc/sysconfig/network-scripts/ifcfg-eth0 は有り、その内容でDEVICEの値もeth0です。 /etc/sysconfig/network-scripts/ifcfg-eth0 は無いです。 /etc/modprobe.confではeth0が、そのLANボードの名前と関連付けてあります。 lsmodを実行しても、LANケーブルを挿してない方のLANボード名は無いです。 ここまで揚げた資料では、eth1については未定義のようです。 VinLinuxが起動後に、GNOME端末で # ifconfig eth0 up 不明なインターフェースです。そのようなでばいすはありません。 となります。 ところが、 # ifconfig eth1 up 不明なインターフェースです。そのようなでばいすはありません。 となりますが、この時ガリっと音がします。 ここで # ifconfig eth0 up すると、表示してた「ネットワークの設定」のチェックボックスがONになり、サーバ公開ができるようになります。 eth0とeth1が変な関連情報を持ってしまっているようです。 どのへんをいじったら直りそうですか?

  • DNSサーバ設定ファイル"resolv.conf"の内容がリセットされる。

    IPでは、Webサイトにアクセスできるが、ドメインではアクセスできないという問題が発生したため、DNSの設定の問題を疑い、DNSサーバ設定ファイル"resolv.conf"ファイル(/etc/resolv.conf) をチャックしました。案の定、内容はコメント以外、空白だったので、DNS1=***.***.***.***、DNS2=***.***.***.***という形で設定したのですが、ネットワークを再起動するたびに、"resolv.conf"がリセットされ空白に戻ってしまいます。 原因をネットで調べて、”ifcfg-eth0”ファイル(/etc/sysconfig/network-scripts/ifcfg-eth0)の設定を変更したのですが、駄目でした。 OS:Linux Fedra 10 現在の”ifcfg-eth0”ファイルの内容は以下。 DEVICE=eth0 HWADDR=00:11:43:80:3c:42 ONBOOT=yes BOOTPROTO=static USERCTL=no PEERDNS=no IPV6INIT=no NM_CONTROLLED=yes TYPE=Ethernet NETMASK=255.255.255.0 IPADDR=192.168.1.105 GATEWAY=192.168.1.1 DHCPCDARGS='N'

  • VMWare のNW設定(bonding)について

    現在VMWare Player 4.0.1を使用してネットワーク設定(bonding)を実施しております。 どうしても通信が不可になってしまう為、どなたかご教授お願いします。 設定前状態 ホストOS(windows7) WMware Network Adapter VMnet1:192.168.20.1/24 ファイアウォール:OFF ゲストOS(RHEL5.6):ホストオンリー接続 eth0:192.168.20.101/24 eth1:192.168.20.150/24 iptable:OFF 上記状態で、ホストOSからTeraTermのSSH接続で192.168.20.101も192.168.20.150も接続が出来ます。 上記状態から下記の変更を行いました。 (1)/etc/modprobe.confの最後に下記を追記 「alias bond0 bonding」 (2)/etc/sysconfig/network-scripts/ifcfg-bond0を作成して下記を追記 DEVICE=bond0 IPADDR=192.168.20.101 NETMASK=255.255.255.0 NETWORK=192.168.20.255 GATEWAY=192.168.20.1 ONBOOT=yes BOOTPROTO=static BONDING_OPTS="mode=1 primary=eth2 miimon=100 updelay=5000" (3)/etc/sysconfig/network-scripts/ifcfg-eht0を下記に修正 DEVICE=eth0 MASTER=bond0 SLAVE=yes BOOTPROTO=none HWADDR=<マックアドレス記載> ONBOOT=yes (4)/etc/sysconfig/network-scripts/ifcfg-eth2を下記に修正 DEVICE=eth2 MASTER=bond0 SLAVE=yes BOOTPROTO=none HWADDR=<マックアドレス記載> ONBOOT=yes (5)「shutdown -r now」にて再起動実施 上記実施後にホストOSからTeraTermにてSSH接続をしたところ、 192.168.20.101も192.168.20.150にたいしても、 ユーザ名、パスフレーズを入力する画面までは出てくるのですが、 OKが押せずにログインが出来ません。 コマンドプロンプトからの通信もタイムアウトになってしまいます。 ping 192.168.20.101 要求がタイムアウトしました。 原因が分からずに困っております。 どなたか原因となるような項目を教えていただければと思います。

  • CentOSのネットワーク設定について

    教えてください。 CentOSのネットワーク設定で2点質問があります。 (1点目) cat /etc/sysconfig/networkにはGATEWAYのアドレスの記述が欠落していると動作的におかしくなることがありますでしょうか? 因みにcat /etc/sysconfig/network-scripts/ifcfg-eth0にはGATEWAYのアドレスがあります。 (2点目) cat /etc/resolv.confに以下のような順番での記述があります。 search (IPアドレス(1)) nameserver (IPアドレス(2)) searchはどのような役目になりますでしょうか? 宜しくお願いします。

  • デフォルトゲートウェイの設定場所

    CentOS5.9を使用しています。 /etc/sysconfig/network と cat /etc/sysconfig/network-scripts/ifcfg-eth0 「GATEWAY」項目があり、同じデフォルトゲートウェイのIPが設定されていることに気づきました。 ただ、別のCentOSサーバを見てみた所 ・/etc/sysconfig/network-scripts/ifcfg-eth0(eth1やeth2の複数ささってるサーバでも) のeth設定ファイルだけに、「GATEWAY」の設定があるが、networkにはない。 ・/etc/sysconfig/network の方にだけにあり、eth関係のファイルにはない。  とサーバで環境がバラバラなことに気づきました。 (同じCentバージョンでも違ってるものがありました。) 特に、インストール時にIPを設定したぐらいで 設定変更等行っていません。 この「/etc/sysconfig/network-scripts/ifcfg-eth0」と「/etc/sysconfig/network」に 設定するGATEWAYなのですが、 ・どちらのファイルに設定してても良いものなのか? ・ifcfg-eth0 の方にあれば良いものなのか? ・network の方にあれば良いものなのか? がわかりません。(特に全サーバ問題なく動いているのですが・・・。) また、全サーバ複数NICがささっていても、アップリンク(インターネット等)への接続は全てeth0になっております。eth0の先のルータで、ルーティングしております。 ご教授お願いします。

  • TurboLinux Server6.5FTP版でのネットワークボード認識について

    Linux超初心者ですが宜しくお願いします。 旧GateWayデスクトップにTurboLinux6.5SVをインストールしましたが NICを認識しません。(メルコLGY-PCI-TXC)最初は ifconfig ではloのみですがmodules.confにalias eth0 sis900を追記保存して モジュールを読み込みするとifconfigでeht0がでてきます。その後 ifconfig eth0 up や/etc/rc.d/init.d/network restartを行っても IPアドレス等を書き込むファイルifcfg-eth0(/etc/sysconfig/network-scripts/)に出てきません。再起動すると、ifconfigでまたloのみになります。 起動時に読み込まれているように出来ますか? それと、少し話は飛びますが、普通のPCにLinuxを入れてサーバー代わりに している話は山ほど聞きますが、常時稼動で電源系統は大丈夫なのでしょうか? それとも、サーバーといえ利用しないときは電源を切って利用しているのでしょうか?・・質問が下手ですみませんが宜しくお願い致します。