• 締切済み
  • 困ってます

Sendmail-8.11.6

自習目的で自宅サーバ(Mac Leopard)にmail serverを立てようとしております。そこで手元にある詳しい参考書の記事(Sendmail-8.11.6用)を頼りにSendmailをダウンロードしましたが、あいにく最新のバージョン(8.14.3)しかダウンロードできず、参考書が役に立ちません。以下の二つの質問をさせて下さい。 Q1. 旧バージョンを入手することは難しいのでしょうか? Q2. 最新バーションにも挑戦しようと、添付のインストールドキュメントを読みましたが、つぎのような記載(ダウンロードした「.mc file」をcf/READMEに従って加工せよ、という指示の後に書いてあります)が良く理解できません。 「Then run "sh ./Build sendmail.cf"」  これを、「次に ./Build sendmai.cfなるコンフィギュレーションフィルをは走らせよ(実行せよ)」という意味に解釈しましたが、「sh」というUnixのコマンドは無いようですので、困ってしまいました。 どなたか、お助け下さい! お願い致します。

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数51
  • ありがとう数2

みんなの回答

  • 回答No.2

あぁ、Mac LeopardってOS Xなんですね http://www.kadoppe.net/2007/12/mac-os-xleopard.html ちゃんとshはあります /binにpathを通せばいいだけ

共感・感謝の気持ちを伝えよう!

質問者からのお礼

unix学習中で、初歩的過ぎる質問をしてしまったようで...。 これからその「パスを通す」ことを学習致します。 ありがとうございました。

  • 回答No.1

> Q1. 旧バージョンを入手することは難しいのでしょうか? もし入手できたとしても8.11.xを使うなどということはセキュリティ上避けるべきです > 「sh」というUnixのコマンドは無いようですので、困ってしまいました。 sh(シェル)がないUNIXって、今お使いのUNIXはなんですか? pathが通ってないだけでは?

共感・感謝の気持ちを伝えよう!

質問者からのお礼

unix学習中で、初歩的過ぎる質問をしてしまったようで...。 これからその「パスを通す」ことを学習致します。 ありがとうございました。

関連するQ&A

  • sendmail8.12.1の設定について

    初めてFreeBSDをセットアップして、sendmailの設定をする者です。 OSはFreeBSD4.2-RELEASEです。 sendmailのバージョンは8.12.1です。サイトからsendmailをダウンロードして、展開したところまではいいんですが、sh Buildを実行するとエラーがでます。 <エラー内容>  Configuration:pfx=,os=FreeBSD,rel=4.2-RELEASE, rbase=4,rroot=4.2-RELEASE,arch=i386,sfx=, variant=optimized  ERROR:Using M4=usr/bin/m4:This version of m4 is broken:length problem m4が何かよくわかりませんでしたが、とりあえずFreeBSDのCD-ROMのpackagesからm4-1.4.tgzというファイルをインストールしなおすと上記エラーはなくなりコンパイル環境が用意されました。たまたま、m4というファイルが壊れていたのかと思っていたんですが、別のPCに別のCD-ROMのFreeBSDをセットアップして、新たに別サイトからダウンロードしたsendmailをインストールすると、やはりsh Buildで上記エラーになりました。 sendmail8.12.1の問題なのでしょうか?sh Buildの前にm4ファイルに何かしなければならないのでしょうか? FreeBSD、sendmailに詳しい方々の回答よろしくお願い致します。

  • turbolinuxサーバーのsendmail設定について

    現在、上記タイトルのような事をしたいと思い参考書などを持っては設定に挑戦をしている所です。 参考書付属のturbolinuxインストールCDを使いインストールした時にインストールタイプで「すべて」を選択しておいたのでsendmailをインストールされてはいました。 そこから cleantools のCF初期化 tools のCF再構築 sendmail-v8.defをバックアップし、mydomain.defという物にコピーした後、設定を変更していました。 一通りの設定が終了した時に問題は発生しました。 マニュアルによると、CFでsendmail用設定ファイルを作成すると記述してありますがどのように作成するのかわかりません。 文によるとmake mydomain.cfとコマンドをうちsendmailの動作を確認しておくれと記述してありますが、make mydomain.cfがないので実行されません。しかもmydomain.cfファイルなどは作った記憶もないのでありません。どのように作成するのか教えて頂けませんでしょうか? お願します。

  • sendmailで外部メールアドレスとやり取りするには

    現在turbolunux6.5によりsendmailの設定をしている所です。 一通りの設定はなんとかで来ました。 しかし、外部(ローカルネットワークではなく)とのメールのやり取りがうまく出来ません。 2冊ぐらいの参考書を買いあさっては、調べ、の作業を繰り返しています。 その中で怪しい設定方法があったのですが、詳しく書かれていないため見よう見まねでやってみた所特に変化が在りません。 作業的には、 sendmail.cf の中を覗き #C[ClientDom] localhost #C[ClientDom] my.client.domain #F[ClientDom] -o /etc/sendmail.clientdomain の所を #C[ClientDom] localhost #C[ClientDom] my.client.domain F[ClientDom] -o /etc/sendmail.clientdomain にしました。(一番下の#をはずしました。) 次に#をはずしたファイル先に sendmail.clientdomain を作り、その中に ALL ALL ALL としました。 これで外部にメールを送る試みをしましたが、 メールが送られませんでした。 送る側では特にメールが返ってくるわけでもなく 行きっぱなしの状態です。 しかし受信側はメールが届いている様子が在りません。 どうか教えて頂けませんでしょうか? お願します。

  • iPhone SDKの旧バージョンをダウンロードする方法

    iPhone開発者の方にご相談があります。 LeopardでiPhoneアプリの開発をしようとしており、Leopardで動作するiPhone SDK バージョン3.1の最新版をダウンロードしたいと思っております。 しかし、以下のサイトにはSnow Leopard用のバージョン3.2しかありません。 http://developer.apple.com/iphone/index.action#downloads バージョン3.1の最新版をダウンロードするためには、どうすればよいのでしょうか? iPhone Developer Programに登録すれば、ダウンロードできるようになるのでしょうか? よろしければご教授ください。 よろしくお願いいたします。

  • Illustrator、Photoshop

    今度、仕事でIllustratorとPhotoshopを使う事になりました。しかも独学でやる事になり、そこで参考書を買おうと思うんですが、独学の苦手な超初心者でもわかりやすい参考書はありますか?因みにバージョンでしょうか?CSって何ですか? 今、最新のバージョンはいくつですか?教えて下さい。 よろしくお願いします

  • FORTRANのフリーソフトFTN77?FTN95?

    FORTRANのフリーソフトFTN77?FTN95? こんにちは、理系大学3年生のものです。 夏休みの課題として、指導教授からFORTRANを学習するように言われました。 先生にはFTN Personal Edition 77をコンパイラとしてダウンロードしなさいと言われました。 宿題として出された参考書のタイトルにもFORTRAN77と書いてあります。 しかし、調べてみてもFTN77のダウンロード先が見当たりません。 どうやら、Salford FTN77の後継バージョンがSilverSoftからFTN95という名前になったらしいのですが、つまり、FTN77はもうダウンロードできないってことなんですか? FTN95をダウンロードしてコンパイラとして使用したら、バージョンが違うから、FORTRAN77の参考書では不都合が起きますか? できるなら参考書通りFTN77をダウンロードしたいと思っているのですが、できますかね? それとも最新のFTN95をダウンロードするべきですか? 回答お願いします。

  • PHPとApacheの最新バージョンを学べるHP

    今からPHPを学びたいと思っています。参考書を買ったのですが、そこに載っているバージョンはちょっとだけ古くてPHP5.1.6とApache2.0.59です。ちょっと設定を変えなくてはならなくて 設定を変えたのですが・・・わけのわからない英文が出てきました。非常に困っております。参考書の最初のページに行く前にこんなところで詰まっております。どちらとも最新バージョンでダウンロードして設定を変更することをちゃんと教えてくれるHPはないですか?よろしくお願いします。ダウンロードしてから、設定を変えて、参考書に戻りたいです。ちなみに本の通りPHP5.1.6をダウンロードしようと思ったらもう結構古いのかダウンロードする前に国旗マークが出てこないので、英語バージョンしか無理だと思い止めました。

    • ベストアンサー
    • PHP
  • MacOSX v.10.3.9でのGoogle earth閲覧

    MacOSX v.10.3.9で以前はGoogle earth をみることができました。 本日、デスクトップのGoogle earth を開こうとしましたら、v.10.4. でないと対応していない、Google earth 4.0 をダウンロードせよ・・とのメッセージが出て、ダウンロードしましたが、見られません。 Google earth はどんどん進化して、最新のOS バージョンでなければ見られなくなって行くものなのでしょうか? そうであれば、私はOSX v.10.3.9 にleopard を購入してインストールしなければ見られないのでしょうか? ちなみに私の家内は古いWindows 2000?あるいはXP?でいまでも見ているようなのですが、win ならば古いOS でも見られて、Mac は最新OSでないと見られないものなのでしょうか? つい先日まで、このバージョンのOSX で見られていたのに、今日は見られないのは私の知識不足なのでしょうか?Google の進化なのでしょうか? ネット初心者ですのでどなたかお教え下さい。

    • ベストアンサー
    • Mac
  • バージョン選びについて

    お世話になります。 Apache PHP MySQLをインストールしたいのですが、 手元にある参考書には、Apache2.2.0 PHP5.0 MySQL5.0を想定して解説してあります。 現在利用しているサーバの利用案内を見たところ、PHPのバージョンは4.4.1となっていますが、PHP4.4.1以外は最新のバージョンのものをインストールし、参考書の通りに進めていけばよいのでしょうか? それともバージョンが違うと設定方法も違ってくるのでしょうか。

    • 締切済み
    • PHP
  • scilabのダウンロードについて

    scilabをダウンロードしたいのですが、scilab5.1.1しか見つかりません。 私は勉強のためにダウンロードをするのですが、scilabの勉強のためにと購入した参考書ではscilab4.1.1を使用しており、同じバージョンのものをインストールしたいのですがscilab4.1.1が見つかりません。 どこに行けばダウンロードできるのでしょうか。 また、バージョンが高いものでも代用可能でしょうか。