-PR-
解決
済み

pingが通らない

  • 暇なときにでも
  • 質問No.25220
  • 閲覧数850
  • ありがとう数7
  • 気になる数0
  • 回答数3
  • コメント数0

お礼率 33% (1/3)

次のような環境で端末NTSVRから端末PC98への
pingが通らないのですが、どのような原因が
考えられるでしょうか。初歩的な質問ですみませんが、
よろしくしくお願いします。

NTSVR:WindowsNT Server 4.0(192.168.0.1)
PC98:Windows98(192.168.0.2)
この二つは、HUBを介して接続されている

(1)NTSVRもPC98も自分自身へのpingは通る。
例:NTSVRより、ping 192.168.0.1 → OK

(2)エクスプローラでお互いの共有リソースは
 見ることができる

(3)相手のマシンへに向けたpingが通らない
(アドレス指定による)
例:NTSVRより、ping 192.168.0.2 → NG

(4)もう一台PC98_2をHUBに追加すると、
PC98・PC98_2の間ではpingが通るが、
NTSVR・PC98_2の間ではpingが通らない

(5)ケーブルの交換、HUBの接続口の交換をしても
同じ結果になる

長文でごめんなさい
通報する
  • 回答数3
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.2
レベル10

ベストアンサー率 33% (61/184)

途中で、ゲートウエイルータを2台以上設置していないでしょうか?
その場合は、ディフォルトゲートウエイ同士で通過設定をしないと、PINGはとおりません。

WindowsNT Server4.0でDHCPサーバを動かしていますでしょうか?
その場合、IPアドレスのリースが切れた時に時々、前の使っていたIPアドレス以外のものを振る時があります。
その場合は、IPアドレスは2台ともうまく設定しているため端末は見えてますが、人間側が同じIPアドレスだと思い込んでいる場合は、
パソコン同士は見えているが
人間側はもう存在しないIPアドレスにPINGをしているという場合もあります。

また、コンピュータ名でPINGがとおるでしょうか?
コンピュータ名「comp1」
付与IPアドレス「192.168.0.20」
ping comp1としますと
192.168.0.20と返ってきます。

WINSサーバを導入して、各端末がWINSサーバを認識しているようでしたら(普通はこのサーバは100%必要ない)
コンピュータ名+ネットワークドメイン名でもPINGが可能です。
コンピュータ名「comp1」
ネットワークドメイン「exsampl.ne.jp」
IPアドレスは同じとしまして
ping comp1.exsample.ne.jp
192.168.0.20と返ってきます。

別のPING方法でもできないでしょうか?
-PR-
-PR-

その他の回答 (全2件)

  • 回答No.1
レベル11

ベストアンサー率 63% (108/169)

NTSVのTCP/IPを一度削除して入れ直してみてはどうでしょうか? その際、TCP/IP削除後のリブートと hosts使用時はバックアップ採取をお忘れなく。 ...続きを読む
NTSVのTCP/IPを一度削除して入れ直してみてはどうでしょうか?
その際、TCP/IP削除後のリブートと hosts使用時はバックアップ採取をお忘れなく。
補足コメント
shin1

お礼率 33% (1/3)

早速の回答ありがとうございます。

TCP/IPの入れなおしたのですが、
うまくいきませんでした。
他に何か考えられる原因はないでしょうか

まず、PC98側には問題がなく、
さらに下記のことから、
HUBと端末NTSVRのネットワークアダプタにも
問題がないと判断しているのですが。

>(2)エクスプローラでお互いの共有リソースは
> 見ることができる
投稿日時 - 2001-01-07 12:33:23


  • 回答No.3
レベル13

ベストアンサー率 26% (511/1924)

ping 通らない事による不具合って何かありましたっけ? ファイル共有やその他の通信ができているのであれば特に問題は無いと思うんですけど・・・ Windows98のネットワークプロパティでTCP/IPがデフォルトになってないとかかなぁ。 IPの設定はDHCPですか?それともスタティックに設定されてるんですか? ...続きを読む
ping 通らない事による不具合って何かありましたっけ?
ファイル共有やその他の通信ができているのであれば特に問題は無いと思うんですけど・・・

Windows98のネットワークプロパティでTCP/IPがデフォルトになってないとかかなぁ。
IPの設定はDHCPですか?それともスタティックに設定されてるんですか?
お礼コメント
shin1

お礼率 33% (1/3)

いろいろとアドバイスありがとうございます。
解決いたしました。

解決は次の修正によってできました。

ハブには、前記の端末のほかに、
ルータがつながっていました。
(つまり、NTSVR、PC98、PC98_2、ルータが
 HUBを中心として接続されていた)
このルータのネットワークアドレスと
端末のネットワークアドレスが
今まで違っていたのですが、
これをそろえたら、PINGが通るようになりました。

>ping 通らない事による不具合って何かありましたっけ?

本などを見ながら初めてのLAN構築に取り組んでいます。
その途中、「pingで確認してください」とあったので、
試してみたところでした。

ありがとうございました!
投稿日時 - 2001-01-07 20:28:10
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ