OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

turbopkgでパッケージの自動アップデート

  • 暇なときにでも
  • 質問No.243766
  • 閲覧数59
  • ありがとう数2
  • 気になる数0
  • 回答数2
  • コメント数0

お礼率 66% (4/6)

こんばんは!私は、TurboLinux7WSを使っています。
turbopkgで、自動アップデート(ローカルにDLしてあるアップデートパッケージ)
のアップデートをしたら、kpackageで新しくRPMパッケージを入れようとしても、
エラーになってインストールできません。
ただし、「依存関係をチェック」のチェックを外すとインストールできるのですが
それだとプログラムが動かない可能性あるということなので…。

エラー内容
0 つのソースと1 つのバイナリパッケージを見つけました
rpmdepCheck() failed.

このエラーは何でしょうか?どなたか修正する方法を知っている方がいましたら
ぜひ教えてください。
通報する
  • 回答数2
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.2
レベル8

ベストアンサー率 40% (12/30)

自動アップデートTOOLの場合によくある事みたいです。
turbopkgが駄目なら、rpmコマンドでアップデートする手があります。アップデートパッケージ名もわかっておられる見たいですし。
こちらだと依存関係の表示もできますので、必要なパッケージの追加でアップデートパッケージをインストールできると思います。
お礼コメント
ino_dai

お礼率 66% (4/6)

回答ありがとうございます。
まだ、rpmコマンドのこともよくわかってないので・・・。まあ、解説書見ながらがんばります。
ありがとうございました。
投稿日時 - 2002-04-01 16:20:04
-PR-
-PR-

その他の回答 (全1件)

  • 回答No.1
レベル13

ベストアンサー率 34% (574/1662)

ユーザーでもなければ使ったこともないのですが、 インストールしようとしているパッケージを 動作させるために必要なパッケージがまだインストールされていない状態でしょうね。 依存関係のチェックとはそういうことです。 当然、無理にインストールしたらまともには動かないはずです。一部の機能が使えない程度ですむ場合もあるかも知れませんが、それもまともに動かないうちです。 解決するには必要なパッケージ ...続きを読む
ユーザーでもなければ使ったこともないのですが、
インストールしようとしているパッケージを
動作させるために必要なパッケージがまだインストールされていない状態でしょうね。
依存関係のチェックとはそういうことです。
当然、無理にインストールしたらまともには動かないはずです。一部の機能が使えない程度ですむ場合もあるかも知れませんが、それもまともに動かないうちです。


解決するには必要なパッケージをインストールするか、
少なくてもそれをダウンロードしておいて
同時にインストール可能な状態にするかしないとだめでしょう。

具体的に何が必要かはどこかに表示されているように思うので、それを調べてください。

>rpmdepCheck() failed.
RPM depend check, つまり依存関係のチェックに失敗したということでしょう。
補足コメント
ino_dai

お礼率 66% (4/6)

ありがとうございます。
しかし、必要なパッケージはどこにも表示されてないんですよ。
ふつうだったら、「xxxのパッケージが必要です。」みたいなことがでると思うんですが。
どのパッケージでもエラーになるのでアップデートに失敗したのではないかと思うのですが。
投稿日時 - 2002-03-31 12:25:04
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ