OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
締切り
済み

Applet について

  • 困ってます
  • 質問No.133146
  • 閲覧数33
  • ありがとう数5
  • 気になる数0
  • 回答数5
  • コメント数0

お礼率 30% (19/63)

J2SEv1.3.1_01をいれたのですが、
Web上でAppletが見れません。
(そのAppletの範囲は確保されて空白のスペースが出来てしまいます。)
ブラウザはIEv4.0を使っています。
ブラウザの設定が悪いのでしょうか?
(Javaに関する部分はいじってないはずなのですが)
通報する
  • 回答数5
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

回答 (全5件)

  • 回答No.1
レベル9

ベストアンサー率 62% (48/77)

ブラウザのバージョンのせいのような気がします。 以前私がIE4.0でアプレットを動作させようとした時、4.0では動作せず5.xなら 動作した覚えがあります。 可能であればバージョンをあげてみてはどうでしょう? (ただし必ずブラウザをインストールした後にJ2SEをインストールして下さい) ...続きを読む
ブラウザのバージョンのせいのような気がします。
以前私がIE4.0でアプレットを動作させようとした時、4.0では動作せず5.xなら
動作した覚えがあります。
可能であればバージョンをあげてみてはどうでしょう?
(ただし必ずブラウザをインストールした後にJ2SEをインストールして下さい)
お礼コメント
satoryu

お礼率 30% (19/63)

失礼しました。IEのバージョンは5.5の間違いでした。
この場合は再インストールがいいんですかね?
投稿日時 - 2001-09-10 21:33:19


  • 回答No.2

ブラウザでJavaアプレットの実行が無効になっていませんか? IE5.5ということなので、 「ツール」-「インターネットオプション」-「セキュリティ」-「レベルのカスタマイズ」で、現在の設定状況を確認してみてはいかがでしょうか? この中で、Javaの実行やスクリプト実行が無効になっていたりするのではないでしょうか? ...続きを読む
ブラウザでJavaアプレットの実行が無効になっていませんか?

IE5.5ということなので、
「ツール」-「インターネットオプション」-「セキュリティ」-「レベルのカスタマイズ」で、現在の設定状況を確認してみてはいかがでしょうか?
この中で、Javaの実行やスクリプト実行が無効になっていたりするのではないでしょうか?
お礼コメント
satoryu

お礼率 30% (19/63)

スクリプトの実行は全て有効に設定されていました。
Javaの実行のレベルは中になってたのですが、
これはこのままでいいのでしょうか?
投稿日時 - 2001-09-10 22:23:26
  • 回答No.3
レベル9

ベストアンサー率 62% (48/77)

たぶんないと思いますが、先にJ2SEをインストールしてしまい、後から ブラウザをインストールするとJ2SEがプラグインされません。この場合、 J2SEをアンインストールして再度インストールし直すといいと思います。 それでもだめな場合、もしかしたらみようとしているAppletがJ2SE1.3.1.01 に対応していないかもしれませんね。このバージョンは最新ですから。 他に怪しいと思われるものは、[ ...続きを読む
たぶんないと思いますが、先にJ2SEをインストールしてしまい、後から
ブラウザをインストールするとJ2SEがプラグインされません。この場合、
J2SEをアンインストールして再度インストールし直すといいと思います。
それでもだめな場合、もしかしたらみようとしているAppletがJ2SE1.3.1.01
に対応していないかもしれませんね。このバージョンは最新ですから。
他に怪しいと思われるものは、[スタート]→[設定]→[コントロールパネル]→
[Java Plug-in]を起動してみて下さい。Java Plug-inでプラグインしている
Javaの設定などができます。(難しいかな・・・)
お礼コメント
satoryu

お礼率 30% (19/63)

再インストールでは変わらなかったので、
JavaPlub-inを起動してみたのですが、
有効にチェックがついているので、これでいいかとも思うのですが。
[詳細]のせっていは「デフォルトで使用」でいいのですか?
投稿日時 - 2001-09-11 12:44:08
  • 回答No.4
レベル9

ベストアンサー率 62% (48/77)

>[詳細]のせっていは「デフォルトで使用」でいいのですか?  他に選択できるなら変えてみて実行してみてはどうでしょう?  とりあえず考えられそうな原因は  1.インストールした順番  2.ブラウザの設定(spoonyさんが紹介している内容です)  3.コントロールパネル内のJavaPlug-inの設定  4.実行しようとしているアプレットがJ2SEのバージョンにあわない  くら ...続きを読む
>[詳細]のせっていは「デフォルトで使用」でいいのですか?

 他に選択できるなら変えてみて実行してみてはどうでしょう?

 とりあえず考えられそうな原因は
 1.インストールした順番
 2.ブラウザの設定(spoonyさんが紹介している内容です)
 3.コントロールパネル内のJavaPlug-inの設定
 4.実行しようとしているアプレットがJ2SEのバージョンにあわない
 くらいかなぁと思うのですが・・・
 IEじゃなくてネスケを使ってみるとか・・・(^^ゞ
 思いつく内容はこのような所なのですが、どうでしょう?(役立たずですみません)
  • 回答No.5
レベル6

ベストアンサー率 75% (3/4)

IEの設定をこれだけ変えても問題が改善されないということは、 恐らくソースに問題があるのかと思われます。 実際、私もコンパイルはできたけど表示がうまくいかないことは よくありました(^^; Appletということなのできっと Image型のdrawImage()メソッドを使っておられることと存じます。 もう一度ソースを見直して、 ・画像がファイルからちゃんと取得されているか、 ・pai ...続きを読む
IEの設定をこれだけ変えても問題が改善されないということは、
恐らくソースに問題があるのかと思われます。
実際、私もコンパイルはできたけど表示がうまくいかないことは
よくありました(^^;
Appletということなのできっと
Image型のdrawImage()メソッドを使っておられることと存じます。
もう一度ソースを見直して、

・画像がファイルからちゃんと取得されているか、
・paint()メソッドの中でちゃんと描画されているか

など、確認してみてはいかがでしょうか?
もしかしたら、getDocumentBase()メソッドで
画像取得の場所が間違っているのかも。
もしよかったらソースも載せていただけると問題も改善し易いかと存じます。
(解答が遅かったかな?)
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
こんな書き方もあるよ!この情報は知ってる?あなたの知識を教えて!
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ