-PR-
解決
済み

自作の掲示板にアクセスできない

  • すぐに回答を!
  • 質問No.31165
  • 閲覧数101
  • ありがとう数2
  • 気になる数0
  • 回答数2
  • コメント数0

お礼率 26% (60/226)

自作で掲示板を作りました。
ApacheとPerlでローカルでの動作確認を行った後、プロバイダのサーバーにアップロードしました。
ところがhttp://xxx.hi-ho.ne.jp/~xxx/xxx.cgiにアクセスすると、ブラウザがアクロバットリーダーで書類を開こうとしてしまい、cgiプログラムが動きません。

cgi,plはEUC(文字)CR+LF(改行)で保存し、アスキーモードでアップロードしました。その他、プロバイダ-が指摘する注意事項(cgiプログラムの置き場所など)も全てチェックしたつもりです。

でもとても初歩的なミスを犯しているのかもしれないと思い、投稿しました。
よろしくお願いします。
通報する
  • 回答数2
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.2
レベル6

ベストアンサー率 27% (3/11)

No91の質問とは掲示板のことでしょうか?
お使いのプロバイダがHI-HOのようですが、SSIにて#execが使えないなどの制限事項があるようです。
SSIを用いて掲示板部分のCGIを読み出しているものをご利用ならば、エラーが出るかと思います。
私もそんなに詳しくはありませんので、参考までにですが。
お礼コメント
masamisss

お礼率 26% (60/226)

すいません。
CGIプログラムの冒頭の「Perlのパス」を間違えているだけでした。ああ恥ずかしい。
おかげで掲示板アップできました。

ありがとうございました。
投稿日時 - 2001-01-23 16:06:42
-PR-
-PR-

その他の回答 (全1件)

  • 回答No.1
レベル10

ベストアンサー率 16% (22/136)

まさかと思いますが、アップロードのあとそれぞれのファイルにパーミッションを設定しましたか? ...続きを読む
まさかと思いますが、アップロードのあとそれぞれのファイルにパーミッションを設定しましたか?
補足コメント
masamisss

お礼率 26% (60/226)

再度すみません。
No.91の質問の補足をさせてください。

その後、ブラウザに「execv failed.(2)(/02/0255/masami-s/cgi-bin/keijiban.cgi)(/chome)」というメッセージが出ていることがわかりました。

これってkeijiban.cgiのプログラム自体になにか問題があるということなんでしょうか?
投稿日時 - 0000-00-00 00:00:00


このQ&Aのテーマ
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
こんな書き方もあるよ!この情報は知ってる?あなたの知識を教えて!
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ