-PR-
kamekamesi

自作キットでFedoraCore4をインストールしました。
ですが、起動時に「eth0 <失敗> インクがありません。ケーブルを確認?」と出ます…。
ケーブルは、別のPCで使っているケーブルを差し替えただけです。
システム設定で「起動」をクリックしても「できませんでした」となります。
ドライバの問題か?と思ったのですが、「ifconfig」で「eth0」の表示があります。
そのほか、「自動的にIPアドレス設定を取得」にもチェックを付けています。

ちなみに、私の一番の疑問は、プロバイダのIDやパスワードは設定しなくてよいのでしょうか?
市販のテキストには、書いてないのでわかりません。アドバイスをお願い致します? 
  • 回答数5
  • 気になる数0
  • Aみんなの回答(全5件)

    質問者が選んだベストアンサー

    • 2005-10-13 19:20:02
    • 回答No.5
    No.3で回答したものです。
    結局ルータはお持ちではなくて、ADSLモデムだけなんですよね?pppoeはそういう環境の時だけ必要です。もしルータをお持ちなら、以下は関係ありませんから無視してください。

    コマンドラインから、

    rpm -qa | grep pppoe

    と実行すると、

    rp-pppoe-3.5-27.FC4.1

    みたいな結果が出ますか?(バージョンは異なるかも)
    この結果が出れば、rp-pppoeがインストールされています。

    私はFC4を使用したことがないのですが、参考URLのサイトを見ると、adsl-setupという便利なコマンドがあるようですね。
    ただし、このサイトの設定どおりに実行するとkamekamesiさんの場合はうまくいかないと思いますので注意して下さいね。

    「ブロードバンドモデムでインターネット接続(PPPoE)」の(1)インターネット接続設定だけ実行すればOKですが、おそらく次の点が異なるだろうと思います。
    ・INTERFACEにはeth0を使用する
    ・DNSには、プロバイダから指定されたDNSのアドレスを入力する
    ・USERCTRLはお好みで
    ・FIREWALLINGは1(STANDALONE)かな?

    設定がうまくいけば、次からは
    /sbin/ifup ppp0
    で接続できるのでは??
    お礼コメント
    ★★インターネットに接続できましたぁ~!!★★

    ありがとうございます!とても分かりやすかったです!感動で~す♪♪

    貴重なお時間をさいて頂きまして、本当にありがとうございました。m( .. )m
    投稿日時 - 2005-10-14 00:33:33
    • ありがとう数0
    -PR-
    -PR-

    その他の回答 (全4件)

    • 2005-10-12 23:12:23
    • 回答No.4
    こんにちは。 ADSL接続では、通常、デフォルトゲートウェイとDNSを設定しないとどこにもつながりません。 私は、FedoraCore4 は使ったことないので判らないのですが、ネットワークを設定するコマンドで「netconfig」というのがあるでしょうか? これがあれば、su で、root になるか、root でログインして、ターミナルから、「netconfig」と打って[Enter]します ...続きを読む
    こんにちは。
    ADSL接続では、通常、デフォルトゲートウェイとDNSを設定しないとどこにもつながりません。

    私は、FedoraCore4 は使ったことないので判らないのですが、ネットワークを設定するコマンドで「netconfig」というのがあるでしょうか?

    これがあれば、su で、root になるか、root でログインして、ターミナルから、「netconfig」と打って[Enter]します。

    すると各項目の設定画面が出てきますので、それらを入れます。

    デフォルトゲートウェイは、ルーターのIPアドレス、DNSはプロバイダから指定されたものをいれます。

    既に NIC の認識は出来てるようなので、大抵はこれでいけるはずですが。
    お礼コメント
    ありがとうございました!
    ★インターネットに接続ができました!!★

    私の説明不足で申し訳なかったのですが、ルーターを使っていなくてADSLモデムのみだったんです。すみません。
    それで、別の方からの回答にあったPPPoEを設定することで接続ができました。

    何度もお時間をさいて頂き、本当にありがとうございました。m(_ _)m
    投稿日時 - 2005-10-14 00:41:25
    • ありがとう数0
    • 2005-10-11 12:00:07
    • 回答No.3
    「別のPC」はどうやって外部のネットに接続していましたか? もしかして、NTTのフレッツADSL等でしょうか? つまり、ルータが無く、PCにADSLモデム直結で、Windowsに接続ツールをインストールしていましたか? だとすると、Linuxにも似たような接続ツールが必要です。 RP-PPPoEというキーワードで見つけられると思います。 ...続きを読む
    「別のPC」はどうやって外部のネットに接続していましたか?
    もしかして、NTTのフレッツADSL等でしょうか?
    つまり、ルータが無く、PCにADSLモデム直結で、Windowsに接続ツールをインストールしていましたか?

    だとすると、Linuxにも似たような接続ツールが必要です。
    RP-PPPoEというキーワードで見つけられると思います。
    補足コメント
    補足いたします。

    参考サイトを拝見しました。

    やってみようと思ったのですが、いきなり「ダウンロードする」とありますが、ネットワークにつながっていないので、どうしていいのかわかりません。

    それと、locateコマンドでpppoeを検索したら、たくさんファイルが存在しました。これってすでにあるってことですよね?

    う~ん。わからない・・・
    投稿日時 - 2005-10-12 14:39:36
    お礼コメント
    ありがとうございます!
    プロバイダはeoホームファイバーなんです。
    でも、PPPoEという存在は、とても勉強になりました。
    一度プロバイダに問い合わせてみようと思います。
    参考サイトも利用させて頂いてます。ありがとうございます。
    投稿日時 - 2005-10-12 00:12:56
    • ありがとう数0
    • 2005-10-10 21:50:44
    • 回答No.1
    > 別のPCで使っているケーブルを差し替えただけです。 LANケーブルがちゃんと挿さってないのでは。 ネットワークインタフェース部に、リンクアップ表示のLEDがついていると思いますので、それを目視確認してみては。 物理的な接続に問題が無ければ、DHCPでのやりとりがうまく言ってない可能性があるので、IPアドレスを直接設定して原因を切り分けるとか。 ...続きを読む
    > 別のPCで使っているケーブルを差し替えただけです。

    LANケーブルがちゃんと挿さってないのでは。
    ネットワークインタフェース部に、リンクアップ表示のLEDがついていると思いますので、それを目視確認してみては。

    物理的な接続に問題が無ければ、DHCPでのやりとりがうまく言ってない可能性があるので、IPアドレスを直接設定して原因を切り分けるとか。
    補足コメント
    すみません。補足いたします。
    固定IPアドレスは有料なんですね…。勝手に設定していました…。やはりDHCPで接続したいので、もし他に方法があればご教授ください。お願いします。
    投稿日時 - 2005-10-12 14:36:06
    お礼コメント
    ありがとうございます。
    ケーブルも差し込みが甘かったみたいです。でも、やはり「eth0 <失敗>」と出ます。

    やはりDHCPがうまくいっていないようで、ためしに固定IPアドレスを設定してみたところ、eth0を起動できました。
    デフォルトゲートウェイはプロバイダに問い合わせるのでしょうか?無知ですみません・・・。
    投稿日時 - 2005-10-11 23:36:24
    • ありがとう数0
    • 2005-10-10 22:12:57
    • 回答No.2
    こんにちは。 >プロバイダのIDや・・・はネットワークを確立してからの問題です。 ブラウザ等で入力します。 まずはそのネットワークがつながってない状態なので、その作業ができません。 一つ考えられるのは、DHCPでIPを取得する設定のようなので、ルータ(多分ADSLモデムでしょうか)をリセットしてみてください。 具体的にはルータの電源コンセントを抜いて、10数えたら、また入れます。 ...続きを読む
    こんにちは。
    >プロバイダのIDや・・・はネットワークを確立してからの問題です。

    ブラウザ等で入力します。

    まずはそのネットワークがつながってない状態なので、その作業ができません。

    一つ考えられるのは、DHCPでIPを取得する設定のようなので、ルータ(多分ADSLモデムでしょうか)をリセットしてみてください。

    具体的にはルータの電源コンセントを抜いて、10数えたら、また入れます。

    これで今までルーターに入ってたIPの情報がリセットされるので、それによるバッティングならこれで回避できます。
    補足コメント
    すみません…補足いたします。
    プロバイダに問い合わせました。
    固定IPアドレスは有料なんですね…勝手に設定したりして、無知でした。ISPはlinuxのサポートは一切
    してないそうです。
    DHCPで接続をしたいです。もし他に方法があればご教授ください。すみません。
    投稿日時 - 2005-10-12 14:33:21
    お礼コメント
    ありがとうございます!
    ルーター(eoホームファイバーです)をリセットしてみたのですが、それでもやはり、同じ結果でした。

    DHCPがうまくいかないのかと、ためしに固定IPアドレスを設定してみたところ、eth0を起動できました!

    でも、ネットワークにはまだつながっていないみたいです。なんだか訳がわからなくなってきました。
    デフォルトゲートウェイも設定が必要ですか?それはプロバイダで聞くのでしょうか?

    無知ですみませんが、よろしければ教えて下さい。
    投稿日時 - 2005-10-11 23:45:50
    • ありがとう数0
    • 回答数5
    • 気になる数0
    • ありがとう数0
    • ありがとう
    • なるほど、役に立ったなど
      感じた思いを「ありがとう」で
      伝えてください
    • 質問する
    • 知りたいこと、悩んでいることを
      投稿してみましょう
    このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
    このQ&Aにはまだコメントがありません。
    あなたの思ったこと、知っていることをここにコメントしてみましょう。

    関連するQ&A

    -PR-
    -PR-

    その他の関連するQ&Aをキーワードで探す

    別のキーワードで再検索する
    -PR-
    -PR-
    -PR-

    特集


    成功のポイントとは?M&Aで経営の不安を解決!

    -PR-

    ピックアップ

    -PR-
    ページ先頭へ