OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

PHP4.0.6をインストールしたのですが

  • 困ってます
  • 質問No.154770
  • 閲覧数46
  • ありがとう数4
  • 気になる数0
  • 回答数3
  • コメント数0

お礼率 57% (44/76)

PHP4.0.6をインストールしたのですが、mb_convert_encodingが利用できずエラーとなってしまいます。どういう原因でしょうか。なにか設定が必要でしょうか。
通報する
  • 回答数3
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.3
レベル4

ベストアンサー率 100% (1/1)

Windows版PHP4.0.6(バイナリ)には、残念ながらmbstring関連のライブラリは同梱されておりません。
正式なものについては、次期バージョンまで待つ必要があります。

なお、PHP-users MLの過去ログで見たのですが、
Windows用にmbstring関連のモジュール込みでコンパイルされたものをアップされているサイトがありましたので、参考までに紹介させていただきます。
(ご利用はあくまでも自己責任にて…)
お礼コメント
shunet

お礼率 57% (44/76)

そうだったんですか、、、
ありがとうございました、助かりました
投稿日時 - 2001-11-11 02:03:42
-PR-
-PR-

その他の回答 (全2件)

  • 回答No.1

お使いのOSはなんでしょうか? Windowsでないならば、参考URLが参考になるかもしれません。参考URLの元サイト「日本PHPユーザ会」なら、かなりPHPのことが書かれているので、そこで質問した方がいいかもしれませんよ。ただし、検索することは大前提になりますが・・・ ではでは☆ ...続きを読む
お使いのOSはなんでしょうか?

Windowsでないならば、参考URLが参考になるかもしれません。参考URLの元サイト「日本PHPユーザ会」なら、かなりPHPのことが書かれているので、そこで質問した方がいいかもしれませんよ。ただし、検索することは大前提になりますが・・・

ではでは☆
補足コメント
shunet

お礼率 57% (44/76)

windows です。URLと同じような状況かもしれません
投稿日時 - 2001-10-23 00:45:15
  • 回答No.2

外れていたらすいません。 私の知る限り2点、チェックポイントがあります。 ./configureを実行時にどのようなパラメータを指定していますか? 日本語(マルチバイト)を有効にするには以下の指定は必要なようです。 --enable-mbstring --enable-mbstr-enc-trans 次にphp.iniの設定もしたほうがよさそうです。 こっちの設定はいろいろあるような ...続きを読む
外れていたらすいません。
私の知る限り2点、チェックポイントがあります。

./configureを実行時にどのようなパラメータを指定していますか?
日本語(マルチバイト)を有効にするには以下の指定は必要なようです。
--enable-mbstring
--enable-mbstr-enc-trans

次にphp.iniの設定もしたほうがよさそうです。
こっちの設定はいろいろあるようなので参考URLを参照してください。
補足コメント
shunet

お礼率 57% (44/76)

ウィンドウズなんですよ、、、php.netはある程度行ってるんですけど
わからないんですよね
投稿日時 - 2001-10-23 00:54:12
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
こんな書き方もあるよ!この情報は知ってる?あなたの知識を教えて!
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ