OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

Comポートについて

  • すぐに回答を!
  • 質問No.105938
  • 閲覧数280
  • ありがとう数3
  • 気になる数0
  • 回答数2
  • コメント数0

お礼率 100% (2/2)

「ポートは既に開かれています」というメッセージが出て通信(インターネット接続)ができません。原因と復旧方法を教えてください、よろしくお願いします。
なお、接続はTAとPCをシリアル接続しています。
通報する
  • 回答数2
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.2
レベル10

ベストアンサー率 42% (48/114)

まず、コントロールパネルのシステムのプロパティからデバイスマネージャ
を表示し、通信ポートがそれぞれ、COM1、COM2 であることを確認して下さい。
そして、各ポートのプロパティを表示し、そのリソースが COM1 の場合、
I/O の範囲が 03F8-03FF に、割込み要求が 04 であること、COM2 の場合、
I/O の範囲が 02F8-03FF に、割込み要求が 03 であることを確認します。

もし、違っている又は「!」マークや「赤いX」マークが付いている時や
通信ポート自体が表示されていないのであれば、COMポートが正常に動作して
いません。

もし、正常に動作していない場合、COMポート(RS-232C端子)が正常に
認識していない場合も考えられます。大抵の場合、BIOSでこの通信ポートが
無効になっている事が多いです。その時は BIOS を起動し、各ポートに
上記の数値を割り当てます。

次に、コントロールパネルのモデムのプロパティで、モデムの使用している
COMポートを確認します。「全般」タブで、モデムを選択し、プロパティボタン
押すと、使用しているポートが表示されますので、COM1 もしくは COM2 で
あるかを確認します。

通常はこの数値にきちんとハートウェアが割振られているとモデムは正常に
動作します。

最後にマザーボード上の正しい COM ポートにケーブルが接続されているか
確認して下さい。普通 USB 端子に近い方が COM1 端子、遠い方が COM2 端子
です。

それでも、動かない場合…
対処療法から試してみましょう。

まず、ドライバー、モデムのドライバーを入れ直して見ましょう。
具体的には、コントロールパネルから、モデムのプロパティを開き
登録されているモデムを削除します。
次に、システムのプロパティのデバイスマネージャから、ポート(COM/LPT)
ないの、通信ポートを削除します。その後、再起動します。

再起動時に「新しいハードウェアを発見しました」とメッセージが表示され
通信ポート(COM)が再び登録されます。
その後、モデムのドライバーを再度インストールしてみましょう。

動作のチェックは、コントロールパネルないのモデムのプロパティで、
検出結果タブを選び、モデムの接続されているポートを選択後、詳細情報
ボタンを押します。詳細情報ウインドが内に Error. **** 何行にも渡って
表示されているとモデムは正常に動作しています。
お礼コメント
big-ben

お礼率 100% (2/2)

ありがとうございます。
PCは友人のもので、二人で対処療法の通信ポートを削除して~モデムのドライバーを再度インストールもしてみたのですが同じでした。私達の設定が基本的なところで間違っているのかもしれませんね。
投稿日時 - 2001-07-18 22:32:20
-PR-
-PR-

その他の回答 (全1件)

  • 回答No.1
レベル13

ベストアンサー率 40% (404/988)

こんにちは。 再起動しても、同じでしょうか? TAから先に電源をあげてください。(あまり落とすことは無いと思われますが・・・。) あと、クロスのケーブルじゃないですよね? ドライバは、正しくインストールされているでしょうか? OS、機種補足いただければ、細かいことも誰か知っているかも・・・。 ...続きを読む
こんにちは。

再起動しても、同じでしょうか?
TAから先に電源をあげてください。(あまり落とすことは無いと思われますが・・・。)

あと、クロスのケーブルじゃないですよね?

ドライバは、正しくインストールされているでしょうか?
OS、機種補足いただければ、細かいことも誰か知っているかも・・・。
お礼コメント
big-ben

お礼率 100% (2/2)

ありがとうございます。
再起動もTAの電源も何度かしましたし、クロスのケーブルではありません。
PCは友人のもので、二人で何度かドライバーのインストールもしたのですが…。
投稿日時 - 2001-07-18 22:36:23

このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
あなたが体験したトラブルや解決方法を共有しませんか?
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ